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Getting Started

Read This First

About This Manual
•　The contents of this manual are subject to change without notice.
•　The contents of this manual have been checked at each step along the production process. Feel free to

contact us if you notice anything that is questionable, erroneous, etc.
•　No part of this manual may be reproduced in any form without the express written consent of the manufacturer.
•　The displays and illustrations (such as key markings) shown in this manual are for illustrative purposes only,

and may differ somewhat from the actual items they represent.
•　QR Code is a registered trademark of DENSO WAVE INCORPORATED in Japan and in other countries.
•　Python is a registered trademark of the Python Software Foundation. Trademark (™) and registered

trademark (®) symbols are not used in this manual.
•　Company and product names used in this manual may be registered trademarks or trademarks of their

respective owners.
•　In no event shall CASIO Computer Co., Ltd. be liable to anyone for special, collateral, incidental, or

consequential damages in connection with or arising out of the purchase or use of this product and items that
come with it. Moreover, CASIO Computer Co., Ltd. shall not be liable for any claim of any kind whatsoever
by any other party arising out of the use of this product and the items that come with it.

•　In no event will the manufacturer and its suppliers be liable to you or any other person for any damages,
expenses, lost profits, lost savings or any other damages arising out of loss of data and/or formulas arising
out of malfunction, repairs, or battery replacement. It is up to you to prepare physical records of data to protect
against such data loss.

Attention fx-CG100 Users
•　Unless otherwise noted, this manual describes operations when “International” is selected for the

Country setting (page 200). When “United States” or something else other than “International” is
selected for the Country setting, screen contents and the arrangement of screen items may differ from
what is shown in this manual.

Attention fx-1AU GRAPH Users
•　Unless otherwise noted, this manual describes operations with fx-CG100 (Country setting (page 200):

International). With the fx-1AU GRAPH, screen contents and the arrangement of screen items may
differ.
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Key Operations
Some of the keys of your calculator have multiple functions assigned to them. This manual uses the conventions
below to indicate the key operations required to access each function.

(1)

(2) (3)

fx-CG100

(1)

(2) (3)

fx-1AU GRAPH

(1) (2) (3)

j 2 r / 3 sj(G) 8 r / Pj )C(

(1) Press j to enter “  ”.
This is the operation for using the function printed on the key top.

(2) After pressing sj, press the above key to enter “G”, which is shown in parentheses.
This operation is used to access the function printed in green (fx-CG100) / blue (fx-1AU GRAPH) above
and to the left of the key.

(3) After pressing Pj, press the above key to enter the “C”, which is shown in parentheses.
This operation is used to access the function printed in orange (fx-CG100) / red (fx-1AU GRAPH) above
and to the right of the key.

O Key and E Key
The O key and E key perform the same operation. In this manual, O is used for selecting or applying a
setting, while E is used for executing a calculation. Note, however, that it makes no difference whether you
press O or E for operations where either O or E is shown.

d/u/l/r Keys
Use these keys to move the cursor or highlighting. These keys are referred to as “cursor keys” throughout this
manual.

General Precautions for All Applications
•　Calculations may take time.

A rotating  icon is shown in the upper right corner of the screen while an internal calculation is in progress.
To interrupt a calculation without waiting for it to complete, press a.
 
Examples of time-consuming calculations
-　Integral calculations (depending on f x  and the range of x)
-　Calculations involving matrices or vectors with a large number of elements
-　Solving simultaneous equations with three or more variables or higher linear equations, or cubic or higher

order equations
-　Drawing regression graphs when there is a large amount of data (especially sinusoidal regression and

logistic regression)
•　Calculation results may be subject to error.

For information about your calculator’s calculation accuracy and error, see “Calculation Ranges, Number of
Digits, and Precision” (page 254).

•　If an error message appears, check its contents.
For the meaning of each error message, see “Error Message Table” (page 247).

•　Most functions are called from the Catalog menu.
See “Catalog Menu Details” (page 221) for descriptions of functions and their syntax.
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Calculator “Get Started” Screen
While the HOME screen is displayed, pressing S will display the “Get Started” screen, which includes the
information below.
•　QR Code for accessing the “Get Started” webpage of the Worldwide Education Service

(https://wes.casio.com/calc/cg/)
The Get Started webpage gives you access to the User’s Guide and other related information to help you get
started with your calculator.

•　Calculator ID number (8-character string)

To adjust the display brightness of the QR Code
While the “Get Started” screen is displayed, use l and r to adjust the display brightness. The settings made
with this adjustment are shared with the Display Settings (page 200) of the System app.

To return to the HOME screen
Press b.

7
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Basic App Operations

Starting Up an Application

2.　Use the cursor keys to move the highlighting to the icon of the app you want to start up, and then press O.
Alternatively, you can press a number or letter key to select an app.
•　If 1 is shown in the upper right corner of the icon you want to select, press 1. If A is shown, press XA.

App Screen Configuration

Status bar

App window

Tab

Status bar
The status bar at the top of the screen shows the current battery level, current settings, various statuses, and
help messages.

App window
This is the display area of the app. While the window displays a graph, you can hide the tabs to expand the
display area (see “Using Tabs” (page 8)).

Tab
Some applications of your calculator have multiple tabs. Each tab is assigned a role or function. The currently
active tab is white, while inactive tabs are black. Some apps do not have tabs.

Using Tabs
Some apps have tabs that are organized according to functions or properties.
•　There are two types of apps with tabs, and the app type depends on the app organization.

One-way type: This type of app has a starting tab and an ending tab. App operations proceed sequentially
from the start (left-most) tab to the end (right-most) tab. Each press of > moves to the
next tab to the right.

Distribution App
 
Pressing < moves in reverse sequence (to the left) until the start (left-most) tab is reached.

1.　Press the h key to display the HOME screen.
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Cyclical type: With this app type, operations proceed cyclically among tabs. Pressing > while any tab

is displayed moves to the next tab to the right.

Graph&Table App Python App
 
Press < to move to the next tab to the left.

•　  and  on either end of the tabs means there is a tab in the direction indicated by the arrow(s).
•　While the window displays a graph, you can hide the tabs by pressing D. This expands the display area.

In some cases, tabs may be hidden automatically. If you are able to show hidden tabs,  will be shown in
the status bar. In this case, press U to show the tabs.

App Alpha Character and Numeric Input

Natural Input and Linear Input
Your calculator lets you enter expressions using either of two input methods: natural input or linear input. Natural
input lets you input expressions in textbook format. With linear input, you can input expressions in linear format.
There are differences between natural input and linear input when entering fractions, square roots (  ), some
functions, vectors, and matrices. The table below shows examples of natural and linear input.

Expression
Input method

Fractions,  
Functions (Integration

example) Matrix

Natural input

Linear input

To incorporate a previously entered numeric value as an argument into a function (natural input only)

Example: To enter 1 + 7
6  and change it to 1 + 7

6

1+e7d6llllsI(INS)

j

Pressing sI(INS) makes 76 , which was input in the above example, the argument of the function (  ) entered

with the next key operation.
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To switch between insert mode and overwrite mode (linear input only)
In overwrite mode, the character at the current cursor position is replaced by the character you enter. Each
press of sI(INS) toggles between the insert and overwrite modes. The cursor shape is “ ” in insert mode
and “ ” in overwrite mode.

Alphabet Input
To enter a single alpha character, press P (which displays  in the status bar), followed by a key marked
with an orange letter (fx-CG100) / a red letter (fx-1AU GRAPH). In addition to the alpha characters, you can
also enter spaces ( ) and quotation marks (").*

*　Other symbols can be entered using C > [All] > [Symbol].

Alpha Lock
You can alpha lock keys to allow continuous input of alpha characters, so you don’t need to press P for each
one.
Pressing sP(Q) alpha locks the keys, which is indicated by  in the status bar. To unlock alpha lock,
press P.

Note
•　When using the Python app’s Editor, keys are automatically alpha-locked to lowercase, which is

indicated by  in the status bar.

Copying, Cutting, and Pasting Expressions
You can select a range of expressions or strings that have already been entered and copy or cut them to the
clipboard. You can then paste the clipboard contents into the same app or another app.

To copy or cut screen data
1.　Move the input cursor ( ) to the start of the range of data you want to copy or cut.

2.　Press s0($).
•　This displays  in the status bar until you press O in step 4.

3.　Move the cursor to the end of the range of data you want to copy or cut.

4.　Select [Copy] or [Cut] in the menu that appeared after you pressed O.
•　You can specify the end point first if you want.

To paste data
1.　Move the input cursor ( ) to the location where you want to paste the data.

2.　Press s.(%).

Frequently Used App Menus

S Settings Menu (Changing App Settings)
The Settings menu displays setting items for the app you are currently using. It includes items common to
multiple apps and items specific to a particular app.

To change app settings

1.　Press h, select an app, and then press O.

2.　Press S to display the Settings menu and then change the app’s settings.
•　If there is a switch (Off: , On: ) to the right of a menu item, press O to toggle between Off and On.
•　For details about setting items and options, see “Settings Menu Details” (page 214).
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V Variable Menu (Inputting a Variable into a Calculation or Expression)
Use the Variable menu to input a variable into a calculation or expression.

To recall this variable: Select this menu item: Details:
Alpha variable V > [Alpha] Using Alpha Variables (page 18)

Function variable V > [Function] Using Function Variables (page 18)
To input a function (page 76)

Vector variable V > [Vector] Inputting a Vector into a Calculation (page 22)
Storing Vector Variables (page 21)

Matrix variable V > [Matrix] Inputting a Matrix into a Calculation (page 25)
Storing Matrix Variables (page 24)

List variable V > [List] Inputting a List into a Calculation (page 27)
Storing List Variables (page 27)

Note
•　The menu item for each variable also shows the line form of the contents currently stored in the variable.

C Catalog Menu (Inputting Functions and Commands)
The Catalog menu is a comprehensive list of all functions, commands, app variables,* and symbols.
*　Variables that automatically store specific input or output values.
For details about the items included on the Catalog menu, see “Catalog Menu Details” (page 221).

Note
•　Pressing C while using the Python app or Base-N app displays the Catalog menu for the app you

are using. For details, see the chapters explaining each app.

T Tools Menu (Displaying Operation Options)
Press T to display the Tools menu. The items that appear on the Tools menu depend on the app or tab you
are currently using.
When  is displayed on the right end of a highlighted menu item, the Tools menu that appears when you press
T will contain operation options enabled for the highlighted line.

F Format Menu (Changing the Display Format)
The Format menu that appears when you press sF* lets you change the format of the calculation result
display and cell details. For details about the items included on the Format menu, see “Changing the Display
Format of Calculation Results (Format Menu)” (page 17).
*　When “  Decimal” is selected for S > [FORMAT Key] (page 220) (initial default).

Menu and Dialog Operations (Using Option Numbers)
Pressing certain keys (C, T, etc.) or executing some operation in an app causes a menu or dialog to appear.

Menu Example Dialog Example
There are two ways to select an item on a menu or dialog.
•　Method 1: Use d and u to move the highlighting to the item you want to use and then press O.
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•　Method 2: Press the number or letter key* that corresponds to the number or letter to the left of the item you
want to select.
The number or letter to the left of an item is its “Option Number”.

*　To enter a letter from A through L, press XA through )L (without pressing P).
To enter a letter from M through Z, press P + 7M to P + 0Z. Be sure to press P first in this case.

Note
•　You can use Option Numbers to select a menu or dialog operation by pressing its corresponding

number or letter key even if its menu or dialog is not currently displayed. To understand how this works,
try performing the example operation below.

•　Option Numbers are displayed when S > [Show Option Numbers] (page 220) is turned on and not
displayed when it is turned off. The default setting is On. Note that menu and dialog operations you
execute by pressing number and letter keys remain in effect even when S > [Show Option Numbers]
is turned off.

Example of Menu Operations Using Option Numbers
The operations in this example are performed with the Calculate app running and the Settings menu displayed.
The following operations will be performed using Option Numbers.
•　Selecting [a+bi] for the [Complex Mode] setting
•　Turning [Show Option Numbers] off and then back on
 

1.　h > Calculate

2.　Press S.
•　This displays the Settings menu.
•　Note that  is shown to the left of [Complex Mode].

3.　Press u.
•　This jumps to the last line of the menu.
•　Note that  is shown to the left of [Show Option Numbers].

4.　Press 2 to select [Complex Mode].
•　This displays a list of available Complex Mode settings.

5.　Press 2 to select [a+bi].
•　This changes the Complex Mode setting to a+bi and returns

to the Settings menu.

6.　Press 8 to select [Show Option Numbers].
•　This turns off the [Show Option Numbers] setting ( ),

which causes the Option Numbers to the left of the menu
items to disappear.
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7.　Press 8 again (or O).
•　This turns on the [Show Option Numbers] setting ( ), which causes the Option Numbers to reappear.

Cases when Option Number Operations Are Disabled
Option Number operations are disabled while a setting item that requires direct numeric input is highlighted
because pressing a number or letter key displays an input dialog. Option Numbers are dimmed when they are
disabled.

Using the Screen Capture Function
To capture what is displayed on the screen, press sk(&). “Capt01” (where “01” is a number from 01 to
20) will appear in the center of the screen when the capture is successful.

The captured image file is saved in the Storage Memory “Capt” folder.

Captured Image Storage Format
Captured images can be saved as either .g4p (default) or .bmp images. For details, see “Specifying the Image
Capture Format (Capture Format)” (page 201).

Viewing Captured Images
You can view the captured images in the “Capt” folder by displaying the Memory app’s Storage Memory tab.
For details, see “Using the Storage Memory Tab” (page 196).

Using Captured Images
An image saved in .g4p format can be used as a graph window background (“Background (Graph)” (page 219)).
Images saved in bmp format can be used by transferring them to a PC (“Connecting the Calculator to a
Computer” (page 210)).

Conditions When Capture Cannot be Performed

Pressing sk(&) when any of the conditions below exists causes  to appear in the center of the
screen, indicating that capture cannot be performed.
•　When there is insufficient Storage Memory available.
•　When you attempt to save a bmp image while all of the available bmp file names (Capt01.bmp to Capt20.bmp)

are in use.
•　When you attempt to save a g4p image while all of the available g4p file names (Capt01.g4p to Capt20.g4p)

are in use.
•　When there is insufficient battery power.
•　When you are in an Exam Mode.

Before Assuming Malfunction
If a problem continues to occur, try performing the steps below starting from ①.
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①　 Reset your calculator’s settings.
(1) h > System
(2) Select [Reset] > [Settings].
(3) On the dialog that appears, select [OK].
If this does not resolve the problem, try step ②.

②　 Press the RESTART button to restart your calculator.

Important!
•　When you press the RESTART button to restart the calculator, data already stored in the memory of

the calculator is normally retained. However, data that is being edited or data that is being entered
but not yet finalized at the time RESTART is pressed is not retained.

RESTART button

After you press the RESTART button, configure all of the following settings that appear sequentially on the
screen: Language, Country (fx-CG100 only), Display Settings, Power Properties, Battery Settings.
For information about each setting, see “System App” (page 199).
If this does not resolve the problem, try step ③.

③　 Reset calculator memory.
Before performing the operation below, make sure to copy any important data stored in the calculator. Step
(2) deletes all the data in your calculator’s Main Memory. Step (3) returns all calculator settings to their initial
defaults and erases all data in Main Memory and Storage Memory.
(1) h > System
(2) Execute [Reset] > [Main Memory].
(3) If the operation does not improve, execute [Reset] > [Initialize All].
For information about the reset operation, see “Resetting the Calculator (Reset)” (page 199).

Low Battery Warning
If the Low Battery Warning below appears, immediately turn off your calculator and replace its batteries.

Important!
•　If you continue to use your calculator without replacing the batteries after the low battery warning

appears, it will automatically turn off to protect memory contents, and you will not be able to turn it on
again.

•　Leaving the unit without replacing the batteries after the low battery warning appears may cause the
memory contents to be cleared.

•　After the low battery warning appears, you will not be able to transfer data to a computer until you
replace the batteries.
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Using Apps

Calculate App
Calculate is an app that lets you use various types of functions to input and execute various functions. It supports
the use of real numbers, complex numbers, vectors, matrices, and lists.

Basic Calculation Operations

Starting a Calculation
1.　h > Calculate

•　The cursor appears at the far left of the input box on the Calculation tab.

2.　Enter the calculation formula and press E.
•　The calculation result appears on the next line, right justified.

Example Calculations

Arithmetic
Calculation 7 × 8 − 4 × 5 = 36 7/8-4/5E

Minus Sign -8 × 7 − (-6) = -50 s-(M)8/7-
s-(M)6E

Fractions 2
3 + 11

2 = 13
6

2e3r+se(B)1
r1d2E

To clear the calculation you are entering
Press a.

To clear all Calculation tab contents
While the cursor is located at the far left of the input box in a line that has nothing input, press a.

Using the Latest Calculation Result (Ans)
The latest calculation result is stored in a variable named Ans. You can input the Ans variable into a new
calculation by pressing PF(Ans).
Example: 

4/20E
jPF(Ans)E

Pressing /, *, +, - operator key at the beginning of a new calculation automatically inputs the Ans
variable followed by the corresponding operator.
Example: 

5/30E
/4E

Ans is automatically entered when you press g or i, or when you enter a function that takes an argument
immediately before it (such as n! or nPr, etc.)
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Using Calculation History
The Calculation tab stores up to 30 sets (calculation line and result) of recent calculation history.

To edit and re-execute a calculation line in calculation history
Use d/u to highlight the calculation line you want to edit. Press l/r to display the cursor in the calculation
line and then edit the formula. After editing, press E to recalculate all subsequent calculation lines and update
the result line.

To copy the result line of a calculation history and insert it into a new formula
Highlight the calculation history result line (result line with numerical values) you want to copy and then press
O. This will copy the line to the clipboard (see “Copying, Cutting, and Pasting Expressions” (page 10)).

This operation cannot be performed in the cases described below.
•　If the result line is in vector, matrix, or list form (In this case, pressing O displays the Ans window.*)
•　If the result line is such that it cannot be entered in a formula (For example, the result of a calculation using

“ISimp” (page 223) “F = 4,  14,” etc.)

*　For information about the Ans window, see “Vct Ans” (page 23), “Mat Ans” (page 26), and “List Ans”
(page 28).

To delete a calculation history set
Highlight either the calculation line or result line of the calculation history set you want to delete and then select
T > [Delete Line].

To clear calculation history
Select T > [Delete All].

Note
•　Changing the S > [  π Result] setting also clears calculation history.

Toggling Calculation Results between Standard (Fraction, π,   Form) and Decimal
Each press of F while a calculation result is displayed toggles the result between the following two forms:

-　a form that includes fraction, π, or  
-　decimal form

Operation Example:

2 /j2E

F

F

Note
•　Toggling calculation result display formats by pressing only F is supported when “  Decimal”

(initial default) is selected for the S > [FORMAT Key] (page 220) setting. If “Format Menu” is selected
for the S > [FORMAT Key] setting, press sF.
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Changing the Display Format of Calculation Results (Format Menu)
Pressing sF*1 displays the Format menu, which you can use to change the display format of calculation
results.

Pressing sF and selecting
this:

Does this:

π   (Standard)  Decimal Switches the displayed calculation result between standard form*2 and
decimal form. Conversion to standard form is enabled when S > [  π
Result] > [On].*3

Switches the displayed calculation fraction result between mixed fraction and
improper fraction form. If the displayed calculation result is in decimal form,
selecting this form converts it to a fraction if conversion is possible.

Sexagesimal Converts the displayed calculation result to degrees/minutes/seconds
(sexagesimal) form.

ENG Notation
Reverse ENG Notation

Converts the displayed calculation result to engineering notation form
(a × 10n form, where n is an integer multiple of 3). Each time you select
[ENG Notation], the current decimal point position in the mantissa is shifted
three places to the right (exponent is decreased by 3). Each time you select
[Reverse ENG Notation], the current decimal point position in the mantissa
is shifted three places to the left (exponent is increased by 3).

*1　When “  Decimal” is selected for S > [FORMAT Key] (page 220) (initial default).
*2　Form that includes a fraction, π, or  
*3　Display ranges of conversions are limited. For information about the displays ranges of the fraction form

and   form of the calculator’s calculation results, see “Fraction Form Calculation Results” (page 17) and
“   Form Calculation Range” (page 18).

Operation Example:

2/j2E

sF > [ π   (Standard)  Decimal]

sF > [ π   (Standard)  Decimal]

Note
•　Display format changes using the Format menu are also applied to the cell details.
•　After entering a formula, pressing sE(J) instead of E displays the calculation results in decimal

form.

Fraction Form Calculation Results
How the calculator displays a fraction calculation result (fraction form or decimal form) depends on the number
of places required to express the result in linear form. The number of places is counted as shown below.

Proper fraction: 1
2  = 1 2

Three places. Two places digits for the numerator and denominator, one place for the separator ( ).
Improper fraction: 3

2  = 11
2  = 1 1 2

Five places. Three places for the integer, numerator, and denominator, and two places for the separators.
If the linear form of the calculation result has 10 digits or fewer, it is displayed in fraction form as shown in
Example 1 below. If it has 11 or more digits, it is displayed in decimal form as shown in Example 2 below.

Example 1: 1 1
123456 = 123457

123456 (Natural form)       1 1 123456 = 123457 123456 (Linear form)
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se(B)1r1d123456E

Example 2: 1 1
1234567 = 1.00000081 (Natural form)       1 1 1234567 = 1.00000081 (Linear form)

se(B)1r1d1234567E

  Form Calculation Range
The allowable display ranges of the   form calculation result are shown below.

±a b, ±d ± a b, ± a b
c ± d e

f
1 ≤ a < 100, 1 < b < 1000, 1 ≤ c < 100
0 ≤ d < 100, 0 ≤ e < 1000, 1 ≤ f  < 100

Example: 10 2 + 15 × 3 3 = 45 3 + 10 2 ... Displayed in   form
99 999  = 297 111 = 3129.089165 ... Displayed as a decimal value

Using Alpha Variables
Alpha variables are used for temporary storage of numerical values. There are 28 variables, named A through
Z, r, and θ.

To display the contents of an alpha variable
Select V > [Alpha].

To assign a value to an alpha variable
Syntax: Value → Alpha Variable
Alpha variables can be entered using key or menu operations.
Example: To assign 5 to alpha variable A

Key operation: 5sX(→)PX(A)E

Menu operation: 5sX(→)V > [Alpha] > [A]E

To batch assign the same value to several consecutive alpha variables
Example: To batch assign 10 to alpha variables A through F

10sX(→)PX(A)
C > [All] > [Symbol] > [~]PN(F)E

To use an alpha variable in a formula

Example: To calculate B+A
B−A  when A = 5 and B = 5

ePe(B)+PX(A)d
Pe(B)-PX(A)E

Note
•　Assigning a value to an alpha variable also updates Ans with that value.
•　The x that is entered by pressing X is the same as alpha variable X.
•　A value is saved to a variable in accordance with the settings of S > [Angle] and S > [Complex

Mode] in effect at the time the value is saved.

Using Function Variables
Functions saved on the Function tab of the “Graph&Table App” (page 75) can be used with the Calculate app.
Example: To recall the function assigned to function variable y1 (y1 = 3x), assign a value of 10 to variable x,

and determine the value of y1
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3.　Enter the value to be assigned and then press E.

(10)E

Note
•　Entering only “y1” and pressing E assigns the value currently assigned to variable x.

Scientific Function Calculations
All built-in functions can be entered from the Catalog menu, which you can display by pressing C. For details,
see “Catalog Menu Details” (page 221). The table below shows example function calculations that can be
entered directly using keys.

Calculation Examples (S > [Angle] > [Radian]*1)

Trigonometric
Functions*1 cos π3 = 1

2 ces7(π)d3r)E

Inverse
Trigonometric
Functions*1

sin-1 0.5 = 1
6π sv(sin-1)0.5)E

Powers (52)3 = 15625 (5i)g3E

Power of 10 4 × 107

3 × 108 = 2
15

e4k7d3k8E*2

4k7e3k8E*3

4k7re3k8E*4

Power Roots
2 × 3 = 3 2 j2r/3E

325 = 2 sj(G)5r32E

Logarithms
log1000 = 3 si(log)1000)E

log2 16 = 4 sg(R)2r16E

Base of Natural
Logarithms e4.5 = 90.0171313 N4.5E

1.　V > [Function]

2.　Highlight [y1] and then press O.
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Natural Logarithms ln (90) = 4.49980967 sN(ln)90)E

Pi (π) π = 3.141592654 s7(π)sE(J)*5

*1　When using trigonometric or inverse trigonometric functions, be sure to specify the angle unit (S > [Angle]).
*2　When S > [ Key] > [  (Power)] is selected. The “× 10□” entered by pressing k is the same

as when you press /10g. Because of this, executing 4 × 107 ÷ 3 × 108 causes the calculation to be
performed sequentially from left to right, which produces a different calculation result than the one in the
above example (using fractions). To obtain the same calculation result, each term needs to be enclosed in
parentheses: (4 × 107) ÷ (3 × 108).

*3　When S > [ Key] > [  (Sci Notation)] is selected. At this time, pressing k and using the 
function that is input to execute 4 7 ÷ 3 8 will produce the same calculation result as in the calculation
example above.

*4　When S > [ Key] > [  (Sci Notation)] is selected (default setting). At this time, pressing k and
using the  function that is input to execute 4 7 ÷ 3 8 will produce the same calculation result as in
the calculation example above.

*5　Pressing sE(J) in place of E will display the calculation result in decimal form.

Prime Factorization
You can use the Calculate app to perform prime factorization on integers 2 or greater and with fewer than 10
digits.
Example: To perform prime factorization on 61226001

61226001E
T > [Prime Factorization]

•　The Prime Factorization dialog is display-only. Its values cannot be edited or copied.
•　To close the Prime Factorization dialog, press b or a.

Note
•　You can also prime factorize a number by highlighting the result line in calculation history (page 16)

and selecting T > [Prime Factorization].

Complex Number Calculations
You can use the Calculate app to perform the operations described below.
•　Complex number input into calculations

To input the rectangular form 1 + i: 1+s9(i)

To enter the polar form 2∠π: j2rs8(∠)s7(π)
•　Imaginary solution display

An imaginary solution is displayed as shown below, depending on the S > [Complex Mode] setting.
[Real] ... Real number: -1 = “Non-Real ERROR” (non-real number error)*1

[a+bi] ... Rectangular form: -1 = i
[r∠θ] ... Polar form: -1 = 1∠1

2π
*2

•　Absolute value, argument of complex, conjugate complex number, real and imaginary part calculation, and
polar and rectangular form conversion
For these calculations, see the “Complex Number” (page 229) section of “Catalog Menu Details” (page 221).
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*1　When the argument is a real number and the solution is an imaginary number. If the argument is a complex
number (such as i), the calculation result is the same as if S > [Complex Mode] were set to [a+bi].

*2　When S > [Angle] > [Radian]. The display range of θ is as follows, depending on the S > [Angle] setting.
Degree: -180 < θ ≤ 180 Radian: -π < θ ≤ π Gradian: -200 < θ ≤ 200

Vector Calculations
Your calculator is provided with vector variables (Vct A to Vct Z, Vct Ans) for vector calculations.

Storing Vector Variables
When using vector variables in calculations, you can store the necessary vectors for the calculation in vector
variables Vct A to Vct Z as required. For example, if you want to calculate 1 2 + 3 4  and 1 2 − 3 4 , store
1 2  in Vct A and 3 4  in Vct B. Next, you can execute the operations Vct A+Vct B and Vct A-Vct B.

The dimension of the vector can be specified within 999 rows by 1 column or 1 row by 999 columns.
Example: To store the 1-row × 2-column vector 4 8  in Vct A

2.　Highlight [Vct A] and choose T > [Dimension].

5.　Press b or O to return to the Vector list.

To assign a vector variable to another vector variable
Example: To assign Vct A to Vct D, input “Vct A → Vct D” on the Calculation tab.

V > [Vector] > [Vct A]
sX(→)V > [Vector] > [Vct D]E

Note
•　Vector variables can be assigned to matrix variables. For example, “Vct A → Mat A” assigns Vct A to

Mat A.

To assign (overwrite) a value to a specific element of a vector variable
Syntax: value being assigned → vector name [row number,column number]
Example: To assign 20 to the element in row 1, column 2 of Vct A when Vct A = [1,2,3]

20 sX(→)V > [Vector] > [Vct A]
s4([)1`2s5(])E

To check the current contents of Vct A: V > [Vector]

To recall the value of a specific element of a vector variable
Syntax: vector name [row number,column number]
Example: To recall the element at row 1, column 2 when Vct A = [1,2,3]

V > [Vector] > [Vct A]s4([)1`2s5(])E

1.　While the Calculation tab is active, press >.
•　This displays the Vector list on the Vector tab.

3.　In the dialog that appears, perform the following operation to specify
one row and two columns: 1E2EO.
•　This displays the Vct A input window.

4.　Perform the following operation to enter the elements of the vector:
4E8E.
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Inputting a Vector into a Calculation
To use a vector, you can use any one of the methods described below to input it into a calculation.

Method 1: Using the name of the vector variable
Example: To input “Vct A”

C > [Vector] > [Vector] PX(A)

Note
•　You can input either an upper-case X (P+(X)) or lower-case x (X) for vector variable “Vct X”. Both

“Vct X” and “Vct x” refer to the same vector variable.

Method 2: Using a template
Vectors with up to 6 rows and 1 column or up to 6 columns and 1 row can be input using a template.

Example: To input the 2-row × 1-column vector 
2
4

.

1.　While the Calculation tab is active, select T > [m×n].

3.　Use the template to enter values.

2d4

Method 3: Using linear input form
To input this: Use this form:

m-row × 1-column vector 

a11

a21

…
am1

a11 a21 …  am1

1-row × n-column vector a11 a12 … a1n a11, a12,  … a1n

The maximum value of both m and n is 999.
Example: To input the 1-row × 3-column vector 1 2 3 .

s4([)s4([)1`2`3s5(])s5(])

Using Vectors in Calculations
Your calculator supports the types of vector calculations.
•　Addition, subtraction, and multiplication of two vectors, and scalar multiplication of one vector.

These types of calculations are performed by entering vectors and operators. Examples of how to perform
these calculations are provided below.

•　Dot product, cross product, norm (magnitude) of a vector, angle between two vectors, unit vector.
For these calculations, see the “Vector” (page 227) section of “Catalog Menu Details” (page 221).

Note
•　The calculation precision of displayed results for vector calculations is ±1 at the least significant digit.

Vector Calculation Examples
The examples here show the various input methods based on the following vector addition: 1 2 + 3 4 = 4 6 .

Using vector variables
Input 1 2  in Vct A and 3 4  in Vct B and then perform the operations below.

2.　In the dialog that appears, perform the following operation to specify
two rows and one column: 2E1EO.
•　This displays a 2-row × 1-column template.
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V > [Vector] > [Vct A]+
V > [Vector] > [Vct B]E

Using a template
T > [m×n]1E2EO1r2r+

T > [m×n]ddO3r4E

Using linear input form
s4([)s4([)1`2s5(])s5(])+
s4([)s4([)3`4s5(])s5(])E

Vct Ans
Vct Ans is a variable that stores the latest vector calculation result. Whenever a calculation result is in vector
form, Vct Ans contents are overwritten with that result. Note that the contents of the “Mat Ans” (page 26)
variable are also overwritten with the result of each vector calculation.
Calculation results less than 256 bytes are displayed on the Calculation tab, but calculation results equal to or
more than 256 bytes are displayed in the Ans window. While the Ans window is displayed, pressing b returns
to the Calculation tab with the result line displayed as “Mat/Vct Result”.

Note
•　Assigning a vector variable to another vector variable does not affect Vct Ans contents.
•　If a vector calculation result is too large to fit into Vct Ans, an error occurs.

Using the Vector Tab
With the Vector tab, you can edit vector variables Vct A through Vct Z, and Vct Ans.

Vector List Operations
To do this: Select this menu item:
Specify the dimension of the highlighted vector
variable. T > [Dimension]

Delete the contents of the highlighted vector variable. T > [Delete]

Clear the contents of all vector variables. T > [Delete All]

Vector Input Window Operations
To do this: Select this menu item:
Delete the highlighted row. T > [Row] > [Delete]

Insert one row before the highlighted row. T > [Row] > [Insert]

Add one row after the highlighted row. T > [Row] > [Add]

Delete the highlighted column. T > [Column] > [Delete]

Insert a column before the highlighted column. T > [Column] > [Insert]

Add a column after the highlighted column. T > [Column] > [Add]

Edit the contents of the highlighted cell. T > [Edit]

Matrix Calculations
Your calculator is provided with matrix variables (Mat A to Mat Z, Mat Ans) for matrix calculations.
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Storing Matrix Variables
When using matrix variables in calculations, you can store the necessary matrices for the calculation in matrix

variables Mat A to Mat Z as required. For example, if you want to calculate 
1 3
2 4

+
2 6
4 8

 and 
1 3
2 4

−
2 6
4 8

, store

1 3
2 4

 in Mat A and 
2 6
4 8

 in Mat B. Next, you can execute the operations Mat A+Mat B and Mat A−Mat B.

The number of both rows and columns of the matrix can be specified within 999.

Example: To store the 2-row × 2-column matrix 
1 3
2 4

 in Mat A

2.　Highlight [Mat A], and then select T > [Dimension].

5.　Press b or O to return to the Matrix list.

To assign a matrix variable to another matrix variable
Example: To assign Mat A to Mat D, input “Mat A → Mat D” on the Calculation tab.

V > [Matrix] > [Mat A]
sX(→)V > [Matrix] > [Mat D]E

Note
•　A matrix variable with 1 row and n columns or m rows and 1 column can be assigned to a vector

variable. For example, “Mat A → Vct A” assigns Mat A to Vct A.

To assign (overwrite) a value to a specific element of a matrix variable
Syntax: value being assigned → matrix name [row number,column number]

Example: To assign 40 to the element in row 2, column 2 of Mat A when Mat A = 
1 2
3 4

40sX(→)V > [Matrix] > [Mat A]
s4([)2`2s5(])E

To check the current contents of Mat A: V > [Matrix]

To recall the value of a specific element of a matrix variable
Syntax: matrix name [row number,column number]

Example: To recall the element at row 2, column 2 when Mat A = 
1 2
3 4

V > [Matrix] > [Mat A]s4([)2`2s5(])E

1.　While the Calculation tab is active, press <.
•　This displays the Matrix list on the Matrix tab.

3.　In the dialog that appears, perform the following operation to specify
two rows and two columns: 2E2EO.
•　This displays the Mat A input window.

4.　Perform the following operation to enter the elements of the matrix:
1E3E2E4E.
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Inputting a Matrix into a Calculation
To use a matrix, you can use any one of the methods described below to input it into a calculation.

Method 1: Using the name of the matrix variable
Example: To input “Mat A”

C > [Matrix] > [Matrix] PX(A)

Note
•　You can input either an upper-case X (P+(X)) or lower-case x (X) for matrix variable “Mat X”.

Both “Mat X” and “Mat x” refer to the same matrix variable.

Method 2: Using a template
A matrix with up to 6 columns and 6 row can be input using a template.

Example: To input the 2-row × 2-column matrix 
2 6
4 8

.

1.　While the Calculation tab is active, select T > [m×n].

3.　Use the template to enter values.

2r6r4r8

Method 3: Using linear input form
To input this: Use this form:

m-row × n-column matrix

a11 a21 … am1

a21 a22 … am2

… … … …
am1 am2 … amn

a11,a21, … ,am1 a12,a22, … ,am2  …  am1,am2, … ,amn

The maximum value of both m and n is 999.

Example: To input the 2-row × 2-column matrix 
2 6
4 8

.

s4([)s4([)2`6s5(])
s4([)4`8s5(])s5(])

Using Matrices in Calculations
Your calculator supports the types of matrix calculations.
•　Addition, subtraction, and multiplication of two matrices, and scalar multiplication, squaring, powers, absolute

value, and complex number calculations of a single matrix.
These types of calculations are performed by entering matrices and operators. Examples of how to perform
these calculations are provided below.

•　Matrix inversion, determinant, matrix transposition, identity matrix, row echelon form of a matrix, reduced row
echelon form of a matrix.
For these calculations, see the “Matrix” (page 227) section of “Catalog Menu Details” (page 221).

Note
•　The calculation precision of displayed results for matrix calculations is ±1 at the least significant digit.

2.　In the dialog that appears, perform the following operation to specify
two rows and two columns: 2E2EO.
•　This displays a 2-row × 2-column template.
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Matrix Calculation Examples
The examples here show the various input methods based on the following matrix addition:
1 3
2 4

+
2 6
4 8

=
3 9
6 12

.

Using matrix variables

Input 
1 3
2 4

 in Mat A and 
2 6
4 8

 in Mat B and then perform the operations below.

V > [Matrix] > [Mat A]+
V > [Matrix] > [Mat B]E

Using a template

T > [m×n]2E2EO1r3r2r4r+
T > [m×n]ddO2r6r4r8E

Using linear input form

s4([)s4([)1`3s5(])s4([)2`4s5(])s5(])+
s4([)s4([)2`6s5(])s4([)4`8s5(])s5(])E

Mat Ans
Mat Ans is a variable that stores the latest matrix calculation result. Any time a calculation result is in matrix
form, Mat Ans contents are overwritten that result. Whenever a matrix calculation result is a 1-row × n-column
or m-row × 1-column matrix, the contents of the “Vct Ans” (page 23) variable are also overwritten with the result
of that matrix calculation.
Calculation results less than 256 bytes are displayed on the Calculation tab, but calculation results equal to or
more than 256 bytes are displayed in the Ans window. While the Ans window is displayed, pressing b returns
to the Calculation tab with the result line displayed as “Mat Result”.

Note
•　Assigning a matrix variable to another matrix variable does not affect Mat Ans contents.
•　If a matrix calculation result is too large to fit into Mat Ans, an error occurs.

Using the Matrix Tab
With the Matrix tab, you can edit matrix variables Mat A through Mat Z, and Mat Ans.

Matrix List Operations
To do this: Select this menu item:
Specify the dimension of the highlighted matrix
variable.

T > [Dimension]

Load a CSV format file into the highlighted matrix
variable.*

T > [CSV] > [Load]

Save the contents of the highlighted matrix variable to
a CSV format file.*

T > [CSV] > [Save As]

Delete the contents of the highlighted matrix variable. T > [Delete]
Clear the contents of all matrix variables. T > [Delete All]

*　For details, see “Using CSV Files” (page 244).

Matrix Input Window Operations
To do this: Select this menu item:
Select two rows and swap their elements. T > [Row Operation] > [Swap]*
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Replace each element of a specified row with the
scalar multiple of that row.

T > [Row Operation] > [*Row]*

Add the scalar multiples of each element of a specified
row to each element of another row.

T > [Row Operation] > [*Row+]*

Add each element of a specified row to each element
of another specified row.

T > [Row Operation] > [Row+]*

Delete the highlighted row. T > [Row] > [Delete]
Insert one row before the highlighted row. T > [Row] > [Insert]
Add one row after the highlighted row. T > [Row] > [Add]
Delete the highlighted column. T > [Column] > [Delete]
Insert a column before the highlighted column. T > [Column] > [Insert]
Add a column after the highlighted column. T > [Column] > [Add]
Edit the contents of the highlighted cell. T > [Edit]

*　Selecting this menu item displays a dialog for specifying row(s) and/or value(s).

List Calculations
Your calculator is provided with list variables (List 1 to List 26, List Ans) for list calculations.

Storing List Variables
You can use any one of the methods below to store list variables.
•　Method 1: Using Statistics app’s List Editor tab to create a list variable.
•　Method 2: Using the Calculate app to assign a list to a list variable

Example 1: {1,2,3} → List 1
Example 2: List 1 → List 2 (Assigns the contents of List 1 to List 2.)

•　Method 3: Using the Graph&Table app or the Table tab of the Recursion app to assign a single column of a
number table to a list variable

To assign (overwrite) a value to a specific element of a list variable
Syntax: value being assigned → list name [element number]
Example: To assign 20 to Element 2 of the following list: List 1 = {1,2,3,4,5}

20 sX(→) V > [List] > [List 1]
s4([) 2 s5(]) E

To check the current contents of List 1: V > [List]

To recall the value of a specific element of a list variable
Syntax: list name [element number]
Example: To recall the element 2 when List 1 = {1,2,3}

V > [List] > [List 1]s4([) 2 s5(]) E

Inputting a List into a Calculation
To use a list, you can use any one of the methods described below to input it into a calculation.

Method 1: Using the name of a list variable
To input “List 1”:

V > [List] > [List 1], or C > [Statistics] > [List] 1

Method 2: Inputting the sub-name of a list variable
To input a list variable with the sub-name* “QTY”:
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C > [Statistics] > [List] ”QTY”
*　For information about sub-names, see “Using the List Editor Tab” (page 31).

Method 3: Using linear input form ({1,2,3,…})
Select C > [Statistics] > [{ }] followed by a comma-separated list of elements.
To input {1,2,3}:

C > [Statistics] > [{ }] 1 ` 2 ` 3

Using Lists in Calculations
Your calculator supports the list calculations described below.
•　Arithmetic operations between lists and values or between lists, and function calculations with lists as

arguments
{1,2,3}+{4,5,6}, {1,2,3}×2, {1,2,3}2, {1,2,3}, etc.

Example 1: {1,2,3}+{4,5,6}
Using linear input form

C > [Statistics] > [{ }] 1 ` 2 ` 3r+
C > [Statistics] > [{ }] 4 ` 5 ` 6E

Using list variables (List 1 = {1,2,3}, List 2 = {4,5,6})
V > [List] > [List 1]+
V > [List] > [List 2]E

Example 2: To square the results of the above calculation

iE

•　Calculations Using List Manipulation Functions
Your calculator gives you the tools to create lists, manipulate elements, and calculate sums and means of the
elements in a list. For details, see the “Statistics” (page 230) section of “Catalog Menu Details” (page 221).

List Ans
List Ans is a variable that stores the latest list calculation result. Whenever a calculation result is in list form,
List Ans variable contents are overwritten with that result.
Calculation results less than 256 bytes are displayed in the result line on the Calculation tab, while results equal
to or more than 256 bytes are displayed in the Ans window. While the Ans window is displayed, pressing b
returns to the Calculation tab with the result line displayed as “List Result”.

Unit Conversions
You can convert a value from one unit to another. For details, see “Unit Conversions” (page 239).
Example: To convert 25.4 cm to inches

25.4 C > [Unit Conversions] > [Length] > [[cm]]
C > [Unit Conversions] > [I]

C > [Unit Conversions] > [Length] > [[in]]E
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Statistics App
The Statistics app provides you with the tools you need to perform statistical calculations based on input data,
to display summary statistics and regression model information, and to draw graphs. It also provides you with
hypothesis testing and confidence interval capabilities.

Selecting What You Want to Do with the Statistics App

2.　Press >.
•　If this causes the Select Type menu to appear, go to step 4 of this procedure. Otherwise, go to step 3.

4.　Use the menu to select what you want to do.

To do this: Highlight this menu item:
Displaying Summary Statistics or Regression Model
Information (page 32)*1

[Calculate Summary Statistics]

Drawing a Statistics Graph (page 35)*2 [Draw Statistics Graph]

Performing a Hypothesis Test (page 42) [Hypothesis Test]
Find a Confidence Interval (page 49) [Confidence Interval]
*1　Regression model information includes regression equations coefficients, coefficient of determination,

etc.
*2　Scatter plots and regression graphs based on 2-Variable data, histograms and box-and-whisker

diagrams based on 1-Variable data, etc.

5.　Press O.
•　This displays on the Setup tab a menu of settings for the item you selected.

Inputting Data
The Statistics app’s List Editor is an app-specific editor for inputting and editing statistical data. You can use
List Editor to create up to 26 list variables (List 1 to List 26) at a time.

Create from one to three list variables, depending on the statistical data to be processed.*1

1.　h > Statistics
•　This enters the Statistics app with the List Editor tab active.

3.　Highlight the first line of the Setup tab and then press O.
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Statistical data: Required list variable(s):
1-Variable (no frequencies) One list variable to assign to XList*2

1-Variable (with frequencies) Two list variables to assign to XList and Freq*2

2-Variable (no frequencies) Two list variables to assign to XList and YList*2

2-Variable (with frequencies) Three list variables to assign to XList, YList and Freq*2

*1　The method of statistical data creation for 1-Variable or 2-Variable statistical calculation is different from
that for performing hypothesis tests (page 42) or finding confidence intervals (page 49).

*2　This calculator displays list data used for 1-Variable statistical calculations as XList, list data used for
2-Variable statistical calculations as XList and YList, and list data used for frequencies as Freq or Frequency.

Frequencies
There are two ways to input statistical data: with frequencies and without frequencies (1 is used for all data
frequencies). You can specify which method you want to use on the Setup tab that appears when you press
> in List Editor, as shown in the example below.

Uses List1 for data.
Frequency of all data values: 1

Uses List1 for data.
Uses List2 for frequencies.

Important!
•　The values contained in a frequency list should be 0 or positive values only. Even a single negative

value causes an error (Out of Domain).
•　Statistical data with a frequency of 0 is not used for calculation of minimum and maximum values.

Inputting Data in List Editor
You can use either of the two methods below to input data in List Editor.

Individual cell input
With this method, you input a value into a cell and then press E.
You can also input a calculation into a cell. If you do, the numeric value that is the result of the calculation is
entered immediately after you press E.

Batch input using the form {1,2,3,...}
Example: To input {1,2,3,4,5}

1`2`3`4`5E

Assigning Other List Variables
You can assign List 1 data directly to List 2 or assign a list calculation (page 28) result to List 2.
Example: To assign List 1+2 (adds 2 to each element of List 1) to List 2

1.　Use the cursor keys to highlight list name List 2.

2.　Input “List 1+2”.

1.　Use the cursor keys to highlight the name of the list you want to use.

2.　Select C > [Statistics] > [{}], input the value, and then press E.
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V > [List] > [List 1]+2

Note
•　You can also use the Calculate app to manipulate list variables. See “Storing List Variables” (page 27).

Using the List Editor Tab

To edit cell contents
To do this: Perform this operation:
Replace the value of a cell Highlight the cell and input a new value.
Edit the contents of a cell Highlight the cell and then select T > [Edit].
Delete the contents of a cell Highlight the cell and then select T > [Delete] > [One Value].

•　This causes all the rows below the deleted cell to be shifted up one row.
Delete the contents of all cells
in a particular list

Highlight any cell in the list whose cell contents you want to delete and then
select T > [Delete] > [One List].

Delete all lists on the List Editor
tab

Select T > [Delete] > [All Lists].

Insert a new cell Select T > [Insert].
•　This inserts a new cell that contains the value 0. All the cells below the

inserted cell are shifted down one row.

To give a list a sub-name
Highlight the “SUB” row of the list to which you want to give a sub-name and then input the name you want. You
can input up to eight characters but only the characters that can fit within the width of the display are shown.
The “SUB” line is not displayed when the S > [Sub Name] setting is turned off.

To change the display color of a value
To do this: Perform this operation:
Change the display color of one
cell

1.　Highlight the cell whose value’s display color you want to change and
then select T > [Color].

2.　Select the color you want and then press O.
Change the display color of all
values in a list*

1.　Highlight the name of the list and then select T > [Color].
2.　Select the color you want and then press O.

*　The color of a list’s sub-name is not affected by this operation. Also, any values you input into blank cells
after performing this operation are displayed in black (default setting).

3.　Press E.

31



Sorting List Elements
Use the procedure below to sort the elements of a list on the List Editor tab in ascending or descending order
of their values. You can specify one list to use as the base list and then simultaneously sort the elements of up
to six lists accordingly.

1.　Select T > [Sort/Jump] > [Sort Ascending] or [Sort Descending].
•　This displays a dialog box for specifying the number of lists to sort.

2.　Specify the number of lists to be sorted and then press O.
•　This displays a dialog for specifying the base list for the sort.

3.　Input the number of the list to use as the base list and then press O.
•　If you specified one list in step 2, pressing O sorts the data in the list whose number you input here.
•　If you specified two or more lists in step 2, pressing O displays a dialog for specifying the second list to

be sorted simultaneously.

4.　As dialogs appear, sequentially input the numbers of the other lists to be sorted.
•　Specifying the same list more than once results in an error. An error also occurs if you try to execute

sorting and all of the lists do not have the same number of elements (lines).

List Files
Your calculator provides six list files (File 1 to File 6) that hold a total of 26 list variables (List 1 to List 26) each,
which means you can store up to 156 list variables in memory. However, the calculator can handle up to 26 list
variables (those in the currently open list file) at one time. To switch between list files, select S > [List File].

Importing and Exporting CSV Files
You can export the currently open list file to a CSV file. You can also import the contents of a CSV file into a
list file. For details, see “Using CSV Files” (page 244).

Displaying Summary Statistics or Regression Model Information
You can use the procedure below to find and display various summary statistics from 1-Variable or 2-Variable
statistical data. This procedure can also be used to display regression equation coefficients and coefficients
of determination (referred to as “regression model information” in this manual) when regression models are
applied to 2-Variable statistical data.

Operation Flow
1.　Input the statistical data to use in the calculation.

•　Use List Editor to input the data and then create the list variables you need. For details, see “Inputting
Data” (page 29).

2.　Use the procedure under “Selecting What You Want to Do with the Statistics App” (page 29) to select
[Calculate Summary Statistics].

3.　Highlight line 2 on the tab and then press O.

4.　On the menu that appears, select the type of statistical calculation you want to perform.

To do this: Select this menu item:
Display summary statistics based on 1-Variable statistical data
(X) 1-Variable

Display summary statistics based on 2-Variable statistical data
(X, Y) 2-Variable

•　This causes the Calculate Statistics menu to appear on the
Setup tab.
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Display regression model information based on 2-Variable
statistical data (X, Y)
(Select the desired regression model from the menu.)

Linear Regression(ax+b)
Linear Regression(a+bx)
Med-Med Regression
Quadratic Regression
Cubic Regression
Quartic Regression
Logarithm Regression
Exp Regression(a･e^bx)
Exp Regression(a･b^x)
Power Regression
Sinusoidal Regression
Logistic Regression

5.　If necessary, specify a list to use as statistical data.
For 1-Variable statistical data:
(1)　 Highlight [1Var XList] and then press O.
(2)　 Use the dialog that appears to specify the number of the list variable to use as data and then press O.
(3)　 Highlight [1Var Freq] and then press O.
For 2-Variable statistical data:
(1)　 Highlight [2Var XList] and then press O.
(2)　 Use the dialog that appears to specify the number of the list variable to use as data for XList and then

press O.
(3)　 Highlight [2Var YList] and then press O.
(4)　 Use the dialog that appears to specify the number of the list variable to use as data for YList and then

press O.
(5)　 Highlight [2Var Freq] and then press O.

6.　Press >. Or highlight  and then press O.

•　See “Summary Statistics” (page 33) and “Regression Model Information” (page 34) for the meanings
of the values that appear on the display.

Summary Statistics

1-Variable

x− mean
Σx sum

Σx2 sum of squares

σx population standard deviation

sx sample standard deviation

n number of data
minX minimum value
Q1 first quartile*
Med median

•　This displays the summary statistics or regression model
information you selected in step 4 on the Results tab. If a
scroll bar appears along the right edge of the window, use
d and u to scroll the display.
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Q3 third quartile*
maxX maximum value
Mod mode
Mod:n number of data mode items
Mod:F data mode frequency

*　The Q1 and Q3 calculation method is in accordance with the S > [Q1Q3 Type] setting. For details, see
“Q1Q3 Type (Statistics)” (page 216).

2-Variable

x− mean of the XList data
Σx sum of the XList data

Σx2 sum of squares of the XList data

σx population standard deviation of the XList data

sx sample standard deviation of the XList data

n number of data
y− mean of the YList data
Σy sum of the YList data

Σy2 sum of squares of the YList data

σy population standard deviation of the YList data

sy sample standard deviation of the YList data

Σxy sum of products of the XList data and YList data
minX minimum value of the XList data
maxX maximum value of the XList data
minY minimum value of the YList data
maxY maximum value of the YList data

Note
•　The value of each summary statistic of 1-Variable above is stored in variables included in C >

[Variable Data] > [Statistics] > [X] (page 240) and C > [Variable Data] > [Statistics] > [Graph]
(page 240) (except Mod:n and Mod:F).

•　The value of each summary statistic of 2-Variable above is stored in variables included in C >
[Variable Data] > [Statistics] > [X] (page 240) and C > [Variable Data] > [Statistics] > [Y] (page 240).

Regression Model Information

When regression model information is displayed on the Results tab, the regression model name is displayed
in the first line and the regression formula is in the bottom line. The information displayed according to the
regression model is shown in the table below.
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Regression Models Displayed Information*

Linear Regression(ax+b) a, b, r, r2, MSe
Linear Regression(a+bx) a, b, r, r2, MSe
Med-Med Regression a, b
Quadratic Regression a, b, c, r2, MSe
Cubic Regression a, b, c, d, r2, MSe
Quartic Regression a, b, c, d, e, r2, MSe
Logarithm Regression a, b, r, r2, MSe
Exp Regression(a･e^bx) a, b, r, r2, MSe
Exp Regression(a･b^x) a, b, r, r2, MSe
Power Regression a, b, r, r2, MSe
Sinusoidal Regression a, b, c, d, MSe
Logistic Regression a, b, c, MSe

*　a, b, c, d, e: regression formula coefficients, r: correlation coefficient, r2: coefficient of determination, MSe:
mean square error

Note
•　Each value of the above “Displayed Information” items is stored in a variable in C > [Variable Data]

> [Statistics] > [Graph] (page 240).
•　When a Med-Med Regression calculation is performed, each of the three sets of summary point

coordinates (x1, y1; x2, y2; x3, y3) is stored in variables in C > [Variable Data] > [Statistics] > [Point
Coordinates] (page 241).

What you can do while viewing regression model information
You can perform the operations shown below while regression model information is displayed on the Results
tab.

To do this: Perform this operation:
Save the calculation result regression equation to a
function variable

1.　Select T > [Save Function].
2.　From the menu that appears, select the destination

function number*1 and then press O.
Find the residuals (yn－y′n) of the actual data (xn, yn)
and the values (xn, y′n) calculated by the regression
model and save them to a list variable

1.　Select T > [Save Residuals in List].
2.　Use the dialog that appears to input the number of

a list*2 and then press O.

*1　Select a function number where nothing is currently stored. Overwrite saving is not available.
*2　Input the number of an empty list. Overwrite saving is not available.

Drawing a Statistics Graph
You can use 2-Variable statistical data to draw scatter plots and various regression graphs. 1-Variable statistical
data can be used to draw seven types of graphs, including histograms and box-and-whisker diagrams. After
drawing a graph, you can display summary statistics and regression model information.

Drawing Scatter Plots and Regression Graphs Using the Default Settings
In this example, we draw a scatter plot from 2-Variable statistical data and then draw a regression graph on
top of it.

1.　Use List Editor to input the data below.

List 1 List 2

11 1.5
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21 2.2

32 3.4

43 5.1

59 8.7

•　For details, see “Inputting Data” (page 29).

2.　Use the procedure under “Selecting What You Want to Do with the Statistics App” (page 29) to select [Draw
Statistics Graph].

Note
•　For details about Graph1 to Graph3 on the Setup tab in step 2 above, see “Drawing Graphs Using

Multiple Graph Setups” (page 42).
•　For details about Graph tab operations in step 4 above and Regression Graph tab operations in step

6, see “Graph Window Operations” (page 41).
•　For the meaning of the values displayed on the Results tab in step 5 above, see “Regression Model

Information” (page 34).

Drawing a 1-Variable Statistics Graph (Histogram, Box-and-Whisker Diagram, etc.)
You can perform the operations below based on 1-Variable statistical data you input into List Editor.
(1) Draw a Box Plot, Histogram, Broken Line Graph, Pie Chart, Bar Graph, Normal Probability Plot, or Normal

Density Curve.
(2) Display summary statistics after drawing the graph (except for Pie Chart).

•　This causes the Draw Statistics Graph menu to appear on
the Setup tab. The default Graph1 setting is Scatter (scatter
plots), and the settings of Graph2 and Graph3 are both None
(Do not graph).

3.　Highlight [Graph1] and then press O.
•　This causes the Setup tab display to change to the Graph1

setting menu.
•　By default, XList is assigned List1, YList is assigned List2,

and Frequency is 1.

4.　Press >.
•　This draws a scatter plot with List1 data on the x-axis and

List2 data on the y-axis.

5.　Press >. From the menu that appears, select [Quadratic
Regression].
•　This applies a quadratic regression model to the data and

displays the calculation results.

6.　Press >.
•　This draws a quadratic regression graph overlaid on the

scatter plot.
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Operation Flow
1.　Use List Editor to input your data.

•　For details, see “Inputting Data” (page 29).

2.　Use the procedure under “Selecting What You Want to Do with the Statistics App” (page 29) to select [Draw
Statistics Graph].

3.　Select the type of graph you want to draw.
(1)　 Highlight [Graph1] and then press O.

(2)　 Press O again.
•　This displays a menu for selecting the graph type.

(3)　 Highlight the type of graph you want to draw from the menu and then press O.

4.　Specify a list to use as statistical data.
For a Box Plot, Histogram, Broken Line Graph, Normal Probability Plot, or Normal Density Curve:

(1)　 Highlight [XList] and then press O.
(2)　 Use the dialog that appears to specify the number of the list variable to use as data and then press

O.
(3)　 Highlight [Frequency] and then press O. (Excluding Normal Probability Plot)

For a Pie Chart:

(1)　 Highlight [Data] and then press O.
(2)　 Use the dialog that appears to specify the number of the list variable to use as data and then press

O.
•　When drawing a Pie Chart, you can use a maximum of 20 list variables (number of rows in a list).

For a Bar Graph:
You can specify up to three list variables as data for drawing bar graphs.

(1)　 Highlight [Data1] and then press O.
(2)　 Use the dialog that appears to specify the number of the list variable to use as data and then press

O.
(3)　 Repeat the steps (1) and (2) above for [Data2] and [Data3].

•　When using multiple list variables, make sure that the number of elements in all of them is the same.
If all of the list variables do not have the same number of elements, an error (Dimension ERROR)
results.

•　When using two list variables, assign them to [Data1] and [Data2]. Assigning list variables to [Data1]
and [Data3] and specifying None for [Data2] results in an error (Condition ERROR).

5.　Specify the graph color and other settings as required.
•　For details, see “Setting Items for Each 1-Variable Statistics Graph Type” (page 38).

6.　To draw the graph, press >. Or highlight  and then press O.
•　The graph is displayed on the Graph tab.

•　This causes the Draw Statistics Graph menu to appear on
the Setup tab.

•　This causes the Setup tab display to change to the Graph1
setting menu.
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•　If the graph you selected in step 3-(2) is a Histogram or Broken Line Graph, a dialog box appears where
you can specify Start (x-coordinate of the graph drawing start point) and Width (graph drawing width).
Input each of the values, highlight , and then press O.

•　For information about the operations you can perform on the Graph tab, see “Graph Window Operations”
(page 41).

7.　To view summary statistics, press >. (This operation cannot be used for a Pie Chart.)
•　This causes the summary statistics to appear on the Results tab. You can use d and u to scroll the

display contents.
•　For the meanings of the displayed summary statistics values, see “Summary Statistics” (page 33).

Setting Items for Each 1-Variable Statistics Graph Type

Box Plot
Outliers: Shows or hides outlier dots in a Box Plot.

[On]: Show
[Off]: Hide

minX

Q1
Med

Q3

maxX

Outlier dot

Box: Specifies the color of the border of the box area from Q1 to Q3, and the Med line.
Whisker: Specifies the color of the lines extending from the ends of the box to minX and maxX.
OutlierColor: Specifies the color of the outlier dots.
Box Inside: Specifies the fill color of the box area from Q1 to Q3.

- Area Color: Specifies the fill color.
Selecting [Auto] fills the area inside of the box from Q1 to Med with blue
and fills the inside of the box from Med to Q3 with yellow.

- Paint Style: Specifies the density of the fill color.
[Normal]: Normal density fill
[Lighter]: Lighter density fill

Note
•　Changing the S > [Q1Q3 Type] setting may alter the position of Q1 and Q3 even if Box Plot is

drawn based on the same data.

Histogram
Area: Specifies the fill color of the histogram.

- Area Color: Specifies the fill color.
Selecting [Auto] automatically colors each data item, cycling through six
colors in the following sequence: blue, red, green, magenta, cyan, yellow.

- Paint Style: Same as Box Plot.
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Border: Specifies the histogram border color. A border is not drawn if [Clear] is selected.

Broken Line Graph
Color: Specifies the graph draw color.

Pie Chart
Display: Specifies the data display form.

[%]: Percentages
[Data]: Values

Pie Area: Specifies the fill color of the pie chart.
- Area Color: Same as Histogram.
- Paint Style: Same as Box Plot.

Pie Border: Specifies the border color of the pie chart. A border is not drawn if [Clear] is selected.

Bar Graph
Stick Style: Specifies the orientation of the bars.

[Length]: Vertical
[Horizontal]: Horizontal

D1 Area, D2 Area, D3 Area:
Specifies the fill color of each bar for Data1, Data2, and Data3

- Area Color: Same as Histogram.
- Paint Style: Same as Box Plot.

D1 Border, D2 Border, D3 Border:
Specifies the border color of each bar for Data1, Data2, and Data3. Borders are not
drawn if [Clear] is selected.

Normal Probability Plot
Mark Type: Specifies the mark to use for the plot.
Color: Specifies the graph draw color.

Normal Density Curve
Color: Specifies the graph draw color.

Drawing a 2-Variable Statistics Graph (Scatter Plot or Regression Graph)
You can perform the operations below based on 2-Variable statistical data you input into List Editor.
(1) Draw a Scatter Plot, xy Line Graph, or regression graph
(2) After drawing a graph, display summary statistics or regression model information
(3) Draw a regression graph over a graph described in (1) above*

*　Common practice in (1) is to draw a Scatter Plot and then draw a regression graph over it. You can also draw
a regression graph over a xy Line Graph or another regression graph.

Operation Flow
1.　Use List Editor to input your data.

•　For details, see “Inputting Data” (page 29).

2.　Use the procedure under “Selecting What You Want to Do with the Statistics App” (page 29) to select [Draw
Statistics Graph].
•　This causes the Draw Statistics Graph menu to appear on the Setup tab.

3.　Select the type of graph you want to draw.
(1)　 Highlight [Graph1] and then press O.

•　This causes the Setup tab display to change to the Graph1 setting menu.
(2)　 Press O again.

•　This displays a menu for selecting the graph type.
•　The menu includes both 1-Variable and 2-Variable graphs. Choose Scatter Plot, xy Line Graph, or

regression graph.
(3)　 Highlight the type of graph you want to draw from the menu and then press O.

39



4.　Specify a list to use as statistical data.
(1)　 Highlight [XList] and then press O.
(2)　 Use the dialog that appears to specify the number of the list variable to use as data for XList and then

press O.
(3)　 Highlight [YList] and then press O.
(4)　 Use the dialog that appears to specify the number of the list variable to use as data for YList and then

press O.
(5)　 Highlight [Frequency] and then press O. (This operation does not work with a Sinusoidal Regression

Graph or Logistic Regression Graph.)

5.　Specify the graph color and other settings as required.
•　Mark Type: If you selected Scatter Plot or xy Line Graph as the graph type, specify the mark to use for

the plot.
•　Color: Specifies the graph draw color.

6.　To draw the graph, press >. Or highlight  and then press O.
•　The graph is displayed on the Graph tab.
•　For information about the operations you can perform on the Graph tab, see “Graph Window Operations”

(page 41).

7.　Display summary statistics or regression model information.
(1)　 Press >.
(2)　 Perform the operations described in the table below.

To display this information: Select this menu item:
Summary statistics 2-Variable

Regression model information
(You can select the one regression model you
want.)

Linear Regression(ax+b)
Linear Regression(a+bx)
Med-Med Regression
Quadratic Regression
Cubic Regression
Quartic Regression
Logarithm Regression
Exp Regression(a･e^bx)
Exp Regression(a･b^x)
Power Regression
Sinusoidal Regression
Logistic Regression

(3)　 Press O.
•　This displays the details of the menu item you selected in step (2) above on the Results tab.
•　See “Summary Statistics” (page 33) and “Regression Model Information” (page 34) for the meanings

of the displayed values.

8.　Press > to go to the Regression Graph tab and draw a regression graph.

9.　Add regression graphs as needed.
You can add multiple regression graphs on the Regression Graph tab. To do this, perform the steps below.

•　Choosing one of the regression models in step 7 draws a
regression graph over the graph drawn in step 6.
Choosing 2-Variable displays only the graph drawn in step
6.

(1)　 Select T > [Draw Regression Graph].
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•　For operations that are available on the Regression Graph tab, see “Graph Window Operations”
(page 41).

Graph Window Operations
This section describes operations available with the Statistics app’s graph window (Graph tab or Regression
Graph tab).

Pie Chart Only Operations
The operations below are available while a Pie Chart is displayed.

To do this: Perform this operation:
Toggle displayed values between data values and
percentages

Select T > [%/Data].

Save displayed Pie Chart percentage values to a list
variable

1.　Select T > [Save % in List].
2.　Use the dialog that appears to input a storage

destination list number and then press O.

To show or hide tabs
See “Showing and Hiding Tabs” (page 79).

To move the graph window up, down, left, or right
Use the cursor keys.

To zoom the graph window in or out
Press + to zoom in or - to zoom out.

Using Trace (Trace)
Trace displays a cross pointer ( ) on a graph, which you can use to read the coordinate values at a specific
location. To enable trace, select T > [Trace]. The operations that can be performed while the trace function
is enabled are described in the table below.

To do this: Perform this operation:
Move the pointer along the graph Press l or r.
When there are multiple graphs, move the pointer
between them

Press d or u.

Exit trace Press b.

Using Zoom (Zoom)
The menu items of T > [Zoom] can be used to change the display range of the graph window. For details, see
“Changing the Graph Window Zoom Setting (Zoom)” (page 81). The Statistics app’s zoom does not support
[Zoom Auto].

To specify the display range of the graph window (View Window)
See “Statistics Graph View Window Settings” (page 52).

Using Sketch (Sketch)
You can use sketch to draw dots, lines, and text within the graphing area. For details, see “Using Sketch
(Sketch)” (page 85). The menu items below are available with the Statistics app.
[Clear Screen], [Plot], [Line], [Circle], [Vertical Line], [Horizontal Line], [Pen], [Text]

To graph a function input with the Graph&Table app (Draw Function)
While a 2-Variable graph is displayed, you can use the operation below to overlay graphs of functions.

(2)　 From the menu that appears, select the regression model
you want and then press O.
•　This adds the graph of the regression model you selected.
•　You can repeat steps (1) and (2) above to add more

regression graphs.
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1.　Select T > [Draw Function].

2.　On the menu that appears, highlight the function you want to graph and then press O.

To find the y-values for x-values on a regression graph (Graph Solve)
While a regression graph is displayed, you can use the operation below to find the y-value for any x-value on
the graph.

1.　Select T > [Graph Solve] > [y-Cal].

2.　Use the dialog that appears to input the x-value and then press O.
•　The x- and y-coordinate values on the regression graph are displayed at the bottom of the window.
•　If both the x- and y-coordinate values are within the window’s range, a pointer appears at the coordinates

on the graph.
•　To redisplay the dialog and input another x-value, press O.

3.　To exit this operation, press b.

To adjust the background image (Fade I/O)
You can use this operation to adjust the opacity of the background image. See “Adjusting the Graph Window
Background Image (Fade I/O)” (page 81).

Drawing Graphs Using Multiple Graph Setups
Graph1, Graph2, and Graph3 in the Draw Statistics Graph menu are independent areas for configuring graph
settings. By default, None (Do not graph) is specified for Graph2 and Graph3, and only the Graph1 settings
are used for graphing.
If you want, you can use two or three graph setups to simultaneously draw multiple graphs.

Note the points below when using multiple graph setups for graphing.
•　Pressing > to go from the Graph tab to the Results tab displays a menu for selecting a graph setup. Choose

a graph setup from the menu and press O.
•　Graph setups for a 1-Variable graph in one area and a 2-Variable graph in another area cannot be used to

draw simultaneous graphs.
•　When drawing a Pie Chart or Bar Graph, only the graph setup for the graph you are drawing should be

assigned to an area. None should be specified for the other areas. In the case of a Pie Chart or Bar Graph,
you can draw using only one graph setup at a time.

Performing a Hypothesis Test
Statistical hypotheses are tested in a variety of ways and results are presented numerically and graphically.
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Operation Flow
1.　Use List Editor to input the data and then create the list variables as required.

•　For details about the input operation, “Inputting Data” (page 29).
•　Create list variables only as needed for the test type. See “Test Types and List Variables” (page 44). You

need to create a list variable if you want to perform a Linear Regression t-Test, χ2 Goodness-of-Fit Test,
or ANOVA.

2.　Use the procedure under “Selecting What You Want to Do with the Statistics App” (page 29) to select
[Hypothesis Test].

3.　Select a test type.
(1)　 Highlight line two of the Hypothesis Test menu and then press O.
(2)　 From the menu that appears, select a test type.

To select this: Select this menu item: Result:
1-Sample Z Test [Z Test] > [1-Sample Z Test]

To Step 4
2-Sample Z Test [Z Test] > [2-Sample Z Test]
1-Proportion Z Test [Z Test] > [1-Proportion Z Test]

To Step 5
2-Proportion Z Test [Z Test] > [2-Proportion Z Test]
1-Sample t Test [t Test] > [1-Sample t Test]

To Step 4
2-Sample t Test [t Test] > [2-Sample t Test]
Linear Regression t Test [t Test] > [Linear Regression t Test] To Step 5

χ2 Goodness-of-Fit Test [χ2 Test] > [χ2 Goodness-of-Fit Test]
To Step 6

χ2 Two-Way Test [χ2 Test] > [χ2 Two-Way Test]
2-Sample F Test [2-Sample F Test] To Step 4
ANOVA [ANOVA] To Step 6

4.　Select the sample data specification method.
(1)　 Highlight [Data] and then press O.
(2)　 Perform the operations described in the table below.

To do this: Perform this operation:
Use a list variable to specify the sample data On the menu that appears, highlight [List] and then

press O.

Input the sample mean, standard deviation,*1 and
number of data points

On the menu that appears, highlight [Variable] and
then press O.

*1　No input is required for the Z test.

5.　Input the parameters for the alternative hypothesis.
•　For information about sample type-specific parameters, see “Test Types and Parameters” (page 45).
•　For example, if you chose [Z Test] > [1-Sample Z Test] in step 3, perform the steps below.
(1)　 Highlight [μ] and then press O.
(2)　 On the menu that appears, highlight the direction of the test (≠, <, or >) and then press O.
(3)　 Highlight [μ0], input the numeric value of the hypothetical population mean, and then press O.

6.　Input the other parameters.
•　For information about sample type-specific parameters, see “Test Types and Parameters” (page 45).

•　This displays the Hypothesis Test menu on the Setup tab.
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7.　Specify the graph color as required.*2

(1)　 Highlight [Color] and then press O.
(2)　 On the menu that appears, highlight the color you want and then press O.

8.　Press >. Or highlight  and then press O.
•　This displays, on the Results tab, test calculation results and input values (or summary statistics calculated

from the specified data).
•　For a description of the calculation results displayed and the operations available on the Results tab, see

“Using the Test Results Tab” (page 46).

9.　To display the graph, press >.*2
•　For operations that can be performed on the Graph tab, see “Using the Test Graph Tab” (page 48).
*2　This operation is not required in the following cases.

-　When the test type is Linear Regression t Test
-　When the test type is ANOVA, with [How Many] > [1] specified

Test Types and List Variables
Depending on the type of test you want to perform, input data in List Editor and create list variables as described
below.

Linear Regression t Test
Required list variable(s): Setup tab display:
Three list variables for use as XList (x data), YList (y data), and Freq
(frequency data)*

*　If you are not using frequency data, you do not need the Freq list variable.

χ2 Goodness-of-Fit Test
Required list variable(s): Setup tab display:
Two list variables used for Observed (observed counts)* and Expected
(expected frequencies)

*　All list elements must be positive integers.

ANOVA
You can perform either One-Way ANOVA or Two-Way ANOVA. On the Setup tab, select [How Many] > [1] for
One-Way ANOVA or [2] for Two-Way ANOVA.

ANOVA Types: Required list variable(s): Setup tab display:
One-Way ANOVA Two list variables used for Factor A (Factor

A condition) and Dependnt (sample data)

Two-Way ANOVA Three list variables used for Factor A
(Factor A condition), Factor B (Factor B
condition) and Dependnt (sample data)

The list variables used in ANOVA are created as described below.
•　One-Way ANOVA: For example, if there are two conditions (Condition 1, Condition 2) for Factor A, each list

is created as shown below.

Factor A Dependent    
1 113

Condition 1 sample data
1 116
2 133

Condition 2 sample data
2 131

•　Two-Way ANOVA: For example, if there are two different conditions (Condition 1, Condition 2) for Factor A
and Factor B, each list is created as shown below.
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Factor A Factor B Dependent    
1 1 113 Factor A Condition 1 × Factor B

Condition 1 sample data1 1 116
2 1 133 Factor A Condition 2 × Factor B

Condition 1 sample data2 1 131
1 2 139 Factor A Condition 1 × Factor B

Condition 2 sample data1 2 132
2 2 126 Factor A Condition 2 × Factor B

Condition 2 sample data2 2 122

1-Sample or 2-Sample Z Test, 1-Sample or 2-Sample t Test, 2-Sample F Test
If you choose [Data] > [List] in step 4 under “Operation Flow” (page 43), need to create the following list variables.

Sample data: Required list variable(s): Setup tab display:
One sample data (no
frequencies)

List variable to assign to List

One sample data (with
frequencies)

Two list variables to assign to List and Freq

Two sample data (no
frequencies)

Two list variables to assign to List(1) and
List(2)

Two sample data (with
frequencies)

Four list variables to assign to List(1),
List(2), Freq(1), Freq(2)

Test Types and Parameters

Alternative Hypothesis Parameters
Test Type: Parameter:

1-Sample Z Test
1-Sample t Test

μ: test conditions (“≠μ0” specifies two-tail test, “<μ0” specifies lower one-tail
test, “>μ0” specifies upper one-tail test.)
μ0: assumed population mean

2-Sample Z Test
2-Sample t Test

μ1: test conditions (“≠μ2” specifies two-tail test, “<μ2” specifies one-tail test
where sample 1 is smaller than sample 2, “>μ2” specifies one-tail test where
sample 1 is greater than sample 2.)

1-Proportion Z Test
Prop: test conditions (“≠p0” specifies two-tail test, “<p0” specifies lower
one-tail test, “>p0” specifies upper one-tail test.)
p0: expected sample proportion (0 < p0 < 1)

2-Proportion Z Test
p1: test conditions (“≠p2” specifies two-tail test, “<p2” specifies one-tail test
where sample 1 is smaller than sample 2, “>p2” specifies one-tail test where
sample 1 is greater than sample 2.)

Linear Regression t Test β&ρ: test conditions (“≠0” specifies two-tail test, “< 0” specifies lower one-tail
test, “> 0” specifies upper one-tail test.)

2-Sample F Test
σ1: test conditions (“≠σ2” specifies two-tail test, “<σ2” specifies one-tail test
where sample 1 is smaller than sample 2, “>σ2” specifies one-tail test where
sample 1 is greater than sample 2.)

Other Parameters
Parameters in the table below that are marked with an asterisk (*) need to be input when you select [Data] >
[Variable] in step 4 of the procedure under “Operation Flow” (page 43).

Test Type: Parameter:

1-Sample Z Test
σ: population standard deviation (σ > 0)
x−: mean of sample*
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n: size of sample (positive integer)*

2-Sample Z Test

σ1: population standard deviation of sample 1 (σ1 > 0)
σ2: population standard deviation of sample 2 (σ2 > 0)
x−1: mean of sample 1*

n1: size of sample 1 (positive integer)*

x−2: mean of sample 2*

n2: size of sample 2 (positive integer)*

1-Proportion Z Test
x: sample value (x ≥ 0 integer)
n: size of sample (positive integer)

2-Proportion Z Test

x1: data value of sample 1 (x1 ≥ 0 integer)
n1: size of sample 1 (positive integer)
x2: data value of sample 2 (x2 ≥ 0 integer)
n2: size of sample 2 (positive integer)

1-Sample t Test
x−: mean of sample*

sx: sample standard deviation (sx > 0)*

n: size of sample (positive integer)*

2-Sample t Test

x−1: mean of sample 1*

sx1: standard deviation of sample 1 (sx1 > 0)*

n1: size of sample 1 (positive integer)*

x−2: mean of sample 2*

sx2: standard deviation of sample 2 (sx2 > 0)*

n2: size of sample 2 (positive integer)*

Pooled: pooling On (in effect) or Off (not in effect)

χ2 Goodness-of-Fit Test

Observed: specify a list variable (List 1 to List 26) that contains observed
counts (all list elements must be positive integers).
Expected: specify a list variable (List 1 to List 26) as the storage location of
expected frequency.
df : degrees of freedom (positive integer)
CNTRB: specify a list variable (List 1 to List 26) as the storage location of
the contribution of each observed count obtained as calculation results.

χ2 Two-Way Test

Observed: Specifies a matrix variable (Mat A to Mat Z) that contains
observed counts. Be sure to specify a matrix that satisfies the conditions
below. An error results if you specify a matrix that does not satisfy these
conditions.
•　The matrix must have at least 2 rows and 2 columns.
•　All elements of the matrix must be positive integers.
Expected: Specifies a matrix variable (Mat A to Mat Z) that contains expected
frequencies.

2-Sample F Test

sx1: standard deviation of sample 1 (sx1 > 0)*

n1: size of sample 1 (positive integer)*

sx2: standard deviation of sample 2 (sx2 > 0)*

n2: size of sample 2 (positive integer)*

ANOVA
How Many:

1: One-Way ANOVA
2: Two-Way ANOVA

Using the Test Results Tab

Information on the Results Tab
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When a test other than ANOVA is performed
Test calculation results and summary statistics of the sample data are displayed on the Results tab. The
meanings of the items that appear on the display are provided below.
Test calculation results
p: p-value
z: z score (Z Test)
t: t value (t Test)

χ2: χ2 value (χ2 Test)
F: F value (F Test)
p: estimated sample proportion (1-

Proportion/2-Proportion Z Test)
p1: estimated proportion of sample 1 (2-

Proportion Z Test)
p2: estimated proportion of sample 2 (2-

Proportion Z Test)
df : degrees of freedom (2-Sample t Test,

Linear Regression t Test, χ2 Test)
a: constant term (Linear Regression t

Test)
b: coefficient (Linear Regression t Test)

Summary statistics of sample data
x−: mean of sample
x−1: mean of sample 1

x−2: mean of sample 2

sx: sample standard deviation

sx1: standard deviation of sample 1

sx2: standard deviation of sample 2

sp: pooled sample standard deviation

n: size of sample
n1: size of sample 1

n2: size of sample 2

se: standard error

r: correlation coefficient

r2: coefficient of determination

When ANOVA is performed
Calculation results are displayed using the same table form as that used in textbooks.

One-Way ANOVA
*1

Line 1: A values
Line 2: ERR values

Two-Way ANOVA
*1

Line 1: A values
Line 2: B values
Line 3: AB values*2

Line 4: ERR values
*1　The tables shown here would be displayed by the calculator across two screens, so you would need to

scroll left and right to view all of the table contents.
*2　Line 3 does not appear when there is only one observation in each cell.
 
Column 1: df ... degrees of freedom
Column 2: ss ... sum of squares
Column 3: ms ... mean squares
Column 4: F ... F value
Column 5: P ... p-value
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Note
•　Values displayed on the Results tab are stored in variables in C > [Variable Data] > [Statistics] >

[Result] > [Test] (page 241) and C > [Variable Data] > [Statistics] > [Input] (page 241). However,
variables a and b are in C > [Variable Data] > [Statistics] > [Graph] (page 240).

What you can do while displaying calculation results
You can use the operation below to save all numeric values currently displayed on the Results tab*1 to a list
variable.

1.　Select T > [Save Result in List].

2.　Use the dialog box that appears to input the number of the list you want to use as a save destination*2*3 and
then press O.

*1　Includes the currently displayed calculation results and input values. However, alternative hypothesis
parameters (page 45) are not saved.

*2　Input the number of an empty list. Overwrite saving is not available.
*3　With ANOVA, each of the five calculation result columns is saved to five list variables, starting from the list

number you input. You can specify a list number within the range from 1 to 22.

Note
•　You can perform the operations described below while the calculation results of Linear Regression t

Test are displayed.
-　Save the calculation result regression equation to a function variable.
-　Find the residuals between the actual data and the values calculated by the regression model and

save them to list variables.
See “What you can do while viewing regression model information” (page 35).

Using the Test Graph Tab

When you perform a test other than Two-Way ANOVA
You can perform the operations below after performing one of the following tests: 1-Sample Z Test, 2-Sample
Z Test, 1-Proportion Z Test, 2-Proportion Z Test, 1-Sample t Test, 2-Sample t Test, χ2 Goodness-of-Fit Test,
χ2 Two-Way Test, 2-Sample F Test.

To do this: Select this menu item:
Display the p-value T > [Calculate P Value]
Z Test: Display the z-value and display a cross pointer at the
corresponding point on the graph T > [Calculate Z Value]*1*2

1-Sample/2-Sample t Test: Display the t-value(s) and display a
cross pointer at the corresponding point on the graph T > [Calculate T Value]*1*2

χ2 Test: Display the χ2-value(s) and display a cross pointer at the
corresponding point on the graph

T > [Calculate CHI Value]*1*2

2-Sample F Test: Display the F-value and display a cross pointer
at the corresponding point on the graph T > [Calculate F Value]*1*2

*1　For a two-tailed test, the cross pointer moves between the two values each time l or r is pressed.
*2　A relevant point outside of the display range is not displayed.

Note
•　Calculation results displayed by the above operations are stored in the alpha variables described

below.

Z Test z- and p-values are stored in variables Z and P respectively.
t Test t- and p-values are stored in variables T and P respectively.
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χ2 Test χ2- and p-values are stored in variables C and P respectively.
F Test F- and p-values are stored in variables F and P respectively.

The displays below show an example of what would happen if you perform a one-sample t-test with μ≠μ0

(two-tailed test) and then draw a graph. The display on the right is an example when you select T > [Calculate
T Value].

When Two-Way ANOVA is performed
With Two-Way ANOVA, you can draw Interaction Plot graphs. The number of graphs depends on Factor B,
while the number of x-axis data depends on Factor A. The y-axis is the mean value of each category.
Selecting T > [Trace] displays a cross pointer on the graph (Trace). Pressing l or r moves the pointer
on the graph in the corresponding direction. When there are multiple graphs, you can use d and u to move
between graphs.

Using the Trace function automatically stores the last condition number of factor A to variable A and the mean
value of the last category to variable M, respectively.

Find a Confidence Interval
You can use the procedure below to find the upper and lower limits of the confidence interval from given sample
data and confidence level.

Operation Flow
1.　Use List Editor to input the data and then create the list variables as required.

•　For details about the input operation, “Inputting Data” (page 29).
•　See “Confidence Interval Types and List Variables” (page 51) for the list variables that need to be created.

2.　Use the procedure under “Selecting What You Want to Do with the Statistics App” (page 29) to select
[Confidence Interval].

3.　Select the confidence interval type.
(1)　 Highlight line 2 of the Confidence Interval menu and then press O.
(2)　 From the menu that appears, select a confidence interval type.

To select this: Select this menu item: Result:
1-Sample Z Interval [Z Confidence Interval] > [1-Sample Z Interval]

To Step 4
2-Sample Z Interval [Z Confidence Interval] > [2-Sample Z Interval]

•　This displays the Confidence Interval menu on the Setup tab.
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1-Proportion Z Interval [Z Confidence Interval] > [1-Proportion Z Interval]
To Step 5

2-Proportion Z Interval [Z Confidence Interval] > [2-Proportion Z Interval]
1-Sample t Interval [t Confidence Interval] > [1-Sample t Interval]

To Step 4
2-Sample t Interval [t Confidence Interval] > [2-Sample t Interval]

4.　Select the sample data specification method.
(1)　 Highlight [Data] and then press O.
(2)　 Perform the operations described in the table below.

To do this: Perform this operation:
Use a list variable to specify the sample data On the menu that appears, highlight [List] and then

press O.
Input the sample mean, standard deviation, and
number of data points

On the menu that appears, highlight [Variable] and
then press O.

5.　Input values for the parameters.
(1)　 Highlight [C-Level] and then use the number keys to input the confidence level.

•　Input a value between 0 and 1. Commonly used confidence levels are 0.95 (95%) and 0.99 (99%).
(2)　 Press O.
(3)　 Input the other parameters.

•　See “Confidence Interval Types and Parameters” (page 51).

6.　Press >. Or highlight  and then press O.
•　This displays confidence interval calculation results and summary statistics of the sample data on the

Results tab. The meanings of the items that appear on the display are provided below.
Confidence interval calculation results
Lower: confidence interval lower limit
Upper: confidence interval upper limit
df : degrees of freedom
p: estimated sample proportion
p1: estimated proportion of sample 1

p2: estimated proportion of sample 2

Summary statistics of sample data
x−: mean of sample
x−1: mean of sample 1

x−2: mean of sample 2

sx: sample standard deviation

sx1: standard deviation of sample 1

sx2: standard deviation of sample 2

sp: pooled sample standard deviation

n: size of sample
n1: size of sample 1

n2: size of sample 2

Note
•　You can use the operation below to save values currently displayed on the Results tab to a list.

(1)　 Select T > [Save Result in List].

(2)　 Use the dialog that appears to input a list number* and then press O.
*　Input the number of an empty list. Overwrite saving is not available.

•　The values displayed on the Results tab are stored in the variables in the menu items shown below.
Confidence interval calculation results: C > [Variable Data] > [Statistics] > [Result] > [Confidence
Interval] (page 241)
Summary statistics of the sample data: C > [Variable Data] > [Statistics] > [Input] (page 241)
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Confidence Interval Types and List Variables
To find confidence intervals using a list of sample data, create the following list variables according to the
confidence interval type.

Sample data: Required list variable(s): Setup tab display:
One sample data (no
frequencies)

List variable to assign to List

One sample data (with
frequencies)

Two list variables to assign to List and Freq

Two sample data (no
frequencies)

Two list variables to assign to List(1) and
List(2)

Two sample data (with
frequencies)

Four list variables to assign to List(1),
List(2), Freq(1), Freq(2)

Confidence Interval Types and Parameters
Parameters in the table below that are marked with an asterisk (*) need to be input when you select [Data] >
[Variable] in step 4 of the procedure under “Operation Flow” (page 49).

Confidence interval type: Parameter:
1-Sample Z Interval σ: population standard deviation (σ > 0)

x−: mean of sample*

n: size of sample (positive integer)*

2-Sample Z Interval σ1: population standard deviation of sample 1 (σ1 > 0)
σ2: population standard deviation of sample 2 (σ2 > 0)
x−1: mean of sample 1*

n1: size of sample 1 (positive integer)*

x−2: mean of sample 2*

n2: size of sample 2 (positive integer)*

1-Proportion Z Interval x: sample value (x ≥ 0 integer)
n: size of sample (positive integer)

2-Proportion Z Interval x1: data value of sample 1 (x1 ≥ 0 integer)
n1: size of sample 1 (positive integer)
x2: data value of sample 2 (x2 ≥ 0 integer)
n2: size of sample 2 (positive integer)

1-Sample t Interval x−: mean of sample*

sx: sample standard deviation (sx > 0)*

n: size of sample (positive integer)*

2-Sample t Interval x−1: mean of sample 1*

sx1: standard deviation of sample 1 (sx1 > 0)*

n1: size of sample 1 (positive integer)*

x−2: mean of sample 2*

sx2: standard deviation of sample 2 (sx2 > 0)*

n2: size of sample 2 (positive integer)*

Pooled: pooling On (in effect) or Off (not in effect)
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Statistics Graph View Window Settings
The settings of the statistics graph View Window are automatically configured according to the graph being
drawn. This is because the calculator selects S > [View Window] (page 216) > [Auto] by default.
If you switch to S > [View Window] > [Manual], changes to View Window settings configured with the menu
that appears when you select T > [View Window] in the graph window are applied to the display range of the
graph window.
For details about View Window settings, see “Specifying the Display Range of the Graph Window (View
Window)” (page 80).

Note
•　Note that View Window parameters are set automatically for the graph types below, regardless of

whether or not S > [View Window] is set to [Manual].
Pie, 1-Sample Z Test, 2-Sample Z Test, 1-Proportion Z Test, 2-Proportion Z Test, 1-Sample t
Test, 2-Sample t Test, χ2 Goodness-of-Fit Test, χ2 Two-Way Test, 2-Sample F Test (x-axis only
disregarded).
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Distribution App
The Distribution app can handle binomial distribution, normal distribution, Poisson distribution, and a variety of
other types of probability distribution.

Note
•　Distribution calculation can also be performed with the Calculate app using the functions in C >

[Distribution]. For information about available functions, see “Distribution: Distribution Calculations”
(page 233).

Operation Flow
Step 1: Select a distribution (Select tab).

2.　Highlight the distribution you want to use for calculation and then press > (or O).
•　You can choose from among the distributions below.

Discrete distribution
-　Binomial distribution
-　Poisson distribution
-　Geometric distribution
-　Hypergeometric distribution

Continuous Distribution
-　Normal distribution
-　Student-t distribution
-　χ2 distribution
-　F distribution

Step 2: Input parameters (Setup tab).

[ ]: Calculates the cumulative probability for specified data value x or lower.
[ ]: Calculates the cumulative probability for the lower (Lower) and upper (Upper)

boundaries of the data values.
[ ]: Calculates the cumulative probability for specified data value x or higher.
[ ]: Calculates the probability for given data value x (discrete distribution only).

4.　Specify whether to use a single data value or multiple data values for the calculation.
(1)　 Highlight [Data] and then press O.
(2)　 Select [Variable] to use a single data value for calculation or [List] for multiple data values.

5.　Input the other parameters.

Parameters common to all distributions
Input the parameters below according to what you specified for [Tail] (step 3) and [Data] (step 4).

1.　h > Distribution
•　This displays the distribution selection menu.

3.　Select a tail setting for probability calculation.

(1)　 Highlight [Tail] and then press O.
(2)　 From the menu that appears, select one of the options

described below.
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Tail
Data

, ,

Variable x: Data value Lower: Data value lower limit
Upper: Data value upper limit

List List*1: List to use as data
values

L.List*1: List to use as the lower boundary
of data values
U.List*1: List to use as the upper boundary
of data values

*1　For the operation to specify a list variable to use as data values, see “To specify a list variable to use as
data values” (page 55).

Distribution Type Specific Parameters
Binomial distribution

Numtrial: Number of trials
p: Probability of success (0 ≤ p ≤ 1)

Normal distribution
DisplayZ: Displays Z-Scores*2

μ: Population mean
σ: Population standard deviation (σ > 0)

Poisson distribution
λ: Mean (λ > 0)

Geometric distribution
p: Probability of success (0 < p ≤ 1)

Hypergeometric distribution
n: Number of trials from population (0 ≤ n integer)
M: Number of successes in population (0 ≤ M integer)
N: Population size (n ≤ N, M ≤ N integer)

Student-t distribution
df: Degrees of freedom (df > 0)

χ2 distribution
df: Degrees of freedom (Positive integer)

F distribution
n:df: Degrees of freedom of numerator (Positive integer)
d:df: Degrees of freedom of denominator (Positive integer)

*2　Select [On] to show Z-scores (standardized values) or [Off] to hide them. If you choose [On], calculation
is performed as μ = 0 and σ = 1.

Note
•　You can specify the color of the graph by highlighting [Color] and then pressing O (only if you chose

[Data] > [Variable] in step 4).
•　Selecting T > [Input Descriptions] displays explanations of the parameters.

Step 3: Display the calculation results (Results tab).

6.　On the Setup tab, press >, or highlight  and then press O.
•　Calculation results are displayed on the Results tab.

Single Data Value Calculation
(When [Data] > [Variable] selected.)

Multiple Data Value Calculation
(When [Data] > [List] selected.)
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To specify a list variable to use as data values
When [Data] > [List] is selected on the Setup tab, use the following operation to specify the list variable to use
as data values. The operations in steps 2 through 5 below are not necessary if you use a list variable that has
already been saved.

1.　On the Setup tab, highlight [List], [L.List], or [U.List] and then press O.

2.　On the menu that appears, highlight [List Editor] and then press O.
•　This displays List Editor.

3.　Input data values in any one of the lists (List 1 through List 26).
•　For information about the input operation, see “Inputting Data in List Editor” (page 30).

4.　After you finish inputting the data, press b.

5.　Press O.

6.　On the menu that appears, highlight [Select List] and then press O.

7.　Use the dialog that appears to input a list number and then press O.

Using the Results Tab
To change data values and recalculate probability values (Only when [Data] > [Variable] is selected.)
Highlight the value of x, Lower, or Upper and then use the number keys or select T > [Edit/View Value] to
change the value.

P (X ≤ x  ) = p
P ( Lower  ≤ X ≤ Upper  ) = p
P (X ≥ x  ) = p
P (X = x  ) = p*

*　Discrete distribution only

To change the probability value and calculate inverse data values (Only when [Data] > [Variable] is
selected.)
Highlight the p-value and then use the number keys or select T > [Edit/View Value] to change the value.

P (X ≤ x) = p
P (Lower ≤ X ≤ Upper) = p *

P (X ≥ x) = p
*　Normal distribution only

Note
•　The inverse operation cannot be performed with [Tail] > [ ] for discrete distribution.

To change the Tail setting
From the menu that appears when you select T > [Tail], select the option you want. For information about
available options, see step 3 under “Operation Flow” (page 53).

Other Operations
To do this: Select this menu item:
Check the value set for the display range of the graph window
(Data: Only when Variable is selected.) T > [View Window]*1

Adjust the background image (Data: Only when Variable is
selected.) T > [Fade I/O]*2
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Save all p-values of the calculation result to the specified list
variable (Only when Data: List is selected.) T > [Save Probabilities in List]

*1　You can use the menu that appears when you select T > [View Window] to check setting values only. If
you change the values, the changes are not reflected in the graph window.

*2　For details, see “Adjusting the Graph Window Background Image (Fade I/O)” (page 81).

Precision and Input Ranges

•　Note that in the below conditions, calculations are performed as ∞ = 9.99 × 1099, −∞ = −9.99 × 1099.
-　Discrete distributions, when  is selected
-　Continuous distributions, when  or  is selected

•　The result of an inverse calculation of a discrete distribution is an integer. Precision is reduced if the cumulative
probability p you input has 10 or more digits.

•　The following conditions cause an error (Out of Domain).
-　Binomial distribution, when you input a value of 100,000 or greater for Numtrial
-　Binomial distribution, when you input a value for p within the range of 0 < p ≤ 0.00001 or 0.99999 ≤ p < 1
-　Normal distribution, when you input a value of 1 × 1010 or greater or 1 × 10−10 or less for μ
-　Normal distribution, when you input a value of 1 × 1010 or greater for σ
-　Poisson distribution, when you input a value of 1,000 or greater for λ
-　Geometric distribution, when you input a value of 0.00001 or less for p, or when p is within the range of

0.99999 ≤ p < 1
-　Hypergeometric distribution, when you input a value of 201 or greater for n
-　Hypergeometric distribution, when you input a value of 100,000 or greater for M  or N
-　χ2 distribution, when you input a value of 1 × 1016 or greater for df
-　F distribution, when you input a value of 2,000,001 or greater for n:df  or d:df
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Spreadsheet App
You can use the Spreadsheet app to input values and formulas into cells, and perform spreadsheet calculations.
You can also enter statistical data into cells, perform statistical calculations, and draw statistical graphs.

Note
•　The maximum file size supported by the Spreadsheet app is about 30KB. The spreadsheet in this app

has 999 rows and 26 columns, but due to file size restrictions, it may not be possible to input data into
all of the cells. The maximum file size also depends on the type of data being input into the spreadsheet
and its formatting, and on the amount of space available in main memory.

•　The Spreadsheet app does not support input of complex numbers.

Using the Spreadsheet Tab
Selecting h > Spreadsheet to start up the app causes the Spreadsheet tab to appear first. The table below
describes the name and function of each part of this tab.

① File name This is the file name of the currently opened file. “SHEET” is the initial default
file of the Spreadsheet app, a “SHEET” file is automatically created when
you start up the Spreadsheet app for the first time.

② Column letter (A to Z) These letters and numbers indicate the current cursor position. For example,
“B2” indicates the second row of column B. The row number and column
letter of the currently selected cell are displayed in white with a blue
background.

③ Row number (1 to 999)

④ Cursor The currently selected cell is indicated by a thick frame. When multiple cells
are selected, all of the selected cells are enclosed in a thick frame.

⑤ Edit box When a single cell is selected, the edit box shows the content of the selected
cell. When multiple cells are selected, the edit box shows the range of cells
that are selected.

Selecting Cells
Before performing any operation on a cell, you must first select it. You can select a single cell, a range of cells,
all the cells in a row or column, or all of the cells in the spreadsheet.

To select this: Do this:
A single cell Use the cursor keys to move the cursor to the cell you want, or use the Jump

command (page 58) to jump directly to the cell.
A range of cells 1.　Move the cursor to the start point of the range of cells you want to select.

•　You could select an entire row or column of cells as the start point, if
you want.

2.　Press s0($).*
•　This changes the cursor to a double frame boundary instead of the

normal thick frame.
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3.　Use the cursor keys to move the cursor to the end point of the range of
cells you want to select.
•　The edit box shows the range of the selected cells.
•　To cancel cell selection, press b.

An entire row of cells Move the cursor to column A of the row whose cells you want to select and
then press l. This causes the cursor to move to the row header and selects
that entire row.

An entire column of cells Move the cursor to row 1 of the column whose cells you want to select and
then press u. This causes the cursor to move to the column header and
selects that entire column.

All of the cells in the
spreadsheet

Press l while the entire column A is selected or press u while the entire
row 1 is selected.

*　Pressing s0($) while you are editing the contents of a cell with the edit box will execute a range
specification operation for copying or cutting the characters in the edit box. For more information, see
“Copying, Cutting, and Pasting Expressions” (page 10).

To use the Jump command to move the cursor
To move the cursor to this
cell

Do this:

A specific cell 1.　Select T > [Edit] > [Jump] > [Go].
2.　On the dialog box that appears, enter the name of the cell (A1 to Z999)

to which you want to jump.
3.　Press O.

Top row of current column Select T > [Edit] > [Jump] > [Move to the Top Row].
Column A of current row Select T > [Edit] > [Jump] > [Move to the First Column].
Bottom row of current column Select T > [Edit] > [Jump] > [Move to the Bottom Row].
Column Z of current row Select T > [Edit] > [Jump] > [Move to the Last Column].

Inputting Data into a Cell
You can input the types of data described below into a cell.
Constants: A constant is something whose value is fixed as soon as you finalize its input. A constant can be

either a numeric value or a calculation formula (such as 7+3, sin(30), A1 × 2, etc.) that does not
have an equal sign (=) in front of it. A constant you input is aligned to the right of the cell.

Formula: A formula that starts with an equal sign (=), such as =A1 × 2, is executed as it is written. The
result of a formula you input is aligned to the right of the cell.

Text: A character string that starts with a quote mark (") is treated as text. Text you input is aligned to
the left of the cell. In addition, a thick vertical line is displayed on the left side of a cell when it
contains text. If a cell contains the text "B, for example, its content is displayed as .

 
Example: Input the text A, B, C into cells A1, A2, A3, the constants 10, 10+10, 10 × 3 into cells B1, B2, B3,

and formulas that specify doubling of the value in the cell to the left into cells C1, C2, C3

Cell contents Display screen after input
 

1.　h > Spreadsheet
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Pk(”)PX(A)E
Pk(”)Pe(B)E
Pk(”)Pj(C)E

Ur (Moves to cell B1.)
10E

10+10E
10/3E

•　This causes the calculation results to appear in cells B2 and B3.

Ur (Moves to cell C1.)
s((=)Pe(B)1/2E

•　Input the formula as-is into cell C1. This causes the numeric result of the calculation to appear in the cell.

U (Moves to cell C1.)
T > [Copy & Paste] (Copies the formula in cell C1.)

dO (Pastes into cell C2.)
O (Pastes into cell C3.)

b (Cancels the copy operation.)

•　For details about copy and paste operations, see “Copying or Cutting Cell Contents and Pasting Them in
Another Location” (page 61).

Note
•　Pressing E in steps 2 through 4 or O in step 5 above causes the cursor to move down to the next

cell. You configure a setting to have the cursor move to the next cell to the right, if you want. For details,
see S > [Cursor Moves] under “Spreadsheet App Settings Menu Items” (page 74).

•　If you input a letter from A to Z, or the characters r or θ as a constant or as part of a formula instead of
text, it will be treated as an alpha variable. For example, if you enter PX(A)E into a cell, the letter
A is treated as a constant and the value stored in variable A appears in the cell.

To fill a range of cells with the same formula (Fill)
Use the Fill command when you want to input the same formula into a specified range of cells. The rules
governing relative and absolute cell name references are the same as those for copy and paste. When you
need to input the same formula into cells B1, B2, and B3, for example, the Fill command lets you do so by
inputting the formula once, into cell B1.
Example: To input into the range of cells B1:B3 a formula that doubles the value in the cell to the left

•　This displays the Spreadsheet tab.

2.　Enter the text into cells A1, A2, A3.

3.　Enter the constants into cells B1, B2, B3.

4.　Input the formula into cell C1.

5.　Copy the formula in cell C1 and then paste it into cells C2 and C3.
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1.　Select the range of cells where you want to input the same formula.
•　You could skip this step and start with step 2, below.

2.　Select T > [Fill].
•　This displays the Fill screen.

3.　Highlight the Formula row and then input the formula you want (“=A1×2” here) into the cell at the top of the
selected range (B1 here).

s((=)PX(A)1/2E

4.　If you did not choose a cell range in step 1, specify the cell range here.
(1)　 Highlight Cell Range.
(2)　 Pe(B)1s`(:)Pe(B)3E

5.　Select  and then press O.
•　This inputs the formula into the range of cells you specified.

To fill a column of cells with a numeric sequence (Sequence)

Example: To input the sequence of numbers produced when variable X in function expression “X2 + 1” is
assigned a value of 2 to 10 in increments of 2 into column B, starting from cell B1

1.　Select the cell from which you want input of the numeric sequence to start.
•　You could skip this step and start with step 2, below.

2.　Select T > [Sequence].

3.　Configure the Sequence operation as described below.

Parameter Description
Expression Input the function expression for generating the number sequence.
Variable Specify the variable name used in the function expression input for

Expression.
Start/End Specify the starting/ending value being assigned to the variable specified

by Variable.
Increment Specify the value that should be added to the variable value with each

step.
1st Cell Specify the starting cell from which the results of the function expression

should be inserted.
 

Xi+1E
XE2E10E2E

Pe(B)1E

•　This displays the Sequence screen.
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•　Performing the next step inputs the number sequence automatically starting from the specified cell. If any
cell that is within the range of cells where the number sequence values will be input already contains data,
the existing data is replaced with the number sequence values.

Copying or Cutting Cell Contents and Pasting Them in Another Location
Use the procedures below to copy or cut the contents of one cell or multiple cells, and then paste them into
another cell or cells.
For information about what happens when you copy or cut cell contents that include cell references and paste
them into another location, see “Relative Cell Reference” (page 62) and “Absolute Cell Reference” (page 62).

To copy the contents of a single cell and paste them into another cell
1.　Select the cell whose contents you want to copy.

2.　Select T > [Copy & Paste].
•　This causes “[OK]: Paste” to appear in the status bar. You can continue to paste while this message is

displayed.

3.　Move the cursor to the cell where you want to paste the contents.

4.　Press O.
•　The contents of the cell you copied are pasted and the cursor moves down* to the next cell.

5.　If you want to paste the same contents to another cell, repeat steps 3 and 4.
•　If you want to continue pasting to the cell to which the cursor has been moved, just repeat the operation

in step 4.

6.　To end the paste operation, press b.
*　Default setting. The direction of cell movement is in accordance with the S > [Cursor Moves] (page 74)

setting.

To copy the contents of a range of cells and paste them into another location in the spreadsheet
1.　Select the range of cells whose contents you want to copy.

2.　Select T > [Copy & Paste].
•　This causes “[OK]: Paste” to appear in the status bar. You can continue to paste while this message is

displayed.

3.　Move the cursor to the cell that is the upper left corner of the range of paste destination cells.

4.　Press O.
•　This pastes the contents of the range of cells you copied.

5.　If you want to paste the same contents to another location, repeat steps 3 and 4.

6.　To end the paste operation, press b.

To cut the contents of a single cell and paste them into another cell
1.　Select the cell whose contents you want to cut.

2.　Select T > [Cut & Paste].
•　This causes “[OK]: Paste” to appear in the status bar.

3.　Move the cursor to the cell where you want to paste, and then press O.

4.　After everything is the way you want, select  and then press
O.
•　This performs all the required calculations according to your

settings and inserts the results into the spreadsheet.
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•　This pastes the contents you cut. At the same time, the contents are deleted from the cell where you
performed the cut operation.

To cut the contents of a range of cells and paste them into another location in the spreadsheet
1.　Select the range of cells whose contents you want to cut.

2.　Select T > [Cut & Paste].
•　This causes “[OK]: Paste” to appear in the status bar.

3.　Move the cursor to the cell that is the upper left corner of the range of paste destination cells.

4.　Press O.
•　This pastes the contents of the range of cells that you cut. At the same time, the contents are deleted from

the cell where you performed the cut operation.

Note
•　Even if S > [Auto Recalculation] (page 68) is turned off, cutting and pasting cell contents results in

only the formulas in the pasted cell(s) being recalculated.

Inputting a Cell Reference
A cell reference is a symbol that references the value of one cell for use by another cell. If you input “= A1 +
B1” into cell C2, for example, the spreadsheet adds the current value of cell A1 to the current value of cell B1,
and displays the result in cell C2.
There are two types of cell references: relative and absolute.

Relative Cell Reference
A relative cell reference changes according to its location on the spreadsheet. The cell reference “= A1” in cell
C2, for example, is a reference to the cell located “two columns to the left and one cell up” from the current
cell (C2, in this case). Because of this, if we copy the contents of cell C2 and paste them into cell D12, for
example, the cell reference changes automatically to “= B11”, because B11 is two columns to the left and one
cell up from cell D12. Be sure to remember that relative cell references always change dynamically in this way
whenever you move them using copy and paste.

Absolute Cell Reference
An absolute cell reference does not change, regardless of where it is located or where it is copied to or moved
to. You can make both the row and column of a cell reference absolute, or you can make only the row or only
the column of a cell reference absolute, as described below.

This cell reference: Does this:
$A$1 Always refers to column A, row 1.
$A1 Always refers to column A, but the row changes dynamically when moved,

as with a relative cell reference.
A$1 Always refers to row 1, but the column changes dynamically when moved,

as with a relative cell reference.
Let’s say, for example, that a reference to cell A1 is in cell C1. The following shows what each of the above
cell references would become if the contents of cell C1 were copied to cell D12.

$A$1 → $A$1 $A1 → $A12 A$1 → B$1

Note
•　If the result of a copy-and-paste operation causes a relative cell reference name to change to

something that is outside the range of the spreadsheet cells, the applicable column letter and/or row
number is replaced by a question mark (?), and “ERROR” is displayed as the cell’s data.

To input a cell reference name using direct input
For example, to input “= A1+5” into cell B1, move the cursor to cell B1 and perform the operation below.

62



s((=)PX(A)1+5E

To input the absolute cell reference name symbol ($)
Select C > [Spreadsheet] > [$].

To input a cell reference name using the GRAB command
For example, to input “= A1+5” into cell B1, move the cursor to cell B1 and perform the operation below.
s((=)T > [Grab]l (Selects cell A1.) O+5E

Note
•　Selecting T > [Grab] causes “[OK]: Enter this cell’s ref” to appear in the status bar. While this message

is displayed, you can use the Jump command in addition to the cursor keys to navigate between cells.
To use the Jump command, press T while “[OK]: Enter this cell’s ref” is displayed. For details, see
“To use the Jump command to move the cursor” (page 58).

Using Special Spreadsheet App Commands
The Spreadsheet app has several special commands like CellSum(), which returns the sum of a range of cells,
and CellIf(,,), which specifies branching conditions. These special commands can be used inside of formulas.
To input these commands, use C > [Spreadsheet]. The commands described below are included in this menu.

CellIf(,,)
Returns Expression 1 when the equality or inequality provided as the branch condition is true, and Expression
2 when it is false.
Syntax: CellIf(equality,expression 1,expression 2) or

CellIf(inequality,expression 1,expression 2)
Example: =CellIf(A1>B1,A1,B1)

Returns the value of A1 when {Cell A1 value} > {Cell B1 value}. Otherwise, returns the value of B1.

CellMin()
Returns the minimum value in a specified range of cells.
Syntax: CellMin(start cell:end cell)
Example: =CellMin(A3:C5)

Returns the minimum value of the data in cell range A3:C5.

CellMax()
Returns the maximum value in a specified range of cells.
Syntax: CellMax(start cell:end cell)
Example: =CellMax(A3:C5)

Returns the maximum value of the data in cell range A3:C5.

CellMean()
Returns the mean value in a specified range of cells.
Syntax: CellMean(start cell:end cell)
Example: =CellMean(A3:C5)

Returns the mean value of the data in cell range A3:C5.

CellMedian()
Returns the median value in a specified range of cells.
Syntax: CellMedian(start cell:end cell)
Example: =CellMedian(A3:C5)

Returns the median value of the data in cell range A3:C5.

CellSum()
Returns the sum of the data in a specified range of cells.
Syntax: CellSum(start cell:end cell)
Example: =CellSum(A3:C5)

Returns the sum of the data in cell range A3:C5.
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CellProd()
Returns the product of the data in a specified range of cells.
Syntax: CellProd(start cell:end cell)
Example: =CellProd(A3:C5)

Returns the product of the data in cell range A3:C5.
 

1.　Move the cursor to cell A4 and input “SUM” as text.

Pk(”)P/(S)P1(U)P7(M)E

2.　Move the cursor to cell B4 and enter the formula to calculate the sum of B1:B3.
•　We want to calculate the sum of B1:B3, so we use the CellSum() command and input: =CellSum(B1:B3).

s((=)
C > [Spreadsheet] > [CellSum()]

Pe(B)1s`(:)Pe(B)3
E

3.　Move the cursor to cell C4 and input the formula to calculate the sum of C1:C3.

s((=)
C > [Spreadsheet] > [CellSum()]

Pj(C)1s`(:)Pj(C)3
E

Editing Cell Contents
You can perform the editing operations described in the table below on the contents of individual cells, as well
as on rows, columns, and the entire spreadsheet.

To do this: Perform this operation:
Edit the contents of a single cell 1.　Select the cell whose contents you want to edit and then select T >

[Edit] > [Cell].
•　This causes the cell contents and cursor to appear left-aligned in the

edit box.
2.　Use l/r to move the cursor to the location you want and edit the

contents as required.
3.　After you are finished editing, press O.

Sort data in a range of a
single row or single column in
ascending or descending order

1.　Select the range of cells whose data you want to sort.
2.　Select one of the menu items below.

To sort in ascending order:
T > [Edit] > [Sort Ascending]

To sort in descending order:
T > [Edit] > [Sort Descending]

Delete a row or column*1 1.　Move the cursor to a cell inside the row or column you want to delete.

Example: To input the formula for calculating the sum the values
in cells B1:B3 and C1:C3 during the example under
“Inputting Data into a Cell” (page 58) into cells B4 and
C4, respectively
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•　You can select multiple rows or multiple columns, if you want. The
row(s) or column(s) you select will be deleted.

2.　Select one of the menu items below.
To delete row(s):
T > [Delete] > [Row]

To delete column(s):
T > [Delete] > [Column]

Insert a row or column*2 1.　Move the cursor to a cell in the row where you want to insert a row or in
the column where you want to insert a column.
•　You can select multiple rows or multiple columns, if you want. The row

or column will be inserted at the location you selected.
2.　Select one of the menu items below.

To insert row(s):
T > [Insert] > [Row]

To insert column(s):
T > [Insert] > [Column]

Delete the contents of all the
cells in a spreadsheet

1.　Press a or select T > [Delete] > [All].
2.　In response to the confirmation dialog that appears, select [OK].

Clearing the contents of
selected cells

1.　Select the range of cells whose contents you want to clear.
2.　Select one of the menu items below.

To do this: Select this menu item:
Clear contents only T > [Clear] > [Content]
Clear formatting only T > [Clear] > [Format]
Clear all contents and formatting T > [Clear] > [All]

*1　This operation can also be performed using the steps below.
(1)　 Move the cursor to the header of the row or column being deleted.
(2)　 Select T > [Delete].

*2　This operation can also be performed using the steps below.
(1)　 Move the cursor to the header of the line or the column where you want to insert a line or column.
(2)　 Select T > [Insert].

Note
•　A Range ERROR occurs if an insert operation causes existing cells that contain data to move outside

the range of A1:Z999.

Spreadsheet File Operations
With the Spreadsheet app, you can use the file operations described in the table below.

To do this: Select this menu item:
Close the currently open file and create a new file T > [File] > [New]*1

Close the currently open file and open another file T > [File] > [Open]
Save the currently open file under a different name T > [File] > [Save As]
Delete a file T > [File] > [Delete]*2

*1　Inputting the name of an existing file in the dialog that appears opens the existing file without creating a
new one.

*2　Deleting the currently open file other than “SHEET” opens the file named “SHEET”. Deleting the currently
open “SHEET” file automatically creates a new “SHEET” file.
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Transferring Data between a Spreadsheet and CSV Files
You can import into a spreadsheet the contents of a CSV file that is stored in calculator memory or transferred
from a computer. You also can save the contents of a spreadsheet as a CSV file. For information about the
procedure for transferring data between a spreadsheet and CSV files, see “Using CSV Files” (page 244).

Specifying the Text Color and Fill Color of Each Cell
For each cell, you can specify the text color, fill color, and fill color intensity (Normal or Lighter).

To specify the text color and fill color of each cell
1.　Select the range of cells whose text color and fill color you want to specify.

2.　Select T > [Color].

3.　Configure the above dialog box with the following settings.

To specify this: Perform this operation:
Specify the text color Select [Char Color]. On the menu that appears,

select the desired color.
Specify the cell color Select [Area Color]. On the menu that appears,

select the desired color.
Specify the intensity of the cell color Select [Paint Style]. On the menu that appears,

select [Normal] or [Lighter].

4.　To apply the settings you configure, press b.

Saving Data to/Recalling Data from Variables
Spreadsheet data can be saved to variables, and data stored in variables can be recalled into a spreadsheet.
Variables that can be saved to or recalled from are described below.
•　Save only: alpha variables
•　Save and recall: vector variables, matrix variables, list variables, list files*

*　A list file is equivalent to 26 list variables. For details, see “List Files” (page 32).

To save spreadsheet data to a variable
1.　Select a single cell or a range of cells containing the data you want to save to a variable.

•　Select the cell range in the table below that corresponds to the type of variable you are saving to.

To save to this type of variable: Select this range:
Alpha variable Single cell
List variable or vector variable A range of cells in a single row or a single column
List file or matrix variable A range of cells that spans multiple rows and columns

•　You could skip this step and start with step 2, below.

2.　Select T > [Memory] > [Store].

3.　On the menu that appears, select the type of variable to which you want to save the data.

To save to this type of variable: Select this menu item: Destination:
Alpha variable [Alpha] A to Z, r, or θ
List variable [List] List 1 to List 26
List file [File] File 1 to File 6
Matrix variable [Matrix] Mat A to Mat Z
Vector variable [Vector] Vct A to Vct Z

4.　Use the screen that appears to specify the cell range and the destination variable.
•　If you specified a cell range in step 1 of this procedure, you do not need to specify it again here.
•　Refer to “Destination” in the table in step 3 for the destinations that you can specify.
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5.　Select  and then press O.

Note
•　Text color and other formatting settings are disregarded when cells are saved to a variable.
•　The following describes what happens if you try to store data in a variable when a cell does not contain

any data, when a cell contains text, or when ERROR is displayed for a cell.
-　If you are assigning data to an alpha variable, an error occurs.
-　If you are storing data in a list variable, a list file, a matrix variable, or a vector variable, 0 is written

into the applicable cell(s).

To recall data stored in a variable into a spreadsheet
1.　Specify the cell to which you want to recall the variable data.

•　Select a cell for recall in accordance with the type of variable as shown in the table below.

To recall from this type of
variable:

Select a cell like this:

List variable When “Down” is selected for S > [Cursor Moves] (page 74): Select
the cell at the top of the range to which you want to recall data. The
data is recalled from top to bottom starting from the selected cell.
When “Right” is selected for S > [Cursor Moves]: Select the leftmost
cell of the range to which you want to recall data. The data is recalled
from left to right starting from the selected cell.

List file or matrix variable Select the cell at the top-left corner of the range to which you want
to recall data.

Vector variable Select the leftmost cell (for a vector with 1 row and n columns) or the
topmost cell (for a vector with n rows and 1 column) of the range to
which you want to recall data.

•　You could skip this step and start with step 2, below.

2.　Select T > [Memory] > [Recall].

3.　On the menu that appears, choose the type of variable whose data you want to recall.

To recall from this type of
variable:

Select this menu item: Recall source:

List variable [List] List 1 to List 26
List file [File] File 1 to File 6
Matrix variable [Matrix] Mat A to Mat Z
Vector variable [Vector] Vct A to Vct Z

4.　Use the screen that appears to specify the variable being recalled and the destination cell.
•　See the “Recall source” column in the table in step 3 for information about the types of variables that can

be specified.
•　If you selected a cell in step 1 of this procedure, you do not need to specify a cell here.

5.　Select  and then press O.

Note
•　If you specify a cell that results in the recalled data not being able to fit within the range of the

spreadsheet (A1:Z999), pressing  in step 5 results in an error and does not execute the recall.
•　The recalled data is formatted according to the default formatting of the cell to which it is recalled.
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Auto Recalculation and Recalculate
“Auto Recalculation” is a setting item on the Settings menu. With the Spreadsheet app’s initial default setting
(Auto Recalculation: On), all formulas in a spreadsheet are automatically re-calculated whenever you open
a file or perform an editing operation in the Spreadsheet app. Depending on the content of the spreadsheet,
auto re-calculation can take a long time to complete. When Auto Recalculation is disabled (Off), you need to
execute re-calculation manually as required.

To execute re-calculation manually
Select T > [Recalculate].

Note
•　Even if the Auto Recalculation setting is On, you should execute T > [Recalculate] in the cases below.

-　When the Settings menu is used to change the Angle setting
-　When a cell contains a formula using an alpha variable or a function variable and the corresponding

variable is updated

Statistical Calculations and Graph Drawing
You can perform statistical calculations and draw statistical graphs using data input into a spreadsheet.

Inputting Data
Depending on the statistical data being processed, input the data using columns 1, 2, and 3 of the Spreadsheet
tab.

Input of 2-Variable data without frequencies Example setup (Setup tab)
 

For this statistical data: Input like this:
1-Variable (no frequencies) Input variable-X data (1VarXCell*1) into a single column.
1-Variable (with frequencies) Input variable-X data (1VarXCell*1) into the first column and frequency

data (1VarFreq*2) into the second column.
2-Variable (no frequencies) Input variable-X data (2VarXCell*1) into the first column and variable-Y

data (2VarYCell*1) into the second column.
2-Variable (with frequencies) Input variable-X data (2VarXCell*1) in the first column, variable-Y data

(2VarYCell*1) into the second column, and frequency data (2VarFreq*2)
into the third column.

*1　In the Spreadsheet app Setup tab, specify the cell range for data being used for 1-Variable statistical
calculation to 1VarXCell (or XCellRange), the cell range for data being used for 2-Variable statistical
calculation to 2VarXCell, 2VarYCell (or XCellRange, YCellRange).

*2　In the Spreadsheet app Setup tab, the cell range of frequency data used for 1-Variable statistical calculation
is displayed as 1VarFreq (or Frequency), while the cell range of frequency data used for 2-Variable statistical
calculation is displayed as 2VarFreq (or Frequency).

Frequencies
There are two ways to input statistical data: with frequencies and without frequencies (1 is used for all data
frequencies). You can specify which method you want to use on the Setup tab that appears when you press
> on the Spreadsheet tab, as shown in the example below.
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Using cell range A1:A5 as data
Frequency of all data values: 1

Using cell range A1:A5 as data
Using cell range B1:B5 as frequencies

Important!
•　The values contained in the cell range used as the frequency data should be 0 or positive values only.

Even a single negative value causes an error (Out of Domain).
•　Statistical data with a frequency of 0 is not used for calculation of minimum and maximum values.

Displaying Summary Statistics or Regression Model Information
You can use the procedure below to find and display various summary statistics from 1-Variable or 2-Variable
statistical data. This procedure can also be used to display regression equation coefficients and coefficients
of determination (referred to as “regression model information” in this manual) when regression models are
applied to 2-Variable statistical data.

To display summary statistics or regression model information
1.　Input the statistical data to use in the calculation.

•　For details, see “Inputting Data” (page 68).

2.　Select the range of cells into which you input statistical calculation data.
•　You could skip this step and go to step 3, below.

3.　Press >.
•　If this causes the Select Type menu to appear, go to step 5 of this procedure. Otherwise, go to step 4.

6.　Highlight line 2 on the tab and then press O.

7.　On the menu that appears, select the type of statistical calculation you want to perform.

To do this: Select this menu item:
Display summary statistics based on 1-Variable statistical data
(X) 1-Variable

Display summary statistics based on 2-Variable statistical data
(X, Y) 2-Variable

Display regression model information based on 2-Variable
statistical data (X, Y)
(Select the desired regression model from the menu.)

Linear Regression(ax+b)
Linear Regression(a+bx)
Med-Med Regression
Quadratic Regression
Cubic Regression

4.　Highlight the first line of the Setup tab and then press O.

5.　Select [Calculate Summary Statistics].
•　This causes the Calculate Statistics menu to appear on the

Setup tab.
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Quartic Regression
Logarithm Regression
Exp Regression(a･e^bx)
Exp Regression(a･b^x)
Power Regression
Sinusoidal Regression
Logistic Regression

8.　Specify the cell range containing the statistical data being used in the calculation as required.
 
For 1-Variable statistical data:
(1)　 Highlight [1VarXCell] and then press O.
(2)　 Use the dialog box that appears to input the range of X-data cells and then press O.
(3)　 Highlight [1VarFreq] and then press O.
(4)　 If you do not want to use frequency data, select [1] on the menu.

If you want to use frequency data, select [Cell Range] and then advance to step (5).
(5)　 Use the dialog box that appears to input the range of frequency data cells and then press O.
 
For 2-Variable statistical data:
(1)　 Highlight [2VarXCell] and then press O.
(2)　 Use the dialog box that appears to input the range of X-data cells and then press O.
(3)　 Highlight [2VarYCell] and then press O.
(4)　 Use the dialog box that appears to input the Y-data cell range and then press O.
(5)　 Highlight [2VarFreq] and then press O.
(6)　 If you do not want to use frequency data, select [1] on the menu.

If you want to use frequency data, select [Cell Range] and then advance to step (7).
(7)　 Use the dialog box that appears to input the range of frequency data cells and then press O.

9.　Press >. Or highlight  and then press O.

•　See “Summary Statistics” (page 33) and “Regression Model Information” (page 34) for the meanings of
the values that appear on the display.

Drawing a Statistics Graph
You can use 2-Variable statistical data to draw scatter plots and various regression graphs. 1-Variable statistical
data can be used to draw seven types of graphs, including histograms and box-and-whisker diagrams. After
drawing a graph, you can display summary statistics and regression model information.

Drawing a 1-Variable Statistics Graph (Histogram, Box-and-Whisker Diagram, etc.)
You can perform the operations below based on 1-Variable statistical data you input into a spreadsheet.
(1)　 Draw a Box Plot, Histogram, Broken Line Graph, Pie Chart, Bar Graph, Normal Probability Plot, or Normal

Density Curve.
(2)　 Display summary statistics after drawing the graph (except for Pie Chart).

To draw a 1-Variable statistics graph
1.　Input the statistical data to use in the calculation.

•　For details, see “Inputting Data” (page 68).

•　This displays the summary statistics or regression model
information you selected in step 6 on the Results tab. If a
scroll bar appears along the right edge of the window, use
d and u to scroll the display.
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2.　Select the range of cells into which you input statistical calculation data.
•　You could skip this step and go to step 3, below.

3.　Press >.
•　If this causes the Select Type menu to appear, go to step 5 of this procedure. Otherwise, go to step 4.

4.　Highlight the first line of the Setup tab and then press O.

5.　On the Select Type menu, select [Draw Statistics Graph].

6.　Select the type of graph you want to draw.
(1)　 Highlight [Graph1] and then press O.

(2)　 Press O again.
•　This displays a menu for selecting the graph type.

(3)　 Highlight the type of graph you want to draw from the menu and then press O.

7.　Specify statistical data cell range on the spreadsheet.
 
For a Box Plot, Histogram, Broken Line Graph, Normal Probability Plot, or Normal Density Curve:
(1)　 Highlight [XCellRange] and then press O.
(2)　 Use the dialog box that appears to input the range of data cells and then press O.
(3)　 Highlight [Frequency] and then press O. (Excluding Normal Probability Plot)
 
For a Pie Chart:
(1)　 Highlight [Category] and then press O.
(2)　 Use the dialog box that appears to input the range of data category name cells and then press O.
(3)　 Highlight [Data] and then press O.
(4)　 Use the dialog box that appears to input the range of data cells and then press O.
 
For a Bar Graph:
You can specify up to three sets of data to draw a bar graph.
(1)　 Highlight [Category] and then press O.
(2)　 Use the dialog box that appears to input the range of data category name cells and then press O.
(3)　 Highlight [Data1] and then press O.
(4)　 Use the dialog box that appears to input enter the range of data cells and then press O.
(5)　 Repeat the steps (3) and (4) above for [Data2] and [Data3].

•　When specifying [Data2] and [Data3], be sure to specify the same number of rows as [Data1] data. If
the number of rows is different, an error (Dimension ERROR) occurs.

•　When specifying two sets of data, be sure to specify the cell range for [Data1] and [Data2]. If a cell
range is specified for [Data1] and [Data3] while [Data2] is set to “None”, an error (Condition ERROR)
occurs.

8.　Specify the graph color and other settings as required.

•　This causes the Draw Statistics Graph menu to appear on
the Setup tab.

•　This causes the Setup tab display to change to the Graph1
setting menu.
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•　For details, see “Setting Items for Each 1-Variable Statistics Graph Type” (page 38).

9.　To draw the graph, press >. Or highlight  and then press O.
•　The graph is displayed on the Graph tab.
•　If the graph you selected in step 6-(3) is a Histogram or Broken Line Graph, a dialog box appears where

you can specify Start (x-coordinate of the graph drawing start point) and Width (graph drawing width).
Input each of the values, highlight , and then press O.

•　For information about the operations you can perform on the Graph tab, see “Graph Window Operations”
(page 41).

10.　To view summary statistics, press >. (This operation cannot be used for a Pie Chart.)
•　This causes the summary statistics to appear on the Results tab. You can use d and u to scroll the

display contents.
•　See “Summary Statistics” (page 33) for the meanings of the displayed values.

Drawing a 2-Variable Statistics Graph (scatter plot or regression graph)
You can perform the operations below based on 2-Variable statistical data.
(1)　 Draw a Scatter Plot, xy Line Graph, or regression graph
(2)　 After drawing a graph, display summary statistics or regression model information

(3)　 Draw a regression graph over a graph described in (1) above*

*　Common practice in (1) is to draw a Scatter Plot and then draw a regression graph over it. You can also draw
a regression graph over a xy Line Graph or another regression graph.

To draw a 2-Variable statistics graph
1.　Input the statistical data to use in the calculation.

•　For details, see “Inputting Data” (page 68).

2.　Select the range of cells into which you input statistical calculation data.
•　You could skip this step and go to step 3, below.

3.　Press >.
•　If this causes the Select Type menu to appear, go to step 5 of this procedure. Otherwise, go to step 4.

4.　Highlight the first line of the Setup tab and then press O.

5.　On the Select Type menu, select [Draw Statistics Graph].

6.　Select the type of graph you want to draw.
(1)　 Highlight [Graph1] and then press O.

(2)　 Press O again.
•　This displays a menu for selecting the graph type.

(3)　 Highlight the type of graph you want to draw from the menu and then press O.

7.　Specify statistical data cell range on the spreadsheet.
(1)　 Highlight [XCellRange] and then press O.

•　This causes the Draw Statistics Graph menu to appear on
the Setup tab.

•　This causes the Setup tab display to change to the Graph1
setting menu.
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(2)　 Use the dialog that appears to input the data cell range and then press O.
(3)　 Highlight [YCellRange] and then press O.
(4)　 Use the dialog that appears to input the data cell range and then press O.
(5)　 Highlight [Frequency] and then press O. (This operation does not work with a Sinusoidal Regression

Graph or Logistic Regression Graph.)

8.　Specify the graph color and other settings as required.
•　Mark Type: If you selected Scatter Plot or xy Line Graph as the graph type, specify the mark to use for

the plot.
•　Color: Specifies the graph draw color.

9.　To draw the graph, press >. Or highlight  and then press O.
•　The graph is displayed on the Graph tab.
•　For information about the operations you can perform on the Graph tab, see “Graph Window Operations”

(page 41).

10.　Display summary statistics or regression model information.
(1)　 Press >.
(2)　 Perform the operations shown in the table below.

To display this information: Select this menu item:
Summary statistics 2-Variable

Regression model information
(You can select the one regression model you want.)

Linear Regression(ax+b)
Linear Regression(a+bx)
Med-Med Regression
Quadratic Regression
Cubic Regression
Quartic Regression
Logarithm Regression
Exp Regression(a･e^bx)
Exp Regression(a･b^x)
Power Regression
Sinusoidal Regression
Logistic Regression

(3)　 Press O.
•　This displays the details of the menu item you selected in step (2) above on the Results tab.
•　See “Summary Statistics” (page 33) and “Regression Model Information” (page 34) for the meanings

of the displayed values.

11.　Press > to go to the Regression Graph tab and draw a regression graph.

12.　Add regression graphs as needed.
You can add multiple regression graphs on the Regression Graph tab. To do this, perform the steps below.
(1)　 Select T > [Draw Regression Graph].

•　Choosing one of the regression models in step 10 draws a
regression graph over the graph drawn in step 9.
Choosing 2-Variable displays only the graph drawn in step
9.

(2)　 From the menu that appears, select the regression model
you want and then press O.
•　This adds the graph of the regression model you selected.
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•　For operations that are available on the Regression Graph tab, see “Graph Window Operations” (page 41).

Note
•　For details about Graph1 to Graph3 on the Setup tab in step 5 above, see “Drawing Graphs Using

Multiple Graph Setups” (page 42).
•　The settings of the statistics graph View Window are automatically configured according to the graph

being drawn. For more information, see “Statistics Graph View Window Settings” (page 52).

Spreadsheet App Settings Menu Items
The Settings menu items (page 214) described below are specific to the Spreadsheet app.

S > [Auto Recalculation] … Toggles between automatic recalculation and no recalculation for each data
input.

S > [Edit Box Shows] … Specifies whether the contents of a formula already entered in a cell are
displayed as a formula or as a value. Even if value is specified by this setting,
the formula is displayed when editing cell contents.

S > [Cursor Moves] … Selects the cursor movement direction (down or right) after data is input or
pasted into a cell.

•　You can repeat steps (1) and (2) above to add more
regression graphs.
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Graph&Table App
You can use the Graph&Table app to draw various types of graphs and to create numeric tables.

Operation Flow
Example: To input the functions y = x2 − 1 and y = x, draw a graph, and create a numeric table

1.　h > Graph&Table

2.　On the Function tab (page 75), input the function.

(1) In the y1 line, input x2 − 1.
(2) In the y2 line, input x.

Xi-1E
XE

3.　To draw a graph of the function you entered, press >.
•　This displays the View Window menu. Change the range specification as required. For more information,

see “Specifying the Display Range of the Graph Window (View Window)” (page 80).

6.　To return to the Function tab, press > or b.

Note
•　Functions input on the Function tab of the Graph&Table app also appear on the Function tab of the

Dyna Graph app (page 89). Similarly, functions input on the Function tab of the Dyna Graph app also
appear on the Function tab of the Graph&Table app.

Out of Drawing Range Graph Warning Message
The Out of Drawing Range warning message appears when there is nothing to draw in the window when you
try to draw a graph. If this happens, choose the desired operation from the menu that appears.

To do this: Select this menu item:
Display the View Window menu [View Window]
Automatically adjust View Window settings and draw a graph [Auto Zoom]
Display the graph window (without drawing a graph) without adjusting View
Window settings

[Cancel]

Using the Function Tab
Within the Function tab, you can enter up to 20 functions of various types.

4.　Highlight  and then press O.
•　This draws the graph on the Graph tab (page 79).

5.　To display the numeric table for the function you entered, press >.
•　This displays the numeric table on the Table tab (page 86).
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Using the Setup Menu
Use the Setup menu to select a function type. You can also use this menu to specify the range of the graph
window and numeric table.

To display the Setup menu
1.　On the Function tab, highlight the first line.

•　Pressing U always highlights the first line.

2.　Press O.

To select a function type
1.　From the Setup menu, select [Type].

•　This displays the Type menu.

2.　Perform the operations described in the table below.

To select this function type: Select this menu item:
Cartesian coordinate type (y= f (x) form) [y=]
Polar coordinate type (r= f (θ) form) [r=]

Parametric type (
Xt= f (T)
Yt= f (T)

 form)
[Param]

Cartesian coordinate type (X= f (Y) form) [X=]
Inequality type (y> f (x), y< f (x), y≥ f (x), y≤ f (x) form) [y>], [y<], [y≥], [y≤]
Inequality type (X> f (Y), X< f (Y), X≥ f (Y), X≤ f (Y) form) [X>], [X<], [X≥], [X≤]

•　The type you choose is applied to the function you are about to input. It does not affect any function that
has already been entered.

To specify the display range of the graph window
From the Setup menu, select [View Window]. See “Specifying the Display Range of the Graph Window (View
Window)” (page 80) for details.

To specify the numeric table domain
From the Setup menu, select [Set Table Domain]. See “Specifying a Table Domain” (page 86) for details.

Inputting and Editing Functions

To input a function
1.　Use the operation under “To select a function type” (page 76) to select the type of function you want to input.

2.　On the Function tab, highlight the line where you want to input, and then input a function.
•　Press X to input the variables (x, θ, T, Y) according to the function type you chose.

Example 1: To input the y form of Cartesian coordinate type y = 2x2 − 2

2Xi-2E

Example 2: To input the polar coordinate type r = sin (θ) − 1

vX)-1E

Example 3: To input parametric type 
Xt ＝ 3sin (T)
Yt ＝ 3cos (T)

3vX)E
3cX)E

Example 4: To input the X form of Cartesian coordinate type X = 2Y2 − 5

2Xi-5E

In addition to the above, you can also use the special format input methods described below.

76



To do this: Perform this operation:
Input a composite function
Example: To input the composite function “y1(y2)”

into y3 after y = x2 − 1 and y = x have
already been input*1

Input “y1(y2)” into the y3 line.
V > [Function] > [y1](

V > [Function] > [y2])E

Input a function containing one or more alpha
variable*2 while simultaneously specifying the
value to be assigned to one of the alpha variables
in the function*3*4

Example: Assign 1, 2, 3 to variable A of y = Ax2 − 1 *5

Input “Ax2 − 1, [A=1,2,3]” into a y line.*6*7

PX(A)Xi-1`
s4([)PX(A)s((=)

1`2`3s5(])E

Input a function that includes a list*3*4

Example: Input y = {1,2,3}x2 *8
Input “{1,2,3}x2” into a y line.

C > [Statistics] > [{ }] 1 ` 2 ` 3rXiE

Input a function with a range of variable values
Example: Specify the x value of y = x2 within the

range 0 ≤ x ≤ 2

Input “x2, [0,2]” into a y line.
Xi`s4([)0`2s5(])E

*1　Composite functions can be nested up to five levels.
*2　Alpha variables except x, θ, T and Y.
*3　If there are multiple variables or multiple elements in the list, multiple graphs will be drawn at the same time

based on a single input function.
*4　The color and line type of the graph drawn by this operation cannot be changed.
*5　If there is only one value to be assigned, it can also be entered using the syntax Ax2 − 1 (A=1).
*6　Be sure to input numeric values within the square brackets ([ ]). You cannot input alpha variables here.
*7　Even if there are multiple variables in a function, values can be assigned to only one of the variables.
*8　When multiple lists are used in a function, all of the lists must have the same number of elements. For

example, y = {1,2,3}x2 − {1,1,1}. If a list does not have the same number of elements as the other lists, a
Dimension ERROR will occur.

Inputting Inequalities and Configuring Fill Settings
Example: To input the inequalities y ≥ x2 − 1 and y < x

1.　Use the procedure under “To select a function type” (page 76) to select [Type] > [y≥].

2.　Input x2 − 1 into the y1 line and x into the y2 line.

3.　Highlight the y2 line and then select T > [Change Symbol] > [<].

4.　Press > to draw the graph.
•　By default (S > [Ineq Region Type] > [Union]), all ranges

satisfying the conditions of each inequality are filled.

•　If you choose S > [Ineq Region Type] > [Intersection] to
draw the graph, only the range that satisfies the conditions
of all inequalities is filled.
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To edit a function
On the Function tab, highlight the line you want to edit and then perform the operation below.

To do this: Perform this operation:
Edit what you have already entered Press l, r, or E. This causes the input cursor to appear so

you can edit the entry.*

Overwrite input Press the key of the number or letter you want to re-input.*

Change the symbol of a Cartesian
coordinate type or inequality type

T > [Change Symbol] and select a sign from the list displayed.

*　Edits are not finalized until you press E after editing. To cancel editing without changing anything, press
b before pressing E.

To delete a function
To do this: Perform this operation:
Delete the function in the highlighted row Highlight the line that contains the content you want to delete,*

and then press I. Or you could select T > [Delete] > [Delete
Formula].

Delete all functions on the Function tab Press a. Or you could select T > [Delete] > [Delete All].
*　For parametric type functions, highlight either the Xt or Yt line.

Graph Drawing Settings (Line Type, Line Color)
On the Function tab, highlight the row that contains the graph drawing settings you want to change and then
perform the operations described in the table below.

To do this: Perform this operation:
Change the line type for graph drawing Select T > [Line Style]. Use the list that appears to select a line

style.
Change the line color for graph drawing Select T > [Line Color]. Use the list that appears to select a

color.
The line type and color you specify are shown by the icons to the left of each line of the Function tab.

Drawing Graphs and Creating Tables

To select a function to draw a graph and create a numeric table
1.　On the Function tab, highlight a line that contains an input function.

2.　Press T.
•　This displays a Tools menu with [Select] highlighted.

3.　Change [Select] to  (On) to enable or to  (Off) to disable graphing and numeric table generation for
the selected function.

4.　Press b to close the Tools menu.
•　The on/off setting of step 3 is indicated by the icons to the left of each line of the Function tab.

… On … Off

Note
•　All functions that you enable (turn on) in step 3 can be graphed, regardless of their type.
•　A numeric table can be created for a function that you enable (turn on) in step 3 if its function type

selected for [Type] on the Setup menu (page 76) is [y=], [r=], or [Param].
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To go from the Function tab to the Graph tab (to draw a graph)
Press > or highlight  and then press O. This causes the View Window menu to appear so you
can specify the range of the graph window. Change the range specification as required. For more information,
see “Specifying the Display Range of the Graph Window (View Window)” (page 80).
To return to the Function tab, press < or b.

Note
•　To prevent the View Window menu from appearing when you go to the Graph tab, turn off S > [Show

V-Win Settings] (page 215).

To go from the Function tab to the Table tab (to create a numeric table)
Press < or highlight  and then press O.
To return to the Function tab, press > or b.

Note
•　If you want to add a column of derivative coefficients to the numeric table on the Table tab, turn on S

> [Derivative] (page 219). In addition to the x and y columns, a y’-column for the derivative coefficient
will be included in the numeric table.

Using the Graph Tab

Showing and Hiding Tabs
While the Graph tab is active, press D* to hide the tab and expand the graph window. Press U to show the
tab again.

 in the lower-right corner of the window and  in the status bar indicate that a hidden tab can be shown
again.
*　You can hide the tab by pressing O, a, or almost any other key. Tabs also may be hidden automatically

when certain functions (such as graph analysis) are executed.  is not displayed, the tab cannot be
redisplayed until execution of the current function is stopped.

Adjusting the Graph Window

To move the graph window up, down, left, or right
Use the cursor keys.

To zoom the graph window in or out
Press + to zoom in or - to zoom out.

To fine-tune the graph window (Tools menu)
To do this: Select this menu item: Details:
Specify the display range T > [View Window] “Specifying the Display Range of

the Graph Window (View Window)”
(page 80)

Zoom the graph window in or out T > [Zoom] “Changing the Graph Window Zoom
Setting (Zoom)” (page 81)
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Grab a point on a window and drag it
around the display

T > [Pan] “Grabbing a Point on a Window and
Drag It Around the Display (Pan)”
(page 81)

Adjust the background image T > [Fade I/O] “Adjusting the Graph Window
Background Image (Fade I/O)”
(page 81)

Specifying the Display Range of the Graph Window (View Window)
Use the View Window menu* to specify the display range (x- and y-axis range) of the graph window. You can
also use this menu to specify the range of values for drawing polar and parametric type graphs.
*　This menu appears on the Graph tab when you select T > [View Window]. It can also be displayed from

other tabs in the Graph&Table app, Dyna Graph app and the Recursion app. The menu contents are the
same regardless of where it is displayed.

Using the Preset View Window Settings

To use this setting: Select T > [View Window] > [Pre-set
Windows] and then select this:

Initial calculator setup [Initialize]

Presets according to the current angle unit setting (S > [Angle]) [Trigonometric]

Calculator standard setup [Standard]
Fix the current y-axis setting and change the x-axis setting so the
on-screen y-axis and x-axis scale widths are one-to-one [Square] > [Y Base]

Fix the current x-axis setting and change the y-axis setting so the
on-screen y-axis and x-axis scale widths are one-to-one [Square] > [X Base]

To specify the display range manually
Use the View Window to input values for the items below.
•　x Minimum, x Maximum, x Scale (x-axis minimum value, maximum value, scale)
•　y Minimum*, y Maximum, y Scale (y-axis minimum value, maximum value, scale)
•　x Dot Value is the value per dot in the x-axis direction. It is determined according to the values of x Minimum

and x Maximum. Changing the x Dot Value value automatically updates the x Maximum value.
*　When the tab is hidden, the value set by y Minimum is the bottom edge of the graph window (red frame

below).

To specify the range of T and θ values and the pitch
These settings are applied when drawing parametric and polar graphs. Use the View Window to input values
for the items below.
•　T,θ Minimum, T,θ Maximum (maximum and minimum values assigned to T in the parametric type function,

and maximum and minimum values to be assigned to θ in the polar coordinate type function)
•　T,θ Pitch is the pitch of the T and θ values when drawing the graph. The smaller the pitch values, the finer

the graph that is drawn. Larger values result in coarser graphs.
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Changing the Graph Window Zoom Setting (Zoom)
Your calculator provides various convenient zoom settings that you can use to change the display range of the
graph window.

To do this within the graph window: Select T> [Zoom] and then select this:
Adjust the display so the graph is drawn along the entire y-axis [Zoom Auto]

Enclose a portion of the window and then zoom in on it [Zoom Box]*1

Zoom in or out on the center of the window*2 [Zoom In]
[Zoom Out]

Correct the x-axis so the x- and y-axis scales are in a 1:1 ratio [Zoom Square]
Make the displayed x-coordinate value an integer when using
trace (page 84) [Zoom Integer]*3

Round the displayed x-coordinate value to the appropriate
number of significant digits when using trace (page 84) [Zoom Round]

Restore previous View Window settings for all subsequent zoom
operations [Zoom Original]

Reset to View Window settings in effect immediately before the
last zoom operation [Zoom Previous]

*1　Selecting T > [Zoom] > [Zoom Box] displays a cross pointer ( ) in the window. Move the pointer to one
of the box’s vertices and then press O. Next, move the pointer to the opposite vertex and then press O.

*2　The zoom in/out ratio is the one specified in the dialog that appears when you select T > [Zoom] > [Zoom
In/Out Factors].

*3　Selecting T > [Zoom] > [Zoom Integer] displays a pointer in the window. Move the pointer to the coordinate
you want to center in the window and press O.

Grabbing a Point on a Window and Drag It Around the Display (Pan)
You can use the hand icon that appears to drag the graph window around the display.

1.　While the graph window is displayed, select T > [Pan].
•　This displays an arrow pointer ( ).

2.　Use the cursor keys to move the arrow pointer to the point in the window that you want to grab and then
press O.
•　This causes the pointer to change from an arrow ( ) to a hand ( ).

3.　Use the cursor keys to move the hand and drag the window around the display.
•　The contents of the window move along with the hand.

4.　Press O.
•　This returns the pointer to an arrow. You can repeat steps 2 and 3 as required.
•　When you are finished dragging window contents, press b.

Adjusting the Graph Window Background Image (Fade I/O)
You can use this operation to adjust the opacity of the background image. This operation can be performed
only when a 16-bit color image is being used as the graph window background image. For information about
displaying a background image, see “Background (Graph)” (page 219).

1.　While the graph window is displayed, select T > [Fade I/O].

2.　Use l and r to adjust the opacity of the background image.

3.　When the setting is the way you want, press b.
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Using Graph Solve (Graph Solve)
You can use Graph Solve to obtain the coordinates of roots, and other values for the integrals, y-axis intercept,
or other key feature points on a graph. For example, perform the operation below to find the root of a function
on a graph.

1.　Enter the function in the Function tab and press > to draw a graph.

2.　Select T > [Graph Solve] > [Root].
•　If there are multiple graphs in the graph window, one of them will flash.

3.　Use d and u to move the flashing to the graph whose root you want to obtain and then press O.
•　This causes a cross pointer ( ) to appear at the coordinates of the root and the coordinate values to

appear at the bottom of the window. If there are multiple roots, you can use r and l to move the pointer
to another root.

4.　To exit graph analysis, press b.
The values that can be obtained using graph analysis are shown in the table below.

To obtain this value: Select T > [Graph Solve] and then
select this:

Roots on a graph [Root]
Maximum value on a graph [Maximum Value]
Minimum value on a graph [Minimum Value]

Coordinates of intersection of two graphs*1 [Intersection]

Integral value of the specified range on the graph*2 [∫dx] > [∫dx]

Integral value and area*2*3 of a range delimited by multiple roots
on the graph [∫dx] > [Root]

Integral and area*2*4 of a range bounded by multiple intersections
of two graphs [∫dx] > [Intersection]

Integral and area*2*5 of a range bounded by the intersection of
two graphs and a root on either of them [∫dx] > [Mixed]

y-axis intercept [y-Intercept]

x-coordinate value on a graph for a given y-value*6 [x-Cal]

y-coordinate value on a graph for a given x-value [y-Cal]
*1　Can be calculated for Cartesian coordinate type (y= f (x) form) and inequality type (y> f (x), y< f (x), y≥ f (x),

y≤ f (x) form) graphs.
*2　Can be calculated for Cartesian coordinate type (y= f (x) form) graphs.
*3　An error occurs if there are more than 21 roots between the two specified roots.
*4　An error occurs if there are more than 21 intersections between the two specified intersections.
*5　You can also use the number keys to specify any x-coordinate value instead of the intersections or roots of

the graph.
*6　Cannot be calculated for parametric type graphs.

Important!
•　In the cases described below, solution accuracy may be reduced or solution may be impossible.
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-　When the solution is at the point of tangency between graphs or at the point of tangency between
a graph and the x-axis.

-　When the solution is at or near the inflection point of a graph.

Operation Example:
Example 1: To graph y = x3 − 2x − 1 and y = -x3 + 2x − 1, specify two intersections, and then calculate the

integral and area between them

1.　Graph the two functions.

2.　Select T > [Graph Solve] > [∫dx] > [Intersection].
•　This causes a pointer to appear at the coordinate of the leftmost intersection.

3.　Press O to make the current pointer location the lower limit of integration.

4.　Press r twice to move the pointer two intersections to the right.

5.　Press O to make the current pointer location the upper limit of integration.
•　This defines the integral range and displays the calculation result.

Integral value

Area

6.　To exit graph analysis, press b.
Example 2: To calculate the x-value of the y = x3 − 2x − 1 graph you drew in Example 1 above when y = -0.5

1.　Select T > [Graph Solve] > [x-Cal].

2.　Use d and u to move the flashing to the graph of y = x3 − 2x − 1 and then press O.
•　This displays a dialog for inputting the y-value.

3.　Input -0.5 and then press O.
•　This will cause a pointer to appear at one of the coordinates where y = -0.5 and the coordinate value will

appear at the bottom of the window. You can use r and l to move the pointer to another coordinate
where y = -0.5.

x-coordinate value

y-coordinate value
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4.　To exit graph analysis, press b.

Using Trace (Trace)
Trace displays a crosshair pointer ( ) on a graph that you can use to read the coordinate values at a specific
location. When S > [Derivative] (page 219) is turned on, derivative coefficients are displayed along with the
coordinate values.

To enable trace
Select T > [Trace].
The operations that can be performed while the trace function is enabled are described in the table below.

To do this: Perform this operation:
Move the pointer along the graph Press l or r.
Move to pointer to a specific x-coordinate on the graph Use the number keys to input an

x-coordinate value and then press O.
When there are multiple graphs, the pointer will move between
them

Press d or u.

Plot a dot with coordinate values on a graph* Move the pointer to the location where you
want to plot a dot with coordinate values
and then press O.

Exit trace Press b.
*　If the dot location is within the coordinates of a graph, it is displayed as a solid red dot ( ). If the dot location

is not within the coordinates of the graph, it is displayed as a red circle ( ).

Modifying a Graph by Changing the Coefficient Values of Its Function (Modify)
You can input a functional expression with five alpha variables included in the coefficients (such as y = Ax + B)
and then change the values of the variables (coefficient values) while the graph is displayed. This lets you see
how changes in the coefficient values affect the appearance of the graph.

Important!
•　When multiple functions are selected for graphing, modify cannot be used if there are more than two

functions that contain variables.

Example: Input y = Ax2 + Bx + C and observe how the shape of the graph is affected when the coefficient values
are changed. The initial values of A, B, and C are A = 1, B = 0, and C = 0.*1

1.　On the Function tab, input y = Ax2 + Bx + C.
•　Select T > [Built-In Function] > [y=Ax^2+Bx+C] and then input the function.*2

2.　Turn off all other function expression graphing settings.
•　See “To select a function to draw a graph and create a numeric table” (page 78).

3.　Press > to draw the graph.

5.　Use l and r to change the value of A.

4.　Select T > [Modify] to enable modify.
•　The current values of A, B, and C and the step value are

displayed in the lower-left corner of the graph window. You
can change the value where the pointer (I) is currently
located.

•　Use d and u to move the pointer (I) up and down.
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•　Each press of l or r changes the value of A by the step value. You can also use the number keys to
enter values.

6.　Press d to move the pointer (I) to B. Use l and r to change the value of B.

7.　Press d to move the pointer (I) to C. Use l and r to change the value of C.

8.　To exit modify, press b.
*1　Assign A = 1, B = 0, and C = 0 before beginning. See “To assign a value to an alpha variable” (page 18).
*2　You can use T > [Built-In Function] to input the functions below.

y = Ax + B

y = A(x − B)2 + C
y = Ax2 + Bx + C
y = Ax3 + Bx2 + Cx + D

y = Asin (Bx + C)
y = Acos (Bx + C)
y = Atan (Bx + C)

Note
•　While modify is enabled, you can copy the function of the currently displayed graph to any function

area on the Function tab (except an area of a function currently being used for drawing). To copy the
function, select T > [Copy] and choose the destination area on the menu that appears.

Using Sketch (Sketch)
You can use sketch to draw dots, lines, and text within the graphing area. For example, to draw a tangent line
on the graph of y = x2 + 1, perform the steps below.

1.　On the Function tab, input the function y = x2 + 1 and then press > to graph it.
•　This example graphs y = x2 + 1 only.

2.　Select T > [Sketch] > [Tangent Line].
•　This draws a line that is tangent to x = 0 of the y = x2 + 1 graph. You can use l or r to change the

coordinates of the point of tangency.

3.　To view the coordinates of the point of tangency, press O.
•　This executed the tangent line drawing and displays a dot ( ) with coordinate values at the point of

tangency.
•　Now you can use l and r to change the coordinates of the point of tangency and add a tangent line

by pressing O.

4.　To exit sketch, press b.
 
The following table shows what you can do with sketch.

To do this: Select T > [Sketch] and then select
this:

Clear all points, lines, and text drawn using sketch [Clear Screen]
Draw a line tangent to a graph [Tangent Line]
Draw a graph normal line [Normal Line]

Draw the inverse graph of a graph*1 [Inverse]

Toggle a point between draw and delete [Plot]
Specify two points and draw a line segment between them [Line]
Draw a circle by specifying its center point and one point on the
circumference

[Circle]

Draw a vertical line [Vertical Line]
Draw a horizontal line [Horizontal Line]

Draw a freehand line*2 [Pen]
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Write text*3 [Text]

*1　Sketch is automatically exited after a graph is drawn.
*2　You can use the cursor keys to move the pointer and draw a line.
*3　Input is possible starting from the current pointer location and ending with the right edge of the graph window.

I key operations while input is in progress are ignored.

Note
•　Sketch points, lines, and text are drawn according to the settings of S > [Plot/Line Color] (page 218)

and S > [Sketch Line] (page 218).

Graphing a Function Copied to the Clipboard
You can copy a function* from another app, paste it onto the Graph tab and then graph it.
*　An f (x) form expression (such as x2 − 2) or a y = f (x) form equation (such as y = x2 − 2).
Example: To copy (x + 2)(x − 2), paste it onto the Graph tab, and then graph it

1.　Use the Calculate app to input (x + 2)(x − 2) and then copy the expression.
•　For details about the copy operation, see “Copying, Cutting, and Pasting Expressions” (page 10).

2.　Start up the Graph&Table app and then press > to graph the expression.

3.　Press s.(%).
•　This graphs y = (x + 2)(x − 2).

Graph Drawing Setting Items
You can use the Settings menu to configure settings for the graph drawing operation and the graph drawing
display area. For details, see “Settings Menu Details” (page 214).

Using the Table Tab
With the Table tab, you can edit the numbers in the x-column of a numeric table and also perform the operations
below from the menu that appears when you press T.

To do this: Select this menu item: Details:
Specify the domain of the table being
created T > [Set Table Domain]

“Specifying a Table Domain”
(page 86)

Draw a graph that shows dots at the
coordinates of a numeric table T > [Graph Points]

“Graphing a Numeric Table”
(page 87)Draw a graph that connects the

coordinates of a numeric table with
straight line segments

T > [Graph Points (Joined)]

Specify the display range of the graph
window T > [View Window]

“Specifying the Display Range of
the Graph Window (View Window)”
(page 80)

Insert or add a row T > [Row]
“Editing a Numeric Table” (page 87)

Edit input data T > [Edit]
Save one column of a numeric table
to a list variable T > [Store List]

“Saving a Numeric Table to a List
Variable” (page 87)

Delete one row of a numeric table or
the entire table T > [Delete] “Editing a Numeric Table” (page 87)

Specifying a Table Domain
The numeric table domain is specified by the value of the x-variable (or θ, T) that is assigned to the function
used to create the numeric table. The following two methods are available to specify a table domain.
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To specify a table domain using this
method: Perform this operation:

Inputting the x-variable starting value,
ending value, and step value

1.　Select T > [Set Table Domain] > [Range].
2.　Input the starting value into the [Start] line, the ending value

into the [End] line, and the step values into the [Step] line.
3.　Highlight  and then press O.

Using list variable elements as the
x-variable

1.　Use List Editor to input the values to be used as the x-variable
into one of the lists (List 1 to List 26). For details, see “Inputting
Data in List Editor” (page 30).

2.　Select T > [Set Table Domain] > [List].
3.　Highlight the list variable in step 1 and then press O.
4.　To close the dialog, press b.

Graphing a Numeric Table
1.　While the numeric table is displayed, select one of the options below.

To draw a graph of coordinate dots only: T > [Graph Points]
To draw a graph by linking coordinate dots with straight line segments: T > [Graph Points (Joined)]

2.　Use the View Window menu that appears to change display range settings as required.
•　For details, see “Specifying the Display Range of the Graph Window (View Window)” (page 80).

3.　Highlight  and then press O.
•　This draws the graph on the Table tab.

Note
•　To prevent the View Window menu from appearing when drawing a graph, turn off S > [Show V-Win

Settings] (page 215).
•　The operations that can be performed while viewing a graph are the same as those on the Graph tab

(except for [Graph Solve] and [Modify]).

Editing a Numeric Table
To do this: Perform this operation:
Overwrite a numeric table x-value* with a different
value

Move the cursor to the x-column* line whose value you
want to change and then input the new value.

Edit a numeric table x-value* Move the cursor to the x-column* line you want to edit
and then select T > [Edit].

Add one row below the row where the cursor is
currently located

Select T > [Row] > [Add].

Insert a row above the row where the cursor is
currently located

Select T > [Row] > [Insert].

Delete the row where the cursor is located Select T > [Delete] > [Row].
Delete the entire numeric table and return to the
Function tab

Select T > [Delete] > [Table].

*　x, θ, or T

Saving a Numeric Table to a List Variable
One column of numeric table data can be saved to a list variable, which is specified by its number.

1.　Move the cursor to the numeric table column you want to save to a list variable.

2.　Select T > [Store List].

3.　Use the dialog that appears to input a list variable number and then press O.
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Displaying a Numeric Table and Graph at the Same Time
When S > [Table with Graph] is turned on, the numeric table window is displayed on the right of the Table
tab, and the graph window is displayed on the left.
•　Nothing is drawn in the graph window immediately after you go from the Function tab or the Graph tab to the

Table tab. Use the following operations to draw the graph.
-　Select T > [Switch Active Window].
-　From T, select [Graph Points] or [Graph Points (Joined)].

•　Each time you select T > [Switch Active Window], the active window (the window that is affected by the
operations you perform) toggles between the numeric table window and the graph window. The numeric table
window is active when the cursor is displayed on the numeric table.

•　The operations below can be used while the numeric table window is active.
“To display a pointer on a graph at the current numeric table cursor location (Graph-Link)” (page 88)
“Specifying a Table Domain” (page 86)
“Editing a Numeric Table” (page 87)
“Saving a Numeric Table to a List Variable” (page 87)

•　You can perform the operations below while the graph window is active.
“Showing and Hiding Tabs” (page 79)
“Adjusting the Graph Window” (page 79) (Excluding Pan and Fade I/O)
“Specifying the Display Range of the Graph Window (View Window)” (page 80)
“Changing the Graph Window Zoom Setting (Zoom)” (page 81)
“Using Trace (Trace)” (page 84)
“Using Sketch (Sketch)” (page 85)

To display a pointer on a graph at the current numeric table cursor location (Graph-Link)

1.　Turn on S > [Table with Graph].

2.　On the Function tab, input the function and then press < to go to the Table tab.

3.　Select T > [Switch Active Window].
•　This makes the graph window active and draws the graph.

5.　To exit this operation, press b.

Note
•　If no graph is drawn in the graph window, the T > [Graph-Link] cannot be performed while the numeric

table window is active. T > [Graph-Link] becomes enabled after a graph is drawn in the graph window.

4.　Select T > [Graph-Link].
•　This causes a crosshair pointer to appear on the graph at

the coordinates that correspond to the numeric table cursor
position.

•　Using d and u to move the numeric table cursor also
causes the graph pointer to move accordingly.
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Dyna Graph App
You can use the Dyna Graph app to input a function like y = Ax + B, which includes alpha variables as
coefficients. A displayed graph is continuously re-drawn as the value of a specific coefficient of its function is
varied within a specific range. A Dynamic Graph makes it possible to observe the effect of coefficient values
on the form and position of a graph.

Operation Flow
Example: To select the Dyna Graph app’s y = Asin Bx + C  built-in function and input it. Observe the change

in the graph as the value of the coefficient B of the function is varied. Specify a value of 1 for A and
C.

Note
•　If there are already functions on the Function tab of the Graph&Table app (page 75), they will also

appear on the Function tab of the Dyna Graph app of step 1 in the procedure below. Note that the
Function tab shown in the example below starts out with no functions.

1.　h > Dyna Graph
•　This displays the Function tab.

3.　Press >, or highlight  and then press O.

4.　In the Setup tab that appears, specify the variable name of the coefficient whose value is to be varied.

5.　Assign values to the variables for each of the other coefficients.

d1E1E

6.　Press > (or highlight  and then press O.)
•　This displays the View Window menu. See “Specifying the Display Range of the Graph Window (View

Window)” (page 80) for details.

7.　Configure View Window settings and draw the graph.
(1)　 Select [Pre-set Windows] > [Trigonometric].
(2)　 Highlight  and then press O.

•　The graph is continually re-drawn as the value of coefficient B is increased or decreased within the
range of 1 and 5, in increments of 1 (default setting*1).

2.　Select T > [Built-In Function] > [y=Asin(Bx+C)].
•　This inputs the function you select.

(1)　 Highlight [Variable] and then press O.
(2)　 On the menu that appears, highlight [B] and then press O.
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•　The Setup tab reappears after 10 iterations of coefficient value increase and decrease (default
setting*2).

•　To interrupt re-drawing of the graph and return to the Setup tab, press a.
*1　You can specify the start value, end value, and step value of the increase/decrease. See “Using the Setup

Tab” (page 91) for details.
*2　You can specify the speed at which the coefficient values are automatically varied during the graph drawing

operation. See “Using the Setup Tab” (page 91) for details.

Using the Function Tab
You can enter up to 20 functions on the Function tab.

Note
•　Functions input on the Function tab of the Dyna Graph app also appear on the Function tab of the

Graph&Table app (page 75).

Inputting and Editing Functions

To select the function type and input a function manually

1.　On the Function tab, highlight the first line and then press O.

2.　On the Setup menu that appears, select [Type].
•　This displays the Type menu.

3.　Perform the operations shown in the table below.

To select this function type: Select this menu item:
Cartesian coordinate type (y= f (x) form) [y=]
Polar coordinate type (r= f (θ) form) [r=]

Parametric type (
Xt= f (T)
Yt= f (T)

 form)
[Param]

•　The function type you choose is applied to the function you are about to input. It does not affect any function
that has already been entered.

4.　Highlight the line where you want to input a function, and then input it.
•　Press X to input the variables (x, θ, T) in accordance with the function type you chose.

Example 1: To input the Cartesian coordinate type y = Ax2 − B

PX(A)Xi-Pe(B)E

Example 2: To input the polar coordinate type r = Asin θ − B

PX(A)vX)-Pe(B)E

Example 3: To input the parametric type 
Xt ＝ Asin(T) − B
Yt ＝ Acos(T) − B

PX(A)vX)-Pe(B)E
PX(A)cX)-Pe(B)E
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To select and input a built-in function
1.　On the Function tab, highlight the line where you want to input.

2.　Select T > [Built-In Function].

3.　On the menu that appears, highlight the function you want to input and then press O.
•　You can input the functions listed below.

y = Ax + B

y = A(x − B)2 + C
y = Ax2 + Bx + C
y = Ax3 + Bx2 + Cx + D

y = Asin (Bx + C)
y = Acos (Bx + C)
y = Atan (Bx + C)

To edit or delete a function
To edit or delete an existing function, use the same operation as one in the Graph&Table app. See “To edit a
function” (page 78) and “To delete a function” (page 78) for more information.

To change the line color for graph drawing
1.　On the Function tab, highlight the function you want to change the line color of the graph.

2.　Select T > [Line Color].

3.　Use the list that appears to select a color.

To select a function to draw a graph
1.　On the Function tab, highlight a line that contains an input function.

2.　Press T.
•　This displays a Tools menu with [Select] highlighted.

3.　Change [Select] to  (On) to enable or to  (Off) to disable graphing for the selected function.

4.　Press b to close the Tools menu.
•　The on/off setting of step 3 is indicated by the icons to the left of each line of the Function tab.

… On … Off

Note
•　If multiple functions are selected on the Function tab for graphing, the message “Too Many Functions”

will appear on the Setup tab.

Using the Setup Tab
You can use the Setup tab to configure the settings described below, which appear when you press T.

To do this: Perform this operation:
Specify the range of variation of
the coefficient value

1.　Select T > [Range].
2.　Input the starting value into the [Start] line, the ending value into the [End]

line, and the step value into the [Step] line.
3.　To close the menu, press b twice.

Specify the speed that the
coefficient value changes
automatically during graph
drawing

1.　Select T > [Speed].
2.　On the menu that appears, highlight the setting you want and then press

O.
•　You can select one of the speeds described below.

[Stop&Go]: Coefficient value changes with each press of l or r
instead of automatically.*

[Slow]: Coefficient value changes at half of normal speed.
[Normal]: Coefficient value changes at normal speed.
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[Fast]: Coefficient value changes at double normal speed.
3.　To close the menu, press b twice.

Specify the display range Select T > [View Window]. For details, see “Specifying the Display Range
of the Graph Window (View Window)” (page 80).

*　If [Stop&Go] is selected for graph drawing, press b to return from the Graph tab to the Setup tab.

Dyna Graph App Settings Menu Items
The Settings menu items (page 214) described below are specific to the Dyna Graph app.
S > [Looping]: Specifies whether graphing should end automatically or continue once started.
S > [Locus]: Specify whether or not to display the graph locus.
S > [Processing Speed]: Speeds up drawing by thinning out the graph dots.
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Conic Graphs App
You can use the Conic Graphs app to graph various types of conic curves (parabola, circle, ellipse, and
hyperbola) using built-in Cartesian, polar, or parametric function equations.

Operation Flow

Example: To graph the parabola x = 2y2 + y − 1 using the built-in Cartesian coordinate function equation
X=AY2+BY+C. Next, use the built-in polar coordinate equation R=2Acos(θ) to graph the circle
r=4cosθ.

2.　Highlight Cartesian and then press > (or O).
•　This displays the Equation tab with a menu of Cartesian coordinate function equations.

3.　Highlight [X=AY2+BY+C] and then press > (or O).
•　This displays the Setup tab (page 94) for input of coefficient values.

4.　Input the values of the coefficients of x = 2y2 + y − 1.

2E
1E

s-(M)1E

5.　To draw the graph, press > (or O).
•　This displays the View Window menu. Change the range specification as required. For more information,

see “Specifying the Display Range of the Graph Window (View Window)” (page 80).

7.　Press < (or b) three times to return to the equation type menu.

8.　Highlight Polar and then press > (or O).
•　This displays the Equation tab with a menu of polar coordinate function equations.

9.　Highlight [R=2Acos(θ)] and then press > (or O).
•　This displays the Setup tab (page 94) for input of coefficient values.

10.　Input the values of the coefficients of r=4cosθ (r=2・2cosθ).

2E

1.　h > Conic Graphs
•　This displays a menu of equation types (Cartesian, Polar,

Parametric).

6.　Highlight  and then press O.
•　This draws the graph on the Graph tab (page 94).
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11.　To draw the graph, press > (or O).

Using the Setup Tab
In addition to inputting the values of coefficients of function equations, you can also use the Tools menu while
on the Setup tab to perform the operations described below.

To do this: Perform this operation:
Specify the display range Select T > [View Window]. See “Specifying the Display Range

of the Graph Window (View Window)” (page 80) for details.
Change the line color for graph drawing Select T > [Line Color]. Use the list that appears to select a

color.

Using the Graph Tab
You can use the Tools menu while on the Graph tab to perform the operations described below.

To do this: Select this menu item: Details:
Specify the display range T > [View Window] “Specifying the Display Range of

the Graph Window (View Window)”
(page 80)

Obtain the coordinates of the x-axis
or y-axis intercept or other key
feature points of a graph

T > [Graph Solve] “Using Graph Solve (Graph Solve)”
(page 94)

Display a pointer on a graph and read
the coordinate values

T > [Trace] “Using Trace (Trace)” (page 84)

Modify a graph by changing the
coefficient values of its function

T > [Modify] “Modifying a Graph (Modify)”
(page 96)

Zoom in and out of the display T > [Zoom] “Changing the Graph Window Zoom
Setting (Zoom)” (page 81)

Draw dots, lines, characters, etc. T > [Sketch] “Using Sketch (Sketch)” (page 85)*

Grab a point on a window and drag it
around the display

T > [Pan] “Grabbing a Point on a Window and
Drag It Around the Display (Pan)”
(page 81)

Adjust the background image T > [Fade I/O] “Adjusting the Graph Window
Background Image (Fade I/O)”
(page 81)

*　The Sketch menu of the Conic Graphs app does not include the following items. Tangent Line, Normal Line,
Inverse

Using Graph Solve (Graph Solve)
Depending on the type of graph currently on the display, you can use Graph Solve to calculate specific
coordinate values (such as the coordinates of the center point of a circle) or to draw specific lines (such as a
parabolic directrix). The table below shows what you can do with Graph Solve.

12.　Next, on the View Window menu that appears, highlight  and
then press O.
•　This draws the graph on the Graph tab (page 94).
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To do this: Select T > [Graph
Solve] and then select
this:

Parabola Circle Ellipse Hyperbola

Calculate the focus [Focus] Yes - Yes Yes
Draw the directrix [Directrix] Yes - - -
Calculate the vertex [Vertex] Yes - Yes Yes
Draw the axis of
symmetry [Axis of Symmetry] Yes - - -

Calculate the length of
the latus rectum [Latus Rectum] Yes - - -

Calculate the center [Center] - Yes Yes Yes
Calculate the radius [Radius] - Yes - -
Draw the asymptotes [Asymptotes] - - - Yes
Calculate the
eccentricity [Eccentricity] Yes - Yes Yes

Calculate the x-axis
intercept [x-Intercept] Yes Yes Yes Yes

Calculate the y-axis
intercept [y-Intercept] Yes Yes Yes Yes

Example: To graph the hyperbola y2 − x2 = 1 
Y − 0 2

12 − X − 0 2

12 = 1  and then determine their vertices

1.　On the Type tab, highlight [Cartesian] and then press O.

2.　Highlight [ Y − K 2

A2 − X − H 2

B2 = 1] and then press O.

3.　On the Setup tab, input the coefficients of the function.

1E
1E
0E
0E

4.　Press > to draw the graph.

6.　To exit Graph Solve, press b.

Note
•　When calculating two foci for an ellipse or hyperbolic graph, press l or r to calculate the second

focus. Pressing l or r returns to the first focus.
•　Pressing r when calculating the vertices of an ellipse will calculate the next value. Pressing l will

scroll back through previous values. An ellipse has four vertices.

5.　Select T > [Graph Solve] > [Vertex].
•　This causes a cross pointer ( ) to appear at the coordinates

of the first vertex and the coordinate values to appear at the
bottom of the window.

•　Press l or r to calculate the second vertex. Pressing l
or r returns to the first vertex.
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Modifying a Graph (Modify)
With the Conic Graphs app, you can select a built-in function equation, input coefficient values, and then draw
a graph. By changing coefficient values while the graph is displayed, you can observe how each affects the
graph.
Example: To graph the parabola y = 2(x − 1)2 − 1 using the built-in Cartesian coordinate function equation

Y=A(X−H)2+K. Next, observe how the graph changes as you vary the values of equation coefficients
A, H, and K.

1.　On the Type tab, highlight [Cartesian] and then press O.

2.　Highlight [Y=A(X−H)2+K] and then press O.

3.　On the Setup tab, input the coefficients of the function.

2E
1E

s-(M)1E

4.　Press > to draw the graph.

6.　Use l and r to change the value of A.
•　Each press of l or r changes the value of A by the step value. You can also use the number keys to

enter values.

7.　Press d to move the pointer ( ) to H. Use l and r to change the value of H.

8.　Press d to move the pointer ( ) to K. Use l and r to change the value of K.

9.　To exit modify, press b.

5.　Select T > [Modify] to enable modification.
•　The current values of A, H, and K and the step value are

displayed in the lower-left corner of the graph window. You
can change the value where the pointer ( ) is currently
located.

•　Use d and u to move the pointer ( ) up and down.
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3D Graph App
You can use the 3D Graph app to draw 3D graphs in three-dimensional space using x-, y-, and z-coordinates.
You can graph lines, planes, spheres, cylinders, and cones using built-in templates, or you can manually enter
functions to draw lines, curved surfaces, solids of revolution, and other forms.

Operation Flow

Using a Built-in Template to Draw a Graph
Example 1: To select the [Sphere] > [ ] built-in template and draw a 3D graph of the

sphere x2 + y2 + z2 = 22.

4.　Select [ ].
•　This displays the template’s numeric value input window.
•　Since we want to graph “x2 + y2 + z2 = 22”, input a=0, b=0, c=0, and r=2.

0E0E0E2E

6.　To draw a 3D graph using a built-in template you stored, press >.
•　This displays the View Window menu. Change the range specification as required. For more information,

see “Specifying the Spatial Range and Drawing Accuracy for 3D Graphing (View Window)” (page 102).

1.　h > 3D Graph
•　This displays the Function tab.

2.　Press O (or select T > [Enter Equation]) to display the Type menu.*

3.　On the Type menu, select [Templates] > [Sphere].
•　This displays a list of sphere templates.

5.　Press O.
•　This displays the template name (Sphere) along with the

values you input.

7.　Highlight  and then press O.
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8.　To return to the Function tab, press > or b.
*　If the highlighted line is blank, simply press O to display the Type menu. If the highlighted line contains an

equation, you need to select T > [Enter Equation].

Using a Manually Input Function to Draw a Graph

Example 2: Continuing from Example 1, above, to manually input Z = X2 + Y2 − 3 and simultaneously draw two
3D graphs

2.　Press O. On the menu that appears, select [Z=].
•　Alternatively, you could also perform the operation T > [Enter Equation] > [Z=].

3.　Input Z = X2 + Y2 − 3.

Xi+P-(Y)i-3E

5.　To return to the Function tab, press > or b.

Out of Drawing Range Graph Warning Message
The Out of Drawing Range warning message appears when there is nothing to draw in the window when you
try to draw a graph. If this happens, choose the desired operation from the menu that appears.

To do this: Select this menu item:
Display the View Window menu [View Window]
Display the graph window (without drawing a graph) without adjusting View
Window settings

[Cancel]

Using the Function Tab
You can use the Function tab to store templates and functions you want to use for 3D graph drawing. You can
store up to a total of three templates and/or functions. The example screen below shows the Function tab when
one template and two functions are stored.

•　This draws the graph on the Graph tab.

1.　Use d to highlight “2:” on the Function tab.

4.　To draw the 3D graph, press >. Next, on the View Window menu
that appears, highlight  and then press O.
•　This draws the graphs on the Graph tab.
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Storing and Editing 3D Graphing Templates

To store a template
1.　On the Function tab, highlight the line where you want to store a template.

3.　Select the template you want to use.
•　Use the template menu to select what you want to graph and the graphing method you want to use.

To graph this: Select this menu item:

Straight line with the equation X − X0
a  = Y − Y0

b  =

Z − Z0
c

[Line] > [ ]

Straight line by using a vector equation r = r0 + t v
(two vectors)

[Line] > [ ]

Straight line by specifying the coordinates of two
points

[Line] > [Line through 2 points]

Straight line by specifying the coordinates of one
point and a direction vector [Line] >[

Through point (X0,Y0,Z0)
Direction vector [a,b,c]

]

Plane by using the equation aX + bY + cZ + d = 0 [Plane] > [ ]

Plane by using a vector equation r = r0 + s u   + t v
(three vectors)

[Plane] > [ ]

Plane by specifying the coordinates of three points [Plane] > [Plane through 3 points]
Sphere by using the equation:
X − a 2 + Y − b 2 + Z − c 2 = r2

[Sphere] > [ ]

Sphere by using the equation:
X2 + Y2 + Z2 + aX + bY + cZ + d = 0

[Sphere] > [ ]

Cylinder [Cylinder]
Cone [Cone]

•　Selecting any one of the above options displays a window for inputting the selected template’s values.

4.　Depending on the template you chose, input the required value in each cell (or row) in the window.

5.　After inputting all of the values, press O.
(If you chose [Cylinder] or [Cone] in step 3, highlight  and then press O here.)
•　This returns to the Function tab.

2.　Select T > [Enter Equation] > [Templates].
•　This displays the Select Template menu.
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Note
•　Note that the following input in step 4 results in an error.

For this template: This type of input results in an error:

[Line] > [ ] a=0 or b=0 or c=0

[Line] > [ ] X, Y, Z elements = 0 for v

[Line] > [Line through 2 points] Both points = Identical coordinate values

[Line] >[
Through point (X0,Y0,Z0)
Direction vector [a,b,c]

]
All direction vector elements = 0

[Plane] > [ ] a=0 and b=0 and c=0

[Plane] > [ ] •　X, Y, Z elements of either or both u  and v  = 0
•　u  and v  = Identical orientation

[Plane] > [Plane through 3 points] •　Two of three points = Identical coordinate
values

•　Three points are on a straight line
[Sphere] > [ ] r = 0 or less

[Sphere] > [ ] Input values do not satisfy a2+b2+c2>4d.

[Cylinder] Radius: 0 or less
Same value for Zmin and Zmax[Cone]

To edit a template

1.　Highlight the line where the template you want to edit is located, and then press O.
•　This displays the template’s numeric input window.

2.　Make changes to the existing values as required.

3.　After everything is the way you want, press O.
(If you are editing a [Cylinder] or [Cone] template, highlight  and then press O here.)

To delete a template
To delete a stored template, use the same operation as that for deleting a Graph&Table app’s stored function.
See “To delete a function” (page 78) for details.

Storing and Editing Functions for 3D Graphing

To store a function
1.　On the Function tab, highlight the line where you want to store a function.

2.　Select T > [Enter Equation].

3.　Perform the operations shown in the table below.

To select this function type: Select this menu item:
Cartesian coordinate type (Z= f (X, Y) form) [Z=]

Parametric type 
Xst ＝ f S, T
Yst ＝ f S, T
Zst ＝ f S, T

 form [Parametric]

Solid of rotation on the X-axis (Y= f (X) form)*1 [x-Axis Rotate]

Solid of rotation on the Y-axis (Y= f (X) form)*2 [y-Axis Rotate]
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*1　This draws a three-dimensional graph on the XY plane input using the Y=f(X) format and rotates it 360
degrees around the X axis.

*2　This draws a three-dimensional graph on the XY plane input using the Y=f(X) format and rotates it 360
degrees around the Y axis.

4.　Input the function in accordance with the selected type.
•　Press X to input the variables (X or T) in accordance with the function type you chose.
•　To input “Y” for a Z= form function, press P-(Y) or press C and then input using the menu that

appears.
•　To input “S” for a parametric type function, press P/(S) or press C and then input using the menu

that appears.

Example 1: To input the Cartesian coordinate type Z = X2 + Y2

T > [Enter Equation] > [Z=]
Xi+P-(Y)iE

Example 2: To input the parametric type 
Xst ＝ 2cos T
Yst ＝ 3sin T
Zst ＝ 3cos T

T > [Enter Equation] > [Parametric]
2cX)E
3vX)E
3cX)E

Example 3: To input the solid of rotation on the X-axis type Y = X2 − 2

T > [Enter Equation] > [x-Axis Rotate]
Xi-2E

Note
•　You can input only Absolute Value (page 226) and Hyperbolic Calc (page 237) category functions

using the menu that appears when you press C in step 4.

To edit or delete a function
To edit or delete a stored function, use the same operation as one in the Graph&Table app. See “To edit a
function” (page 78) and “To delete a function” (page 78) for more information.

Graph Drawing Settings (Line Color, Area Color)
On the Function tab, highlight the row that contains the graph drawing settings you want to change and then
perform the operations described in the table below.

To do this: Perform this operation:
Change the line color for graph drawing Select T > [Line Color]. Use the list that appears to select a

color.
Change the area color for graph drawing Select T > [Area Color]. Use the list that appears to select a

color.
The line color and area color you specify are shown by the icons to the left of each line of the Function tab as
shown below.

Area Color

Line Color
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Drawing Graphs

To select a function to draw a graph
1.　On the Function tab, highlight a line where a template or function is stored.

2.　Press T.
•　This displays a Tools menu with [Select] highlighted.

3.　Change [Select] to  (On) to enable or to  (Off) to disable graphing for the selected template or
function.

4.　Press b to close the Tools menu.
•　The on/off setting of step 3 is indicated by the icons to the left of each line of the Function tab.

… On … Off

To go from the Function tab to the Graph tab (to draw a graph)
Press > or highlight  and then press O. This causes the View Window menu*1*2 to appear so you
can specify the range of the graph window. Change the range specification as required. For more information,
see “Specifying the Spatial Range and Drawing Accuracy for 3D Graphing (View Window)” (page 102).
To return to the Function tab, press < or b.
*1　You can also display the View Window menu by pressing UO on the Function tab.
*2　To prevent the View Window menu from appearing when you go to the Graph tab, turn off S > [Show

V-Win Settings].

Using the Graph Tab

Adjusting the Graph Window

To zoom the graph window in or out
Press + to zoom in or - to zoom out.

To rotate a 3D Graph manually
Use the cursor keys to rotate a 3D graph up, down, left, and right.

Note
•　You can also rotate a 3D graph automatically. See “Auto Rotating a 3D Graph (Rotate)” (page 106).

To fine-tune the graph window (Tools menu)
To do this: Select this menu item: Details:
Specify the display range T > [View Window] “Specifying the Spatial Range and

Drawing Accuracy for 3D Graphing
(View Window)” (page 102)

Zoom the graph window in or out T > [Zoom] “Changing the Graph Window Zoom
Setting (Zoom)” (page 106)

Specifying the Spatial Range and Drawing Accuracy for 3D Graphing (View Window)
You can use the View Window menu to specify the spatial range (x-, y-, and z-axis ranges) and the precision
for drawing a 3D graph. This View Window also lets you specify the range of values for drawing a parametric
type graphs, and the viewpoint of a 3D graph.

To display the View Window menu
On the Graph tab, select T > [View Window].
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To specify the coordinate range and drawing precision for drawing a 3D graph
Use the View Window to input values for the items below.
•　x Minimum, x Maximum, x Grid (x-axis minimum value*1, maximum value*1, grid value*2*3)
•　y Minimum, y Maximum, y Grid (y-axis minimum value*1, maximum value*1, grid value*2*3)
•　z Minimum, z Maximum (z-axis minimum value*1, maximum value*1)

To specify the range and drawing precision for each of the parameters (S and T) of a parametric type
graph
These settings are applied when drawing parametric graphs. Use the View Window to input values for the items
below.
•　S Minimum, S Maximum, S Grid (parameter S minimum value*1, maximum value*1, grid value*2*3)
•　T Minimum, T Maximum, T Grid (parameter T minimum value*1, maximum value*1, grid value*2*3)

To adjust the viewpoint of the graph window
Use the settings below to adjust the viewpoint of the graph display with respect to the x-axis and z-axis. Always
specify a value in degrees, regardless of the current S > [Angle] (page 215) angle unit setting.
Angle θ: Specifies the angle of clockwise rotation of the x-axis (-180° < θ < 180°) viewed from the positive end
of the x-axis (0°).
Angle φ: Specifies the angle rotation of the z-axis towards the back (0° < φ < 360°) viewed from the positive
end of the z-axis forward (0°).

To initialize the View Window settings
On the View Window menu, select [Pre-set Windows] > [Initialize].
 
*1　Input minimum/maximum values in the range where the absolute value is smaller than 1 × 1098.
*2　Input a grid value in the range 2 ≤ grid ≤ 50.
*3　The grid value specifies the number of calculation points (number of divisions) for drawing a graph within

the specified drawing range (from the minimum value to the maximum value). However, in the case of a
sphere and certain other graph forms, the grid value is the number of divisions of the graph itself rather than
the number of divisions of the drawing range.

Note
•　The greater the x Grid and y Grid values, the more detailed the graph. Also note, however, that larger

values require more calculation, which means that the graphing operation takes more time.
•　Graphing may be impossible if the x Grid and y Grid values are too small.

Displaying the Cross Section of a 3D Graph
You can display the cross section of a 3D graph sliced with any vertical plane relative to the x-, y-, or z-axis.
This operation is available for lines, planes, spheres, cylinders, or cones drawn using a template.

To display the cross section of a 3D graph
On the Graph tab that already shows a 3D graph, perform the operations in the table below.

To do this: Select T > [Graph Solve] > [Draw
Cross Section] and then select this:

Display a cross section of a 3D graph sliced with a plane
perpendicular to the x-axis.

[Cross X]

Display a cross section of a 3D graph sliced with a plane
perpendicular to the y-axis.

[Cross Y]

Display a cross section of a 3D graph sliced with a plane
perpendicular to the z-axis.

[Cross Z]

Example: To display a cross section sliced on a plane perpendicular to the x-axis of the sphere graphed for
Example 1 of “Operation Flow” (page 97).
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T > [Graph Solve] > [Draw Cross Section] > [Cross X]

Note
•　The outline of the cross section of a 3D graph sliced with a plane is highlighted using the opposite

color of the color specified by Area Color (page 101). Also, the outline of the cross section is displayed
in the forefront plane.

•　When a planar graph is sliced, the outer border of the planar graph is highlighted if the planar graph
overlaps the plane being used for slicing.

To view a cross section from a particular direction
While a cross section is displayed, perform one of the operations below.

To do this: Select this menu item:
Display the view along the positive x-axis T > [View From pos x Direction]
Display the view along the positive y-axis T > [View From pos y Direction]
Display the view along the positive z-axis T > [View From pos z Direction]
Return the view direction to its original view T > [Zoom Original]

To move the cross section of a 3D graph
Press U or D to move a cross section on the applicable axis. You can also specify a location on a cross
section by directly inputting a coordinate value on the applicable axis.

Determining the Intersect of Straight Lines or Planes (fx-CG100 only)
You can use the operations below to determine the intersect of two lines, the intersect of a line and a plane, or
the intersect of two planes. This operation can be performed on lines and/or planes drawn using a template.

Example 1: To graph the lines X − 1
1  = Y − 1

1  = Z − 1
-1  and X − 1

2  = Y − 1
2  = Z − 1

2 , and determine where they

intersect

1.　Use Function tab templates to store the equations of the two lines.
T > [Enter Equation] > [Templates] >

[Line] > [ ]

1E1E1E1E1Es-(M)1EE
dT > [Enter Equation] > [Templates] >

[Line] > [ ]

1E1E1E2E2E2EE

2.　Press > to draw the graph.

Example 2: To graph the two planes X+Z=0 and X+Y=0 and determine their intersect

1.　Use Function tab templates to store the equations of the two planes.

3.　Select T > [Graph Solve] > [Intersection].
•　This displays the intersect of the two lines. The coordinates

of the intersect are shown in the lower left corner of the
display.
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T > [Enter Equation] > [Templates] >
[Plane] > [ ]

1E0E1E0EE
dT > [Enter Equation] > [Templates] >

[Plane] > [ ]
1E1E0E0EE

2.　Press > to draw the graph.

Note
•　The message “NOT FOUND” appears if the two 3D graphs do not intersect.
•　The message “COINCIDENT” appears in the cases described below.

-　Two straight lines that are being considered align perfectly
-　Two planes that are being considered overlap completely
-　A line and plane are being considered, and the line is on the plane

•　When there are three straight lines or planes, you can change how they are combined by pressing U
or D.

Determining the Relationship Between Straight Lines or Planes (fx-CG100 only)
You can determine the relationship between two 3D graphs using the combinations below.

For this combination: You can determine these types of relationships:
Line-line Intersect, orthogonal, parallel, skew lines, or same line
Line-plane Intersect, orthogonal, parallel, or line on the plane
Plane-plane Intersect, orthogonal, parallel, or same plane

This operation can be performed on lines and/or planes drawn using a template.

Example: To graph line r =
-1
-2
1

+ t
1
1
0

 and plane r =
1
2
0
+ s

1
1
0
+ t

0
1
1

, and determine the relationship between

them

1.　On the Function tab, use the templates to store the equations of the line and plane.
T > [Enter Equation] > [Templates] >

[Line] > [ ]
s-(M)1Es-(M)2E1E1E1E0EE

dT > [Enter Equation] > [Templates] >
[Plane] > [ ]

1E2E0E1E1E0E0E1E1EE

2.　Press > to draw the graph.

•　The meanings of the relationship messages that appear in the lower left corner of the display are shown
in the table below.

3.　Select T > [Graph Solve] > [Intersection].
•　This displays the intersect of the two planar graphs. The

parametric equation of the intersect is shown in the lower left
corner of the display.

3.　Select T > [Graph Solve] > [Relationship].
•　A message indicating the relationship between the line and

the plane is displayed in the lower left corner of the display.
In this example, the relationship is “PARALLEL”.
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Message Meaning
INTERSECT Intersecting point or lines

ORTHOGONAL Perpendicular intersection
PARALLEL Parallel

SKEW LINES Skewed relationship
COINCIDENT Same line

ON THE PLANE Line on the plane
COINCIDENT Same plane

Note
•　When there are three straight lines or planes, you can change how they are combined by pressing U

or D.

Using Trace (Trace)
Trace displays a crosshair pointer ( ) on a graph that you can use to read the coordinate values at a specific
location. To enable trace, select T > [Trace].
The operations that can be performed while the trace function is enabled are described in the table below.

To do this: Perform this operation:
Move the pointer along the graph Press d, u, l, or r.
Move the pointer to a specific x- and y- coordinates on
the graph

Use the number keys to input x-coordinate and
y-coordinate values and then press O.
(Z= graphs and parametric type graphs only)

Move the pointer between graphs when multiple
graphs are displayed

Press D or U.*

Exit trace Press b.

*　If there is only one graph on the display and the crosshair pointer ( ) is shown (because you selected T
> [Trace]), pressing D or U returns the pointer to its initial position.

Changing the Graph Window Zoom Setting (Zoom)
To do this within the graph window: Select T> [Zoom] and then select this:
Zoom in or out on the center of the window [Zoom In][Zoom Out]
Display the view along the positive x-axis [View From pos x Direction]
Display the view along the positive y-axis [View From pos y Direction]
Display the view along the positive z-axis [View From pos z Direction]
Return the 3D graph to its original (unrotated, unzoomed) state [Zoom Original]

Auto Rotating a 3D Graph (Rotate)
You can rotate a 3D graph automatically using Auto Rotate. Auto rotation stops automatically after two rotations.

1.　On the Graph tab, select T > [Rotate].

2.　On the menu that appears, select a rotation direction.
•　To stop the auto rotation part way through, press a.
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Using Sketch (Sketch)
You can use sketch to draw dots and text within the graphing area. The following table shows what you can
do with sketch.

To do this: Select T> [Sketch] and then select
this:

Clear all points and text drawn using sketch [Clear Screen]

Toggle a point*1 between draw and delete [Plot]

Write text*1*2 [Text]

*1　Sketch points and text are drawn according to the settings of S > [Plot/Line Color] (page 218).
*2　Input is possible starting from the current pointer location and ending with the right edge of the graph window.

I key operations while input is in progress are ignored.

3D Graph App Settings Menu Items
The Settings menu items (page 214) described below are specific to the 3D Graph app.
S > [3D Axes] ... Shows/hides Cartesian coordinate axes in the graph window.
S > [Box] ... Shows/hides boxed axes in the graph window.
S > [3D Label] ... Shows/hides axis labels in the graph window.
 

Setting Examples

3D Axes: On
Box: On

3D Label: On

3D Axes: Off
Box: On

3D Label: On

3D Axes: On
Box: On

3D Label: Off
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Recursion App
You can use the Recursion app to work with general terms or two-term or three-term recursion formulas of
numeric sequences. It creates a numeric table from a recursion formula and draws a graph. You can also draw
a Phase Graph based on two recursion formulas of the same type, or a Web Graph to check the convergence
or divergence of two-term recursion formulas.

Operation Flow
Example: To create a numeric table for the three-term recursion formula (Fibonacci sequence) un + 2 = un + 1 + un

where the first term is u1 = 1 and the second term is u2 = 1, and the value of the n-variable changes
from 1 to 6, and then draw a graph of the numeric table

1.　h > Recursion

2.　Specify the formula type, first term type and the numeric table domain.
(1)　 On the Sequence tab, press u to highlight the first line.
(2)　 Press O, and then use the Setup menu that appears to configure the settings shown below.

•　[Type] > [un+2]
•　[First Term] > [u1]
•　[Set Table Domain] > [Start]： 1 ; [End]： 6

3.　On the Sequence tab, input un + 2 = un + 1 + un, u1 = 1, u2 = 1.

d (Highlights line 2 (un+2).)
C > [Recursion] > [un+1]+
C > [Recursion] > [un]E

1E
1E

5.　To draw a graph, select T > [Graph Points].

6.　To return to the numeric table display, press b.
•　Pressing < returns to the Sequence tab.

Using the Sequence Tab
On the Sequence tab, select one of the formula types shown below and input the formula.

For this formula type: Enter this formula:
un General term (Up to three of un, vn, wn)

un+1 Two-term recursion formula (Up to three of un + 1, vn + 1, wn + 1)

4.　To display the numeric table, press >.
•　The numeric table is displayed on the Table tab.

(1)　 Use the View Window menu that appears to select [Pre-set
Windows] > [Standard].

(2)　 Next, highlight  and then press O.
•　This causes the graph of the numeric table to appear on

the Table tab.
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un+2 Three-term recursion formula (Up to three of un + 2, vn + 2, wn + 2)

un,vn Two general terms un and vn
un,vn+1 General term un and two-term recursion formula vn + 1

un+1,vn Two-term recursion formula un + 1 and general term vn
un+1,vn+1 Two two-term recursion formulas un + 1 and vn + 1

Using the Setup Menu

To display the Setup menu

1.　On the Sequence tab, use u to highlight the first line.
•　Pressing U always highlights the first line.

2.　Press O.

To choose the formula type and first term type
To select this: Select this from the Setup menu:
General term (un) [Type] > [un]

Two-term recursion formula (un + 1) [Type] > [un+1]

Three-term recursion formula (un + 2) [Type] > [un+2]

Two general terms un and vn [Type] > [un,vn]

General term un and two-term recursion formula vn + 1 [Type] > [un,vn+1]

Two-term recursion formula un + 1 and general term vn [Type] > [un+1,vn]

Two two-term recursion formulas un + 1 and vn + 1 [Type] > [un+1,vn+1]

First term type u0
* [First Term] > [u0]

First term type u1
* [First Term] > [u1]

*　The first term type must be specified when the formula type is [un+1], [un+2], [un,vn+1], [un+1,vn] or [un+1,vn+1].

To specify the numeric table domain
1.　From the Setup menu (page 109), select [Set Table Domain].

2.　Highlight [Start], input a starting value (0 or some positive integer) and then press E.

3.　Highlight [End], input the ending value* (a positive integer that is greater than the starting value) and then
press E.

4.　To close the menu, press b.
*　Do not specify an ending value that exceeds the starting value plus 998. The ending value must be equal to

or less than 1 × 106.

To specify the starting coordinates for drawing a web graph (Formula type: un+1)
Before drawing a web graph on the Table tab, specify the starting coordinates (x-coordinates) for drawing in
advance. To specify the starting coordinates, select [Set Web Graph Start] from the Setup menu (page 109).
For information about web graph drawing, see “Using Web Graph to Check the Convergence or Divergence
of a Numeric Sequence” (page 112).

Inputting and Editing Recursion Formulas

To input or edit a recursion formula
•　On the Sequence tab, highlight the line where you want to input something and then start inputting. To edit

part of something you have already entered, press O, r, or l.
•　Use C > [Recursion] to input n, un, un + 1 (and vn, vn + 1, wn, wn + 1).
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•　If the formula type is [un+1], [un,vn+1], [un+1,vn] or [un+1,vn+1], input the first term. If the formula type is [un+2],
input the first and second terms.

Note
•　The restrictions described below apply when [un,vn], [un,vn+1], [un+1,vn] or [un+1,vn+1] is selected as the

formula type.

With this formula type: This type of input is not supported:
un,vn •　Input of vn in the left-side un expression and input of un in the left-side

vn expression at the same time*1

•　Input of an expression that includes w*2

un,vn+1 •　Input of vn in the left-side un expression and input of un + 1 in the left-side
vn + 1 expression at the same time*1

•　Input of an expression that includes w*2

un+1,vn •　Input of vn + 1 in the left-side un + 1 expression and input of un in the
left-side vn expression at the same time*1

•　Input of an expression that includes w*2

un+1,vn+1 •　Input of vn + 1 in the left-side un + 1 expression and input of un + 1 in the
left-side vn + 1 expression at the same time*1

•　Input of an expression that includes w*2

*1　Input on the Sequence tab itself is possible, but doing so causes an error (Circular ERROR) when you try
to create a table.

*2　Input in the Sequence tab itself is possible, but doing so causes an error (Syntax ERROR) when you try to
create a table.

Example of Inputting a Two-term Recursion Formula and General Term at the Same Time
Example: To enter the equation below, which consists of two-term recursion formula un + 1 and a general term

vn. Next, create a numeric table and then graph the table.

un + 1 =
6un + 2
un + 5  (However u0 = 8)

vn =
un − 2
un + 1

1.　On the Sequence tab, press u to highlight the first line.

2.　Press O. Next, use the Setup menu that appears to configure the settings shown below.
•　[Type] > [un+1,vn]
•　[First Term] > [u0]
•　[Set Table Domain] > [Start]： 1 ; [End]： 6

3.　Input: un + 1 =
6un + 2
un + 5  , u0 = 8 , vn =

un − 2
un + 1

d (Highlights line 2 (un + 1).)
e6C > [Recursion] > [un]+2d

C > [Recursion] > [un]+5E
8E

eC > [Recursion] > [un]-2d
C > [Recursion] > [un]+1E

4.　To display the number table, press >.
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5.　To draw a graph, select T > [Graph Points].

To delete a recursion formula
See “To delete a function” (page 78).

To specify the line type and line color of a graph drawn from a recursion formula
See “Graph Drawing Settings (Line Type, Line Color)” (page 78).

Creating a Numeric Table
•　Of the recursion formulas on the Sequence tab, those with T > [Select] turned on can be used for numeric

table creation. You can determine the current on/off setting by checking the icon to the left of a recursion
formula.

… On … Off
•　To create a numeric table, press > or <, or highlight  and then press O.
•　Turning on S > [ΣDisplay] adds a cumulative sum column to the numeric table for each term (Σun, Σvn, Σwn).

Using the Table Tab
The Table tab displays a numeric table or a graph. When you move from the Sequence tab to the Table tab,
the numeric table is initially displayed. You can switch from numeric table display to graph display by using the
T menu.

Operations While a Numeric Table is Displayed
You can use the cursor keys, as well as the U and D keys to move the cell highlighting between cells. You
can also perform the operations below from the T menu.

To do this: Select this menu item:
Specify the domain of the table being created*1 T > [Set Table Domain]

Draw a graph that shows dots at the coordinates*2 of a numeric
table

T > [Graph Points]

Draw a graph that connects the coordinates*2 of a numeric table
with straight line segments

T > [Graph Points (Joined)]

Use Web Graph to check the convergence or divergence of a
numeric sequence*3

T > [Web Graph]

Draw a Phase Graph based on two recursion formulas*4 T > [Phase Graph]

Specify the display range of a graph*5 T > [View Window]

Save one column of a numeric table to a list variable T > [Store List]
Delete an entire numeric table and return to the Sequence tab T > [Delete]

*1　See “To specify the numeric table domain” (page 109).
*2　Each coordinate consists of the numeric table n-column as the x-axis and the un/vn/wn-column as the y-axis.

•　This displays the numeric table on the Table tab.

(1)　 Use the View Window menu that appears to select [Pre-set
Windows] > [Standard].

(2)　 Next, highlight  and then press O.
•　This causes the graph of the numeric table to appear on

the Table tab.
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*3　Drawing is possible when un+1 is selected as the formula type. See “Using Web Graph to Check the
Convergence or Divergence of a Numeric Sequence” (page 112).

*4　Drawing is possible when un, un+1, or un+2 is selected as the formula type. See “Drawing a Phase Graph
From Two Sequences” (page 112).

*5　See “Specifying the Display Range of the Graph Window (View Window)” (page 80).

Drawing a Phase Graph From Two Sequences
You can create numeric tables (sequences) from two recursion formulas and then draw a Phase Graph using
the values of one formula as the horizontal axis and the values of the other formula as the vertical axis.
Example: To input the two two-term recursion formulas un + 1 = 0.9un and vn + 1 = vn + 0.1n − 0.2, where the first

terms are u1 = 1 and v1 = 1 respectively. Next, create sequences that change the value of variable
n from 1 to 10, and then use the sequences to draw a Phase Graph.

1.　On the Sequence tab, press u to highlight the first line.

2.　Press O, and then use the Setup menu that appears to configure the settings shown below.
•　[Type] > [un+1]
•　[First Term] > [u1]
•　[Set Table Domain] > [Start]： 1 ; [End]： 10

3.　On the Sequence tab, input un + 1 = 0.9un, u1 = 1, vn + 1 = vn + 0.1n − 0.2, v1 = 1.

4.　Press > to go to the Table tab.

5.　Select T > [Phase Graph].

6.　On the View Window menu that appears, input the values shown below.
x Minimum = 0, x Maximum = 2, x Scale = 1
y Minimum = 0, y Maximum = 4, y Scale = 1

Note
•　A Phase Graph can be drawn when un, un+1, or un+2 is selected as the formula type.
•　The x-axis values are those of the formula that is higher in the Sequence tab list, while the y-axis

values are those of the lower formula.
•　The color used to draw the graph is the color assigned to the formula that is higher in the Sequence

tab list.
•　If three regression formulas (un, vn, wn) have been entered and all three are selected for numeric table

creation, a menu will appear in step 5 above asking you to select two of the three (un-vn, vn-wn, un-wn).
•　If S > [ΣDisplay] is turned on, a menu will appear to select whether to graph using un (sequence) or
Σun (cumulative sum of sequences) in step 5 above.

Using Web Graph to Check the Convergence or Divergence of a Numeric Sequence
For example, graph y = f (x) where un + 1 = y and un = x in a two-term recursion formula that can be expressed
in terms of un + 1 and un. Overlap this with a straight line with a slope of 45 degrees (graph of y = x). You can
use these two graphs to draw a web graph automatically.
Selecting [Web Graph] in the example procedure below automatically graphs y = f (x) and draws a straight line
with a 45-degree slope. Then you can simply press O multiple times to draw the web graph. By observing the
behavior of the web graph, you can intuitively grasp whether the sequence is convergent or divergent.

7.　Highlight  and then press O.
•　Phase Graph appears on the Table tab.
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Convergent Divergent
Example: To enter the two-term recursion formula equation un + 1 = -3un2 + 3un (first term u0 = 0.01), draw a web

graph, and determine if the graph is convergent or divergent

1.　On the Sequence tab, press u to highlight the first line.

2.　Press O, and then use the Setup menu that appears to configure the settings shown below.
•　[Type] > [un+1]
•　[First Term] > [u0]
•　[Set Table Domain] > [Start] : 0 ; [End] : 6
•　[Set Web Graph Start] > [unStart] : 0.01*

*　Make the x-coordinate of the starting point for drawing the web graph the same value as u0.

3.　On the Sequence tab, input un + 1 = -3un2 + 3un, u0 = 0.01.

4.　Press > to go to the Table tab.

5.　Select T > [Web Graph].

6.　On the View Window menu that appears, input the values shown below.
x Minimum = -0.52, x Maximum = 1.52, x Scale = 1
y Minimum = 0, y Maximum = 1, y Scale = 1

8.　Press O.
•　This causes a cross pointer ( ) to flash at the starting point of the web graph.

Note
•　A web graph can be drawn when un+1 is selected as the formula type.
•　You can specify the line type and line color of the y= f (x) graph drawn above. For details, see “Graph

Drawing Settings (Line Type, Line Color)” (page 78).

7.　Highlight  and then press O.
•　This graphs un + 1 = -3un2 + 3un and draws a straight line with

a slope of 45 degrees.

9.　Press O 20 times.
•　Each press of O draws the straight lines of the web graph.

The graph indicates that the numeric series is convergent.
•　To exit web graph drawing, press b.
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Operations While a Graph is Displayed
To do this: Select this menu item: Details:

Specify the display range T > [View Window]
“Specifying the Display Range of
the Graph Window (View Window)”
(page 80)

Display a pointer on a graph and read
the coordinate values T > [Trace] “Using Trace (Trace)” (page 84)

Zoom in and out of the display T > [Zoom]
“Changing the Graph Window Zoom
Setting (Zoom)” (page 81)

Draw dots, lines, characters, etc. T > [Sketch] “Using Sketch (Sketch)” (page 85)

Grab a point on a window and drag it
around the display T > [Pan]

“Grabbing a Point on a Window and
Drag It Around the Display (Pan)”
(page 81)

Adjust the background image T > [Fade I/O]
“Adjusting the Graph Window
Background Image (Fade I/O)”
(page 81)

Displaying a Numeric Table and Graph at the Same Time
When S > [Table with Graph] is turned on, the numeric table window is displayed on the right of the Table
tab and the graph window is displayed on the left.

•　Nothing is drawn in the graph window immediately after you move to the Table tab from the Sequence tab.
Use the following operations to draw the graph.
-　Select T > [Switch Active Window].
-　From T, select the menu item for drawing a graph.

•　Each time you select T > [Switch Active Window], the active window (the window that is affected by the
operations you perform) toggles between the numeric table window and the graph window. The numeric table
window is active when the cursor is displayed on the numeric table.

•　While the numeric table window is active, you can perform the operations described under “Operations While a
Numeric Table is Displayed” (page 111). While the graph window is displayed, you can perform the operations
under “Operations While a Graph is Displayed” (page 114), except for Pan and Fade I/O.
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Equation App
You can use the Equation app to solve simultaneous linear equations (two to six unknowns) and higher-order
equations (2 to 6 degrees). It also has a Solver function that solves an equation for any variable.

Solving Simultaneous Linear Equations

Example: To solve the following equations for x and y 
2x − y = 5
x＋ 2y = 10

1.　h > Equation

2.　On the Type tab, select [Simultaneous] and then press > or O.

3.　On the Unknowns tab, select the number of unknowns and then press > or O.
•　Here we have two unknowns, (x and y), so we choose [2 Unknowns].

4.　On the Editor tab, input the coefficients of the equation.

2Es-(M)1E5E
1E2E10E

*　When S > [  π Result] is turned on, display is in   and π form when possible (decimal form when not
possible).
When S > [  π Result] is turned off, display is in decimal form only.

Note
•　The message “Infinitely Many Solutions” is displayed when there are infinite solutions.
•　The calculator uses inverse matrix M -1 of coefficient matrix M  to solve a linear system of equations.

Because of this, accuracy may suffer as determinant Det(M) of coefficient matrix M  approaches 0.

Solving Higher-Order Equations
Example: To solve x2 + 2x − 2 = 0

1.　h > Equation

2.　On the Type tab, select [Polynomial] and then press > or O.

3.　On the Degree tab, select the degree of the equation and then press > or O.
•　Since we are solving a quadratic equation, we select [a2X2+a1X+a0=0] here.

4.　On the Editor tab, input the coefficients of the equation.

5.　To solve the equations, press > or O.
•　This displays the solutions for x and y on the Result tab.

Details about the values in the cell at the current cursor
location are shown in the lower-right corner of the window.*
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1E2Es-(M)2E

*　When S > [  π Result] is turned on, display is in   and π form when possible (decimal form when not
possible). When S > [  π Result] is turned off, display is in decimal form.

Note
•　If the equation has multiple solutions, the number of solutions is displayed to the right of the solution.

Example: Solution of x3 + 3x2 + 3x + 1 = 0

Higher-order equation calculations may not produce accurate results or cause an error when the
equation has multiple solutions.

•　If the equation has an imaginary solution, the solution is displayed in the form specified by the S >
[Complex Mode] setting.

•　S key operation is ignored on the Result tab. Operate the S key on the Editor tab.

Using Solver
You can find the value of any variable in the equation without having to solve the equation by transforming or
organizing the equation.
Example: Suppose an object is thrown into the air with initial velocity V and reaches height H after T time.

Use the equation below to determine initial velocity V when H = 14 (m) and T = 2 (seconds), and
gravitational acceleration G = 9.8 (m/s2).

H = VT − 1
2GT

2

1.　h > Equation

2.　On the Type tab, select [Solver] and then press > or O.

3.　On the Setup tab, enter the equation into the Eq line.

H = VT -e1d2r GT i

4.　Press O.
•　This displays a list of variables included in the equation.

5.　Specify for which of the variables you want to solve.
(1)　 Press O to display the Solve for dialog.
(2)　 To obtain initial speed V, select [V] and then press O.

6.　Sequentially input H=14, T=2, and then G=9.8.

5.　To solve the equation, press > or O.
•　This displays the solution for x on the Result tab. Details

about the values in the cell at the current cursor location are
shown in the lower-right corner of the window.*

116



14E0E*2E9.8E

 

*　The value to be solved for is the initial estimate
value. Here, the initial estimated value is 0.

•　In the “Upper=” and “Lower=” lines, input the upper and lower limits of the desired solution, if necessary.

Note
•　x and X are treated as the same variable.
•　If you input an expression without “=” in the “Eq” line in step 3, “expression = 0” is assumed.
•　Functions registered with the Graph&Table app can be input into the “Eq” line. Select T > [Recall],

highlight the function you want to enter, and then press O.
•　Solver uses Newton’s method of approximation to find solutions. “Lft=” and “Rgt=” values are displayed

because calculation using Newton’s method may produce an error with respect to the true solution.
The closer the difference between the values of “Lft=” and “Rgt=” gets to 0, the smaller the error in the
calculation results.

•　The  button appears on the display when the calculator judges that convergence is not
sufficient for the displayed results.

•　Solver obtains only one solution. For information about obtaining multiple solutions of a higher-order
equation (such as ax2+bx+c=0), see “Solving Higher-Order Equations” (page 115).

7.　Press >. Or select  and then press O.
•　This displays the calculation results on the Result tab.
•　“Lft=” and “Rgt=” are the calculated results of the left side

and right side with the obtained result.
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Num Ineq App (fx-CG100 only)
You can use the Num Ineq (Numeric Inequality) app to solve a 2nd, 3rd, or 4th degree inequality.

Operation Flow

Example: To solve x2 + 2x − 3
4 ≥ 0

3.　On the Type tab, select the inequality symbol type and orientation (>, <, ≥, ≤).

•　Here we want to solve x2 + 2x − 3
4 ≥ 0, select [a2X2+a1X+a0≥0] and then press O.

1E2Es-(M)3e4E

d

*　When S > [  π Result] is turned on, display is in   and π form when possible (decimal form when not possible).
When S > [  π Result] is turned off, display is in decimal form only.

Note
•　“No Solution” appears on the Result tab when no solution exists for an inequality (such as x2 < 0).
•　“All Real Values of X ” appears on the Result tab when the solution of an inequality is all numbers

(such as x2 ≥ 0).
•　S key operation is ignored on the Result tab. Operate the S key on the Editor tab.

1.　h > Num Ineq
•　This displays the Degree tab.

2.　On the the Degree tab, select [a2X2+a1X+a0], and then press O.
•　This displays the Type tab.

4.　On the Editor tab that appears, input coefficient values.

5.　Press > or E.
•　This will display the solution on the Result tab. Details about

the values in the cell at the current cursor location are shown
in the lower-right corner of the window.*
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Python App
The Python app supports a version of MicroPython Version 1.9.4, which has been adapted to run on this
calculator.

Important!
•　Note that generally, MicroPython is different from the Python that runs on a computer. Also, the Python

app does not support all of the functions, commands, modules, and libraries of MicroPython.
•　The Python app performs executions using the MicroPython processing system. Because of this,

calculation results and other data produced by this app may differ from execution results of other
function apps.

Operation Flow
Example: To create the script shown below and then execute it

Input Meaning
def f(x,y,z):

if x>0:
t=x+y+z

else:
t=x-y-z

return(t)

Defines a user-defined function with function name f, and arguments x, y, and z.
If variable x is greater than 0,
Defines variable t as the execution result of x+y+z.
Otherwise (if variable x is 0 or less),
Defines variable t as the execution result of x-y-z.
Makes t the return value.

1.　h > Python
•　This displays Editor and opens a py file named “module.py”.

4.　Call user-defined function f and then input 1, 2, 3 for arguments x, y, and z, respectively.
(1)　 Press V to display the Variable menu.
(2)　 Select f(,,) and then press O.
(3)　 Input 1, 2, and 3 as f arguments.

6.　To return to Editor, press b.

2.　Input the script.
•　For information about input operations, see “App Alpha

Character and Numeric Input” (page 9) and “Input
Operations (Same for Editor and Shell)” (page 121).

3.　To execute the resulting script, press >.
•　The imports module.py into Shell.

5.　Press E to execute f(1,2,3).
•　Since x>0, t=x+y+z (=1+2+3) is executed and a value of t=6

is returned.
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Using Editor
The first thing you will see when you enter the Python app from the HOME screen is Editor. A py file named
“module.py” will always open automatically immediately after you enter the Python app.

Creating and Editing Scripts
You can input your scripts directly into “module.py” or edit another py file by performing the operations below.

To do this: Select this menu item:
Close the currently open file and create a new file T > [File] > [New]
Close the currently open file and open another file T > [File] > [Open]
Save the currently open file under a different name T > [File] > [Save As]

The Python app lets you input up to 255 characters × 300 lines (text, functions, commands) for each file. For
information about inputting text, functions, and commands into the Editor, see “Input Operations (Same for
Editor and Shell)” (page 121).

To toggle alpha lock on and off
Whenever you enter the Python app, the Editor alpha lock setting is lowercase characters, which is indicated
by  in the status bar. Press P to change the alpha lock setting to uppercase character input. This causes

 to appear in the status bar. Press P again to unlock alpha lock.

To copy or cut scripts within Editor
1.　Move the cursor to the start of the range that you want to copy or cut.

2.　Press s0($).
•　This displays  in the status bar until you press O in step 4.

3.　Move the cursor to the end of the range of data you want to copy or cut.

4.　Select [Copy] or [Cut] in the menu that appears when you press O.
•　You can specify the end point first if you want.

To paste a copied or cut script within Editor
1.　Move the input cursor to the location where you want to paste the script.

2.　Press s.(%).

To move the cursor to a specified line
Select T > [Jump]. Use the dialog that appears to input a line number that specifies the move destination.

To save the currently open py file and overwrite its previous version
Select T > [File] > [Save].

To delete all scripts in Editor
Press a or select T > [Delete All].

To delete a py file

1.　Select T > [File] > [Delete].

2.　Use the file list that appears to select the file you want to delete and then press O.

3.　In response to the confirmation dialog that appears, select [OK].
•　You cannot use this operation to delete a currently open file.
•　If you delete “module.py,” a new “module.py” file will be created automatically and opened the next time

you start up the Python app.

Executing a Script
Use the operation below to execute the script that is currently displayed in Editor.
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1.　Press > (or <), or select T > [Run].
•　If the script (py file) has already been saved, this will go to Shell and execute the script.

2.　If the script (py file) has not been saved, use the dialog that appears to select an operation.

To do this: Select this:
Save a py file, go to Shell and execute a script [Yes]
Go to Shell without saving the py file and execute a script [No]
Return to Editor without executing the script [Cancel]

Input Operations (Same for Editor and Shell)
To use the Character Select menu to input characters
Select T > [Character Select] to display a character list along the bottom of Editor.

You can use this list to input alpha characters, symbols, and operators. To input a character, use the cursor
keys to move the highlight to the character you want to input and then press O. To hide the character list,
press b or a.

To use keys to input characters and functions
The table below shows the characters and functions that you can input using keys.

Key Input Character Key Input Character Key Input Character
0 to 9 0 to 9 ` ， s`(:) :

i **2 / * sv(sin-1) asin()

g ** * / sc(cos-1) acos()

X x + ＋ st(tan-1) atan()

v sin() - － s((=) =

c cos() k *10** s4([) [

t tan() j sqrt() s5(]) ]

( ( N exp() s7(π) pi

) ) sN(ln) log() s9(i) 1j

. ． si(log) log10()    

Autocomplete during input into Editor
Autocomplete is enabled while you are inputting into Editor. Inputting alpha-characters causes the
corresponding candidate commands to appear on the display.
You can perform the following operations while input candidates are displayed.

To do this: Do this:
Scroll through candidates (when multiple candidates
are available)

Use d/u.

Input the currently displayed candidate Press r or O.
Stop display of input candidates Press l. (This causes the cursor to move one

character back.)
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Note
•　The autocomplete function only displays the commands in the menu that appears when you press C.
•　Autocomplete cannot be disabled.

To input commands and functions from the Catalog menu
1.　Select the menu for the item you want to input.

When you want to input this: Select this menu item:
Built-in Python commands and functions C > [Built-in]
math module commands and functions C > [math]
random module commands and functions C > [random]
matplotlib.pyplot module commands and functions C > [matplotlib.pyplot]
turtle module commands and functions C > [turtle]
casioplot module (page 137) commands and functions C > [casioplot]
Symbols and operators C > [Symbol]
Commands and functions from an alphabetic list C > [All] > [a] to [z]

•　This displays a list of items.

2.　Highlight the item you want to input and then press O.
•　You can jump to an item in the list by using the XA to 0Z keys to input the first characters of the item

name.

Auto Indent Upon Newline
Pressing E while editing a script in Editor inputs a newline.
•　Pressing E after the colon (:) at the end of a line, adds two more spaces at the beginning of the new line

(Auto Indent).
•　Pressing E while in an indented line will add the same indent (space) to the new line.

Statement Block Input
When inputting to Editor, selecting a command that has a multi-line syntax such as “if:else” or “for:range()” from
the Catalog menu inputs a statement block that includes line breaks and spaces.
Example: To select “if:else” and add the multi-line context shown below, where “□” indicates a space

if□:
□□
else:
□□

When inputting into Shell, only the first line of the block is input.

To input user-defined variables and functions

1.　Press V to display the Variable menu.

2.　Highlight the variable or function you want to input and then press O.
•　The Variable menu displays variables and functions as described below.

When V is pressed while
Editor is displayed

Displays global variables and user-defined functions that are defined in
the displayed py file.

When V is pressed while
Shell is displayed

Displays global variables and user-defined functions that were defined in
the last py file executed before Shell initialization.*

*　See “Initializing Shell” (page 123).

Note
•　The items below are not shown on the Variable menu.
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-　Local variables, functions within functions, function arguments, user-defined classes
-　Variables and functions contained in a py file imported from the currently open py file
-　Variables defined with Shell
-　Variables and functions contained in py files imported from Shell

•　Variables displayed when you press V in other apps are not displayed in the Python app.

Using Shell
Shell is an interactive command line. From the Shell >>> prompt, you can input commands*1 and press E to
obtain the result*2 immediately. Shell history stores up to 200 of the latest prompt and result lines.*3
*1　Up to 255 characters. For information about inputting text, functions, and commands into the Shell, see

“Input Operations (Same for Editor and Shell)” (page 121).
*2　Result output has up to 509 characters per line.
*3　Until you select T > [Delete All] or start up another app.

To display Shell
While Editor is displayed, execute a script (page 120) or select T > [Shell].* Shell is initialized at this time.
*　Selecting T > [Shell] does not execute the script currently displayed by Editor.

Initializing Shell
Shell stores variables and functions defined in the most recently executed script in the Shell heap area
(temporary memory area for storage). Whenever you go from Shell to Editor, the Shell heap area contents
up to that point are cleared. This clearing of Shell heap area contents is called “SHELL initialization.” When
Shell is initialized, the message “* SHELL Initialized *” is inserted on the line that corresponds to when it was
initialized.

To clear all Shell history contents
Press a or select T > [Delete All].

matplotlib.pyplot Module
The matplotlib.pyplot module provides functions for drawing graphs with the Python app.

Important!
•　The matplotlib.pyplot module of the Python app is a proprietary module created to run on this calculator.

It is different from the matplotlib.pyplot module that runs on PC-based Python.
•　The functions included in the matplotlib.pyplot module in the Python app of this calculator may differ

from those of the matplotlib.pyplot module of PC-based Python in terms of behavior, supported
arguments, and other specifications. Each function supports only the format and arguments specified
here.

Note
•　To use functions in the matplotlib.pyplot module, you must import the matplotlib.pyplot module.
 

To import the matplotlib.pyplot module

1.　Select C > [matplotlib.pyplot].

2.　On the menu that appears, select the commands below.
-　from matplotlib.pyplot import *
-　import matplotlib.pyplot

 
•　In the syntax of each function shown in this section, anything included in square brackets ([ ]) can be

omitted.

123



The functions included in the matplotlib.pyplot module of the Python app are described below.

Displaying the Drawing Screen

show()
Shows graphs, grids, and axes that have been specified for drawing on the drawing screen.

Syntax: show()     (no argument)
 
To return to Shell after displaying the drawing screen, press b.

Note
•　Execution of show clears all of the following items that were specified prior to execution.

-　Graphs that were specified for drawing
-　Axis settings (Returned to initial default settings.)
-　Grid settings (Returned to initial default settings.)

•　If a script contains multiple show calls, the graphs, grids, and axes that were described or configured
between the second-to-last show and the final show will be displayed on the drawing screen.

Axis and Grid Settings

axis()
This function can be used to specify the display range of an axis and to change axis settings.
 

Syntax 1: axis(listxy)
Input the axis display range in the form [xmin,xmax,ymin,ymax] for the argument listxy. The coordinates of
the lower left corner of the screen are determined by xmin and ymin.

xmin x-axis minimum value
xmax x-axis maximum value
ymin y-axis minimum value
ymax y-axis maximum value

-　listxy type: list or tuple
-　listxy element type: int or float
-　Initial defaults: [0,1,0,1]

xmin xmax

ymin

ymax

 
Syntax 2: axis(option)
Specifies the axis setting by inputting one of the keywords (type: str) into the option argument.

"on": Show axis
"off": Hide axis
"auto": Automatically set the axis range to match the graph*1

 
Syntax 3: axis()     (no argument)
Returns to the display range of the currently specified axis.*2

 
*1　axis("auto") is valid only when it comes after the graph drawing function.
*2　When executed with Shell. To write to a py file and output the setting values, you need to write

“print(axis())”.

Note
•　The axis display color is always black.

grid()
Use this function to show or hide the grid and to specify the grid color.
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Syntax 1: grid(option[,color])
Specifies show/hide grid. You can also specify the grid color at the same time.
•　option argument: Specifies show/hide grid.

-　To specify using str type, use the keywords below.
"on", "True", or "true": Show grid
"off", "False", or "false": Hide grid

-　To specify using bool type, use the terms below.
True: Show grid
False: Hide grid

•　color argument: Specifies the grid color.
-　Type: str
-　How to specify: Use the syntax grid(option,color="keyword") to specify the grid color. For information

about text strings that can be specified as keywords, see “Color Keywords” (page 129).
-　Operation when omitted: The grid is drawn with solid gray lines. (The grid is not shown if the "Hide grid"

argument option is specified.)
 
Syntax 2: grid(color)
Specifies the grid color. Also switches to "Show grid." (This is the same as when grid("on") is specified in
Syntax 1.)
•　color argument: Specifies the grid color. The type and method for specifying the color are the same as that

for Syntax 1.
 
Syntax 3: grid()     (no argument)
Toggles the grid setting between show and hide.
•　For example, calling grid() after grid("on") toggles the grid from show to hide.
•　Calling grid() after grid("off") toggles the grid from hide to show. In this case, the grid is drawn as solid gray.

Note
•　If axis was used to hide the axis, the grid will also be hidden.

Drawing Graphs and Text Strings

plot()
Plots a point or draws a line segment.
 

Syntax 1: plot(x,y[,color])
Plots a point at the specified coordinates. You can also specify the color of the point.
•　x, y arguments: Specifies coordinates (x, y).

-　Type: int or float
•　color argument: Specifies the color.

-　Type: str
-　How to specify: Use the syntax plot(x,y,"keyword") to specify the color. For information about text strings

that can be specified as keywords, see “Color Keywords” (page 129).
-　Operation when omitted: The color is specified automatically. For details, see “Auto Color Specification”

(page 129).
 
Syntax 2: plot([listx,]listy[,color])
Draws a line segment connecting multiple specified coordinates. You can also specify the color of the line
segment.
•　listx, listy arguments: Specifies multiple coordinates (x1, y1 ; x2, y2 ; x3, y3 ; …).

-　listx, listy type: list or tuple
-　listx, listy element type: int or float
-　Omitting listx automatically assigns listx = [0,1,2,3,…].
-　When both listx and listy are specified, both lists must contain the same number of elements.

•　The color argument is the same as that for Syntax 1.

125



Note
•　The form of a point drawn at the coordinates specified by plot is always a cross (+).
•　Executing plot without specifying anything for axis causes the axis to be adjusted automatically.
•　If you input a "shape keyword" that is supported by PC-based Python for the color argument, the

keyword will be ignored without causing an error. If you input only a shape keyword for the color
argument, the color argument will be treated as if no argument was input. The behavior is the same
as when it is omitted.

bar(,)
Draws a bar chart.
 

Syntax 1: bar(x,y[,width])
Draws a single bar chart.
•　x argument: Specifies the bar chart x-coordinate.
y argument: Specifies the bar chart height.
-　x, y type: int or float

•　width argument: Specifies the bar chart width (scale width along the x-axis). Specifying 0 draws using a
width of one dot.
-　Type: int or float
-　Initial default: 0.8 (0.8 when omitted)

 
Syntax 2: bar(listx,listy[,width])
Draws a bar chart with one or multiple bars.
•　listx argument: Each list element specifies the x-coordinate each bar.

listy argument: Each list element specifies the height of each bar.
-　listx, listy type: list or tuple
-　listx, listy element type: int or float
-　The number of elements in listx and listy must match.

•　The width argument is the same as that for Syntax 1.

Note
•　Executing bar without specifying anything for axis causes the axis to be adjusted automatically.
•　The color of a bar chart drawn using bar is specified automatically. For details, see “Auto Color

Specification” (page 129).

scatter(,)
Draws a scatter plot.
 

Syntax 1: scatter(x,y)
Plots a point at the specified coordinates.
•　x, y arguments: Specifies coordinates (x, y).

-　x, y type: int or float
 
Syntax 2: scatter(listx,listy)
Draws a scatter plot by plotting points at all of the specified coordinates.
•　listx, listy arguments: Specifies multiple coordinates (x1, y1 ; x2, y2 ; x3, y3 ; …).

-　listx, listy type: list or tuple
-　listx, listy element type: int or float
-　The number of elements in listx and listy must match.

Note
•　The form of a point drawn at the coordinates specified by scatter is always a cross (+).
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•　Executing scatter without specifying anything for axis causes the axis to be adjusted automatically.
•　The color of the points drawn using scatter is automatically specified. For details, see “Auto Color

Specification” (page 129).

hist()
This function draws a histogram (a frequency distribution chart in which the horizontal axis represents classes
and the vertical axis represents frequencies).
 

Syntax 1: hist(x[,bins])     or     hist(x,listbins)
Draws a histogram where the number of data points is 1 (frequency=1).
•　x argument: Inputs a data value.

-　x type: int or float
•　bins argument: Specifies the number of bins in the histogram as an integer greater than or equal to 1.

-　bins type: int
-　Initial default: 10 (10 when this argument is omitted)
-　How to specify: To specify four bins, for example, use hist(x,bins=4), or hist(x,4).

•　listbins argument: Specifies multiple values for the histogram class division points.
-　listbins type: list or tuple
-　listbins element type: int or float
-　For example, hist(1,[0,2,4]) would result in two intervals of 0-to-2 and 2-to-4.

 
Syntax 2: hist(listx[,bins])     or     hist(listx,listbins)
Draws a histogram with multiple data points.
•　listx argument: Input a data value for each element.

-　listx type: list or tuple
-　listx element type: int or float

•　The bins and listbins arguments are the same as that for Syntax 1.

Note
•　Executing hist without specifying anything for axis causes the axis to be adjusted automatically.
•　The color of the histogram drawn by hist is specified automatically. For details, see “Auto Color

Specification” (page 129).
•　Values input for the listbins argument are automatically sorted into ascending order. For example,

inputting [4,0,2] is treated as [0,2,4].
•　Data values at the division point of a class are included

in the class above the division point, except in the
case of the maximum value. For example, executing
hist([1,1,2,2,2,3,4,5,7],3) specifies 3 for the bins argument,
so the classes are 1-to-3, 3-to-5, and 5-to-7. Data value 3 at
the division point would be included in the 3-to-5 class, and
data value 5 in the 5-to-7 class. However, the maximum
value of 7 will be included in the 5-to-7 class.

arrow(,,,)
Draws an arrow.
 

Syntax: arrow(x,y,dx,dy[,edgecolor[,facecolor[,head_width[,head_length]]]])
•　x, y arguments: Specify the coordinates (x, y) of the draw start point of the arrow.
•　dx, dy arguments: Specify the end point* of the arrow, which will be at the coordinates (x+dx, y+dy).

-　x, y, dx, dy type: int or float
*　End point of the line segment that does not include the arrowhead.

 
•　edgecolor argument: Specifies the arrow edge color.
•　facecolor argument: Specifies arrowhead face color.
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-　edgecolor, facecolor type: str
-　edgecolor initial value: black; facecolor initial color: blue (These colors are used when these arguments

are omitted.)
•　head_width argument: Specifies the arrowhead width.
•　head_length argument: Specifies the arrowhead length.

-　head_width, head_length type: int or float
-　head_width initial value: 0.003; head_length initial value: head_width × 1.5
-　If a negative value is specified for head_width or head_length, the absolute value of the value is applied.

 
Example: To draw an arrow with coordinates (0, 0) as its start point and coordinates (0.5, 0.5) as its end

point. Specify blue for the arrow edge color, red for the arrowhead face color, and 0.5 for the head
width and length.

from matplotlib.pyplot import *
arrow(0,0,0.5,0.5,edgecolor="blue",facecolor="red",head_width=0.5,head_length=0.5)
show()

 
Operation results are shown below.

facecolor edgecolor

head_width head_length

Note
•　When specifying the edgecolor, facecolor, head_width, and head_length arguments, you should

always write a string that specifies an argument (edgecolor= part) as shown in the Example above.
The text string specifying each argument can be entered using C > [matplotlib.pyplot].

•　See “Color Keywords” (page 129) for keywords like blue, red, etc. that can be used to specify colors.
•　The axis is not adjusted automatically if you execute arrow without specifying anything for axis. If

the arrow extends beyond the drawing screen, specify the axis manually.

text(,,)
Draws a text string at the specified coordinates.
 

Syntax: text(x,y,text)
•　x, y arguments: Specify the coordinates (x, y) of the left end of the string.

-　x, y type: int or float
•　text argument: Specifies a text string.

-　There are no restrictions on the text argument’s type. Any text string can be entered by enclosing it within
double quotes (" ").
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Note
•　The axis is not adjusted automatically if you execute text without specifying anything for axis. If the

text string extends beyond the drawing screen, specify the axis manually.
•　The color of text strings drawn with text is always black.

Color Keywords
The keywords shown in the tables below can be used as grid, plot, and arrow arguments to specify colors.

To specify this color: Use this keyword:
Blue "b" or "blue"
Red "r" or "red"

Green "g" or "green"
Magenta "m" or "magenta"

Black "k" or "black"
Cyan "c" or "cyan"

Yellow "y" or "yellow"

To specify this color: Use this keyword:
White "w" or "white"
Grey "grey"

Orange "orange"
Purple "purple"
Brown "brown"
Pink "pink"

Note
•　Color keywords can be input using C > [matplotlib.pyplot].

Auto Color Specification
When a graph is drawn using a single execution of plot*, bar, scatter, or hist, blue is automatically specified as
the color. When these functions are executed in succession to draw graphs, the graph colors are automatically
specified in the following sequence:

blue red green magenta

blackcyanyellow

Each execution of show causes the auto graph color sequence to return to blue.
*　For the plot function, the color is automatically assigned only when the color argument is omitted.
 
Example: To use plot and bar to draw two graphs in succession. Omit the plot color argument.

from matplotlib.pyplot import *
plot([1,1.5,2.5])
plot([0,0.5,0.2])
bar(1,1)
bar([2,3],[2,3])
show()

 
Operation results are shown below.
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plot([1,1.5,2.5])

plot([0,0.5,0.2])

bar(1,1)
bar([2,3],[2,3])

turtle Module
The turtle module provides functions to manipulate a virtual "turtle" ( ) with the pen. You can make the turtle
draw shapes and patterns.

Important!
•　The turtle module of the Python app is a proprietary module created to run on this calculator. It is

different from the turtle module that runs on PC-based Python.
•　The functions included in the turtle module in the Python app of this calculator may differ from

those of the turtle module of PC-based Python in terms of behavior, supported arguments, and other
specifications. Each function supports only the format and arguments specified here.

Note
•　To use functions in the turtle module, you must import the turtle module.

To import the turtle module

1.　Select C > [turtle].

2.　On the menu that appears, select the commands below.
-　from turtle import *
-　import turtle

 

 
•　The functions below can be written as is only when executed with Shell. To write them to a py file and

output the setting values, you need to write them inside print(), such as print(pencolor()).
pencolor(), pensize(), width(), shape(), speed(), isvisible(), isdown(), xcor(), ycor(), position(),
distance(,), towards(,), heading()

 
•　In the syntax of each function shown in this section, anything included in square brackets ([ ]) can be

omitted.

•　When using the turtle module with the Python app, the
coordinates are fixed as shown below.
Origin: 0, 0
x-axis minimum value: -192, maximum value: 191
y-axis minimum value: -95, maximum value: 96

96

-95

1910-192

The functions included in the turtle module of the Python app are described below.
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Specifying a Pen

pendown()
Lowers the pen, enabling drawing.
 

Syntax: pendown()       (no argument)
•　When you move the turtle with the pen down, a line is drawn from the current location of the turtle to its

destination. To move the turtle, use the functions under “Specifying Direction and Forward/Back Movement”
(page 132) and “Moving to Specified Coordinates” (page 132).

 

penup()
Raises the pen, disabling drawing.
 

Syntax: penup()       (no argument)
•　When the pen is up, nothing is drawn if the turtle is moved.

 

pencolor()
•　Specifies the line drawing color or returns the value of the line drawing color.
 

Syntax 1: pencolor(colorstring)
•　colorstring argument: Uses a keyword to specify the line drawing color.

-　Type: str
-　How to specify: Use the syntax pencolor("keyword") to specify the color. The text strings below can be

specified as keywords
black, blue, green, red, cyan, yellow, magenta, white, orange, purple, brown, pink, grey

 
Syntax 2: pencolor(list)
•　list argument: Uses RGB values to specify the line drawing color.

-　Type: list or tuple
-　Element type: int or float
-　How to specify: Use the syntax [r,g,b] (0 ≤ r ≤ 1, 0 ≤ g ≤ 1, 0 ≤ b ≤ 1) to specify RGB values. Each RGB

value corresponds to a Syntax 1 keyword as shown in the table below.

Keyword RGB Values
black [0,0,0]
blue [0,0,1]

green [0,1,0]
red [1,0,0]

cyan [0,1,1]

Keyword RGB Values
yellow [1,1,0]

magenta [1,0,1]
white [1,1,1]

orange [1,0.65,0]
purple [0.66,0,0.66]

Keyword RGB Values
brown [0.75,0.25,0.25]
pink [1,0.75,0.8]
grey [0.66,0.66,0.66]

 
Syntax 3: pencolor()       (no argument)
•　Returns the RGB values (or the keyword if applicable) of the current line drawing color.

 

pensize(), width()
Specifies the line width or returns the value of the current line width.
 

Syntax 1: pensize(n)
width(n)

•　n argument: Specifies the line width as a real number from 0 to 5. The greater the number, the wider the
line.
-　Type: int or float

 
Syntax 2: pensize()       (no argument)
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width()       (no argument)
•　Returns the value of the current line drawing width.

Specifying Direction and Forward/Back Movement

right()
Rotates the turtle to the right by a specified angle so its head is pointed in a desired orientation.
 

Syntax: right(a)
•　a argument: Specifies in degrees the angle (0° ≤ a < 360°) which the turtle should be rotated.

-　Type: int or float
 

left()
Rotates the turtle to the left by a specified angle so its head is pointed in a desired orientation.
 

Syntax: left(a)
•　argument a is the same as that for right.

 

•　a argument: Specifies the orientation of the head of the turtle in degrees (0° ≤ a < 360°).
-　Type: int or float

 

forward()
Moves the turtle forward in the direction of the current turtle head orientation. The head orientation does not
change.
 

Syntax: forward(n)
•　n argument: Specifies the distance of turtle movement.

-　Type: int or float
 

backward()
Moves the turtle back, in the direction opposite that of the current turtle head orientation. The head orientation
does not change.
 

Syntax: backward(n)
•　The argument n is the same as that for f orward.

Moving to Specified Coordinates

goto(,)
Moves the turtle to the specified coordinates. The head orientation does not change.
 

Syntax: goto(x,y)
•　x, y arguments: Specify the coordinates (x, y) of the turtle’s destination.

-　x, y type: int or float
 

setposition(,)
Moves the turtle to the specified coordinates. The head orientation does not change.

setheading()
Specifies the absolute orientation of the turtle’s head, with east
being 0° (right), 90° north (top), 180° west (left), and 270° south
(bottom).

Syntax: setheading(a)

90°

270°

0°180°
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Syntax: setposition(x,y)
•　The x, y arguments are the same as those for goto.

 

setx()
Moves the turtle to the specified x-coordinate without changing its current y-coordinate. The head orientation
does not change.
 

Syntax: setx(x)
•　x argument: Specifies x-coordinate of the turtle’s destination.

-　x type: int or float
 

sety()
Moves the turtle to the specified y-coordinate without changing its current x-coordinate. The head orientation
does not change.
 

Syntax: sety(y)
•　y argument: Specifies y-coordinate of the turtle’s destination.

-　y type: int or float
 

home()
Moves the turtle to the origin (0,0) and returns the head to its initial orientation (rightward).
 

Syntax: home()       (no argument)

Drawing Circles and Text

circle()

 
Syntax: circle(radius[,extent=360])
•　radius argument: Specifies a circle radius.

-　Type: int or float
•　extent argument: Specifies an arc angle in degrees.

-　Type: int or float
-　How to specify: For example, to set the extent to 180, use circle(radius,extent=180) or circle(radius,180).
-　Initial default: 360 (360 when omitted)

 

write()
Draws a text string from the current turtle location.
 

Syntax: write(text)
•　text argument: Specifies a text string.

-　There are no restrictions on the text argument’s type. Any text string can be entered by enclosing it within
double quotes (" ").

Draws a circle or an arc from the current turtle location. The circle
or arc is drawn counterclockwise starting from the current turtle
location. The figure on the right shows the relationship between
the arguments in the following syntax and the arc being drawn,
assuming that the current position of the turtle is (x1, y1).

radius

extent

(x1, y1)
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Specifying the Turtle Status

shape()
Use this function to specify the turtle shape or to return the current turtle shape. There are two available turtle
shapes.

"classic" "turtle"

 
Syntax 1: shape(name)
Use this syntax to specify the shape of the turtle.
•　name argument: Uses keywords (classic, turtle) to specify the turtle shape.

-　Type: str
-　How to specify: For example, if you want a "classic" (arrow) shaped turtle, specify shape(name="classic")

or shape("classic").
-　Initial default: "classic"

 
Syntax 2: shape()       (no argument)
Returns the currently specified turtle shape.

 

speed()
Specifies the drawing speed of the turtle (the speed the turtle moves when the pen is down) or returns the
currently specified turtle drawing speed.
 

Syntax 1: speed(speed)
Specifies the speed of turtle drawing. The speed argument can be a real number or a keyword.
•　Specifying by real number: Input a value from 0 to 10. 0 is the fastest speed. For non-zero values, a greater

number corresponds to a faster speed. The setting defaults to 0 if a value outside of the allowable range
is specified.
-　Type: int or float
-　Initial default: 5

•　Specifying by keyword: Use the keyword strings shown in the table below.

Keyword Corresponding Real Number
fastest 0

fast 10
normal 6
slow 3

slowest 1
-　Type: str
-　How to specify: To specify slow, for example, use speed(speed="slow"), or speed("slow")
-　Initial default: speed=None

 
Syntax 2: speed()       (no argument)
Returns the real number that corresponds to the turtle’s currently specified drawing speed.

 

showturtle()
Displays the turtle on the drawing screen.
 

Syntax: showturtle()       (no argument)
 

hideturtle()
Hides the drawing screen turtle.
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Syntax: hideturtle()       (no argument)

Get Status

isvisible()
Returns the current turtle show/hide status (Show: True, Hide: False).
 

Syntax: isvisible()       (no argument)
 

isdown()
Returns the current pen state (Pen down: True, Pen up: False).
 

Syntax: isdown()       (no argument)
 

xcor()
Returns the x-coordinate of the turtle’s current location.
 

Syntax: xcor()       (no argument)
 

ycor()
Returns the y-coordinate of the turtle’s current location.
 

Syntax: ycor()       (no argument)
 

position()
Returns the turtle’s current location (x, y coordinates).
 

Syntax: position()       (no argument)
 

distance(,)
Returns the linear distance from the turtle’s current location to the specified coordinate.
 

Syntax: distance(x,y)
•　x, y arguments: Specify the coordinates (x, y) of the point to which you want to check the linear distance

from the turtle’s current location.
-　x, y type: int or float

 

towards(,)
Returns the angle of the arc created by the current turtle location and the specified coordinates (See Note
below).
 

Syntax: towards(x,y)
•　x, y arguments: Specify the coordinates (x, y) at which you want to check the angle with the current turtle

location.
-　x, y type: int or float
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Note
•　If the current turtle location is (x0, y0) and the specified coordinates are (x, y), then the angle of the

arc shown by the dashed line in the figure below will be returned by the towards(x,y) function.

towards(x,y)

(x,y)

(x0, y0)

x0 < x, y0 < y

towards(x,y)

(x,y)

(x0, y0)

x < x0, y0 < y

towards(x,y)

(x,y)

(x0, y0)

x < x0, y < y0

towards(x,y) (x,y)

(x0, y0)

x0 < x, y < y0
 
•　When x = x0, y = y0, towards(x,y) returns 0.

 

heading()
Returns the current turtle orientation. See “setheading()” (page 132) for information about turtle orientation.
 

Syntax: heading()       (no argument)

Turtle Reset and Drawing Screen Clear

reset()
Clears the contents of the drawing screen and initializes the turtle.
 

Syntax: reset()       (no argument)
 
The initial status of the turtle is shown in the table below.

Status Type Initial Default
Location (0,0)
Orientation 0° (east, right)
Color (0,0,0) (black)
Pen up/down Down
Pen drawing width 1
Turtle drawing speed 5
Turtle show/hide Show
Turtle shape "classic"
 

clear()
Clears the contents of the drawing screen while preserving the current turtle state.
 

Syntax: clear()       (no argument)
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casioplot Module
The casioplot module is a CASIO-original module that includes draw functions for drawing pixels and character
in the Python app. To input these functions, use C > [casioplot]. The functions described below are included
in the casioplot module. Arguments enclosed in square brackets ([ ]) in a function syntax can be omitted.

show_screen()     (No argument)
Displays the drawing screen. For details about displaying the drawing screen, drawing screen refresh and clear
timing, and other information, see “Drawing Screen” (page 139).
Example: To display the drawing screen

from casioplot import *
show_screen()

clear_screen()     (No argument)
Clears all draw contents from the drawing screen. This function is executed regardless of whether or not there
are any draw contents on the drawing screen.

set_pixel(x,y[,color])
Draws a pixel of the specified color at the specified coordinates.
 
x argument, y argument:
Specifies the x- and y-coordinates of the pixel to be drawn. Only int type values within the following ranges can
be specified: 0 ≤ x ≤ 383, 0 ≤ y ≤ 191
The figure below shows the relationship between coordinate values and locations on the drawing screen.

(0,0) (383,0)

(0,191) (383,191)

color argument:
Specifies the color of the pixel to be drawn. For details about this argument, see “Draw Function color Argument”
(page 139).
Example: To draw a straight line that runs from the upper left corner to the lower right corner of the display

and display the drawing screen

from casioplot import *
for i in range(192):

set_pixel(i*2,i)
show_screen()

Note
•　If either the x- or y-coordinate value is outside of the allowable range, function execution will be ignored

(nothing drawn, no error).

get_pixel(x,y)
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Gets color information at the specified coordinates on the drawing screen.
 
x argument, y argument:
Specifies the x- and y-coordinates of the pixel whose color information is to be retrieved. The range and type
of value that can be specified are the same as the x-argument and y-argument of set_pixel. The retrieved color
information is returned as a 256-gradation RGB value.
Example: To get color information (0,0,0) of coordinates (0,0)

from casioplot import *
set_pixel(0,0,(0,0,0))
get_pixel(0,0)

Note
•　If either the x- or y-coordinate value is outside of the allowable range, nothing is returned.

getkey()     (No argument)
Returns the key code of the calculator key pressed at the time this function is executed.
The key codes of the keys are shown below.

12 13 14 15 16

21 22 23 24 25 26

31 32 33 34 35 36

41 42 43 44 45 46

51

61 62 63 64

71 72 73 74 75

81 82 83 84 85

91 92 93 94 95

52 53 54 55 56

Example: To display the key code of the pressed key in the upper left corner of the drawing screen. For this
example, the 5 key is held down.

from casioplot import *
while (True):

key=getkey()
clear_screen()
draw_string(0,0,str(key))
show_screen()

Note
•　To stop script execution, press a.

draw_string(x,y,s[,color[,size]])
Draws a character string of the specified color at the specified coordinates.
 
x argument, y argument:
Specify the x-coordinate and y-coordinate of the upper left corner of the first character of the string to be drawn.
The range and type of value that can be specified are the same as the x-argument and y-argument of set_pixel.
s argument:
Specifies the character string to be drawn as a str type. Only ASCII characters* can be displayed.
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color argument:
Specifies the color of the character string to be drawn. For details about this argument, see “Draw Function
color Argument” (page 139).
size argument:
Specifies one of the following as the character size of the character string to be drawn: “large”, “medium”,
“small”. “medium” is applied when this argument is omitted.
*　A-Z a-z 0-9 ! " # $ % & ' ( ) * + , - . / : ; < = > ? @ [ \ ] ^ _ ` { | } ~ space
Example: To draw large size “abc” in black at coordinates (0,0) and display the drawing screen

from casioplot import *
draw_string(0,0,”abc”,(0,0,0),”large”)
show_screen()

Note
•　If both the x- and y-coordinate values are within the allowable range, the drawn character string will be

displayed within the drawing screen range, even if it partially runs off of the drawing screen. If either the
x- or y-coordinate value is outside of the allowable range, function execution will be ignored (nothing
drawn, no error).

Draw Function color Argument
The color argument specifies the drawing color in 256 shades of RGB. For example, to specify black, input
(0,0,0) or [0,0,0]. To specify white, input (255,255,255) or [255,255,255]. If color argument input is omitted,
(0,0,0) is applied. Note that due to the performance of the display, the displayed color may be an approximation
of the specified value.

Drawing Screen
Executing show_screen displays the drawing screen with the contents drawn by set_pixel and draw_string are
displayed.

Updating and Clearing the Drawing Screen
The drawing screen is updated each time show_screen is executed and cleared when clear_screen is executed
or when Shell is initialized. The currently displayed drawing screen is also updated when the py script finishes
executing.
 
To return to Shell from the drawing screen, press b.

File Compatibility
py files can be shared between your calculator and a computer. A py file created with the calculator can be
transferred to a computer for editing with a text editor or other software. A py file created on a computer can
be transferred to and run on the calculator.
py files you create in the Python app are stored in the calculator’s storage memory (with file name extension
py). For information about the procedure for transferring files between the calculator and a computer, see
“Connecting the Calculator to a Computer” (page 210).

py Files Created and Saved with This Calculator
The formats of py files created and saved with this calculator are shown below.
Character Code: ASCII code
Characters used: ASCII*
Newline code: CR+LF
Indent: Spaces (two spaces for auto indent)
*　A-Z a-z 0-9 ! " # $ % & ' ( ) * + , - . / : ; < = > ? @ [ \ ] ^ _ ` { | } ~ space
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Precautions When Using an Externally Created py File on this Calculator
The restrictions below apply whenever you are trying to use the calculator’s Python app to display (file name
or file content), edit, or run a py file that was transferred to the calculator from a computer.

File Names
•　Your calculator recognizes only file names made up of ASCII characters.* A file name that includes any

non-ASCII characters is not recognized.
*　The ASCII characters below are not supported.

\ / : * ? " < > | .
•　If the name of a py file transferred to storage memory from a computer or other source has a file name that is

more than eight characters long, its name will abbreviated to eight characters when displayed on the storage
memory information screen. (Example: AAAABBBBCC.py will become AAAABB~1.py.)

File Content Display and Editing
Opening a py file that satisfies conditions (A) and (B) below in the Python app will produce a normal display of
all of the file contents. A py file that shows contents can be displayed normally and edited in the Python app.
(A)　 py file written in ASCII characters only and saved using UTF-8 or other ASCII-compatible codes

•　If a file is saved with character codes that are not compatible with ASCII, none of its contents will be
displayed if you open it in the Python app. All of the characters will be replaced by spaces, or appear
garbled.

(B)　 py file with up to 300 lines, each line containing up to 255 characters
•　The contents of a py file that exceeds the number of characters and/or number of lines specified above

cannot be displayed in the Python app. If a file cannot be opened, use the command below to import it.
   from (filename) import *

•　All tab codes in a py file will be replaced by two spaces when the file is opened in the Python app.
•　No type of newline codes (LF, CR, CR+LF) affect Python app display contents. All newline codes in a py

file will be replaced by CR+LF (Windows standard newline code) when the file is opened in the Python
app. Before transferring a py file that was edited and saved in the Python app to a computer for use on
the computer, replace its newline codes with the type that is appropriate for the environment where the
file will be used.

Running a py File
A py file in the file list that appears when you select T > [File] > [Open] may be executable with the Python
app. Note the information below.
•　Running a py file that includes commands not supported by the calculator’s Python app will result in an error.
•　Using the Python app to open a py file created on a computer will cause characters and newline codes to

be replaced. Because of this, opening a py file in the Python app, saving it, and running it, will change the
content from the original py file, which may affect the running results. For details, see “File Content Display
and Editing” (page 140).
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Base-N App
The Base-N application batch returns the results of a calculation in hexadecimal, decimal, octal, and binary
form. The calculation can be input using hexadecimal, decimal, octal, or binary numbers.
In this chapter, subscripts are appended to values to indicate the radix of the value. For example, 116 means
hexadecimal 1.

Basic Calculation Operations

To start a calculation
1.　h > Base-N

•　This causes the input cursor to appear in the upper left corner of the app window.

2.　Use F to select a number system (base).
•　Each press of F cycles the number system setting in the sequence: [Decimal] → [Hexadecimal] →

[Binary] → [Octal]. The currently selected number system is shown in line two of the app window.

3.　Input the calculation and then press E.
•　The calculation result is displayed in Hex (hexadecimal), Dec (decimal), Oct (octal), and Bin (binary) form.

Inputting Values
•　The letters A through F for hexadecimal values can be entered using key input or menu input.
XA, eB, jC, gD, iE, NF or C > [Hex Value] > [A], [B], [C], [D], [E], [F]

•　You can specify the number system for any value in a calculation by including d, h, b, or o before the value.
C > [Base Prefix] > [d], [h], [b], [o] (d: Decimal, h: Hexadecimal, b: Binary, o: Octal)
Example: d10 is treated as 1010. b111 is treated as 1112.

•　Input of decimal fractions and exponents is not supported. If a calculation result produces a decimal fraction
or exponent, the decimal fraction or exponent will be cut off.

Example Calculation

112 + 12 F > [Binary]
11+1E

1F16 + 116 F > [Hexadecimal]
1NF+1E

1010 + 1016 + 102 F > [Decimal]
10+

C > [Base Prefix] > [h]10+
C > [Base Prefix] > [b]10E
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Latest Calculation Result (Ans)
•　The result of the latest calculation is stored in a variable named Ans, which is independent of the Calculate

app’s Ans. To input Ans into a new calculation, press PF(Ans).
•　Pressing F clears the calculation and all results, but Ans retains the latest calculation result.
•　The Base-N app’s Ans is reset to 0 each time you exit the Base-N app.

Logical Operations and Negative Number Calculations
The following functions and commands can perform logical (bitwise operations) and negative number
calculations.
C > [Logic Operation] > [Neg()], [Not()], [and], [or], [xor], [xnor]

Syntax

Neg(n) Obtains the negative value*1 of n.
Not(n) Negates*2 n.
n and m Obtains the logical conjunction*3 of n and m.
n or m Obtains the logical disjunction*3 of n and m.
n xor m Obtains the exclusive OR*3 of n and m.
n xnor m Negates*3 the exclusive OR of n and m.

*1　Two’s complement. Negative binary, octal, and hexadecimal values are produced by taking the two’s
complement of a 32-bit binary number and then returning the result to the original number base. With the
decimal number base, negative values are displayed with a minus sign.

*2　One’s complement (bitwise complement)
*3　Bitwise AND, bitwise OR, bitwise XOR, bitwise XNOR

Example Calculation

Logical Operators

To obtain the result of
12016 and AD16

F > [Hexadecimal]
120C > [Logic Operation] > [and]

XAgDE

Negative Value Calculations

To obtain the negative
value of 1100102

F > [Binary]
C > [Logic Operation] > [Neg()]

110010E
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Input/Output Ranges
•　Input and output ranges for each number system are shown below (32 bits).

Base Input/Output Range
Binary Positive: 00000000000000000000000000000000 ≤ x ≤

01111111111111111111111111111111
Negative: 10000000000000000000000000000000 ≤ x ≤

11111111111111111111111111111111
Octal Positive: 00000000000 ≤ x ≤ 17777777777

Negative: 20000000000 ≤ x ≤ 37777777777
Decimal -2147483648 ≤ x ≤ 2147483647
Hexadecimal Positive: 00000000 ≤ x ≤ 7FFFFFFF

Negative: 80000000 ≤ x ≤ FFFFFFFF
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Financial App
You can use the Financial app to perform a variety of financial calculations.

Important!
•　Calculation results and graphs produced in this app should be regarded as reference values only.
•　Whenever performing an actual financial transaction, be sure to check any calculation results obtained

using this calculator against the figures calculated by your financial institution.
•　Whether you should use a positive or a negative value for the present value (PV) or the purchase price

(PRC) depends on the type of calculation you are trying to perform.

Operation Flow
Example: To calculate the total principal and interest after two years (730 days*) when $3,000 is invested at a

simple interest rate of 5.0%, and then to display a graph and check the calculation results against
the graph
*　S > [Number of Days/Year] (page 152): 365

3.　Since we want to determine the sum of principal and interest, select the [Type] menu’s [Future Value (SI)]
item.
(1)　 Highlight [Type] and then press O.
(2)　 On the menu that appears, select [Future Value (SI)] and then press O.

4.　Input the following information: n (days) = 730; I% (annual interest rate) = 5; PV (present value) = -3000.

d730E5Es-(M)3000E

5.　Specify the color that you want to use for the graph in step 7 of this procedure.
(1)　 Select T > [Graph Color].
(2)　 Select the color you want and then press O.

1.　h > Financial
•　This displays the Financial tab.

2.　Highlight [Simple Interest] and then press O.
•　This displays the Simple Interest Setup tab.

6.　To execute the calculation, press > (or highlight  and press
O).
•　This displays the calculation result for future value (FV =

principal + interest) on the Result tab.
•　An error occurs if parameters are not configured correctly.
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7.　To display the graph, press >.

9.　To return from the Graph tab to the Result tab, press b or <.

Performing Financial Calculations
The calculations in the table below can be performed with the Financial app.

To perform this type of calculation: Select this on the Financial tab:
Interest without compounding based on the number of days
money is invested

Simple Interest*1

Interest based on compounding parameters specified by you Compound Interest*2

Value of money paid out or received in varying amounts over time Cash Flow
Interest and principal portions of a payment or payments Amortization*2

Effective or nominal interest rate for interest compounded
multiple times during a year

Conversion

Cost, selling price, or margin of profit on an item given the other
two values

Cost/Sell/Margin

Number of days between two dates, or the date that is a specified
number of days from another date

Days Calculation*1

Amount that a business expense can be offset by income
(depreciated) over a given year

Depreciation

Purchase price or annual yield of a bond Bond Calculation*1*3

*1　Before performing a calculation, specify S > [Number of Days/Year] (page 152).
*2　Before performing a calculation, specify S > [Payment Point] (page 152).
*3　Before performing a calculation, specify S > [Interest Paid] (page 152).

Calculation Examples
Example 1 (Conversion):

To determine the annual percentage rate (APR) on a bi-monthly compounded (n = 6) bond with an effective
interest rate (I%) of 5%

1.　On the Financial tab, highlight [Conversion] and then press O.
•　This displays the Conversion Setup tab.

2.　Since we want to find the annual percentage rate, select [Annual Percent Rate] from the [Type] menu.
(1)　 Highlight [Type] and then press O.
(2)　 On the menu that appears, select [Annual Percent Rate] and then press O.

3.　Input the following information: n (number of compoundings) = 6; I% (interest rate) = 5.

d6E5E

8.　To check the calculation results on the graph, select T > [Trace].
•　This enables trace and causes a crosshair pointer ( ) to

appear on the graph.
•　Each press of r while trace is enabled cycles the displayed

value in the sequence: present value (PV) → simple interest
(SI) → future value (FV). Pressing l cycles in the reverse
direction.

•　To exit trace, press b.

145



 
Example 2 (Depreciation):

To use the sum-of-years’-digits method to calculate the first-year depreciation for a personal computer with
a useful life (n) of 5 years and original cost (PV) of $12,000. Assume 12 months as the number of months
of depreciation in the first year (Y-1). Also, display a list of the depreciation for each year.

1.　On the Financial tab, highlight [Depreciation] and then press O.
•　This displays the Depreciation Setup tab.

2.　Since we are using the sum-of-years’-digits method, select [Sum-of-the-Years’-Digits] from the [Type] menu.

3.　Input the following information: n (useful life) = 5; PV (original cost) = 12000; FV (residual book value) = 0; j
(year for calculation of depreciation cost) = 1; Y-1 (number of months in the first year of depreciation) = 12.

d5E12000E0E1E12E

 
Example 3 (Bond Calculation):

You want to purchase a semiannual bond*1 that matures on December 15, 2028 (d2) and has a settlement
date of June 1, 2024 (d1). The bond is calculated based on 365 days per year.*2 The bond is redeemed
at 100% of its face value (RDV) and the coupon rate (CPN) is 3%. If the yield to maturity (YLD) is 4%,
determine the price of the bond (PRC), the accrued interest (INT), and the purchase price including accrued
interest (CST).
*1　S > [Interest Paid] (page 152): Semi-annually
*2　S > [Number of Days/Year] (page 152): 365

1.　On the Financial tab, highlight [Bond Calculation] and then press O.
•　This displays the Bond Calculation Setup tab.

2.　Since we want to determine the bond price, select [Bond’s Price] from the [Type] menu.

3.　Input the following information: d1 = 6/1/2024 (month/day/year); d2 = 12/15/2028 (month/day/year); RDV =
100; CPN = 3; YLD = 4.

4.　To execute the calculation, press >.
•　This displays the calculation result on the Result tab.

4.　To execute the calculation, press >.
•　This displays the calculation result on the Result tab.

5.　To display a list of the depreciation for each year, press >.
•　The Table tab shows the depreciation (SYD) for each year

(j) and the remaining depreciated value (RDV) at the end of
each year.

•　While viewing the Table tab, you can display the graph by
pressing >.
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dE6E1E2024EE
E12E15E2028EE

100E3E4E

Note: Bond Calculation Memorandum Screen
•　Selecting T > [Display Memorandum] on the Result tab of Bond Calculation displays the number-of-

day values used in the calculation as shown below.

•　Selecting T > [Show Coupon Payment Day] while the Memorandum screen is displayed changes to
a screen showing the interest payment date (only when S > [Number of Days/Year] is “365”). If there
are multiple interest payment dates from the redemption year to the year of purchase, each press of
O while this screen is displayed each interest payment date scrolls back sequentially until the first
payment is reached.

PRD: number of days from d1 to d2
N: number of coupon payments between settlement date

and maturity date
A: accrued days
B: number of days from settlement date until next coupon

payment date (D − A)
D: number of days in coupon period where settlement occurs

Input/Output Terms and Calculation Formulas

Simple Interest

SI: interest
n: number of interest periods
PV : principal

I%: annual interest rate
FV : principal plus interest

365-day Mode: SI ′ =   n365 × PV × i     i =   I%100

360-day Mode: SI ′ =   n360 × PV × i     i =   I%100

SI =  -SI ′
FV =  - PV + SI ′

Compound Interest

n: number of compound periods
I%: annual interest rate
PV : present value
PMT : payment

FV : future value
P/Y : installment periods per year
C /Y : compounding periods per year

When calculating PV, PMT, FV, n

I% ≠ 0 PV = - α × PMT + β × FV

PMT = -PV + β × FV
α

FV = -PV + α × PMT
β

4.　To execute the calculation, press >.
•　This displays the calculation result on the Result tab.
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n =
log 1 + iS × PMT − FV × i

1 + iS × PMT + PV × i

log 1 + i

I% = 0 PV = - PMT × n + FV     n > 0

PMT = -PV + FV
n     n > 0

FV = - PMT × n + PV     n > 0

n = -PV + FV
PMT

 

α = (1 + i × S) × 1 − β
i 　　β = 1 + i -n

 

  When S > [Payment Point] is “End” When S > [Payment Point] is “Beginning”
S = 0 1

 

  When P/Y = C /Y = 1 When P/Y ≠ 1 and/or C /Y ≠ 1

i =   I%100 1 + I%
100 × C /Y

C /Y
P/Y

− 1

 

When calculating I%
i (effective interest rate) is calculated using Newton’s Method.
PV + α × PMT + β × FV = 0
I% = is calculated from i using the formulas below:

  When P/Y = C /Y = 1 When P/Y ≠ 1 and/or C /Y ≠ 1

I% = i × 100 1 + i
P/Y
C /Y − 1 × C /Y × 100

Important!
•　When inputting both the present value (PV) and future value (FV) for a calculation, either PV or FV

must be positive, while the other (PV or FV) is negative.
•　Annual interest rate (I%) calculations are performed using Newton’s Method, which produces

approximate values whose precision can be affected by various calculation conditions. Interest
calculation results produced by this application should be used keeping the above in mind, or results
should be confirmed separately.

Cash Flow
This calculator uses the discounted cash flow (DCF) method to perform investment appraisal by totalling cash
flow for a fixed period. This calculator can perform the following four types of investment appraisal.

NPV : Net present value
IRR: Internal rate of return

NFV : Net future value
PBP: Payback period

A cash flow diagram like the one shown below helps to visualize the movement of funds.

CF0

CF1

CF2 CF3
CF4

CF5
CF6

CF7

With this graph, the initial investment amount is represented by CF0. The cash flow one year later is shown by
CF1, two years later by CF2, and so on.
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NPV = CF0 +
CF1
1 + i + CF2

1 + i 2 +
CF3

1 + i 3 + ･･･ + CFn
1 + i n

(i = I%
100 , I%: Interest rate, n: natural number up to 254)

NFV = NPV × 1 + i n

 
IRR is calculated using the formula below:

0 = CF0 +
CF1
1 + i + CF2

1 + i 2 +
CF3

1 + i 3 + ･･･ + CFn
1 + i n

In this formula, NPV  = 0, and the value of IRR is equivalent to i × 100. It should be noted, however, that
minute fractional values tend to accumulate during the subsequent calculations performed automatically by
the calculator, so NPV  never actually reaches exactly zero. IRR becomes more accurate the closer that NPV
approaches to zero.

PBP =
 
 

0……………………… CF0 ≥ 0

n − NPVn
NPVn + 1 − NPVn

･･･(Other than those above)

NPVn = ∑
k = 0

n CFk
1 + i k

n: smallest positive integer that satisfies the conditions
NPVn ≤ 0, 0 ≤ NPVn + 1, or 0

Amortization

PM1: first installment of installments 1 through n
PM2: second installment of installments 1 through n
n: installments
I%: interest rate
PV : principal

PMT : payment for each installment
FV : balance following final installment
P/Y : installments per year
C /Y : compoundings per year

a

b

1

c

PM1 PM2

1 payment

Last
Number of payments

e

d

1 PM1 PM2

1 payment

Last
Number of payments

 

a: interest portion of installment PM1 (INT) INTPM1 = BALPM1-1 × i × PMT  sign

b: principal portion of installment PM1 (PRN) PRNPM1 = PMT + BALPM1-1 × i

a + b = one repayment (PMT)
 

c: balance of principal after installment PM2 (BAL) BALPM2 = BALPM2-1 + PRNPM2

d: total principal from installment PM1 to payment of
installment PM2 (ΣPRN) ∑

PM1

PM2
PRN = PRNPM1 + PRNPM1+1 + ･･･ + PRNPM2

e: total interest from installment PM1 to payment of
installment PM2 (ΣINT) ∑

PM1

PM2
INT = INTPM1 + INTPM1+1 + ･･･ + INTPM2

When S > [Payment Point] is “End”, BAL0 = PV .
When S > [Payment Point] is “Beginning”, INT1 = 0 and PRN1 = PMT .
 

Converting between the nominal interest rate and effective interest rate
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The nominal interest rate (I% value input by user) is converted to an effective interest rate (I%’) for installment
loans where the number of installments per year is different from the number of compound interest calculation
periods.

I%′ = 1 + I%
100 × C /Y

C /Y
P/Y

− 1 × 100

The following calculation is performed after conversion from the nominal interest rate to the effective interest
rate, and the result is used for all subsequent calculations.

i = I%′ ÷ 100

Conversion

EFF: Effective interest rate (%)
APR: Annual percent rate (%)

n: number of compoundings
I%: Interest rate

 

EFF = 1 + APR/100
n

n
− 1 × 100 APR = 1 + EFF100

1
n − 1 × n × 100

Cost/Sell/Margin

Cst: Cost price Sel: Selling price Mrg: Margin (%)
 

Cst = Sel  1 − Mrg100
Sel = Cst

1 − Mrg
100

Mrg(%) = 1 − CstSel × 100

Days Calculation
Number of Days = d2-d1 (d1: date 1, d2: date 2)
Days After = d1+D (d1: date, D: number of days)
Days Before = d1-D (d1: date, D: number of days)

Depreciation

Straight-Line Method (SL)

SL j: depreciation charge for the jth year
n: useful life
PV : original cost (basis)
FV : residual book value
j: year for calculation of depreciation cost
Y − 1: number of months in the first year of depreciation

 

SL1 =
PV − FV

n × Y − 1
12 SL j =

PV − FV
n SLk =

PV − FV
n × 12 − Y − 1

12 k = n + 1, Y − 1 ≠ 12
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Fixed-Percent Method (FP)

FP j: depreciation charge for the jth year
RDV j: remaining depreciable value at the end of jth year
I%: depreciation ratio

FP1 = PV × I%
100 × Y − 1

12
FP j = RDV j − 1 + FV × I%

100 FPn + 1 = RDVn Y − 1 ≠ 12

RDV1 = PV − FV − FP1 RDV j = RDV j − 1 − FP j RDVn + 1 = 0 Y − 1 ≠ 12

Sum-of-the-Years’-Digits Method (SYD)

SYD j: depreciation charge for the jth year
RDV j: remaining depreciable value at the end of jth year

Z = n n + 1
2 n′ = n − Y − 1

12 Z′ = Intg n′ + 1 Intg n′ + 2 × Frac n′
2

SYD1 =
n
Z × Y − 1

12 (PV − FV ) SYD j =
n′ − j + 2

Z′ (PV − FV − SYD1) j ≠ 1

SYDn + 1 =
n′ − n + 1 + 2

Z′ (PV − FV − SYD1) × 12 − Y − 1
12  ({Y − 1} ≠ 12)

RDV1 = PV − FV − SYD1 RDV j = RDV j − 1 − SYD1  

Declining-Balance Method (DB)

DB j: depreciation charge for the jth year
RDV j: remaining depreciable value at the end of jth year
I%: depreciation factor

DB1 = PV × I%
100n ×

Y − 1
12

RDV1 = PV − FV − DB1 DB j = RDV j − 1 + FV × I%
100n

RDV j = RDV j − 1 − DB j DBn + 1 = RDVn Y − 1 ≠ 12 RDVn + 1 = 0 Y − 1 ≠ 12

Bond Calculation

①　 Issue date
②　 Coupon payment dates
③　 Purchase date (d1)
④　 Redemption date (d2)

PRC: price per $100 of face value
CPN : coupon rate (%)
YLD: annual yield (%)
M : number of coupon payments per year (1=annual, 2=semi annual)
N : number of coupon payments between settlement date and maturity date
RDV : redemption price or call price per $100 of face value
INT : accrued interest
CST : price including interest
D: number of days in coupon period where settlement occurs
A: accrued days
B: number of days from settlement date until next coupon payment date = D − A

For one or fewer coupon period to redemption

D

A B
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PRC = - 
RDV + CPN

M

1 + B
D × YLD/100

M
+ A
D × CPNM

For more than one coupon period to redemption

PRC = -  RDV

1 + YLD/100
M

N − 1 + B
D
− ∑
k = 1

N CPN
M

1 + YLD/100
M

k − 1 + B
D
+ A
D × CPNM

INT = -  AD × CPNM CST = PRC + INT  

Important!
•　The Financial app performs annual yield (YLD) calculations using Newton’s Method, which produces

approximate values whose precision can be affected by various calculation conditions. Because of
this, annual yield calculation results produced by this app should be used keeping the above in mind,
or results should be confirmed separately.

Financial App Settings Menu Items
The Settings menu items (page 214) described below are specific to the Financial app.

S > [Payment Point] ... Specifies the beginning of the period (Beginning) or the end of the period
(End) as the payment date. This setting affects Compound Interest and
Amortization calculations.

S > [Number of Days/Year] ... Specifies the number of days in a year as 365 or 360. This setting affects
Simple Interest, Days Calculation and Bond Calculation.

S > [Interest Paid] ... Specifies the interval between interest payments in a Bond Calculation as
either once a year or once every six months.
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Geometry App
Select h > Geometry to start up the Geometry app. This app allows you to draw and analyze geometric
objects. For example, you can draw a circle and then draw a line that is tangent to a particular point on the
circle.

The Geometry app also includes an animation feature that lets you watch how a figure changes in accordance
with conditions you define.

Note
•　Changes to the Angle, Grid, or Axes settings of the Settings menu in the Geometry app, affect only the

Geometry app. They do not affect other apps. Conversely, changes made to these settings in other
apps do not affect the Geometry app.

•　The initial default setting of the Geometry app’s Angle setting is Degree.
•　The examples in this chapter assume Geometry app initial default settings are in use (which are

configured when a new file is created as described under “Using the File Menu” (page 161)), unless
otherwise noted.

Drawing and Editing Objects
This section explains how to perform the following operations.
•　Plot points, draw line segments, polygons, etc. (Draw menu, Draw Special menu)
•　Insert text into screen images
•　Undo an operation
•　Select and deselect objects, move an object, delete an object and other editing operations

Using the Pointer
You can use the following operations to move the on-screen pointer ( ) around the display when drawing
objects, editing objects, etc.

To move the pointer
Use the cursor keys (d/u/l/r) to move the pointer around the display. Holding down a cursor key moves
the pointer at high speed.

To make the pointer jump to a particular location
Pressing a number key (1 to 9) causes the pointer to jump to the corresponding location of the screen as
shown below.
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7 8 9

4 5 6

1 2 3

Using the Draw Menu
The Draw menu contains menu items for drawing basic geometric elements such as points, line segments,
circles, etc.

To do this: Select this menu item: And then specify these points:*1

Plot a point T > [Draw] > [Point] One point*2

Draw a line segment T > [Draw] > [Line Segment] Two points in different locations (line
segment start and end points)

Draw a straight line T > [Draw] > [Line] Two points in different locations (two points
through which a straight line passes)

Draw a ray T > [Draw] > [Ray] Two points in different locations (ray start
point and a point through which the ray
passes)

Draw a vector T > [Draw] > [Vector] Two points in different locations (vector
start and end points)

Draw a circle T > [Draw] > [Circle] Two points in different locations (circle
center point and one point on the
circumference)

Draw an arc T > [Draw] > [Arc] Three points in different locations*3

Draw a semicircle T > [Draw] > [Semicircle, by
Diameter]

Two points in different locations (either end
of a circle diameter)

*1　To specify a single point, move the pointer to the desired location and then press O.
*2　See the Example 1 (page 154) below.
*3　See the Example 2 (page 155) below.
 
Example 1: To plot a point

1.　Select T > [Draw] > [Point].

2.　Move the pointer to the location where you want to plot a point and then press O.
•　This plots a point at the pointer location.
•　The  icon remains on the screen, which means you repeat step 2 to plot more points if you want.

3.　After you are finished plotting all the points you want, press b to deselect the Point tool.

Note
•　Some drawing tools remain after you draw something, like the Point tool. To deselect such a tool,

press b or a.
•　You can use the following procedure to add a labeled point to an existing line, to a side of a polygon,

to the periphery of a circle, etc.
(1)　 Select T > [Draw] > [Point].
(2)　 Move the pointer on the screen towards the line where you want to add the labeled point, and then

press O.
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Example 2: To draw an arc

1.　Select T > [Draw] > [Arc].

2.　Move the pointer to the location where you want the center point of the arc to be and then press O.

3.　Move the pointer to the location where you want the start point of the arc to be and then press O.

6.　Press b to deselect the Arc tool.

Using the Draw Special Menu
The Draw Special menu contains menu items for drawing triangles, rectangles, and polygons, as well as menu
items for drawing graphs based on the input functions.

To do this: Select this menu item: And then specify these points:*1

Draw a triangle T > [Draw Special] > [Triangle] Two points in different locations*2

Draw an isosceles triangle T > [Draw Special] > [Isosceles
Triangle]

Draw a rectangle T > [Draw Special] > [Rectangle]
Draw a square T > [Draw Special] > [Square]
Draw a polygon T > [Draw Special] > [Polygon] At least three points in different locations*3

 

To do this: Select this menu item: And then perform this operation:
Draw a regular n-gon T > [Draw Special] > [Regular n-

gon]
In the dialog that appears, input an integer
from 3 to 12 and then press O.

Draw a function graph T > [Draw Special] > [Function f(x)] In the dialog that appears, enter a function
in the form y = f x  and then press O.*4

*1　To specify a single point, move the pointer to the desired location and then press O.
*2　See the Example 1 (page 155) below.
*3　See the Example 2 (page 156) below.
*4　The angle unit of the graph that is drawn is always Radian, regardless of the Angle setting on the Settings

menu.
 
Example 1: To draw a triangle

1.　Select T > [Draw Special] > [Triangle].

2.　Move the pointer to any location on the screen and then press O.

4.　Move the pointer and the line segment to the location where you want
the end point of the arc to be.

5.　Press O.
•　This draws an arc from the start point to the end point, in a

counterclockwise direction.

3.　Move the pointer to another location.

155



Note
•　The same type of two-point selection boundary in the above procedure is also used when drawing an

isosceles triangle, rectangle, square, or regular n-gon.
In each case, the resulting object is the maximum size that fits in the screen if the second point specified
is too close to or at the same location as the first point.

Example 2: To draw a polygon

1.　Select T > [Draw Special] > [Polygon].

2.　Move the pointer to the location where you want a vertex of the polygon to be and then press O.

4.　Press b to deselect the Polygon tool.
•　If you press b without performing the operation in step 3 above, the figure is finalized as-is, resulting in

an unclosed non-polygon.

Inserting Text into Screen Images

To insert text into a screen image

2.　Select T > [Option] > [Text].

•　This causes a selection boundary to appear, indicating the
size of the triangle to be drawn.

4.　Press O.
•　This draws a triangle.

•　Repeat this step as many times as required to specify the
other vertices of the polygon.

3.　To complete the polygon, move the pointer to the location of the first
vertex and then press O.

1.　Move the pointer to the location where you want to insert the text.
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To edit screen text
1.　Select the text you want to edit.

2.　Press V.
•　This displays the measurement box at the bottom of the screen.

3.　Press O.

4.　Edit the text and then press O.

5.　To close the measurement box, press b twice.

Note
•　For details about the measurement box, see “Using the Measurement Box” (page 168).

Undoing and Redoing an Operation

To undo the last operation you performed
Immediately after performing the operation, you want to undo, press / or select T > [Edit] > [Undo/Redo].

Note
•　T > [Edit] > [Clear All] operations cannot be undone. Also, you cannot undo an object select or

deselect operation, a T > [View] menu item operation (View Window settings, pan, scroll, zoom
operations), or a setting change.

To redo an operation
Immediately after undoing the operation, press / or select T > [Edit] > [Undo/Redo].

•　This displays a text input dialog box and automatically
switches the calculator’s keys to alpha lock.

3.　Input up to 31 characters of text and then press O.
•　The text you input is inserted into the screen image at the

location of the pointer.

•　This displays a text input dialog box.

•　This causes the newly edited text to appear on the screen.
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Selecting and Deselecting Objects
To edit an object (move, delete, change color, etc.) or to create a drawing using an object (such as constructing
a midpoint of a line segment), you first need to select part of or all of the object. This section explains how to
select and deselect objects.
Before starting the operations shown in the table below, make sure that no tool icons are displayed in the upper
right corner of the screen. If a tool icon is displayed, press b or a to deselect the tool.

To do this: Perform this operation:
Select a particular object 1.　Move the pointer close to the object you want to select.

•　This causes one or more  marks to appear on the object. At this time the
object begins to flash.

2.　Press O.
•　This causes  to change to  and changes the outline of the object to

become a thick line, which indicates that the object is selected.

•　Now you can repeat steps 2 and 3 to select other objects if you want.
Select an entire polygon 1.　Move the pointer close to the polygon you want to select.

•　This causes  marks to appear on some part (vertex or side) of the polygon.
2.　Press P or select T > [Edit] > [Select Figure].

•　This selects the entire polygon.

Select an entire semicircle You can use the same operation as that under “Select an entire polygon” above
to select the semicircle.

Select an entire circle 1.　Move the cursor near the circumference of the circle you wish to select.
•　This causes four  marks to appear on the circumference. At this time the

circumference begins to flash.
2.　Press O.

•　This selects the entire circle.
Deselect a particular
object

1.　Move the pointer close to the object you want to deselect.
•　This causes the  marks to become highlighted. At this time the object

begins to flash.
2.　Press O.

Note
•　You can use the same operation as the one described above to deselect

only a portion (vertex or side) of a polygon that is entirely selected.
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Select all objects on the
screen

Select T > [Edit] > [Select All].

Deselect all objects on the
screen

Press a or select T > [Edit] > [Deselect All].

Moving and Deleting an Object

To move an object
1.　Select the object you want to move.

Note
•　If you press X when nothing is selected on the screen, the pointer changes to , which you can

use to pan (shift) the entire screen.
•　Sometimes you may find that an object does not move the way you want it to. If this happens, press /

to cancel the move and then do the following to try the move again.
-　Lock the part(s) of the object that you do not want to move (see “Locking or Unlocking a Measurement

of an Object” (page 171))
-　Temporarily unlock all objects by selecting T > [Option] > [Clear Constraint] (page 172)

To delete an object
1.　Select the object you want to delete.

•　If you want to move only one of the vertices of a triangle for
example, select the vertex. To move only one side of the
triangle, select the side.

•　In each of the steps below, an example screenshot is shown
when one side of a triangle is selected and moved.

2.　Press X.
•　This causes the  icon to appear in the upper right corner

of the screen and the pointer to change from  to . Also,
a rectangle encloses the object that you selected in step 1.

3.　Use the cursor keys to move the object in the direction you want.

4.　To move the object to the current location of the rectangle, press O.
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•　If you want to delete only one of the vertices of a triangle for example, select the vertex. To delete only
one side of the triangle, select the side.

2.　Press I or select T > [Edit] > [Delete].
•　This deletes the selected object.

To delete all objects on the screen

Important!
•　Performing the operation below deletes all the objects currently on the screen. This operation cannot

be undone.

1.　Select T > [Edit] > [Clear All].

2.　In response to the confirmation dialog that appears, select [OK].

Note
•　You can also delete all objects by pressing a twice while nothing is selected on the screen.

Hiding and Showing Objects

To hide an object
1.　Select the object you want to hide.

2.　Select T > [Option] > [Hide].
•　This hides the selected objects.

To show all hidden objects
Select T > [Option] > [Show All]. This shows all currently hidden objects.

Changing the Display Priority of Objects
Objects you draw in the Geometry app are stacked in the order they are drawn (newest drawing on top). You
can use the operations below to move a drawn object to the top or the bottom of the stack. You also can move
all text to the front, if you want.
•　To move a particular object to the front, select T > [Properties] > [to the front].
•　To move a particular object to the back, select T > [Properties] > [to the back].
•　To move all text to the front, select T > [Properties] > [All Text].

Specifying an Object’s Color and Line Thickness

To specify text color
1.　Select the text whose color you want to specify.

2.　Select T > [Color Select] > [Char Color]. On the menu that appears, select the desired color.

•　To specify the text color of a label appended to a point
(for example, the center point of a circle or the vertex of a
polygon), select the point where the label is appended.

3.　To apply the settings you configure, press b.
•　Press a to deselect all objects.
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To specify the color and thickness of a line
1.　Select the line whose color and thickness you want to specify.

2.　Select T > [Color Select] > [Line Style]. On the menu that appears, select the desired line style.

3.　Select T > [Color Select] > [Line Color]. On the menu that appears, select the desired color.

To specify fill color and intensity of a closed figure (polygon, circle, etc.)
1.　Select the closed figure whose fill color and intensity you want to specify.

•　To fill a polygon or semicircle, press P to select the entire figure. To fill a circle, select its circumference.

2.　Select T > [Color Select] > [Area Color]. On the menu that appears, select the desired color.

3.　Select T > [Color Select] > [Paint Style]. On the menu that appears, select “Normal” or “Lighter”.

Note
•　You can also select three arbitrary points (the vertices of a polygon,

the center of a circle, the edge of a line segment, etc.) and specify
the fill color and intensity of the area enclosed within the three points.
Select the three points in step 1 above.
Note that this operation is possible only when three points are
selected. This operation is not performed if four or more points are
selected.

Using the File Menu
The table below shows the file operations that you can perform with the Geometry app.

To do this: Select this menu item:
Clear the current drawing and create a new file T > [File] > [New]
Clear the current drawing and open the Geometry app file stored
in Main Memory

T > [File] > [Open] > [Main Memory]

Clear the current drawing and open an image file (.g4p or .g3p)*1

or Geometry app file (.g4p)*2 with the background image stored
in Storage Memory

T > [File] > [Open] > [Storage Memory]

Name and save the current drawing T > [File] > [Save As]
Delete the Geometry app file stored in Main Memory T > [File] > [Delete] > [Main Memory]

•　If you want to specify the color and thickness for all sides
of a polygon simultaneously, press P to select the entire
polygon (see “Select an entire polygon” under “Selecting and
Deselecting Objects” (page 158)).

4.　To apply the settings you configure, press b.
•　Press a to deselect all objects.

4.　To apply the settings you configure, press b.
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Delete an image file (.g4p or .g3p)*1 or Geometry app file*2 (.g4p)
with background image stored in Storage Memory

T > [File] > [Delete] > [Storage Memory]

*1　You can open a g4p or g3p file and use it as a background image for a Geometry app drawing. Attempting
to open a g4p or g3p file may cause the following message to appear: “View window value is not suitable.
Set initial value? ”. To open the file using the Geometry app View Window initial default value, select [OK].
For information about g4p and g3p files, see “Files Displayed on the Storage Memory Tab” (page 196).

*2　For details, see “Displaying a Geometry App Screen Background Image” (page 162).

Note
•　Each time a new file is created in the Geometry app, View Window settings (page 162) are initialized.

In addition, the Settings menu settings below are returned to their initial default settings (noted in
parentheses).
Angle (Degree) Angle Unit (On) Length Unit (Off)
Grid (Off) Grid Space (1) Axes (Off)

Displaying a Geometry App Screen Background Image
In the Geometry app, you can open an image file (.g4p or .g3p) and use it as a background image for a Geometry
app drawing. If you open a g4p or g3p file, draw something, and then save the result to a file, the file is saved
in g4p format, along with the Geometry app data.

Note
•　You can edit the Geometry app data (objects drawn with the app) on the saved g4p file later. However,

once you save the result to a g4p file, you cannot change the background image of the file or remove
it.

To adjust the opacity of the background image (Fade I/O)
This operation can be performed only when a 16-bit color image is being used as the background image.

1.　Select T > [Properties] > [Fade I/O].

2.　Use l and r to adjust the opacity of the background image.

3.　When the setting is the way you want, press O.

Using the View Menu
You can use the View menu to perform the operations below and adjust the viewing area of the drawing screen.
•　Specify the display range numerically or restore default settings (View Window)
•　Shift the display range up, down, left, right (Pan, Scroll)
•　Zoom the display range (Zoom Box, Zoom In, Zoom Out, Zoom to Fit)

Configuring View Window Settings
You can configure View Window settings to specify the coordinates of the screen’s left edge (X Minimum) and
right edges (X Maximum). The length of the y-axis is configured automatically using a ratio of 1:2 (y-axis:x-axis),
but you can specify what part of the y-axis is in the middle of the screen (Y Middle).

To configure View Window settings

1.　Select T > [View] > [View Window].
•　To display the View Window menu.

2.　Input values for X Minimum, X Maximum, Y Middle.
•　If you want to return these settings to their initial defaults, select [Pre-set Windows] > [Initialize].

3.　After all the settings are the way you want, select  and then press O.
•　To close the View Window menu without applying any of the settings you changed, press b instead of

performing step 3.
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Using Pan and Scroll to Shift the Display Image

To pan the screen

1.　Select T > [View] > [Pan].
•　This enters the pan mode, which is indicated by the  icon in the upper right corner of the screen.

2.　Move the pointer to the location on the screen you want to grab and then press O.
•　This causes the pointer to change from  to .

3.　While the  pointer is displayed, use the cursor keys to shift the screen in the direction you want.

•　In the pan mode, each press of O toggles the shape of the pointer between  and . While the  pointer
is displayed, you can use the cursor keys to move it to another location on the screen. Pressing the cursor
keys while the  pointer is displayed shifts (pan) the screen contents.

4.　To exit the pan mode, press b.

To scroll the screen

1.　Press . or select T > [View] > [Scroll].
•　This enters the scroll mode, which is indicated by the  icon in the upper right corner of the screen. The

pointer disappears from the screen at this time.

2.　Use the cursor keys to scroll the screen in the direction you want.

3.　To exit the scroll mode, press b.

Zooming

To zoom using the zoom box

1.　Select T > [View] > [Zoom Box].
•　This causes the  icon to appear in the upper right corner of the screen.

2.　Move the pointer to the location on the screen on one edge of the area you want to select as the zoom box
area and then press O.

3.　Move the pointer in the direction of the opposite edges of the zoom box area.
•　As you do, the calculator displays a selection boundary that expands as you move the pointer.

4.　After selecting the zoom box area you want, press O.
•　The area within the zoom box area expands to fill the entire screen.

To zoom in and out
To double the size of the displayed image, press + or select T > [View] > [Zoom In].
To halve the size of the displayed image, press - or select T > [View] > [Zoom Out].

To zoom the screen image to fit the window area
Press F or select T > [View] > [Zoom to Fit].
•　This enlarges or reduces the currently display image so it fills the screen.
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Note
•　The above operation does not apply in the case of a graph drawn using T > [Draw Special] > [Function

f(x)].

Using the Construct Menu
You can use the Construct menu to create a drawing based on a previously drawn figure, as described in the
table below.

To construct
this:

Select one or two of the following geometric
elements:

Select T > [Construct] and then
select this:

A
perpendicular
bisector

A line segment, a side of a polygon, or two points*1 [Perpendicular Bisector]

A
perpendicular
line

One point*1 plus one of the following geometric
elements: A line segment, a straight line, a side of
a polygon

[Perpendicular Line]

A midpoint A line segment, a side of a polygon, or two points*1 [Midpoint]

An intersection
point

Any two of the following (or two of the same) geometric
elements: line segment,*2 straight line, ray, vector,
side of a polygon, circle, arc

[Intersection Point]

An angle
bisector

Any two of the following (or two of the same) geometric
elements: line segment, straight line, ray, vector, side
of a polygon

[Angle Bisector]
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A parallel line A single point*1 plus one of the following geometric
elements: line segment, straight line, ray, vector, side
of a polygon

[Parallel Line]

*3

A tangent A single circle, semi circle, arc, or function graph*4 [Tangent]
*4

*1　The vertices of a polygon, the center point of a circle, or any other point that constitutes a figure.
*2　If two line segments with no points of intersection are selected, an intersection point is created at the location

where the two line segments eventually intersect when extended.
*3　A symbol (>) indicating parallelism appears or both one ends of the selected line segment, line, ray, or

polygon and the drawn parallel line.
*4　In the case of drawing a tangent, you don’t need to select a figure first. After selecting T > [Construct] >

[Tangent], move the pointer to a point on the figure to which you want to draw a tangent line, and then press
O.

Attaching an Angle Measurement to a Figure
You can select two line segments or two sides of a polygon and attach an angle value to them.
Example: To select two sides of a polygon and append an angle value

1.　Draw a triangle and select two of its sides.

•　While the “Select Display Position” message is displayed, you can use the cursor keys to specify which
angle measurement is displayed for the two selected sides.

3.　To determine the display location of an angle measurement, press O.

Using the Transformations Menu
You can use the Transformations menu to perform various transform operations, such as object reflection,
object rotation, etc.

Reflecting an Object
You can specify a line segment, line, ray, one side of a polygon, or the x-axis or y-axis as the axis of reflection.

2.　Select T > [Construct] > [Attached Angle].
•　This attaches the angle measurement to the figure.
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Example: To draw a triangle shifted symmetrically along the x-axis

1.　Select S > [Axes] > [Scale].
•　This displays the x-axis and y-axis with a scale.

2.　Draw a triangle and then use the P key to select the entire triangle.
•　For more information about how to select the triangle, see “Select an entire polygon” (page 158).

3.　Select T > [Transformations] > [Reflection].
•　This causes the message “Select Axis” to appear.

Translating an Object Using an Existing Vector
Example: To translate a triangle according to a vector direction and magnitude

1.　Daw a triangle, and then draw a vector for translation.

2.　Use P to select the entire triangle. For more information about how to select the triangle, see “Select an
entire polygon” (page 158).

3.　Select T > [Transformations] > [Translation (Select Vector)].
•　This causes the message “Select Vector” to appear.

4.　Move the pointer to a location where the tip is touching the x-axis.
•　Move the pointer to a location on the x-axis away from the

origin.

5.　Press O.
•　This draws the triangle by shifting it symmetrically on the
x-axis.

4.　Move the pointer close to the vector until  marks appear on it.

5.　Press O.
•　The triangle is translated according to the selected vector.
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Note
•　If you select only part of an object before performing step 3 of the above procedure, only the selected

part is translated.

Other Transformation Operations
Before starting any of the operations shown in the table below, draw the figure you want to transform and then
select the entire figure. If you select only part of an object, only the selected part is transformed.

To do this: Select this menu item: And then perform this operation:
Translate an object
by specified values

T > [Transformations]
> [Translation (Enter
Vector)]

1.　On the Translation screen that appears, input the values
for the translation distance along the x-axis and the
translation distance along the y-axis.

2.　Select  and then press O.
Rotate an object T > [Transformations] >

[Rotation]
1.　While the message “Select Center of Rotation” is

displayed, move the pointer to the location you want
to specify as the center of rotation, and then press O.

2.　On the dialog box that appears, input the angle of
rotation (counterclockwise) in degrees and then press
O.

Dilate an object T > [Transformations] >
[Dilation]

1.　While the message “Select Center of Dilation” is
displayed, move the pointer to the location you want
to specify as the center of dilation, and then press O.

2.　On the dialog box that appears, input a scale value in
the range of 0.1 ≤ | x | ≤ 10 and then press O.
•　See the figure in the Note below for details about

the meanings of the terms used during the dilation
operation.

Rotate an object
180 degrees on a
specified point

T > [Transformations] >
[Point Reflection]

While the message “Select Center Point” is displayed, move
the pointer to the location you want to specify as the center
of rotation, and then press O.
•　This draws the figure rotated 180 degrees on the selected

point. In addition, a point is plotted at the center point.

Note
•　The following figure illustrates the meanings of the terms used in the dilation procedure above.

Center of Dilation

Original Object

Scale: -1 Scale: 0.5 Scale: 2
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Using the Measurement Box

Viewing the Measurements of an Object

The table below describes the information that appears in the measurement box when you select each icon
and explains when each icon is available for selection.

Measurement Icon Table

Icon*1 This icon is available for selection
when: Selecting this icon displays:

Coordinates

( )
A single point is selected. Coordinates of the point

Distance/Length

( ) Two points are selected, or a single line
segment or vector is selected.

Distance between two points, length
of a line segment or vector

Slope

( ) A single line, ray, line segment, or vector is
selected.

Slope of the line, ray, line segment,
or vector

Angle

( )

Two of the following line elements in
any combination are selected: lines, line
segments, rays, or vectors.*2

Angle and its supplement formed by
the two objects

Supplementary
Angle

( )

Radius

( ) A single circle, semicircle, or arc is
selected. Radius of circle, semicircle, or arc

Circumference

( )*3 A single circle, semicircle, or arc is
selected. Length of the circumference

Perimeter

 
A single polygon is selected. Sum of the lengths of the sides

Area

( )*3 A single circle, semicircle, arc, or polygon is
selected, or any three points are selected. Area*4

Equation

  A single line or line segment, ray, circle,
semicircle, arc, or function graph is
selected.

Function of the object (using
rectangular coordinates)

Vector

( )
A single vector is selected. Vector components

Tangency

( ) Two circles, two arcs, a line and circle, or
a line and arc are selected. Whether the two items are tangent

Pressing V displays a measurement box at the bottom of the
screen. Press b twice to hide the measurement box.
You can use the measurement box to view the measurements
of an object, to specify a measurement of an object, to lock a
measurement of an object, or to name an object.

The type of information that can be displayed in the measurement
box depends on the object currently selected on the screen. The
nearby screen shows an example when a circle is selected.
You can change the display information type by highlighting the
up arrow button to the left of the measurement box, pressing O,
and then using the cursor keys to highlight the appropriate icon
on the icon palette that appears.
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Congruence

( )
Two line segments are selected. Whether the line segments are the

same length

Incidence

( ) A point and line, a point and arc, a point and
circle, or a point and vector are selected. Whether the point is on the line/curve

Rotation angle

  Two points created by the Rotation
(page 167) command are selected. Angle of rotation

Scale of dilation

  Two points created by the Dilation
(page 167) command are selected. Scale of dilation

Label/Text

  A point or pasted measurement*5 that has
a label or an object that can be named is
selected.

Label text

Expression

  A single expression is selected (“EXPR=”
object). Calculation expression

*1　“ ” to the right of the icon indicates that the measurement is lockable. See “Locking or Unlocking a
Measurement of an Object” (page 171) for information about lock operations.

*2　When two vectors are selected, the angle that is displayed in the measurement box does not mean the
angle formed mathematically by the two vectors. It merely indicates the simple angle that would be formed
if the vectors were two lines.

*3　Circumference and area measurements are lockable only when a circle is selected.
*4　A value that shows the area of an object whose lines intersect is indicated by double asterisks ( ) to the

left of the value. This indicates that the value may not indicate the correct area.
*5　See “Pasting Measurements into a Screen Image” (page 172).

To view the measurements of a line segment
1.　Draw a line segment and select it.

4.　Select the icons on the icon palette to display other measurements.
•　In the case of the line segment, for example, you can view its length, slope, and equation.

Slope Equation

5.　To close the measurement box, press b twice.

2.　Press V to display the measurement box.
•　This displays the length of the line segment.

3.　Press l to highlight the up arrow button to the left of the
measurement box and then press O.
•　This displays an icon palette.

169



Specifying and Locking a Measurement of an Object
The following example shows how to specify and lock an angle of a triangle. For example, locking ∠ACB of
△ABC at 90 degrees causes ∠ACB to remain at 90 degrees regardless of where the vertex is moved. In the
example below, the S > [Angle] setting is set to “Degree”.

To specify and lock the measure of an angle of a triangle
1.　Draw a triangle, and then select its side AC and side BC.

4.　Try moving vertex B (make sure ∠ACB is locked at 90 degrees).
(1)　 Press b twice to hide the measurement box.
(2)　 Press a to deselect all objects.
(3)　 Move the pointer to vertex B and then press X. See “To move an object” (page 159) for more

information.
(4)　 Use the cursor keys to move vertex B to the location you want and press O.

•　Vertex A moves so ∠ACB maintains 90 degrees.

Note
•　Specifying any one of the following measurements for the first time in the file you are editing (or

immediately after an all-clear operation (T > [Edit] > [Clear All]) causes the resulting object to be
resized so it fits within the display area.
-　Length of one side of a triangle
-　Length of a line segment or vector
-　Length of one side of a rectangle, square, polygon, or regular n-gon
-　Circumference of a circle or length of an arc
View Window settings are reconfigured automatically so the size of the object on the display may
not appear to change very much. The following example shows what happens when the length of
the base of a triangle drawn with the initial default View Window settings (with a screen width of 10)
is changed to 50.

2.　Press V to display the measurement box.
•　This displays the measure of ∠ACB in the measurement box.
•　At this time, the icon to the right of the measurement box is

 (unlocked).

3.　Input 90 into the measurement box and press E.
•　This specifies and locks the measure of ∠ACB at 90

degrees.
•　This causes the icon to the right of the measurement box to

change to  (locked), indicating that the angle is locked.
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View Window settings are reconfigured in order to ensure that specifying a measurement of an object
does not make it too big to fit on the screen or too small to see.
Note that all other objects currently on the screen also are resized by the same amount as the object
whose measurement you are specifying.

•　Once you specify one measurement of an object, it is not resized further if you specify another of its
measurements.

Locking or Unlocking a Measurement of an Object
As described in “Specifying and Locking a Measurement of an Object” (page 170), a measurement is
automatically locked as soon as it is specified numerically. This section describes how to lock or unlock a
measurement without specifying a numeric value.

Note
•　Only some measurements of an object can be locked. For information about which measurements can

be locked, see the “Measurement Icon Table” (page 168).

To lock a particular measurement
Example 1: To lock the length or slope of a line segment

1.　Draw a line segment and select it.

2.　Press V to display the measurement box.

3.　Press l to highlight the up arrow button to the left of the measurement box and then press O.

4.　On the icon palette that appears, highlight the icon (  or ) of the measurement you want to lock and

then press O.

5.　Use r to highlight the  icon and press O.*
•　The icon changes to , indicating that the measurement is locked.

Length locked Slope locked
 
*　You can also perform the steps below in place of step 5.

(1)　 Highlight the up arrow button to the right of the  icon and press O.
(2)　 On the menu that appears, select [Lock] and then press O.

 
Example 2: To lock two sides of a triangle to equal lengths

1.　Draw a triangle, and then select its side AC and side BC.

2.　Press V to display the measurement box.

3.　Press l to highlight the up arrow button to the left of the measurement box and then press O.

4.　On the icon palette that appears, highlight the  icon and then press O.

•　This causes “No” to appear in the measurement box.

5.　Use r to highlight the  icon and press O.
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To unlock a particular measurement
You can unlock a particular measurement by performing any one of the following operations.
•　If the icon to the right of the measurement box is , use l and r to highlight the icon and press O. This

causes the icon to change to , indicating that the measurement is unlocked.
•　Use l and r to highlight the up arrow button to the right of the  icon and press O. On the menu that

appears, select [Unlock] and then press O.

To unlock all objects on the screen
Select T > [Option] > [Clear Constraint]. This unlocks all locked settings.

Note
•　The above operation unlocks both measurements you locked manually, as well as objects that are

locked automatically whenever they are drawn.
For example, the above operation unlocks the lock condition below:
-　The lock that is applied when you draw an isosceles triangle (ABC) that keeps side AB and side BC

equal (side AB and side BC congruence lock)

Pasting Measurements into a Screen Image
You can use the procedures below to paste object measurements into the image on the screen. The
measurements change dynamically as you manipulate the object.
Example: To paste an internal angle measurement into a screen image

2.　Press V to display the measurement box.

3.　Use r to highlight the up arrow button on the right side of the measurement box and then press O.

4.　On the menu that appears, select [Paste].
•　This causes the measurement in the measurement box to be pasted into the screen image. At this time,

the pasted measurement text is selected.

5.　Move the text to another location on the screen, if you want.
•　Press X and then use the cursor keys to move the pasted measurement around the screen. For details,

see “To move an object” (page 159).

Note
•　You can also paste the measurement that is currently in the measurement box into the screen image

by pressing s.(%) while the measurement box is highlighted in step 2 of the above procedure.

•　This causes the icon to change to , indicating that
the measurement is locked. Also, the measurement box
contents change to “Yes”.

1.　Draw a triangle and select two of its sides.
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•　The following types of measurements can be pasted into a screen image: coordinates, distance/
length, slope, radius, circumference, perimeter, area, angle, supplementary angle, equation, vector
components.

•　The pasted measurement is prefixed with a name (or symbol) depending on its type. In the example
above, ∠: is appended to indicate an angle. “Area:” is appended to indicate an area, and “Eq:” is
appended to indicate an equation or vector components. You can use the measurement box to edit
an appended name (or symbol). See “Changing a Label or Adding a Name to an Object” (page 173)
for information about editing operations.

Changing a Label or Adding a Name to an Object
You can change the label name of a point, vector, or pasted measurement, or add a name to each element as
explained in the following example.
Example: To change the label name of the center of a circle from “A” to “Center”

2.　Press V to display the measurement box.
•　If this causes the  icon to appear, advance to step 6 of this procedure.

3.　Press l to highlight the up arrow button to the left of the measurement box and then press O.

4.　On the icon palette that appears, highlight the  icon and then press O.

5.　Press r to highlight the measurement box and then press O.

Displaying the Result of a Calculation that Uses On-screen Measurement Values
You can use the procedure in this section to perform calculations using the angle value, line length, and other
measurement values attached to an object, and display the result on the screen.
 
Example 1: To input the expression that determines the sum of one angle of a triangle and its supplementary

angle and paste the result on the screen.

1.　Draw the circle, and then select its center point.

6.　On the label edit dialog box that appears, input “Center”.
•　You can input up to 14 characters for the label name.
•　To delete the label name, press a.

7.　Press O.
•　This displays the changed name on the screen as shown

here.

1.　Draw a triangle and paste the measurements of the ∠BAC angle and
supplementary angle on the screen.
•　For information about pasting measurements on the

screen, see “Pasting Measurements into a Screen Image”
(page 172).
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3.　Now you can use the labels to specify measurement values in the calculation you input in the measurement
box.
•　To input a measurement value in the measurement box, input the “@” symbol followed by the numeric label

of the value: @1, @2, etc. Since we want to calculate the sum of the angle (@1) and the supplementary
angle (@2) here, you would input the following: @1+@2.

•　You can input “@” by pressing C and then O.

5.　Press b twice to hide the measurement box.

Note
•　When a measurement is a coordinate or vector component, the label format becomes, “@1X”, “@1Y”,

etc. “@1X” indicates the x-value of a coordinate or the x-component value of a vector, while “@1Y”
indicates the y-value of a coordinate or the y-component value of a vector.

Example 2: To draw △ABC and then draw △A’B’C’ by doubling the length of each side of △ABC. Next, divide
the area of △A’B’C’ by the area of △ABC.

In this example, the Area Calc command is used, which allows input of the area of a filled figure into a formula.

2.　Select T > [Option] > [Expression].
•　This displays “EXPR=” at the pointer location and displays

the measurement box.
•　The above also displays labels (@n, where n is a serial

number) for each measurement currently on the screen.

4.　After inputting the calculation expression, press O.
•　The calculation result is displayed to the right of “EXPR=”.

6.　Try moving the vertex B to somewhere else on the screen.
•　This way you can confirm that the calculation results for the

entered expression are constant.
•　For information about moving a point, see “To move an

object” (page 159).

1.　Draw and select △ABC and then use T > [Transformations] >
[Dilation] to draw the double scale △A’B’C’.
•　For details about using the Dilation operation, see “Other

Transformation Operations” (page 167).

2.　Specify yellow as the fill color for △ABC and cyan as the fill color for
△A’B’C’.
•　For information about changing the fill color of figures, see

“To specify fill color and intensity of a closed figure (polygon,
circle, etc.)” (page 161)

174



3.　Select T > [Option] > [Area Calc].
•　This selects one of the filled triangles (in this case △ABC) and displays the message “[←][→]: Select

Figure” in the status bar.

5.　Press * and then u.
•　This causes the message “[←][→]: Select Figure” to reappear in the status bar.

8.　Press b to hide the measurement box.

Specifying the Number Format of a Measurement
You can specify the number format for each measurement on the screen.

Note
•　The initial default number format is “Fix2: 0.12”. For details about number format options, see “Display

(General)” (page 218).
•　Regardless of the current number format setting, integer values are always displayed with their decimal

parts cut off.

Example: After completing Example 1 under “Displaying the Result of a Calculation that Uses On-screen
Measurement Values” (page 173), change the display format of the two angle measurements to
Fix0: 0. (rounded to one decimal place)

4.　Use l and r to select △A’B’C’ and then press O.
•　This inputs “@1”, which represents the area of △A’B’C’, into

the measurement box.

6.　Use l and r to select △ABC and then press O.
•　This inputs “@2”, which represents the area of △ABC, into

the measurement box.

7.　Press O.
•　The measurement box contents change from “@1÷@2” to

“△A’B’C’÷△ABC”, and the calculation result appears in the
upper left corner of the screen.

1.　Select the measurements whose number format you want to change.
•　Here we select measurements for two angles (∠BAC and its

supplementary angle).

2.　Select T > [Option] > [Number Format] > [Fix0: 0.].
•　The selected measurements are displayed according to the

currently specified number format.
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Working with Animations
An animation consists of one or more point/curve pairs, in which the curve can be a line segment, circle,
semi-circle, arc, or function. You build an animation by selecting a point/curve pair and then adding it to an
animation.

Creating and Running an Animation

To add an animation and run it
Example 1: To draw a circle and its radius (line segment AC), and draw point D on the radius. Next, create an

animation that moves point C on the circumference and point D on line segment AC at the same
time.

1.　Draw a circle and its radius line segment AC (A: center, C: point on the circumference), and draw point D
on the radius.

3.　Select T > [Animate] > [Add Animation].
•　This adds an animation that moves point C on the circumference.

4.　Press a to deselect all figures and then select point D and line segment AC.

5.　Select T > [Animate] > [Add Animation].
•　This adds an animation that moves point D on line segment AC.

6.　To run the animation, select T > [Animate] > [Go(once)] or [Go(repeat)].
•　Point C moves on the circumference and point D moves on line AC at the same time.

7.　To stop the animation, press b or a.
 
Example 2: To graph the cubic function f (x) = 0.1x3 − 1.5x and draw tangents to the graph. Next, create an

animation to move the points of contact on the graph and observe the change in the tangent line.

1.　Graph f (x) = 0.1x3 − 1.5x and draw tangents to the graph.
•　To draw the graph, use T > [Draw Special] > [Function f(x)] (page 155).
•　To draw the tangent line, use T > [Construct] > [Tangent] (page 164).

3.　Select T > [Animate] > [Add Animation].

4.　To run the animation, select T > [Animate] > [Go(once)].
•　This causes point A (contact point) to move on the graph and the tangent line to move accordingly.

2.　Select point C and the circumference.

2.　Select point A (contact point) and the graph.
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Note
•　While a point and curve are selected, selecting T > [Animate] > [Replace Animation] discards the

current animations and sets up an animation for the new point and curve set.
•　The calculator’s auto power-off feature turns off power if an animation is being performed. If calculator

power is turned off (either by auto power off or manually) while an animation is being performed, the
animation is stopped.

To trace a locus of points
Example 1: To draw a parabola using Trace

1.　Use the steps below to draw the required line segments.

For information about how to use the measurement box to lock objects in steps (2) through (4) below, see
“Locking or Unlocking a Measurement of an Object” (page 171).

(2)　 i) Select point C. ii) Display the measurement box. iii) Select the  icon and lock the coordinates. iv)

Close the measurement box.
(3)　 i) Press a, and then select line segment AB and line segment DE. ii) Display the measurement box. iii)

Select the  icon and lock the angle between the two lines at 90 degrees. iv) Close the measurement

box.
(4)　 i) Press a, and then select line segment DE and line segment CD. ii) Display the measurement box. iii)

Select the  icon to lock the length of both segments to the same length. iv) Close the measurement

box.

2.　Press a, select point E and line segment AB, and then select T > [Animate] > [Add Animation].

3.　Press a, select point D, and then select T > [Animate] > [Trace].
•　This specifies point D as the “trace point”.

 
Example 2: To draw a sine curve using Trace

1.　Use the steps below to draw a figure.

(1)　 Draw three line segments AB, CD, DE as shown on the
example screen to the right.
•　When drawing line segment DE, locate point E on line

segment AB.

4.　Select T > [Animate] > [Go(once)].
•　This should cause a parabola to be traced on the display.

Note that line segment AB is the directrix and point C is the
focus of the parabola.

(1)　 Draw line segment AB, a circle, and point E as shown on the
example screen to the right.
•　Locate the center of the circle (point C) on line segment

AB.
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For information about how to use the measurement box to lock objects in steps (2) through (4) below, see
“Locking or Unlocking a Measurement of an Object” (page 171).
(2)　 Select the circumference of the circle, and then displays the measurement box.

(3)　 Select the  icon and lock the length of the radius.

(4)　 Close the measurement box.
For information about how to draw perpendicular lines and intersections in steps (5) through (7), see “Using
the Construct Menu” (page 164).

2.　Select point C and line segment AB, and then select T > [Animate] > [Add Animation].

3.　Press a, select point E and the circumference of the circle, and then select T > [Animate] > [Add
Animation].

4.　Press a, select point F, and then select T > [Animate] > [Trace].
•　This specifies point F as the “trace point”.

Note
•　All of the points that are currently selected on the screen become trace points when you select T >

[Animate] > [Trace].
•　Specifying a new trace point causes all currently specified trace points to be discarded.
•　Any traces drawn using Trace are cleared each time an animation is run.
•　Traces drawn using Trace can be selected and deleted, but they cannot be moved.

To edit an animation
The steps below continue from the procedure of Example 1 under “To trace a locus of points” (page 177).

2.　Edit the animation following the procedure below.
•　Times:

•　Draw point E on the circumference of the circle.

(5)　 Draw a line that is perpendicular to line segment AB and
passes through point C.

(6)　 Draw a line that is perpendicular to the line you drew in step
(3) and passes through point E.

(7)　 Draw two perpendicular lines that intersect at point F.
•　The screen to the right shows what the screen should look

like following steps (5) through (7) are complete.

5.　Select T > [Animate] > [Go(once)].
•　This should cause a sine curve to be traced on the display.

1.　While the animation you want to edit is on the screen, select T >
[Animate] > [Edit Animation].
•　This displays the Edit Animations screen.

178



This setting specifies how many times the animation should be executed when you select T > [Animate]
> [Go(repeat)]. The initial default value is 10, which can be changed to a value from 0 to 20. Inputting 0
here causes the animation to repeat until you press b or a to stop it.

•　Steps:
This setting specifies how many steps point E takes to move line segment AB. The initial default value is
20, which can be changed to a value from 2 to 100.

•　Animations:
The “E” under “Animations” indicates that point E is the point moved by the animation. When you are
building multiple animations, a list of all applicable points appears here. Selecting T > [Delete] while
a letter is highlighted deletes the applicable animation. Selecting T > [Delete] while “Animations” is
highlighted deletes all the animations.
“t0” and “t1” specify the range of movement of point E on line segment AB. The initial default values are t0
= 0 and t1 = 1. During animation, the length of AB is considered to be one unit. The default values specify
that movement of point E is from start point A (point where length equals 0) up to end point B (point where
length equals 1). You can input a number from -10 to 10 for t0 and t1.
Changing the value of t0 to 0.5 causes point E to move from the middle of line segment AB to point B.
Changing the value of t0 to -1 causes point E to begin at a point outside line segment AB (in this case, the
distance from point A to point E equals the length of line AB) and end with point B. Changing the values
to t0 = 1, t1 = 0 causes point E to move from point B to point A.

•　Traces:
This item shows the specified trace point. Selecting T > [Delete] while a letter is highlighted cancels the
applicable trace point setting. Selecting T > [Delete] while “Traces” is highlighted cancels all the trace
point settings.

3.　After all the settings are the way you want, press b.

Generating an Animation Table
Under default settings, an animation causes a specified point to move along a specified line segment, circle,
arc, or function in 20 steps. You can configure the calculator to generate a table, called an “animation table”,
which records the coordinates of each step, the length of the line segment, the area of the object, etc.
Any of the following data can be added to the animation table: coordinates (x, y), distance/length, slope, radius,
circumference, perimeter, area, angle, supplementary angle, vector segments (x, y), and expression.
You can also select a single column of the animation table and save it as a list, or save the entire animation table
as spreadsheet data. The saved data can then be used for analysis with the Statistics app or the Spreadsheet
app.

To add columns to the animation table
The steps below continue from the procedure of Example 2 under “To trace a locus of points” (page 177).
First, the coordinates of point F are added to the animation table. Then the angles of line segments EC and
AB connecting point E and point C are added to the animation table.

1.　Here we will generate an animation table for the coordinates (x, y) of point F, so first select point F.

3.　Use r to highlight the up arrow button on the right side of the measurement box and then press O.

4.　On the menu that appears, select [Add Table] and then press O.

2.　Press V to display the measurement box.*1

•　If the  (coordinates) icon does not appear on the left

edge of the screen, highlight the up arrow to the left of the
measurement box and then press O. On the icon palette
that appears, select the  icon.
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5.　Press b to close the animation table screen.

6.　Press b twice to make the drawing screen active.

7.　Press a, and then draw a line segment that connects point E and point C (line segment CE).

10.　To exit the animation table screen, press b.
*1　Instead of using the measurement box, you can also add an animation table by selecting T > [Animate]

> [Add Table]. However, this operation does not allow you to specify the type of measurement to be added
to the table. The first measurement that appears when the measurement box is displayed is added.

*2　When angle and supplementary angle are added to the animation table, the angle unit follows the setting
of S > [Angle] that is in effect at the time of addition. Changing the S > [Angle] setting does not affect
the values in the animation table that are already added.

Note
•　You can add up to 26 columns to an animation table.
•　Animation table contents are cleared whenever one of the operations below is performed.

-　Using the Edit Animations screen to change an animation
-　Adding or replacing an animation
-　Specifying a new trace point
-　Deleting a geometric element (line segment, point, etc.) used in an animation
-　Launching an application other than the Geometry app

To display the animation table
To display the animation table you generated with the procedure under “To add columns to the animation table”
(page 179), select T > [Animate] > [Display Table].

To save an animation table column to a list
1.　Display the animation table.

2.　Use l and r to highlight the column you want to save as list data.

3.　Select T > [Store] > [List].

4.　Use the dialog that appears to input a list number and then press O.

•　This displays an animation table that shows the coordinates
of point F at each step of the animation in columns labeled
“X” and “Y”.

8.　Select line segments CE and AB, and then press V.*1

•　If the  (angle) icon does not appear on the left edge of the

screen, highlight the up arrow to the left of the measurement
box and then press O. On the icon palette that appears,
select the  icon.

9.　Perform steps 3 through 4 above.
•　An “Angle” column is added to the right of the “X” and “Y”

columns that were added in step 4, above.*2
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Note
•　The lists saved during the above operation can be viewed

using the Statistics app’s List Editor. For example, following
step 9 of the procedure under “To add columns to the
animation table” (page 179), you can save each column of
the animation table to a list from List 1 to List 3, and then
launch the Statistics app to view a list as shown on the
example screen to the right.

To save an entire animation table as a spreadsheet file
1.　Display the animation table.

2.　Select T > [Store] > [Spreadsheet].

3.　Use the dialog that appears to input up to eight characters for the file name and then press O.

Note
•　The spreadsheet file saved by the above operation opens

automatically the next time you start up the Spreadsheet
app. For example, if you save the animation table to a
spreadsheet file following step 9 of “To add columns to the
animation table” (page 179), starting up the Spreadsheet
app displays the table as shown on the example screen to
the right.

To delete a particular column from an animation table
1.　Display the animation table.

2.　Use l and r to highlight the column you want to delete.

3.　Select T > [Delete] > [Delete].

To delete all of the columns from an animation table
1.　Display the animation table.

2.　Select T > [Delete] > [Delete All].

3.　In response to the confirmation dialog that appears, select [OK].

Using Key Help
Pressing the 0 key or selecting T > [Key Help] displays the Key Help window, which provides information
about the function assigned to each key in the Geometry app. Note that the key operations shown on the Key
Help window apply to the drawing screen only.

Geometry App Settings Menu Items
The Settings menu items (page 214) described below are specific to the Geometry app.

S > [Angle Unit] … Specifies whether to include units when displaying angles for a figure on the
drawing screen.

S > [Length Unit] … Specifies whether to include units when displaying lengths for a figure on the
drawing screen.

S > [Grid Space] … Specifies the pitch (spacing) of the grid points and lines on the drawing screen.
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Database App
The Database app contains element and physical constant data. You can browse the stored data, edit values,
and use the values in other applications.*
*　Values of atomic weights and physical constants can be saved to alpha variables. You can also batch-save

element data as Spreadsheet app data.

Note
•　Elements and physical constant notations and values are subject to change. Refer to the beginning

of each section of this chapter (“Periodic Table” (page 182) and “Fundamental Physical Constants”
(page 185)) for the original data to which this calculator conforms.

•　The Database app has a function for editing and saving recorded atomic weight and physical constant
values. The values you edit and save are retained even if you update the Database app to a newer
version. To overwrite saved values with the values of the updated version, use the operations under
“Initializing All Atomic Weight Values” (page 183) and “To initialize all physical constant values”
(page 187) to restore the atomic weight and physical constant values to their initial default values.

Periodic Table
You can select an element from the periodic table of elements and display information about it. You can also
search for elements by name or atomic weight.

Note
•　The atomic weights displayed by the Database app are in accordance with the IUPAC (International

Union of Pure and Applied Chemistry), 2021.
•　The electron configuration displayed by the Database app complies with the CRC Handbook of

Chemistry and Physics, 91st Edition.

Selecting an Element from the Periodic Table to Display Its Information
Example: On the periodic table, select gold (element symbol: Au), atomic number 79 to display its detailed

information.

1.　h > Database

2.　Highlight [Periodic Table] and then press O or r.
•　This displays the periodic table. In this case, the cursor

(①) appears at hydrogen (element symbol: H) with atomic
number 1. The symbol, atomic number, and atomic weight
of the element at the cursor location are also displayed at
location ②.

3.　Use the cursor keys to move the cursor to atomic number 79.
•　Instead of using the cursor keys to move the cursor, you can

also search for an element by its name or atomic number.
The following is an example of how to search by atomic
number.
(1)　 Select T > [Search] > [Atomic No.].
(2)　 Use the dialog box that appears to input 79, and then press

O.

4.　To display detailed information about the element where the cursor
is located, press O.
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*　Atomic weights of elements that do not have stable isotopes are enclosed within square brackets ([ ]).
For example, a number like [209] shows the mass number of the longest-lived isotope of that element.
However, since thorium (Th), protactinium (Pa), and uranium (U) do have a characteristic terrestrial
isotopic composition, their atomic weights are not enclosed in square brackets. The names of elements
whose atomic weights are enclosed in square brackets have an asterisk (*) next to them.

5.　To return to the periodic table, press b or O.

Highlighting Elements of a Specific Classification on the Periodic Table
You can use the operations below to highlight the elements of a specific classification.

To highlight the elements of this classification: Select this menu item:
Transition Elements T > [Series] > [Transition]
Alkali Metals T > [Series] > [Alkali Metals]
Alkali Earth Metals T > [Series] > [Alkaline Earth Metal]
Halogens T > [Series] > [Halogens]
Noble Gases T > [Series] > [Noble Gases]
Rare Earth Elements T > [Series] > [Rare Earth]

To unhighlight a classification, select T > [Clear].

Note
•　The classification of elements is not definitive. Classifications displayed by the Database app are those

that are commonly accepted at the time this app was developed.

Saving Periodic Table Information as a Spreadsheet File
You can use the operation below to save periodic table information as a spreadsheet file.

1.　Select T > [Store].

2.　Use the dialog that appears to input up to eight characters for the file name and then press O.
•　The spreadsheet file contains the information below in columns A through D, in that order.

Atomic number (numeric), element symbol (text), electron sequence (text), atomic weight (numeric)*

*　If the atomic weight value has been changed, the new value is saved. For information about changing the
atomic weight value, see “To edit an atomic weight value” (page 184).

Initializing All Atomic Weight Values
You can use the operation below to restore all atomic weight values that have been edited using the operation
under “To edit an atomic weight value” (page 184) to their initial Database app values.

1.　Select T > [Initialize Weight].

2.　In response to the confirmation dialog that appears, select [OK].

Searching for an Element
You can use the methods shown in the table below to search for an element. If the element you are searching
for is found, the cursor jumps to the element.

•　This displays detailed information about the element. The
following is the detailed information that appears.
①　 Atomic number, element symbol, element name, properties
②　 Electron configuration
③　 Image of the element and explanation of the image

④　 Atomic weight*

183



To search by this: Perform this operation:
Element Name 1.　Select T > [Search] > [Name].

2.　Select the desired element name from the alphabetical list*1 and then press
O.

Element symbol 1.　Select T > [Search] > [Symbol].
2.　Select an element symbol from the alphabetical list*1 and then press O.

Atomic number 1.　Select T > [Search] > [Atomic No.].
2.　Use the dialog that appears to input an atomic number and then press O.

Atomic weight 1.　Select T > [Search] > [Weight].
2.　Use the dialog that appears to input an atomic weight up to 12 digits long

(including decimal point) and then press O.*2

*1　While the alphabetical list is displayed, you can press a key from XA to 0Z to jump to the top of the list
for the letter whose key you pressed.

*2　This searches for the element with the smallest atomic weight that is greater than or equal to the input value.

Enlarging the Periodic Table
Pressing + or < while viewing the periodic table zooms in on the area in the vicinity of the current cursor
position. Pressing -, >, or b returns to the full table display. Note that the T key operation is disabled
while the periodic table is zoomed.

Using the Detailed Information Screen
Pressing O while the periodic table is displayed switches to the detailed information screen for the element
where the cursor is currently located. For details about the display contents of the detailed information screen,
see “Selecting an Element from the Periodic Table to Display Its Information” (page 182). This section describes
the operations you can perform while the detailed information screen is displayed.

To edit an atomic weight value
1.　Display the detailed information screen for the element whose atomic weight value you want to edit.

2.　Select T > [Edit] or press r.*
•　This causes the cursor to appear to the left of the current atomic weight value.

3.　Use l and r to move the cursor to the digit you want to edit and then edit it as required.
•　You can input only numbers and the decimal point for an atomic weight, which can be up to 12 digits long.
•　To cancel the editing operation, press b here.

4.　To save an edited value, press O.
*　Instead of performing this operation, you can also press a number key to start editing.

To show/hide atomic weight value square brackets
1.　Display the detailed information screen for the element whose square brackets you want to show or hide.

2.　Select T > [1 ⇔ [1]].
•　Each time you perform this operation, the square brackets ([ ]) around the atomic weight value are toggled

between show and hide.
•　For information about the meaning of square brackets around an atomic weight, see the step 4 note under

“Selecting an Element from the Periodic Table to Display Its Information” (page 182).

To restore edited atomic weight values to their initial default Database app values
Select T > [Initialize].
This returns the atomic weight value and the show/hide square brackets setting to their Database app initial
default settings.

To store an atomic weight value to an alpha variable
1.　Display the detailed information screen for the element whose atomic weight value you want to store.
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2.　Select T > [Store].

3.　Use the dialog that appears to input one letter from A to Z and then press O.
•　This stores the atomic weight value to the alpha variable of the letter you input.
•　For details about alpha variables, see “Using Alpha Variables” (page 18).

Fundamental Physical Constants
The Database app maintains the values of the physical constants shown in the table below and displays them
in a list grouped by category. You can edit the physical constant values and store them to an alpha variable for
use in other applications.

Note
•　The values and names of the physical constants included in the Database app are based on 2022

CODATA.

Categorized List of Physical Constants
Category Symbol Name

Universal

c speed of light in vacuum 

μ0 vacuum magnetic permeability 4παħ/(e2c)

ε0 vacuum electric permittivity 1/μ0c2

Z0 characteristic impedance of vacuum μ0/ε0 = μ0c

G Newtonian constant of gravitation
h Planck constant
ħ reduced Planck constant 
mP Planck mass (ħc/G)1/2

lP Planck length ħ/mPc = (ħG/c3)1/2

tP Planck time lP/c = (ħG/c5)1/2

Electromagnetic

e elementary charge
Ф0 magnetic flux quantum 2πħ/2e

G0 conductance quantum 2e2/2πħ
KJ Josephson constant 2e/h

RK von Klitzing constant μ0c/2α = 2πħ/e2

μB Bohr magneton eħ/2me

μN nuclear magneton eħ/2mp

Atomic & Nuclear

α fine-structure constant e2/4πε0ħc

R∞ Rydberg constant

a0 Bohr radius ħ/αmec = 4πε0ħ
2/mee2

me electron mass

μe electron magnetic moment 

mμ muon mass

μμ muon magnetic moment

tau mass

mp proton mass

μp proton magnetic moment

mn neutron mass
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μn neutron magnetic moment

Physico-Chemical

NA Avogadro constant

mu atomic mass constant m(12C)=2hc/R∞α2c2Ar(e)

F Faraday constant NAe

R molar gas constant R=NAk

k Boltzmann constant
Vm molar volume of ideal gas RT/p (273.15K, p=100kPa)

σ Stefan-Boltzmann constant (π2/60)k4/ħ3c2

Adopted Values

KJ−90 conventional value of Josephson constant 

RK−90 conventional value of von Klitzing constant 

gn standard acceleration of gravity 

Displaying a Physical Constant and Its Information

•　See “Categorized List of Physical Constants” (page 185) for information about the physical constants
included in which category.

•　See “Using a Physical Constant in a Calculation” (page 187) for information about operations that use
physical constant values for calculations.

5.　To return to the category list, press b.

Editing a Physical Constant Value

To edit a physical constant value
1.　Perform the first three steps of the procedure under “Displaying a Physical Constant and Its Information”

(page 186) to highlight the physical constant whose value you want to edit.

2.　Select T > [Edit] or press r.*
•　This displays the input cursor to the left of the value of the physical constant.

3.　Use l and r to move the cursor to the digit you want to edit and then edit it as required.
•　Only up to 15 significant digits are stored, even if you input more than 15 digits.
•　An error (Syntax ERROR) occurs if you attempt to edit a constant using incorrect input.

1.　h > Database

2.　Highlight [Fundamental Physical Constants] and then press O or
r.
•　This displays a list of Physical Constants categories.

3.　Highlight the physical constant category whose values you want to
display and then press O or r. For example, to display the value
of Bohr magneton (μB), highlight [Electromagnetic] and then press
O or r.
•　This displays a list of Electromagnetic category physical

constants and their values.

4.　To display information about Bohr magneton, highlight the [μB] row
and then press O or select T > [Description].
•　This displays a dialog with the applicable information (name,

symbol, units). To close the dialog, press O or b.
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•　An error (Math ERROR) occurs if you input a mathematically incorrect expression while editing a constant.
•　To cancel the editing operation, press b here.

4.　To save an edited value, press O.
*　Instead of performing this operation, you can also press a number key to start editing.

To initialize a single physical constant value
1.　Perform the first three steps of the procedure under “Displaying a Physical Constant and Its Information”

(page 186) to highlight the physical constant whose value you want to initialize.

2.　Select T > [Initialize] > [Selected Constant].

To initialize all physical constant values

1.　While the physical constant list screen is displayed, select T > [Initialize] > [All].

2.　In response to the confirmation dialog that appears, select [OK].

Using a Physical Constant in a Calculation
The physical constant values can be stored to alpha variables for use in calculations by Calculate and other
apps.
Example: To calculate the time required for light to reach the Earth from the Sun. This calculation uses the

average distance from the Sun to the Earth (1 au = 149,597,870,700 m) and the speed of light in
vacuum (c = 299792458 m/s), which is the calculator’s default value.

1.　In the Physical Constants category list, select [Universal] and then press O.

3.　Input one letter from A to Z and then press O.
•　Here, press jCO, which stores the value to alpha variable C.

4.　Select h > Calculate to start up the Calculate app.

149597870700*Pj(C)E

•　The calculation result shows it takes approximately 499 seconds for light to reach the Earth from the Sun.
•　For details about alpha variables, see “Using Alpha Variables” (page 18).

Using My Drawer
You can use My Drawer to store often-used physical constants.

To save a physical constant to My Drawer
1.　Perform the first three steps of the procedure under “Displaying a Physical Constant and Its Information”

(page 186) to highlight the physical constant you want to store in My Drawer.

2.　Select T > [Store in My Drawer].

2.　Highlight [c] (speed of light in vacuum) and then select T > [Store
Const. as Variable].
•　This displays a dialog for specifying the alpha variable

storage destination.

5.　Execute the calculation.
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To display physical constants saved to My Drawer
In the Physical Constants category list, select [My Drawer].

To delete a single physical constant that was saved to My Drawer
1.　In the Physical Constants category list, select [My Drawer].

2.　Highlight the physical constant you want to delete from My Drawer.

3.　Select T > [Delete] > [Selected Constant].

To delete all physical constants saved to My Drawer
1.　In the Physical Constants category list, select [My Drawer].

2.　Select T > [Delete] > [All].

3.　In response to the confirmation dialog that appears, select [OK].
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Prob Sim App
The Prob Sim app performs the six types of simulations described below.
•　Coin Toss
•　Dice Roll
•　Spinner

•　Marble Grab
•　Card Draw
•　Random Numbers (Random Integers)

Operation Flow
Step 1: Select a simulation type (Probability tab).

2.　Highlight the type of simulation you want to run and then press > (or O).
•　This displays the Setup tab, which shows the settings for the type of simulation you chose.

Step 2: Specify the number of simulation trials and configure other settings (Setup tab).
3.　Specify the number of simulation trials.

(2)　 In the dialog box that appears, input an integer between 1 and 999 and then press O.

4.　Configure other settings.

Setting Items Specific to Particular Simulation Types
Type Item Description Setting*1

Coin Toss Coins Specifies the number of coins. 1, 2, 3
Dice Roll Dice Specifies the number of dice. 1, 2, 3

Die Sides Specifies the number of faces for each die. 4, 6, 8, 12, 20
Spinner Sections Specifies the number of divisions on the

spinner.
2, 3, 4 to 8

Marble Grab Marble Types Specifies the types of marbles. Selecting 2 for
this setting will specify A, B for the marble
types, while selecting 5 will specify A, B, C, D,
E.

2, 3, 4, 5

Replacement Specifies whether a drawn marble is replaced
(On) or not (Off) after being drawn. “ ” is
displayed in the upper left corner of the result
screen when On is selected for replacement.

On, Off

Card Draw Decks Specifies the number of card decks. 1, 2, 3
Deck Size Specifies the number of cards in a deck. 32, 52
Replacement Specifies whether a drawn card is replaced

(On) or not (Off) after being drawn. “ ” is
displayed in the upper left corner of the result
screen when On is selected for replacement.

On, Off

1.　h > Prob Sim
•　This displays a menu for selecting a simulation type.

(1)　 Highlight [# of Trials] and then press O.
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Random
Numbers

# of RanNums Specifies the number of random numbers to be
generated.

1 to 6

Range Start Specifies the lower limit of the random number
generation range.

0, 1 to 98

Range End Specifies the upper limit of the random number
generation range.

1 to 40 to 99

Repeat*2 Specifies whether the same value can be
repeatedly generated (On) or not (Off). “ ”
is displayed in the upper left corner of the result
screen when On is selected for repeat.

On, Off

Setting Items Common to All Simulation Types
Item Description Setting*1

Refresh Freq Specifies how often (in terms of the number of
results) the result screen should be refreshed.
Specifying “After Last Trial” here causes the
screen to be refreshed after the last trial.

After 1 Trial, After
20 Trials, After 50
Trials, After Last
Trial

Random Seed Specifies a seed value to use for generation of
pseudo-random numbers.

1 to 99999

*1　Underlined settings indicate initial defaults.
*2　When Off is specified for the Repeat setting, the random number range must be set to a value that is

greater than the number of random numbers to be generated.

Note
•　To restore all Setup tab setting items to their initial default settings, select T > [Initialize].
•　For Coin Toss, Dice Roll, Spinner, and Marble Grab, you can specify an occurrence rate bias (for

example, probability that Coin Toss will produce heads or tails). See “Specifying an Occurrence Rate
Bias (Bias)” (page 191) for details.

Step 3: Run the simulation and display its results (Result tab).

5.　On the Setup tab, press >, or highlight  and then press O.
•　The results of the simulation are displayed on the Result tab. See “Using the Result Tab” (page 192) for

information about the results displayed for each simulation type.

Example simulation result display:

Dice Roll Random Numbers
•　The leftmost column of the table shows the number of trials.
•　You can use u and d to scroll a table up and down. You can use l and r to scroll a graph left and

right.
•　The table below shows operations you can perform on the Result tab.

To do this: Perform this operation:
Re-run a simulation for the same number of trials as
the original

Press O.

Re-run the simulation for a specified number of trials On the dialog box that appears when you press a
number key or select T > [Increase trials (n)], input
the desired number of trials and then press O.
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Select Table, Graph, or Graph + Table as result
display format*1

Select T > [Results Display].

Store the simulation results to a list variable Select T > [Store].*2

Delete the current simulation results and return to
the Setup tab

Select T > [Delete].

Display a crosshair pointer ( ) and read the bar
chart values (frequency and probability)*3

Select T > [Trace].

*1　This operation can be performed for Coin Toss, Dice Roll, Spinner, and Marble Grab.
*2　See “To store simulation results to a list variable” (page 192) for details.
*3　This operation can be performed while T > [Results Display] > [Graph] is selected. For more

information, see “To read bar chart frequency and probability values” (page 193).

6.　To return to the Setup tab, press < (or b).
•　In response to a dialog box that appears asking if you want to delete the current simulation results, select

[OK].

Specifying an Occurrence Rate Bias (Bias)
In real life, one side of a coin tends to appear more often than the other side, and one number of a die tends
to appear more often than the others. This is due to the physical shape of the coin or die, or an offset of its
center of gravity. Also, the number of Marble Grab marbles may differ depending on the marble type. This kind
of occurrence rate bias can be specified for each simulation type. Occurrence rate bias can be specified for
Coin Toss, Dice Roll, Spinner, and Marble Grab.

To specify Bias for Coin Toss, Dice Roll, or Spinner
1.　Display the Setup tab for Coin Toss, Dice Roll, or Spinner.

3.　Change the Weight or Prob value for each outcome.

Weight: Specify a value between 0 and 999 (initial default: 1). Changing the Weight of one
outcome causes the Prob values of all outcomes to be recalculated accordingly.

Prob: Specify a value with up to four decimal places. Changing the Prob of one outcome
causes the Prob and Weight values of all outcomes to be recalculated accordingly.

•　To initialize all Weight and Prob values, select T > [Initialize].

4.　After everything is the way you want, press b to close the editing screen.

To specify Bias for Marble Grab
1.　Display the Setup tab for Marble Grab.

3.　For each marble type, specify the number of marbles between 0 and 999 (initial default: 10).
•　To initialize this setting, select T > [Initialize].

4.　After everything is the way you want, press b to close the editing screen.

2.　Select T > [Bias].
•　This displays a screen for changing the weight (Weight) and

probability (Prob) of a particular outcome.

2.　Select T > [Bias].
•　This displays a screen for editing the number of each type of

marble.
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Using the Result Tab
The table below shows the Result tab contents for each simulation type.

Type Table Graph
Coin Toss 1 coin Cumulative number of heads over

multiple tosses
Head/tail frequencies over multiple
tosses

2 coins/3 coins Number of heads for a single toss Cumulative frequencies of number of
heads over multiple tosses

Dice Roll 1 die Number produced by a single roll Frequencies of each number over
multiple rolls

2 dice/3 dice Total of numbers produced by a
single roll

Frequencies of roll totals over
multiple rolls

Spinner Spinner number by a single spin Frequencies of each number over
multiple spins

Marble Grab Types of marbles for a single grab Frequencies of each type of marble
over multiple grabs

Card Draw Rank and suit of drawn card -
Random Numbers Generated random integer -

To store simulation results to a list variable
Example 1: To store the results of a simulation of 20 tosses of 3 coins to a list variable

1.　Display the Setup tab for Coin Toss.

2.　Highlight [# of Trials], input “20” and then press O.

3.　Highlight [Coins] and then press O.

4.　On the menu that appears, select [3] and then press O.

5.　Press >.
•　The results of the simulation are displayed on the Result tab.

7.　If necessary, change the list variable number to specify the destination where each row of data should be
stored.
(1)　 Highlight the line you wish to change and then press O.
(2)　 Use the dialog box that appears to input a list number and then press O.

•　Inputting a list number that is already specified in another line causes the message “Data is in use” to
appear. Press O to close the message and then specify a different list number.

8.　Highlight  and then press O.
•　This stores the simulation results to the specified list variable.

Note
•　You can check what has been stored by starting up the Statistics app and displaying the List Editor.

6.　Select T > [Store].
•　This displays a screen for specifying the store destination list

variable.

192



•　For Card Draw results, the Value (rank) and Suit results are
stored in separate lists. Also, the A, J, Q, and K ranks and
the heart, club, spade, and diamond suits are stored as the
values shown below.

A = 1, J = 11, Q = 12, K = 13
 = 1,  = 2,  = 3,  = 4

To read bar chart frequency and probability values
Example 2: To display a full-screen bar graph of the simulation results of Example 1 and display the frequency

and probability values for each bar

1.　Perform steps 1 through 5 of Example 1.

2.　Select T > [Results Display] > [Graph].
•　This displays a full-screen bar chart.

4.　To clear the pointer from the bar chart, press b.

Prob Sim App Settings Menu Items
The Settings menu items (page 214) described below are specific to the Prob Sim app.

S > [Maximum Scale] … Specifies whether the maximum value of the vertical axis on the Result tab is
shown or hidden on the graph.

S > [Animation] … Specifies whether an animation should be displayed before results when a
simulation is performed.

3.　Select T > [Trace].
•　This causes a crosshair pointer ( ) to appear at the left-

most bar, along with the frequency (Freq) and probability
(Prob) values at the top of the screen.

•　You can use l and r to move the pointer to the left and
right.
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Memory App
Your calculator has two data storage areas named Main Memory and Storage Memory. You can use the
Memory app to manage these two memory areas.
 
Main Memory: This area is used for storage of input data, variables, and configuration data for

apps such as Statistics and Graph&Table.
Storage Memory: This area is used to store relatively large-volume data such as image files and py

files. This area can also be used to create backup files of Main Memory data.
 
When you select h > Memory to start up the Memory app, the Main Memory tab contents appear first. You
can use < and > to navigate between the Main Memory tab and the Storage Memory tab.

Using the Main Memory Tab

Data Displayed on the Main Memory Tab
The Main Memory tab shows calculator data using the names shown below.

Data Name Contents
 ALPHA MEM Alpha variables

 CONICS Conic Graphs app data

 DIST Distribution app data

 DYNA MEM Dyna Graph app data

 EQUATION Equation app data

 FINANCE Financial app data

 LISTFILE List variable group

 LIST n List variables (n = 1 to 26 and ANS)

 LISTFILE n List files (n = 1 to 6)

 MAT_VCT Matrix and vector variable group

 MAT n Matrix variables (n = A to Z and ANS)

 VCT n Vector variables (n = A to Z and ANS)

 NUMINEQ (fx-CG100 only) Num Ineq app data

 RECURSION Recursion app data

 SETUP Settings data and other setup data

 STAT Statistics app data

 SYSTEM Operating system and shared app data (clipboard, calculation history, etc.)

 S-SHEET Spreadsheet app group

 _SETTING Spreadsheet app setting data

 SHEET Spreadsheet app data (“SHEET” is the initial default spreadsheet file name.)

 Each spreadsheet name Spreadsheet app data

 TABLE Graph&Table app table data

 Y=DATA Function variables
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 3DGRAPH 3D Graph app group

 3DGRAPH 3D Graph app data

 DBASE Database app group

 Periodic Database app periodic table data

 Adopted, Atomic, Electoro,
Physico, Univers, User

Database app fundamental physical constants data

 GEOM Geometry app group

 @IMAGE Geometry app current data

 Each geometry file name Geometry app data

 PROBSIM Prob Sim app group

 PROBSIM Prob Sim app data

Main Memory Tab Operations

To create a backup file of all data
Use the procedure below to store a backup file of all Main Memory data in Storage Memory. The name of the
file is always “BACKUP.g4m” and cannot be changed. If you want to create a save destination folder, go to the
Storage Memory tab and create the folder in advance.

1.　Select T > [Backup] > [Save Backup Data].
•　This displays a dialog you can use to select a folder to save the data.

2.　Use the operation below to select the save destination folder.

To select this folder: Perform this operation:
Root directory Highlight ROOT and then press O.
Other folders (1)　 Highlight the folder you want to select and then press O. This will

take you into the selected folder.
(2)　 Highlight the folder’s name and then press O again.

To restore all data from a backup file
You can use the procedure below to restore all data in Main Memory from a backup file stored in Storage
Memory.

1.　Select T > [Backup] > [Load Backup Data].
•　This displays a dialog for selecting the folder where the backup file is stored.

2.　Use the operation below to select the folder where the backup file is stored.

To select this folder: Perform this operation:
Root directory Highlight ROOT and then press O.*

Other folders (1)　 Highlight the folder you want to select and then press O. This will
take you into the selected folder.

(2)　 Highlight the folder’s name and then press O again.*

•　This displays a confirmation message asking if you want to overwrite existing data.

3.　Select [OK] to overwrite all existing data in Main Memory with the contents of the backup file, or [Cancel] to
cancel the operation.

*　If the selected folder does not contain a backup file, the message “No Data” will appear.

To save specific data or groups as a single file in Storage Memory
1.　Highlight the data or group you wish to save to a file.

2.　Select T > [Save As].
•　This displays a dialog you can use to select a folder to save the data.
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3.　Use the operation below to select the save destination folder.

To select this folder: Perform this operation:
Root directory Highlight ROOT and then press O.
Other folders (1)　 Highlight the folder you want to select and then press O. This will

take you into the selected folder.
(2)　 Highlight the folder’s name and then press O again.

4.　Use the dialog that appears to input up to eight characters for the file name and then press O.
•　The file name extension of the saved file is .g4m.
•　Saved files can be loaded into Main Memory using the operations on the Storage Memory tab. See “To

load a g4m file into Main Memory” (page 197).

To delete specific data or groups
1.　Highlight the data or group you want to delete.

2.　Select T > [Delete].
•　This causes a delete confirmation message to appear.

3.　To delete, select [OK]. To cancel the operation, select [Cancel].

Using the Storage Memory Tab

Files Displayed on the Storage Memory Tab
Files created with the calculator and files transferred from a computer to the calculator are displayed on the
Storage Memory tab.

File Extension Description
 .g4m File that contains Main Memory data.

 .g4p*1 File that contains a screen image captured with the calculator.*2

 .bmp Bitmap format image file.

 .g3p*1 File that contains a screen image captured with an earlier Color Graph
scientific calculator.

 .py Python script file (py file)
 .csv CSV files

 Other file name extensions These files are not supported by this calculator, but you can use this
calculator to delete them.

*1　Files of these formats can be used as background images (page 219) of graph windows.
*2　The Geometry app data with background image is also saved as a g4p file. For more information, see

“Displaying a Geometry App Screen Background Image” (page 162).

Note
•　Folders are indicated by the icon  on the Storage Memory tab.
•　If the name of a file transferred to Storage Memory from your computer has a file name that is more

than eight characters long, its name will be abbreviated to eight characters when displayed on the
Storage Memory tab (Example: AAAABBBBCC.py > AAAABB~1.py). Also, if a file name extension
has more than three characters, everything after the third character of the file name extension will be
trimmed off.

•　Up to 200 files per folder can be displayed on the Storage Memory tab. If a folder has more than 200
files and you need to display them all, divide them among multiple folders so the total number of files
in a single folder is not greater than 200.

•　Though you can create folders on your computer nested to more than three levels in Storage Memory,
this calculator will display only up to the third level.
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•　The following are single-byte characters that can be used in file names and folder names.
A-Z, a-z, 0-9, !, #, $, %, ,(comma), (, ), +, –, ., ;, =, @, [, ], ^, _, `, space
Note that file names and extensions are not case-sensitive.

Storage Memory Tab Operations

To load a g4m file into Main Memory
You can use the operation below to load g4m files* into Main Memory.
*　Backup files created with Main Memory tab operations or individually saved files with Main Memory tab

operations.

Important!
•　If duplicates of the data items below are found in step 2 of the procedure below, a confirmation message

will appear asking if you want to overwrite the existing data.
DYNA MEM, LIST n, LISTFILE n, MAT n, VCT n, Spreadsheet app data, data in the DBASE group,
data in the GEOM group

The data items below are always overwritten without displaying a confirmation message.
ALPHA MEM, CONICS, DIST, EQUATION, FINANCE, NUMINEQ (fx-CG100 only), RECURSION,
SETUP, STAT, SYSTEM, S-SHEET (_SETTING), TABLE, Y=DATA, 3DGRAPH, PROBSIM

For details about data contents, see “Data Displayed on the Main Memory Tab” (page 194).

1.　Highlight the g4m file you want to load into Main Memory.

Note
•　In the cases described below, the load operation does not start when you select T > [Load] in step

2.
-　When battery power is low (Low Battery error)
-　When there is not enough free space in Main Memory (Memory Full error)
-　When there are too many data items in Main Memory (Too Much Data error)
-　When a file that is not a g4m file is selected (Invalid Type error)

To create a folder
1.　Display the location (in the root directory or folder) where you want to create a folder.

•　You can nest folders up to three levels.

2.　Select T > [Folder] > [Make Folder].

3.　Use the dialog that appears to input up to eight characters for the folder name and then press O.

To rename a folder
1.　Highlight the folder you want to rename.

2.　Select T > [Folder] > [Rename Folder].

3.　Use the dialog that appears to input up to eight characters for the folder name and then press O.

2.　Select T > [Load].
•　This starts the load operation. During loading, a confirmation

message like the one on the right may appear. For more
information, see “Important!” above. To overwrite, select
[OK]. To cancel the operation, select [Cancel].

•　The message Complete! appears on the display when the
load operation is complete.
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To view detailed information about a file
1.　Highlight the file whose details you want to view.

2.　Select T > [Detail].
•　This displays the detailed information screen.
•　With a g4p or g3p file, you can preview images by pressing r.
•　Pressing u or d while a detailed information screen (or image preview screen) is displayed will scroll

either up or down to the detailed information screen (or image preview screen) of the next file in the
sequence that the files are listed on the Storage Memory tab.

To delete a file or folder
1.　Highlight the file or folder you want to delete.

2.　Select T > [Delete].
•　This causes a delete confirmation message to appear.

3.　To delete, select [OK]. To cancel the operation, select [Cancel].
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System App
Use the System app to reset the calculator or to change settings that affect the overall calculator operation.

System Manager Menu

System Manager Menu Items

Resetting the Calculator (Reset)
1.　From the System Manager menu, select [Reset].

2.　Select the menu item for the type of reset operation you want to perform.

To reset/delete this: Select this menu item:
Main Memory SETUP (page 194) contents
System app settings listed below:

CSV Format
[Settings]

All the Main Memory data
Main Memory SETUP (page 194) contents

[Main Memory]

All the Storage Memory data [Storage Memory]
All the Main Memory and Storage Memory data
Main Memory SETUP (page 194) contents

[Main&Storage]

All the Main Memory and Storage Memory data
Main Memory SETUP (page 194) contents
System app settings listed below:

Display Settings, Auto Power Off, Battery Settings, CSV Format,
Capture Format

[Initialize All]

•　Selecting a menu item causes a confirmation message to appear for the type of reset you selected.

3.　To reset, select [OK]. To cancel the operation, select [Cancel].

Important!
•　After selecting [Initialize All], you need to perform several initial setup operations, just as you would

immediately after turning on the calculator for the first time. The setup screens appear automatically
in the following sequence. Configure the settings on each screen.
-　Display language selection (page 200)
-　Country Setting (fx-CG100 only) (page 200)
-　Display brightness adjustment (page 200)
-　Auto power off and backlight duration settings (page 200)
-　Battery type selection (page 201)

After you select h > System to launch the app, the System
Manager menu appears first. All of the operations described in
this section start from this menu.
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Viewing Version Information (Version)
You can view the OS version of the calculator on the Version information screen that appears when you select
[Version] from the System Manager menu.

Note
•　While the Version information screen is displayed, pressing T will display the menu item [OS Update].

Selecting a Display Language (Language)
1.　From the System Manager menu, select [Language].

•　This displays the currently selected language.

2.　Press O.

3.　From the menu that appears, select the display language you want.

Changing the Country Setting (Country) (fx-CG100 only)
The four available options for the Country setting are shown below. The default setting is “International”.

•　International
•　Portugal

•　United Kingdom
•　United States

 
The Country setting affects this calculator as described below.
•　The arrangement of the HOME screen app icons
•　The Catalog menu configuration and content

-　Display sequence in which categories appear on the menu
-　Items included in each category and the sequence in which they appear (except for the All category)

•　Exam Modes that can be selected with the Exam Mode app and the sequence in which they appear on the
menu.

Note
•　Change the Country setting as required to use this calculator in specific countries. Otherwise, use the

default setting (International).

Use the operation below to change the Country setting.

1.　From the System Manager menu, select [Country].
•　This displays the currently selected Country setting.

2.　Press O.
•　This displays a menu of Country setting options.

3.　Highlight the option you want and then press O.

Adjusting Display Brightness (Display Settings)
1.　From the System Manager menu, select [Display Settings].

2.　Use l and r to adjust display brightness.

Configuring Auto Power Off and Backlight Duration Settings (Power Properties)
1.　From the System Manager menu, select [Power Properties].

2.　Perform one of the operations below to configure the setting you want.

To configure this setting: Perform this operation:
Auto Power Off duration (1)　 Highlight [Auto Power Off] and then press O.

(2)　 From the menu that appears, select [10 Min.] to specify approximately
10 minutes or [60 Min.] to specify approximately 60 minutes.
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Backlight illumination duration (1)　 Highlight [Backlight] and then press O.
(2)　 From the menu that appears, select [30 Sec.], [1 Min.], or [3 Min.].

Specifying the Battery Type (Battery Settings)

Important!
•　After replacing the batteries, be sure to perform the operation below to select the battery type of the

new batteries.

1.　From the System Manager menu, select [Battery Settings].

2.　Press O.

3.　From the menu that appears, select [Alkaline batteries] or [Ni-MH].
•　Read the warning message that appears on the display.

4.　To register the selected battery type, select [OK]. To cancel the operation, select [Cancel].

Specifying the CSV File Import and Export Format (CSV Format)
When importing a CSV file that has been transferred from a computer to the calculator, specify the delimiter
symbol and decimal point in accordance with the settings you specified on the application when outputting the
CSV file. The comma ( , ) or semi-colon ( ; ) can be specified for the delimiter, while the period ( . ) or comma
( , ) can be specified as the decimal point.

1.　From the System Manager menu, select [CSV Format].

2.　Use u and d to move the highlighting to [Separator], and then press O.

3.　From the menu that appears, select [Comma] or [Semi-Colon], and then press O.

4.　Use u and d to move the highlighting to [Decimal Separator], and then press O.

5.　From the menu that appears, select [Period] or [Comma], and then press O.
•　If you chose [Comma] in step 2 above, you cannot choose [Comma] here.

Specifying the Image Capture Format (Capture Format)
Use the procedure below to specify the format of an image that was saved using screen capture (page 13).

1.　From the System Manager menu, select [Capture Format].
•　This displays the currently selected image format.

2.　Press O.

3.　From the menu that appears, select [Memory] (to save in .g4p format) or [Bitmap] (to save in .bmp format).

Registering a User Name (User Name)
You can register a user name and organization name on your calculator. The registered user name and
organization name are displayed on the screen when you turn off the calculator.

1.　From the System Manager menu, select [User Name].

2.　Highlight the line below “User Name.”

3.　Input up to 19 characters for the user name and then press O.

4.　Highlight the line below “Organization.”

5.　Input up to 19 characters for the organization name and then press O.

•　This displays the currently selected battery type.
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Note
•　Select T > [Delete All] to delete all input on this screen.
•　“ID” at the bottom of the screen where you register your user name and organization name indicates

the ID number of the device.
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Exam Mode App (for fx-CG100)
The Exam Mode puts some limits on calculator functions, which allows it to be used when taking an exam or
test. Enter the Exam Mode only when actually taking an exam or test.
Your calculator has four* different Exam Modes.
•　IB (International Baccalaureate)
•　Portugal
•　United Kingdom
•　Texas (USA)

*　You can choose from among four Exam Modes when “International” (default setting) is selected for the
Country setting of the System app. If you select a different setting for Country, only the Exam Mode specific
to that country and IB can be selected.

Restrictions While in an Exam Mode
Entering an Exam Mode affects calculator operation as described below.
•　Some of the apps and functions are disabled. For more information, refer to the help that appears when you

perform the operation below.

(2)　 Select the Exam Mode whose restrictions you want to view and then press O.

(1)　 On the Exam Mode Manager menu, select [Exam Mode
Help] > [Apps & Functions].
•　This displays a menu for selecting Exam Mode type.

•　The calculator will back up user data (main memory) when you enter an Exam Mode. Backed-up data will be
restored when you exit the current Exam Mode. Data you created while in an Exam Mode is deleted when
you exit the mode.

•　The information below applies to the Python app operations.
-　You can enter up to five characters for a py file name.
-　You can use single-byte numeric and alphabetic characters (lowercase only) for a py file name.
-　py files are stored in the calculator’s main memory.
-　The “Memory ERROR” message appears when main memory capacity is low. If this happens, delete any

unnecessary files in order to increase available free space.
•　Only the settings below are saved before entering an Exam Mode.

Angle, Complex Mode, Display, Fraction Result,  π Result, Key, Show Option Numbers, FORMAT
Key, pinned input history, Q1Q3 Type, Language, Country, Battery Settings
However, some are forced to change as shown below while in an Exam Mode.
-　System app’s Auto Power Off setting: Always “60 Min.”
-　System app’s User Name and Organization entries: Always blank
Both of the above items are restored to their previous settings when you exit the Exam Mode.

Important!
•　Replacing batteries with a set of fresh ones is recommended before using an Exam Mode.

Select h > Exam Mode to start up the app and display the Exam
Mode Manager menu.
You can use this menu to enter any one of the Exam Modes or to
unlock an Exam Mode of another calculator.
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•　In an Exam Mode, the backlight brightness level will change to the darkest setting automatically if you
do not perform any operation on the calculator for about 30 seconds. Note that in an Exam Mode the
backlight will not turn off, so battery power runs down faster. Exit the Exam Mode as soon as possible
after you get through using it.

Entering an Exam Mode
1.　h > Exam Mode

•　This displays the Exam Mode Manager menu.

2.　Highlight [Enter Exam Mode] and then press O.

3.　From the menu that appears, select the Exam Mode you want to enter.

4.　Press O.
•　This displays the “Enter Exam Mode?” dialog on the calculator.

5.　Press O.

Exam Mode Calculator Operations
•　Exam Mode screens are identified by a boundary around the screen and a flashing icon in the upper right

corner. The color of the boundary and the icon type depend on the Exam Mode.

Exam Mode Boundary Color Icon
IB Green
Portugal Blue
United Kingdom Magenta
Texas (USA) Cyan

The flashing interval of the icon slows down about 15 minutes after you enter an Exam Mode.
•　In an Exam Mode, the Auto Power Off trigger setting is fixed at approximately 60 minutes.
•　Selecting [Elapsed Time] on an Exam Mode Manager menu causes the dialog box shown below to appear.

The dialog box shows the elapsed time in an Exam Mode.

You can restart the elapsed time count by performing one of the operations below.
-　Press the RESTART button.
-　Remove the calculator’s batteries.
-　Delete Main Memory data.
-　If you are already in an Exam Mode, re-enter it.*

*　If you are already in one Exam Mode you will not be able to enter the other Exam Mode. To change to
the other Exam Mode, exit the current Exam Mode and then enter the other one.

•　The table below shows how certain operations affect the Exam Mode.

•　If, in step 3 of this procedure, you select any Exam Mode
besides IB, a warning dialog will appear at this time. To
continue with the operation and enter the Exam Mode you
selected in step 3, select [OK]. If you are about to take an IB
exam, select [Cancel] to return to step 3, and then select IB.

•　After displaying the message Entering Exam Mode. for about
three seconds, the calculator enters the Exam Mode you
selected in step 3 above and displays the Exam Mode
Manager menu.
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If you do this: The calculator stays in the
Exam Mode.

Data input in the Exam Mode
is retained.

Turn power off and then back on again Yes Yes
Press the RESTART button Yes No
Remove the calculator’s batteries Yes No
Delete Main Memory data Yes No

Re-entering the Exam Mode You are Currently In
You can re-enter an Exam Mode even if you are currently in an Exam Mode. Doing so discards any data you
input and settings you configured while currently in the Exam Mode and returns them to what they were when
you first entered the Exam Mode.*
*　The only settings retained is the Battery Settings in the System app.

1.　While in an Exam Mode, highlight [Re-Enter Exam Mode] and then press O.
•　This displays the “Re-Enter Exam Mode?” dialog on the calculator.

2.　Press O.
•　After the message “Re-Entering Exam Mode.” is displayed for about three seconds, the calculator

automatically restarts and re-enters the Exam Mode.

Exiting an Exam Mode
There are three ways to exit an Exam Mode.

(1) Exiting an Exam Mode by Connecting to a Computer

1.　Use a USB cable*1 to connect the calculator that is in an Exam Mode to a computer.
•　This displays the “Select Connection Mode” dialog on the calculator.

2.　Highlight [USB Flash / Unlock Exam Mode] and then press O.
•　The message “Preparing USB” will appear on the calculator screen. Stand by and do not perform any

operation on the calculator.

3.　On the computer, open the calculator drive.

4.　On the computer, copy or delete any file that is on the calculator drive.

5.　On the computer, terminate the connection between the calculator and computer.
•　Terminating a connection automatically causes the calculator to restart. This causes the calculator to exit

an Exam Mode and return to the state it was in before the Exam Mode was entered.
*1　Use of a genuine CASIO USB cable is recommended. If you plan to use a commercially available USB

cable, be sure to use a cable that can transfer data.

(2) Exiting an Exam Mode by Allowing 12 Hours to Elapse
Approximately 12 hours after entering an Exam Mode, turning on the calculator will cause it to exit the Exam
Mode automatically.

Important!
•　If you press the RESTART button or if you replace batteries before turning on the calculator, it will

re-enter the Exam Mode when turned on, even if 12 hours have elapsed.

(3) Exiting an Exam Mode by Connecting to another Calculator
1.　On the calculator that is in an Exam Mode (Calculator A), display the Exam Mode Manager menu.

•　The screen shown to the right appears when a connection is
established between the calculator and the computer.
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2.　Use a 2.5mm plug cable*2 to connect Calculator A to another calculator that is not in an Exam Mode
(Calculator B).

3.　On Calculator A, highlight [Unlocked Exam Mode] and then press O.

4.　On Calculator B, select h > Exam Mode, highlight [Unlock Exam Mode] and then press O.
•　When the “Complete!” message appears on Calculator B, Calculator A automatically restarts. Calculator

A exits an Exam Mode and the data on Calculator A returns to the state it was in before the Exam Mode
was entered.

*2　Included in the optionally-available SB-2000 package (USB cable and 2.5mm plug cable).

Note
•　You can also connect your calculator to another calculator model that has an exam mode and unlock

your calculator’s Exam Mode from the other model or unlock the other model’s exam mode from your
calculator.
For details about the required operation on the other model, see the information below.
-　Exam Mode Manager menu’s [Exam Mode Help] > [How to Exit]
-　User’s documentation of the other calculator model
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Exam Mode App (for fx-1AU GRAPH)
The Exam Mode puts some limits on calculator functions, which allows it to be used when taking an exam or
test. Enter the Exam Mode only when actually taking an exam or test.

Restrictions While in the Exam Mode
Entering the Exam Mode affects calculator operation as described below.
•　Some of the apps and functions are disabled. For details, see [Exam Mode Help] > [Apps & Functions] on

the Exam Mode Manager menu.
•　The calculator will back up user data (main memory) when you enter the Exam Mode. Backed-up data will

be restored when you exit the Exam Mode. Data you created while in the Exam Mode is deleted when you
exit the mode.

•　Only the settings below are saved before entering the Exam Mode.
Angle, Complex Mode, Display, Fraction Result,  π Result, Key, Show Option Numbers, FORMAT
Key, pinned input history, Q1Q3 Type, Language, Battery Settings
However, some are forced to change as shown below while in the Exam Mode.
-　System app’s Auto Power Off setting: Always “60 Min.”
-　System app’s User Name and Organization entries: Always blank
Both of the above items are restored to their previous settings when you exit the Exam Mode.

Important!
•　Replacing batteries with a set of fresh ones is recommended before using the Exam Mode.
•　In the Exam Mode, the backlight brightness level will change to the darkest setting automatically if you

do not perform any operation on the calculator for about 30 seconds. Note that in the Exam Mode the
backlight will not turn off, so battery power runs down faster. Exit the Exam Mode as soon as possible
after you get through using it.

Entering the Exam Mode
1.　h > Exam Mode

•　This displays the Exam Mode Manager menu.

2.　Highlight [Enter Exam Mode] and then press O.
•　This displays the “Enter Exam Mode?” dialog on the calculator.

3.　Press O.

Exam Mode Calculator Operations
•　Entering the Exam Mode causes the entire display screen to be surrounded by a green boundary. A flashing

display icon ( ) will also appear on the display. The flash rate of the icon slows down about 15 minutes after
entering the Exam Mode.

Select h > Exam Mode to start up the app and display the Exam
Mode Manager menu.
You can use this menu to enter the Exam Mode or to unlock the
Exam Mode of another calculator.

•　After displaying the message Entering Exam Mode. for about
three seconds, the calculator enters the Exam Mode and
displays the Exam Mode Manager menu.
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•　In the Exam Mode, the Auto Power Off trigger setting is fixed at approximately 60 minutes.
•　Selecting [Elapsed Time] on the Exam Mode Manager menu causes the dialog box shown below to appear.

The dialog box shows the elapsed time in the Exam Mode.

You can restart the elapsed time count by performing one of the operations below.
-　Press the RESTART button.
-　Remove the calculator’s batteries.
-　Delete Main Memory data.
-　If you are already in the Exam Mode, re-enter it.

•　The table below shows how certain operations affect the Exam Mode.

If you do this: The calculator stays in the
Exam Mode.

Data input in the Exam Mode
is retained.

Turn power off and then back on again Yes Yes
Press the RESTART button Yes No
Remove the calculator’s batteries Yes No
Delete Main Memory data Yes No

Re-entering the Exam Mode
You can re-enter the Exam Mode even if you are currently in the Exam Mode. Doing so discards any data you
input and settings you configured while currently in the Exam Mode and returns them to what they were when
you first entered the Exam Mode.*
*　The only settings that are retained are the System app’s Battery Settings.

1.　While in the Exam Mode, highlight [Re-Enter Exam Mode] and then press O.
•　This displays the “Re-Enter Exam Mode?” dialog on the calculator.

2.　Press O.
•　After the message “Re-Entering Exam Mode.” is displayed for about three seconds, the calculator

automatically restarts and re-enters the Exam Mode.

Exiting the Exam Mode
There are three ways to exit the Exam Mode.

(1) Exiting the Exam Mode by Connecting to a Computer

1.　Use a USB cable*1 to connect the calculator that is in the Exam Mode to a computer.
•　This displays the “Select Connection Mode” dialog on the calculator.

2.　Highlight [USB Flash / Unlock Exam Mode] and then press O.
•　The message “Preparing USB” will appear on the calculator screen. Stand by and do not perform any

operation on the calculator.

3.　On the computer, open the calculator drive.

4.　On the computer, copy or delete any file that is on the calculator drive.

5.　On the computer, terminate the connection between the calculator and computer.
•　Terminating a connection automatically causes the calculator to restart. This causes the calculator to exit

the Exam Mode and return to the state it was in before the Exam Mode was entered.
*1　Use of a genuine CASIO USB cable is recommended. If you plan to use a commercially available USB

cable, be sure to use a cable that can transfer data.

•　The screen shown to the right appears when a connection is
established between the calculator and the computer.
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(2) Exiting the Exam Mode by Allowing 12 Hours to Elapse
Approximately 12 hours after entering the Exam Mode, turning on the calculator will cause it to exit the Exam
Mode automatically.

Important!
•　If you press the RESTART button or if you replace batteries before turning on the calculator, it will

re-enter the Exam Mode when turned on, even if 12 hours have elapsed.

(3) Exiting the Exam Mode by Connecting to another Calculator
1.　On the calculator that is in the Exam Mode (Calculator A), display the Exam Mode Manager menu.

2.　Use a 2.5mm plug cable*2 to connect Calculator A to another calculator that is not in the Exam Mode
(Calculator B).

3.　On Calculator A, highlight [Unlocked Exam Mode] and then press O.

4.　On Calculator B, select h > Exam Mode, highlight [Unlock Exam Mode] and then press O.
•　When the “Complete!” message appears on Calculator B, Calculator A automatically restarts. Calculator

A exits the Exam Mode and the data on Calculator A returns to the state it was in before the Exam Mode
was entered.

*2　Included in the optionally-available SB-2000 package (USB cable and 2.5mm plug cable).

Note
•　You can also connect your calculator to another calculator model that has an exam mode and unlock

your calculator’s Exam Mode from the other model or unlock the other model’s exam mode from your
calculator.
For details about the required operation on the other model, see the information below.
-　Exam Mode Manager menu’s [Exam Mode Help] > [How to Exit]
-　User’s documentation of the other calculator model
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Other Information

Connecting the Calculator to a Computer
You can connect your calculator to a computer and transfer data between them. You can also use the computer
to update the operating system of the calculator.

Important!
•　Never touch the USB cable plugs and calculator screen while a data communication operation is in

progress.

Connecting and Disconnecting with a Computer

Establishing a Connection between the Calculator and a Computer
Use of a genuine CASIO USB cable is recommended for connection. If you plan to use a commercially available
USB cable, be sure to use a cable that can transfer data.

1.　Use the USB cable to connect your computer to the calculator.
•　This displays the “Select Connection Mode” dialog on the calculator.

2.　Highlight [USB Flash] and then press O.
•　The message “Preparing USB” will appear on the calculator screen. Stand by and do not perform any

operation on the calculator.

3.　Open the calculator drive on the computer.
•　Depending on your computer settings, a calculator drive window may automatically open when a

connection is established between the calculator and computer. The calculator drive window shows files
and folders stored in calculator memory.

•　If the Calculator Window does not open automatically, follow the instructions below that correspond to
your computer’s operating system.
Windows: Use File Explorer to open the calculator drive, which is located in “PC.” Note that “PC” may be

a different name depending on the OS version.
macOS: Double-click the Calculator Drive icon on the desktop to open the calculator drive window.

4.　Use the Calculator Drive window to manipulate files and folders as required.
•　You can copy and delete files and folders. Use the same operations that you normally use for such

operations on your computer.
•　For information on the files and folders displayed in the Calculator Drive window, see “Calculator Drive

Contents” (page 211).

Important!
•　Do not format the calculator drive from a computer. Doing so deletes all data in calculator memory.

If the USB connection between the calculator and the computer is terminated, the message “File
System ERROR” will appear on the calculator screen. See “Error Message Table” (page 247) for more
information on what you need to do.

•　The screen shown to the right appears when a connection
is established between the calculator and computer. At the
same time, your calculator’s storage memory is mounted on
the computer as a USB drive. Here, this USB drive is referred
to as the “calculator drive.”
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5.　After you finish all the operations you want to perform, terminate the connection between the calculator and
a computer.
•　See “Terminating the Connection between the Calculator and a Computer” (page 213).

Note
•　The “Select Connection Mode” dialog will not appear if you connect the USB cable to the calculator

while the  icon is in the status bar or while a graph, Geometry app figure, or other figure is flashing
on the display. Wait until the  icon disappears or perform the required operation to stop the flashing
of the graph, and then try connecting the USB cable again.

•　If the message “Storage Memory Full” appears when you are trying to connect the calculator to a
computer, it means that there is not enough calculator storage memory available. If this happens,
delete any calculator storage memory files that you no longer need to free up memory and then try
connecting again.

•　When copying a file from your computer’s local disk to the calculator drive, it may take several minutes
before copying starts. This is because copying automatically performs optimization of the calculator’s
storage memory. It does not indicate malfunction.

•　A USB connection between the calculator and a computer may be terminated automatically if the
computer enters a power save mode, sleep mode, or any other standby state.

OS Update
Select [OS Update] on the Select Connection Mode dialog* when using a computer to update the calculator’s
operating system. For details, see the text of releases that are issued when a new operating system version is
released.
*　See step 1 of the procedure under “Establishing a Connection between the Calculator and a Computer”

(page 210).

Calculator Drive Contents
Your calculator has a main memory and a storage memory for storing data. You can use the Memory app
(page 194) to display the contents of each memory area.
 
You can also use the calculator drive to display calculator’s Storage Memory contents on a computer screen.
The root directory of the calculator drive displays the files and folders described below.
•　@MainMem folder ... This folder contains the data of calculator main memory. See “@MainMem folder

contents” (page 211). The contents of this folder are copied from main memory to storage memory each time
the calculator is connected to a computer via USB.*

•　Capt folder ... This folder is automatically created, when you capture a screen image (page 13), to save the
captured image. Captured images saved in bmp format can be displayed on a computer screen.

•　module.py ... This file is automatically created when you start up the Python app (page 119).
•　Other ... Other files that contain calculator data (.g4m file name extension), py files, csv files, etc. are also

displayed. For details, see “Files Displayed on the Storage Memory Tab” (page 196).
*　If there is not enough storage memory space available to perform this copy operation, the message “Storage

Memory Full” appears when you connect via USB, and the copy operation will not be performed. If this
happens, delete any calculator storage memory files that you no longer need to free up memory and then
try connecting again.

@MainMem folder contents
All of the files below correspond to data in the calculator’s main memory. For details about data contents, see
“Data Displayed on the Main Memory Tab” (page 194).
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Folder name File name*

@3DGRAPH 3DGRAPH.g4m
@GEOM @IMAGE.g4m

<Data name>.g4m
@DBASE Adopted.g4m, Atomic.g4m, Electoro.g4m, Periodic.g4m, Physico.g4m,

Univers.g4m, User.g4m
@PROBSIM PROBSIM.g4m
LISTFILE FILEx.g4m (LISTFILE x), LISTxx.g4m, LISTANS.g4m (LIST ANS)
MAT_VCT MATx.g4m, MATANS.g4m (MAT ANS), VCTx.g4m, VCTANS.g4m (VCT ANS)
SSHEET _SETTINGS.g4m, SHEET.g4m, <Data name>.g4m
ROOT ALPHAMEM.g4m (ALPHA MEM)

CONICS.g4m
DIST.g4m
DYNAMEM.g4m (DYNA MEM)
EQUATION.g4m
FINANCE.g4m
NUMINEQ.g4m (fx-CG100 only)
RECUR.g4m (RECURSION)
SETUP.g4m
STAT.g4m
SYSTEM.g4m
TABLE.g4m
Y=DATA.g4m

*　File name extensions are not displayed on the Main Memory tab of the calculator’s Memory app. For files
that names enclosed in parentheses, the Main Memory tab shows the name in parentheses.

Main Memory Data Updating upon Termination of a USB Connection
While there is a USB connection between the calculator and a computer, you can use the computer to edit
the @MainMem folder contents by deleting folders and files, adding files, etc. When you terminate the USB
connection, the calculator’s main memory data is updated with the current contents of the @MainMem folder.
Note the following important points.
•　Deleting the @MainMem folder will cause all data in the calculator’s main memory to be initialized.
•　Updating the @MainMem folder affects up to three levels of folders inside the storage memory root folder.

SMEM ← Storage memory root folder

@MainMem (Level 1)

Folder (Level 2)

Folder (Level 3) ← Updating affects files up to this.

Any folders and files past Level 3 are moved to a folder named “SAVE-F” in storage memory.
•　Adding a g4m file to the @MainMem folder while there is a USB connection between the calculator and a

computer will copy the data item(s) included in the g4m file to the calculator’s main memory. For details about
the main memory data item names that correspond to the g4m file names in the @MainMem folder, see
“@MainMem folder contents” (page 211). If there is no folder in main memory that corresponds to the data
items included in the g4m file, a corresponding folder will be created automatically and the data items will be
copied to that folder.
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•　Depending on the data type, an overwrite confirmation message will appear if there is already data with the
same name in calculator’s main memory as the data being copied from @MainMem folder. For information
about which types of data cause a confirmation message to appear, see “Important!” under “To load a g4m
file into Main Memory” (page 197).

•　If you place a file or folder that is not supported by the calculator into the @MainMem folder, it will be
transferred to a folder named “SAVE-F” in the calculator’s storage memory and will not be shown in main
memory.

•　If the size of the data in the @MainMem folder exceeds the available capacity of main memory, the message
“Memory ERROR” will appear on the calculator when you terminate the USB connection and main memory
will not be updated.

Terminating the Connection between the Calculator and a Computer

Important!
•　Do not disconnect the USB cable connecting the calculator to the computer until the System Manager

menu appears when you complete the operation in step 4 below.

1.　If the calculator is connected to a Windows computer, note the drive letter (E, F, G, etc.) assigned to the
calculator drive.

2.　Depending on your computer’s operating system, perform one of the operations below.
Windows: Click the “Safely Remove Hardware” icon in the task tray in the lower right corner of the display.

On the menu that appears, select the drive whose letter matches the calculator drive letter
you noted in step 1 above. Check to make sure the “Safe To Remove Hardware” message is
displayed.

macOS: Drag the calculator drive icon to the Eject icon (Trash icon). Check to make sure that the
calculator drive icon is no longer on your desktop.

3.　While the message “Updating Main Memory” is displayed on the calculator, wait and do not perform any
operation.

4.　When the message “Complete!” appears on the calculator display, press O.
•　This displays the System Manager menu of the System app.
•　You can disconnect the USB cable connecting the calculator to the computer at this time.
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Settings Menu Details

Settings Menu and Submenus
The number of items that appear on the Settings menu depends on the app you are configuring. There are
several different item types as described below.

Item Type Description
General These items are common to most apps.
Graph These items are displayed for the Graph&Table app. Some of these items also appear in

the Recursion, 3D Graph, Dyna Graph, Conic Graphs, Statistics, Distribution, Financial,
and Geometry apps.

Statistics These items appear for the Statistics app.
Spreadsheet These items appear for the Spreadsheet app.
Financial These items appear for the Financial app.
Prob Sim These items appear for the Prob Sim app.
Dyna Graph These items appear for the Dyna Graph app.
3D Graph These items appear for the 3D Graph app.
Geometry These items appear for the Geometry app.
Specific These items appear for specific apps.

In the following sections, the type of each item is shown in parentheses after the item name. A diamond mark
(◆) in the following sections indicates the initial default setting of each item.

Auto Recalculation (Spreadsheet)
Selects whether or not the Spreadsheet app should perform auto recalculation each time data is input.

 On◆ Formulas are automatically recalculated each time data is input.

 Off Formulas are not recalculated when data is input.

Edit Box Shows (Spreadsheet)
Specifies what the edit box of the Spreadsheet app shows when the cursor is at a cell that contains a formula.

Formula◆ Displays cell contents as a formula.

Value Displays cell contents as a value.

Cursor Moves (Spreadsheet)
Specifies the direction the cursor moves after data is input or pasted into a Spreadsheet app cell.

Down◆ Moves down one cell.

Right Moves right one cell.

Payment Point (Financial)
This setting affects Financial app Compound Interest and Amortization calculations.

Beginning Specifies the beginning of the period as the payment date.

End◆ Specifies the end of the period as the payment date.

Number of Days/Year (Financial)
This setting affects Financial app Simple Interest, Days Calculation, and Bond Calculation.

365◆ Specifies 365 as the number of days per year for calculations.

360 Specifies 360 as the number of days per year for calculations.
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Interest Paid (Financial)
This setting affects the Financial app Bond Calculation.

Annually◆ Specifies an annual interest payment interval.

Semi-annually Specifies a semi-annual interest payment interval.

Maximum Scale (Prob Sim)
Specifies whether the maximum value of the vertical axis on the Result tab of the Prob Sim app is shown or
hidden on the graph.

 On Shows the maximum value.

 Off◆ Hides the maximum value.

Animation (Prob Sim)
Specifies whether an animation should be displayed before results when a simulation is performed in the Prob
Sim app.

 On◆ Plays an animation before displaying results.

 Off Displays only the results without an animation.

Looping (Dyna Graph)
When graphing with the Dyna Graph app, specifies whether the app should automatically return to the Setup
tab after a specified number of iterations or continue drawing.

 On Drawing continues until you press a.

 Off◆ The display automatically returns to the Setup tab after 10 iterations of coefficient value
increase and decrease.

Locus (Dyna Graph)
Specifies whether to show or hide the loci of all graphs drawn with the Dyna Graph app.

 On Shows loci.

 Off◆ Hides loci.

Processing Speed (Dyna Graph)
Specifies whether the Dyna Graph app plots all x-axis dots or plots every other dot. This setting is enabled only
when graphing y= type functions.

High Plot every other x-axis dot. This results in faster graphing than Normal speed.

Normal◆ Plot all x-axis dots.

Angle (General)
Selects the angle unit for input and output.
Degree, Radian◆, Gradian*

*　The Geometry app does not have a “Gradian” option.

Table with Graph (Graph)

 On Displays both the numerical table and graph on the Table tab.

 Off◆ Displays only the numerical table on the Table tab.

Show V-Win Settings (Graph)

 On◆ Causes the View Window dialog to appear when a graph draw operation is started.*
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 Off The View Window dialog does not appear when a graph draw operation is started.*
Instead, the current View Window settings are applied.

*　A graph draw operation is started when you press > on the Function tab of the Graph&Table application,
etc.

3D Axes (3D Graph)
Specifies whether the 3D Graph app shows or hides Cartesian coordinate axes in the graph window.

 On◆ Shows Cartesian coordinate axes.

 Off Hides Cartesian coordinate axes.

Box (3D Graph)
Specifies whether the 3D Graph app shows or hides boxed axes in the graph window.

 On◆ Shows boxed axes.

 Off Hides boxed axes.

3D Label (3D Graph)
Specifies whether the 3D Graph app shows or hides axis labels in the graph window.

 On◆ Shows axis labels.

 Off Hides axis labels.

View Window (Statistics)

Auto◆ View Window settings are automatically adjusted based on the type of graph you are
drawing.

Manual View Window settings are normally applied regardless of the type of graph you are
drawing. However, in the case of a pie chart or hypothesis test graph, the calculator
always uses automatically-generated View Window settings.

Q1Q3 Type (Statistics)
Use this setting to choose how to calculate the first and third quartiles (Q1 and Q3).

Standard◆ With this method, the data set is divided into two halves at the median (50th percentile, or
Q2), and then the upper and lower sets of data are divided into two halves to determine
Q1 (25th percentile) and Q3 (75th percentile) respectively.

OnData When the 25% cumulative frequency percentage determined from the data is a and the
75% percentage is b, this method returns the data value closest to and above a as Q1,
and the data value closest to and above b as Q3.

Sub Name (Statistics)

 On◆ Shows the SUB (subname) line of the List Editor.

 Off Hides the SUB (subname) line of the List Editor.

List File (Statistics)
Any one of six files (File1◆ to File6) can be selected as the “List Files” (page 32).

Coord (Graph)
This is a display setting that controls what happens when the trace pointer is displayed on a graph while using
the graph analysis and trace functions.

 On◆ Shows the coordinates of the current trace pointer position.
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 Off Hides the coordinates of the current trace pointer position.

Angle Unit (Geometry)
Specifies whether to include units when displaying angles for a figure on the Geometry app drawing screen.

 On◆ Displays angles with units.

 Off Displays angles without units.

Length Unit (Geometry)
Specifies whether to include units when displaying lengths for a figure on the Geometry app drawing screen.

mm, cm, m, km, in,
ft, yd, mile

Displays lengths with units.

Off◆ Displays lengths without units.

Grid (Graph)
Use this setting to show or hide grid points or grid lines within the graphing area.

On Shows grid points.

Off* Hides grid points and lines.

Line◆ Shows grid lines.

*　The initial default setting for the Geometry app is “Off”.

Grid Space (Geometry)
Specifies the pitch (spacing) of the grid points and lines on the Geometry app drawing screen. You can specify
a value from 0.01 to 1◆ to 1000, in increments of 0.01.

Axes (Graph)
Use this setting to show or hide coordinate axes (x-axis and y-axis) in the graphing area.

On Shows coordinate axes.

Off* Hides coordinate axes.

Scale◆ Shows coordinate axes along with a scale on each axis.

*　The initial default setting for the Geometry app is “Off”.

Label (Graph)

 On◆ Shows x-axis, y-axis, and origin (0) labels.

 Off Hides labels.

Show Equation (Graph)
This is a display setting that controls what happens when the trace pointer is displayed on a graph while using
the graph analysis and trace functions.

 On◆ Shows the equation of the graph where the trace pointer is currently located.

 Off Hides the equation of the graph where the traces pointer is currently located.

Graph Simultaneously (Graph)
Specifies the graphing method when drawing multiple graphs.

 On All graphs drawn at the same time.

 Off◆ Graphs drawn individually.
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Plot/Line Color (Graph)
Specifies the color of the points and lines drawn by trace and sketch.
Black, Blue, Red, Magenta, Green◆, Cyan, Yellow

Sketch Line (Graph)
Specifies the type of line drawn by sketch.
Normal◆, Thick, Broken, Dot, Thin

Draw Type (Graph)

Connect◆ Draws a graph using a continuous line.

Plot Draws a graph by plotting individual points.

Complex Mode (General)
This setting specifies the calculation ranges of real and imaginary numbers, and the display format of complex
numbers.

Real◆ Calculates a range of real numbers.
An error is displayed if the calculation contains even one function term with a real
number argument and an imaginary whose solution is imaginary. However, if a complex
number is specified as an argument while “Real” is selected, a complex number
calculation will be performed. If the result of a calculation containing a complex number
is a complex number, it is displayed in the form a+bi.

a+bi Calculates a range of real and imaginary numbers. The result of a complex number
calculation is displayed in rectangular form.

r∠θ Calculates a range of real and imaginary numbers. The result of a complex number
calculation is displayed in polar form.

Display (General)
This setting specifies the display format (number of digits) of calculation results. It also specifies engineering
symbols appended to calculation results.

Fix0: 0. - Fix9:
0.123456789

Specifies the number of decimal places (0 to 9) for calculation results. Calculation
results are rounded to the next digit following the specified digit.

Sci1: 1×10-1 - Sci10:
1.234567890×10-1

Specifies the number of significant digits (1 to 10) and the exponent of calculation
results. Calculation results are rounded to the next digit following the specified digit.

Norm1: 1.23×10-3◆,
Norm2: 0.00123

Displays calculation results in exponential form when they are within the ranges below.
Norm1: 1.23×10-3

： |x| < 10-2, 1010 ≤ |x|
Norm2: 0.00123： |x| < 10-9, 1010 ≤ |x|

Engineer Symbol

 On Displays calculation results using engineering symbols.*

 Off◆ Displays calculation results without engineering symbols.

*　m, μ, n, p, f, k, M, G, T, P, E

Fraction Result (General)
◆ Displays the result of a fraction calculation as an improper fraction.

Displays the result of a fraction calculation as a mixed fraction.
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 π Result (Specific)
This setting specifies whether the Calculate, Num Ineq (fx-CG100 only) and Equation apps display results that
include   and/or π.

 On◆ Displays calculation results in a form that includes   and/or π when possible.

 Off Displays calculation results in decimal form even if it is possible to display them in a
form that includes   and/or π.

Background (Graph)
This setting selects a background image for the graph window.

None◆ No background image displayed.

Open Selecting this item displays a dialog you can use to select a background image. For
information about images that can be used as backgrounds (.g4p or .g3p), see “Using
the Storage Memory Tab” (page 196).

Key (General)
This setting specifies the operation of the k key. For an example of operation of the k key, see “Scientific
Function Calculations” (page 19).

 (Power) Pressing k produces the same input result as pressing /10g.

 (Sci Notation) Pressing k inputs the function . This function takes arguments before and after it
with the form a n (n is an integer) and returns the result of 10n multiplied by a.

 (Sci Notation)◆ Pressing k inputs the function . This function takes arguments before and after it
with the form a n (n is an integer) and returns the result of 10n multiplied by a.

ΣDisplay (Specific)
This setting shows or hides a column of cumulative sums on the Table tab of the Recursion app.

 On Shows the cumulative sum column on the Table tab.

 Off◆ Hides the cumulative sum column on the Table tab.

Ineq Region Type (Graph)
This setting specifies how multiple inequality graphs should be filled.

Intersection Shades only areas where the conditions of all of the graphed inequalities are satisfied.

Union◆ Shades all areas where the conditions of each graphed inequality are satisfied.

Derivative (Graph)
This setting shows or hides a differential coefficient column on the Table tab of the Graph&Table app. This
setting also affects whether or not the differential coefficients at the position of the trace pointer on the Graph
tab of the Graph&Table app or Conic Graphs app are displayed.

 On Shows a differential coefficient column on the Table tab. When this setting is selected,
differential coefficients at the position of the trace pointer on the Graph tab are also
displayed.*

 Off◆ Hides differential coefficients on both the Table tab and the Graph tab.

*　Display of differential coefficients at the trace pointer position is enabled only when the S > [Coord] setting
is turned on.

Simplify (Specific)
Use this setting to specify whether or not to reduce fractions produced as calculation results by the Calculate
app.

219



Auto◆ Automatically reduces fractional calculation results.

Manual Displays fractional calculation results without reducing them.*

*　Fractional results are initially displayed without reduction, but you can reduce them later. See “Simplification”
(page 223).

Show Option Numbers (General)
Specifies whether to show Option Numbers (numbers and letters to the left of menu items) on menus and
dialogs. For details about Option Numbers see “Menu and Dialog Operations (Using Option Numbers)”
(page 11).

 On◆ Shows Option Numbers.

 Off Hides Option Numbers.

FORMAT Key (General)
You can toggle what happens when F is pressed between the two operations described below.

 Decimal◆
(Toggle)

Each press of F toggles the displayed calculation result between a form that includes
fraction/π/   and decimal form. Press sF to display the Format Menu (page 17).

Format Menu
(Menu)

Press F to display the Format Menu (page 17). Each press of sF toggles the
displayed calculation result between a form that includes fraction/π/   and decimal form.
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Catalog Menu Details
The Catalog menu, which appears when you press C, is a comprehensive list of all functions, commands,
app variables,* and symbols available on the calculator. You can select the item you want on the calculator and
enter it into a calculation or expression.

The list produced by C > [All] contains all items supported by your calculator. While the alphabetical list is
displayed, you can press a key from XA to 0Z to display a list of items beginning with the letter you pressed.

Functions and symbols that are not included in a group from [A] to [Z] can be accessed with C > [All] >
[Symbol].
*　Items included in C > [Variable Data] (input/output variables used in an app)

Note
•　Pressing C while using the Python app or the Base-N app displays a Catalog menu specific to each

app. For details, see the chapters explaining each app.
•　The Catalog menu displays the names of functions and commands in the menus by category (such

as Integration (∫), etc.). On the C > [All] and Input History menus, the functions and commands are
displayed in line input syntax (such as ∫(,,), etc.).

Using Input History
Up to 10 of the latest functions and commands* recently entered from the Catalog menu are maintained as
input history. To view the input history, select C > [History (Pin )].
*　Including pinned input history.

Pinning Input History
While viewing input history, select the item you wish to pin and then press T. This causes a pin to appear to
the left of the item.
The next time you open the input history, the pinned item will be at the top of the list.

To unpin an item, select the item you wish to unpin and press T.
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Category Grouped Item List
Note the following points concerning the syntax of functions and commands, except those in the Unit
Conversions category.
•　If the natural input syntax and line input syntax are different for a function, the natural input syntax is shown

first, followed by the line input syntax.
•　Anything that is optional in a syntax is enclosed in square brackets ([ ]). With the syntax ∫( f (x),a,b[,tol]), the
tol argument can be omitted, resulting in ∫( f (x),a,b).

Note
•　The categories listed in this section and the functions, commands, app variables,* and symbols

included in each category are presented in the order they appear when [Country] > [International] is
selected in the System app.

•　Regardless of the model (fx-CG100 or fx-1AU GRAPH) or configuration, items included in C > [All]
are the same. All items listed in this manual are displayed in alphabetical order.

*　Items included in C > [Variable Data] (input/output variables used in an app)

Function Analysis

1st Derivative (d/dx)      d/dx(,)
Uses approximate calculation to determine the first-order differential coefficient of f x  at x = a.

Syntax: ddx ( f (x))|x = a       d /dx( f (x),a)

Not allowed within this syntax: d /dx, d2/dx2, ∫dx, Σ, FMin, FMax, Solve, RndFix

Example: ddx ( f (x3 + 4x2 + x − 6))|x = 3 = 52

Precautions
•　When f x  is a trigonometric function, make sure to select the following for the angle unit: S >

[Angle] > [Radian].
•　Inaccurate results and errors can be caused by any one of the following:

-　Discontinuous points in x values
-　Extreme changes in x values
-　Inclusion of the local maximum point and local minimum point in x values
-　Inclusion of the inflection point in x values
-　Inclusion of indifferentiable points in x values
-　Calculation results approaching zero

2nd Derivative (d2/dx2)      d2/dx2(,)
Uses approximate calculation to determine the second-order differential coefficient of f x  at x = a.

Syntax: d
2

dx2 ( f (x))|x = a       d
2/dx2( f (x),a)

The items that are not allowed within this syntax and precautions are the same as those for d /dx.

Integration (∫)      ∫(,,)
Uses approximate calculation to determine the integral of f x  at a ≤ x ≤ b. This function returns a positive
value when f x  is in the positive range and a negative value when f x  is in the negative range (Example:

∫2
3x2 − 4dx = 7

3 ; ∫1
2x2 − 4dx = -5

3 ).

Syntax: ∫a
b f (x)dx       ∫( f (x),a,b[,tol])

•　For tol, input the allowable error (tolerance) range. Default: 1 × 10-5 if omitted and for natural input.
Not allowed within this syntax: d /dx, d2/dx2, ∫dx, Σ, FMin, FMax, Solve, RndFix

Example: ∫1
52x2 + 3x + 4dx = 404

3
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Precautions
•　When f x  is a trigonometric function, make sure to select the following for the angle unit: S >

[Angle] > [Radian].
•　Because numerical integration is used, large error may result in calculated integration values due to

the content of f x , positive and negative values within the integration interval, or the interval being
integrated. (Examples: When there are parts with discontinuous points or abrupt change. When the
integration interval is too wide.) In such cases, dividing the integration interval into multiple parts
and then performing calculations may improve calculation accuracy.

Summation (Σ)       Σ(,,,)
Obtains the sum for a specified range of f x .

Syntax: ∑
x=a

b
( f (x))       ∑( f (x),x,a,b[,n])       a, b, n = integers, a < b

•　x can be any alpha variable. n specifies the step interval. Default: 1 if omitted and for natural input.
Not allowed within this syntax: d /dx, d2/dx2, ∫dx, Σ, FMin, FMax, Solve, RndFix

Example: ∑
x=2

6
(x2 − 3x + 5) = 55

Solve Equation (SolveN)      SolveN()
Obtains multiple solutions of an equation.

Syntax: SolveN( f x  [= right side] [,x] [,lower limit,upper limit])
•　If [=right side] is omitted, f x  = 0 is assumed. Specify any alpha variable for [,x] and use the same variable

for f x . If [,x] is omitted, the variable x is used.
•　Up to 10 solutions are returned in list form.
•　“No Solution” is returned if no solution exists.
•　If a solution other than one(s) provided might exist, the message “More solutions may exist. ” appears on

the display.
Not allowed within this syntax: d2/dx2, Σ, FMin, FMax, Solve

Example: SolveN(x2 − 5x − 6) = {-1,6}

Solve Equation (Solve)      Solve(,)
Approximates a single solution for f x  = 0. This function has the same functionality as the Equation app’s
“Using Solver” (page 116).

Syntax: Solve( f x  ,initial estimate [,lower limit,upper limit])
Not allowed within this syntax: d2/dx2, Σ, FMin, FMax, Solve

Remainder of Integer÷Integer      Rmdr
Obtains the remainder when an integer is divided by another integer.

Syntax: dividend Rmdr divisor
Example: 17 Rmdr 7 = 3

Integer Part of Int÷Int      Int÷
Obtains the quotient of an integer divided by another integer.

Syntax: dividend Int÷ divisor
Example: 17 Int÷ 7 = 2

Simplification       ISimp
Reduces a fraction to its lowest terms. With the Calculate application, use the settings below.
S > [Simplify] > [Manual] S > [Complex Mode] > [Real]
Use one of the syntaxes below for ISimp.

Syntax 1: FractionISimp
Automatically reduces the fraction in the argument by dividing by the smallest prime number that
can be divided. The prime number and the result of the reduction are shown on the display.

Syntax 2: FractionISimp n
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Divides the fraction in the argument by the divisor specified by n. The result of the division is
shown on the display.

Example 1: 15
60 = 5

20 = 1
4

15e60r
C > [Function Analysis] > [Simplification]E

C > [History (Pin )] > [ISimp]E

Example 2: 15
60 = 3

12 (Specifies a divisor of 5.)

15e60r
C > [Function Analysis] > [Simplification]5E

Precautions
•　When [a+bi] or [r∠θ] is selected for S > [Complex Mode], fraction calculation results always are

simplified before being displayed, even if S > [Simplify] is set to [Manual].

Function Minimum      FMin(,,)
Returns, in list form, the coordinates of the minimum values of f x  at a ≤ x ≤ b.

Syntax: FMin( f x ,a,b[,n])      n: Calculation accuracy (n = integer from 1 to 9)
Not allowed within this syntax: d /dx, d2/dx2, ∫dx, Σ, FMin, FMax, Solve, RndFix

Example: FMin(x2,-2,1) = {0,0}

Precautions
•　Discontinuous points or sections with drastic fluctuation can adversely affect precision or cause an

error.
•　Inputting a larger value for n increases the precision of the calculation, but it also increases the

amount of time required to perform the calculation.

Function Maximum      FMax(,,)
Returns, in list form, the coordinates of the maximum values of f x  at a ≤ x ≤ b.

Syntax: FMax( f x ,a,b[,n])      n: Calculation accuracy (n = integer from 1 to 9)
The items that are not allowed within this syntax and precautions are the same as those for FMin.

Probability

Factorial (!)      !
Obtains the factorial of 0 or a positive integer.

Syntax: n!       n = integer

Permutation (P)     P
Obtains the total number of r-permutations taken from set n.

Syntax: nPr       n, r = integers
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Combination (C)      C
Obtains the total number of r-combinations from set n.

Syntax: nCr       n, r = integers

Random Number (0 to 1)      Ran#
Each execution returns a 10 digit random number (from 0 to 1).

Syntax: Ran# [a]       1 ≤ a ≤ 9 (a = integer)
•　a: Specifies the random number sequence. If omitted, a true random number is returned. If specified, the

corresponding calculator random number sequence is invoked, and a fixed random number is returned. For
example, executing Ran# 1 after initializing the sequences* always returns random numbers from Sequence
1 in order (0.701320948, 0.9297706456, 0.2939058016, ...)

*　To initialize the sequences, execute Ran# 0. This also initializes the sequences in RanList#. The sequences
can also be initialized by using Ran# or RanList# to generate a series of random numbers that is different
from the last executed series or by generating a true random number.

Random Integer (n to m)      RanInt#(,)
Generates an integer random number between two specified integers n and m.

Syntax: RanInt#(n,m[,a])       n < m, |n| < 1×1010, |m| < 1×1010, m ‒ n < 1×1010, 1 ≤ a ≤ 999
•　a: Specifies the number of random numbers. If omitted, one random number is returned. If specified, returns

the specified number of random numbers in list form.

Random Number (Normal)      RanNorm#(,)
Uses normal distribution to generate a 10-digit random number based on the specified mean μ and standard
deviation σ.

Syntax: RanNorm#(σ,μ[,n])      σ > 0, 1 ≤ n ≤ 999
•　n: Specifies the number of random numbers. If omitted, one random number is returned. If specified, returns

the specified number of random numbers in list form.
Example: To generate a random number of height values obtained according to a normal distribution for a

group of children less than one year old with a mean height of 68 cm. Assume that the standard
deviation is 8: RanNorm#(8,68)

Random Number (Binomial)      RanBin#(,)
Uses binomial distribution based on the specified number of trials n, and the value of probability p to generate
a random integer.

Syntax: RanBin#(n,p[,m])       1 ≤ n ≤ 100000, 1 ≤ m ≤ 999, 0 ≤ p ≤ 1
•　m: Specifies the number of random numbers. If omitted, one random number is returned. If specified, returns

the specified number of random numbers in list form.

Random Num (0 to 1) to List      RanList#()
Each execution returns, in list form, the specified number of random numbers (0 to 1, 10 digits).

Syntax: RanList#(n[,a])       1 ≤ a ≤ 9, 1 ≤ n ≤ 999 (a, n = integers)
•　n: Specifies the number of trials. This parameter specifies the number of random numbers to be generated.
•　a: Same as Ran#.

Example: (Immediately after Ran# 0 is executed) RanList#(3,1) =
{0.701320948,0.9297706456,0.2939058016}

Random Sample from List      RanSamp#(,)
Randomly samples elements from a list and returns the result in list form.

Syntax: RanSamp#(List,n[,m])
•　List: A list variables (List 1 through List 26 or List Ans)* or a list
*　List variables can also be specified using sub-names (page 27).

•　n: Number of trials (1 ≤ n ≤ 999 when m = 0, 1 ≤ n ≤ number of elements in List when m = 1)
•　m: Specifies 0 or 1 (0 when omitted). When m = 0, each element can be extracted multiple times. When m

= 1, each element can be extracted only once.
Example: To extract two random elements from {1,3,6,7}: RanSamp#({1,3,6,7},2,1)

To extract five random elements from {1,3,6,7}: RanSamp#({1,3,6,7},5)
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Numeric Calc

GCD      GCD(,)
Obtains the greatest common divisor of multiple integers.

Syntax: GCD(n,m)

LCM      LCM(,)
Obtains the least common multiple of multiple integers.

Syntax: LCM(n,m)

Absolute Value      Abs()
Finds the absolute value of argument n.

Syntax: |n|       Abs(n)

Integer Part      Int()
Extracts the integer part of argument n.

Syntax: Int(n)
Example: Int(-3.5) = -3

Fraction Part      Frac()
Extracts the fractional part of argument n.

Syntax: Frac(n)
Example: Frac(-3.5) = -0.5

Round Off      Rnd
This function is available on the Calculation tab of the Calculate app. It rounds the value of the last calculation
result (Ans) on the result display in accordance with the S > [Display] setting.

Syntax: Rnd (no argument, valid for previous calculation result only)
Example: While [Display] > [Fix3: 0.123], to divide 10 by 3 and then multiply Ans by 3

Rnd not used: 10*3E
/3E

Rnd used:

10*3E
C > [Numeric Calc] > [Round

Off]E
/3E

•　When the setting is [Display] > [Fix3: 0.123], 10÷3=3.333 is displayed, but 15 digits is retained internally, so
Ans×3=10.000. If the result of 10÷3 is rounded using Rnd as shown, Ans×3=9.999.

Largest Integer      Intg()
Returns the largest integer that does not exceed argument n.

Syntax: Intg(n)
Example: Intg(-10.56) = -11

Round Internal      RndFix()
Rounds argument n to the place following the number of decimal places specified by m (0 to 9).

Syntax: RndFix(n[,m])
•　If m is omitted, rounding is performed in accordance with the S > [Display] setting, the same as with the

Rnd function.
Not allowed within this syntax: d /dx, d2/dx2, ∫dx, Σ, FMin, FMax, Solve, RndFix, logab

Example: RndFix(1.23456,3) = 1.235

Division Remainder      MOD(,)
This function obtains the remainder of a division operation. It returns the remainder when n is divided by m.

Syntax: MOD(n,m)       (n, m = integers)
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Example: MOD(17,3) = 2

Remainder Exponentiation      MOD_Exp(,,)
This function calculates a modular exponent. It returns the remainder when n is multiplied by p power and then
divided by m.

Syntax: MOD_Exp(n,p,m)       (n, p, m = integers)
Example: MOD(2,4,3) = 1

Vector
Vct n and Vct m can be vectors or vector variables.
The vectors listed the example (such as 1 2 ) are entered using T > [m×n]. For details, see “Inputting a
Vector into a Calculation” (page 22).

Note
•　When calculating a dot product, cross product, and angle formed by two vectors, the dimensions of

the two vectors must be the same.

Vector      Vct
Enters “Vct ”. Next, specify a vector variable by entering a letter from A to Z, or Ans.

Dot Product      DotP(,)
Obtains the dot product of two vectors.

Syntax: DotP(Vct n,Vct m)
Example: DotP( 1 2 , 3 4 ) = 11

Cross Product      CrossP(,)
Obtains the cross product of two vectors.

Syntax: CrossP(Vct n,Vct m) (The dimensions of Vct n and Vct m must be 1 × 2, 1 × 3, 2 × 1, or 3 × 1.)
Example: CrossP( 1 2 , 3 4 ) = 0 0 -2

2-Vector Angle      Angle(,)
Obtains the angle between two vectors.

Syntax: Angle(Vct n,Vct m)

Example: When S > [Angle] > [Radian], Angle( 1 1 , -1 1 ) = 12π

Unit Vector      UnitV()
Calculates the unit vector of the vector specified by the argument.

Syntax: UnitV(Vct n)

Example: UnitV( 5 5 ) = 2
2

2
2

Vector Norm      Norm()
Calculates the norm (magnitude) of a specified vector or matrix.

Syntax: Norm(Vct n) ; Norm(Mat n) (Mat n = matrix or matrix variable)

Example: Norm( 1 3 ) = 10 ; Norm(
1 3
2 4

) = 30

Matrix
Mat n and Mat m are matrices or matrix variables.

The matrices shown in the example (such as 
0 -1
1 0

) are entered using T > [m×n]. For details, see “Inputting

a Matrix into a Calculation” (page 25).
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Note
•　Determinants and inverse matrices are subject to error due to dropped digits.
•　The row echelon form and reduced row echelon form operation may not produce accurate results due

to dropped digits.

Matrix      Mat
Enters “Mat ”. Next, enter a letter from A to Z or Ans to specify a matrix variable.

Inverse Matrix     -1

Obtains the inverse of the specified square matrix.
Syntax: Mat n-1

Example: 
0 -1
1 0

-1
 = 

0 1
-1 0

Precautions
•　Calculation precision is affected for matrices whose determinant is near zero.

Determinant      Det()
Obtains the determinant of the specified square matrix.

Syntax: Det(Mat n)

Example: Det(
1 3
2 4

) = -2

Matrix Transpose      Trn()
Obtains the transpose matrix of the specified matrix.

Syntax: Trn(Mat n)

Example: Trn(
1 2
3 4
5 6

) = 
1 3 5
2 4 6

Note
•　The “Trn” command can be used with a vector as well. It converts a 1-row × n-column vector to an
n-row × 1-column vector, or an m-row × 1-column vector to a 1-row × m-column vector.

Matrix Identity      Identity()
Creates an identity matrix with the specified number of rows and columns.

Syntax: Identity(n)       (n = integer)

Example: Identity(2) = 
1 0
0 1

Row Echelon Form      Ref()
This command uses the Gaussian elimination algorithm to find the row echelon form of a matrix.

Syntax: Ref(Mat n)

Example: Ref(
1 2 3
4 5 6

) = 
1 5

4
3
2

0 1 2

Reduced Row Echelon Form      Rref()
Obtains the reduced row echelon form of the specified matrix.

Syntax: Rref(Mat n)

Example: Rref(
1 3 5
2 4 6

) = 
1 0 -1
0 1 2
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Matrix Augment      Augment(,)
Combines two matrices (or vectors), each of which contains the same number of rows, into a single matrix.

Syntax: Augment(Mat m,Mat n) ; Augment(Vct m,Vct n)
•　Either or both of the matrices (Mat m, Mat n) can be replaced with Vct m, Vct n, respectively.

Example: Augment(
1 3
2 4

,
2 6
4 8

) = 
1 3 2 6
2 4 4 8

 ; Augment(
1
2

,
2 6
4 8

) = 
1 2 6
2 4 8

Fill Matrix      Fill(,)
Replaces all elements in a matrix variable (or vector variable) with the specified value m.

Syntax: Fill(m,Mat n) ; Fill(m,Vct n)

Dimensions      Dim()
(1) Obtains the dimensions of a matrix (or vector) and outputs them in list form.

Syntax 1: Dim(Mat n) ; Dim(Vct n)
•　Since the result of the Dim command is a list, it is stored in List Ans.

(2) Specifies dimensions in list form and creates a matrix (or vector) with all zero elements.
Syntax 2: {a,b} → Dim(Mat n)　(a, b = integers, 1 ≤ a ≤ 999, 1 ≤ b ≤ 999) ;

{a,b} → Dim(Vct n)　(a, b = integers, 1 ≤ b ≤ 999 when a = 1, 1 ≤ a ≤ 999 when b = 1)

Complex Number
The letter z in the syntax below represents a complex number. Calculations using Arg, Ir∠θ, and Ia+bi are
affected by the S > [Angle] setting.

Note
•　The calculator regards a complex number in the form a+bi as a coordinate on a Gaussian plane, and

calculates absolute value |z| and argument Arg(z).

Norm of a Complex Number      Abs()
Obtains the absolute value of a complex number.

Syntax: |z|       Abs(z)

Example: |1+i| = 2

Argument      Arg()
Obtains the argument of a complex number.

Syntax: Arg(z)

Example: Arg(1+i) = 14π      (S > [Angle] > [Radian])

Complex Conjugate      Conjg()
Obtains the conjugate complex number.

Syntax: Conjg(z)
Example: Conjg(1+i) = 1−i

Real Part      ReP()
Extracts the real part of a complex number.

Syntax: ReP(z)
Example: ReP(1+2i) = 1

Imaginary Part      ImP()
Extracts the imaginary part of a complex number.

Syntax: ImP(z)
Example: ImP(1+2i) = 2

Ir∠θ      Ir∠θ
Converts a rectangular form value to polar form.
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Syntax: zIr∠θ

Example: 1 + 3iIr∠θ = 2∠1
3π      (S > [Angle] > [Radian])

Ia+bi       Ia+bi
Converts a polar form to rectangular form.

Syntax: zIa+bi

Example: 2∠1
3πIa+bi = 1 + 3i      (S > [Angle] > [Radian])

Statistics
In all of the syntaxes below, “List n” and “List m” are lists or list variables. For list variables, n, m can be a value
from 1 to 26, or Ans. List variables can also be specified using sub-names (page 27).

{}     {}
Inputs curly brackets ( { } ) to enter a new list.

List     List
Inputs “List ”. Following “List ”, input a value from 1 to 26, or Ans to specify a list variable.

Dimensions     Dim()
(1) Determines the number of elements in a list.

Syntax 1: Dim(List n)
(2) Specifies the number of list elements and creates a list variable with zero in all elements.

Syntax 2: Number of Elements a → Dim(List n) (a = integer, 1 ≤ a ≤ 999)

Fill List     Fill(,)
Replaces the values in all elements in a list variable with the same value (a).

Syntax: Fill(a,List n)

Generate Sequence     Seq(,,,,)
Defines a function to generate a number sequence and return it in list form.

Syntax: Seq( f (x),x,Start Value,End Value,Increment)
•　x can be any alpha variable.

Example: Seq(x2,x,1,11,5) = {1,36,121}

Minimum     Min()
Syntax 1: Min(List n) Extracts the minimum value from all elements in a list.
Syntax 2: Min(List n,List m) Extracts the lesser element at the same position in two lists.

Maximum     Max()
Syntax 1: Max(List n) Extracts the maximum value from all elements in a list.
Syntax 2: Max(List n,List m) Extracts the larger element at the same position in two lists.

Mean     Mean()
Finds the mean value of all elements in a list.

Syntax: Mean(List n)

Median     Median()
Finds the median of two lists, one of which is data and the other is frequencies.

Syntax: Median(List n,List m)
•　List n： Data list, List m： Frequency list

The number of elements in List n and List m must be the same.
Example: When List 1 = {36,16,58,46,56}, List 2 = {75,89,98,72,67}, Median(List 1,List 2) = 46

Combine Lists     Augment(,)
Combines two lists into one.

Syntax: Augment(List n,List m)
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Sum of List Elements     Sum()
Finds the sum of all elements in a list.

Syntax: Sum(List n)

List Product     Prod()
Finds the sum product of all the elements in a list.

Syntax: Prod(List n)

Cumulative Frequency     Cuml()
Calculates the cumulative frequency of the elements of a list.

Syntax: Cuml(List n)
Example: When List 1 = {2,3,6,5,4}, Cuml(List 1) = {2,5,11,16,20}

Data Percentages     Percent()
Calculates the percentage of each element relative to the sum of all elements in a list.

Syntax: Percent(List n)

List Data Diff     ΔList
Calculates {Element 2 − Element 1, Element 3 − Element 2, ... Element n − Element n−1} in a list of n (n ≥ 2)
elements and returns the result in list form.

Syntax: ΔList a (a = List variable number)
Note: You can save the result to List 2 by typing “ΔList 1→List 2”.

Estimated x-Data     x
Estimated y-Data     y

These functions are used immediately after performing a regression calculation* with the Statistics app. For a
value specified for one variable (x or y) they, estimate the other variable, based on a regression model.

Syntax: y-value x (Calculates an estimated x-value for the y-value.)
x-value y (Calculates an estimated y-value for the x-value.)

*　Estimated values cannot be calculated for the following types of regression model: Med-Med Regression,
Quadratic Regression, Cubic Regression, Quartic Regression, Sinusoidal Regression, Logarithm
Regression.

Sample Standard Deviation     StdDev()
Finds the sample standard deviation of data specified by a list.

Syntax: StdDev(List n[,List m]) (List n ... Sample data, List m ... Frequency data)
Example: StdDev({10,20,30,40},{3,5,4,1}) = 9.26808696

Population Standard Deviation     StdDev_σ()
Finds the population standard deviation of data specified by a list.

Syntax: StdDev_σ(List n[,List m]) (List n ... Sample data, List m ... Frequency data)

Unbiased Variance     Variance()
Finds the unbiased variance of data specified by a list.

Syntax: Variance(List n[,List m]) (List n ... Sample data, List m ... Frequency data)

Population Variance     Variance_σ2()
Finds the population variance of data specified by a list.

Syntax: Variance_σ2(List n[,List m]) (List n ... Sample data, List m ... Frequency data)

List to Matrix     List→Mat()
Saves list contents to Mat Ans.

Syntax: List→Mat(List n,List m)
(The number of elements in List n and List m must be the same.)

Example: When List 1 = {2,3,4}, List 2 = {20,30,40}, List→Mat(List 1,List 2) = 
2 20
3 30
4 40
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Matrix to List     Mat→List()
Saves the specified columns of a matrix variable to List Ans.

Syntax: Mat→List(Mat n,m)
(n is a letter from A to Z, or Ans, and m is a column number.)

Example: When Mat A = 
2 20
3 30
4 40

, Mat→List(Mat A,1) = {2,3,4}

Note: You can assign the elements of Column 1 of Mat A to List 1 by inputting “Mat→List(Mat A,1)→List 1”.

Distribution: Probability Calculation for Standard Normal Distribution

Attention fx-1AU GRAPH Users
•　The fx-1AU GRAPH does not have a Distribution category, but all commands described in this section

can be called from C > [All].
Example: To call "P()", select C > [All] > [P] > [P()].

Each mathematical function described in this section is intended for use immediately after you perform a
1-Variable statistical calculation with the Statistics app.

Normal Probability P(t)     P()
Normal Probability Q(t)     Q()
Normal Probability R(t)     R()

Taking normalized variable t as an argument, these functions find the probability values for the standard normal
distribution shown in the figures below. The t-value is determined using the function t().

Syntax: P(t) ; Q(t) ; R(t)

P(t)

0 t

Q(t)

0 t

R(t)

0 t

Normal Variable t(x)     t()
Normalized variable t(x) at data value x is determined using the formula below based on the mean x− and
population standard deviation σx, which is obtained as the result of 1-Variable statistical calculation.

t(x) = x − x−
σx

Syntax: t(x)
This function is used in combination with P(), Q(), and R() to find the probability values of the standard normal
distribution.
Example: The height data of 20 students at a university were input with the Statistics app and a 1-Variable

statistical calculation was performed. Determine what percentile does the 180 cm tall student fall.
R(t(180))
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Distribution: Distribution Calculations

Attention fx-1AU GRAPH Users
•　The fx-1AU GRAPH does not have a Distribution category, but all commands described in this section

can be called from C > [All].
Example: To call "NormPD()", select C > [All] > [N] > [NormPD()].

Each function in this section performs a different type of distribution calculation.

Syntax Notes
•　The list below shows the meanings of the symbols and abbreviations in the syntax.
x: data value
Lower: lower boundary
Upper: upper boundary
μ： population mean
σ： population standard deviation (σ > 0)
λ： mean (λ > 0)
p: probability (0 ≤ p ≤ 1)
df : degrees of freedom (df  > 0)

n:df : degrees of freedom of numerator (positive
integer)
d:df : degrees of freedom of denominator (positive
integer)
P: success probability (0 ≤ P ≤ 1)
n: number of trials from population (0 ≤ n integer)
M : number of successes in population (0 ≤ M  integer)
N : population size (n ≤ N  , M  ≤ N  integer)

•　The following values are substituted whenever any of the arguments enclosed in brackets ([ ]) are omitted.
μ=0, σ=1, tail=”L” (Left)

Calculation Result Storage Variables
Variables (p, xInv, x1InvN, x2InvN, zLow, zUp, tLow, tUp) to which the calculation results of each function are
stored can be accessed from C > [Variable Data] > [Distribution].

Normal Probability Density     NormPD()
Returns the normal probability density (p value) for the specified data.

Syntax: NormPD(x[,μ,σ])
•　A single value or a list can be specified for x. Calculation result p is assigned to variables p and Ans (List

Ans when x is a list).
Example: NormPD(1) = 0.2419707245 ; NormPD({0.5,1}) = {0.3520653268,0.2419707245}

Normal Cumulative Dist     NormCD(,)
Returns the normal cumulative distribution (p value) for the specified data.

Syntax: NormCD(Lower,Upper[,μ,σ])
•　Single values or lists can be specified for Lower and Upper. Calculation results p, zLow, and zUp are

assigned respectively to variables p, zLow, and zUp. Calculation result p also is assigned to Ans (List Ans
when Lower and Upper are lists).

Example: NormCD(-1,1) = 0.6826894921 ; NormCD({-1,-2},{1,2}) = {0.6826894921,0.9544997361}

Inverse Normal Cumul Dist     InvNormCD()
Returns the inverse normal cumulative distribution (Lower and/or Upper value(s)) for the specified p-value.

Syntax: InvNormCD([tail,]p[,μ,σ])
•　You can specify Left, Right, or Center for “tail”. To specify the “tail” setting, input the numbers or letters

below.
Left： -1 or ”L” Center： 0 or ”C” Right： 1 or ”R”
•　A single value or a list can be specified for p. Calculation results are output in accordance with the tail

setting as described below.

tail = Left The Upper value is assigned to variables x1InvN and Ans (List Ans when p is a list).
tail = Right The Lower value is assigned to variables x1InvN and Ans (List Ans when p is a list).
tail = Central The Lower and Upper values are assigned respectively to variables x1InvN and

x2InvN. Lower only is assigned to Ans (List Ans when p is a list).

Example: InvNormCD(”L”,0.7,35,2) = 36.04880103
InvNormCD({0.5,0.7},35,2) = {35,36.04880103}
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t Probability Density     tPD(,)
Returns the Student-t probability density (p value) for the specified data.

Syntax: tPD(x,df ) See “PD Syntax” (page 236).
Example: tPD(1,1) = 0.1591549431 ; tPD({0,1},1) = {0.3183098862,0.1591549431}

t Cumulative Distribution     tCD(,,)
Returns the Student-t cumulative distribution (p value) for the specified data.

Syntax: tCD(Lower,Upper,df )
•　Single values or lists can be specified for Lower and Upper. Calculation results p, tLow, and tUp are

assigned respectively to variables p, tLow, and tUp. Calculation result p also is assigned to Ans (List Ans
when Lower and Upper are lists).

Example: tCD(0,1,1) = 0.25 ; tCD({0,0},{1,2},1) = {0.25,0.3524163823}

Inverse t Cumulative Dist     InvTCD(,)
Returns the inverse Student-t cumulative distribution (Lower value) for the specified p value.

Syntax: InvTCD(p,df ) See “Inverse CD Syntax (continuous distributions)”
(page 236).

Example: InvTCD(0.25,1) = 1 ; InvTCD({0.25,0.75},1) = {1,-1}

χ2 Probability Density     ChiPD(,)
Returns the χ2 probability density (p value) for the specified data.

Syntax: ChiPD(x,df ) See “PD Syntax” (page 236).
Example: ChiPD(1,1) = 0.2419707245 ; ChiPD({0,1},1) = {0,0.2419707245}

χ2 Cumulative Distribution     ChiCD(,,)
Returns the χ2 cumulative distribution (p value) for the specified data.

Syntax: ChiCD(Lower,Upper,df ) See “CD Syntax” (page 236).
Example: ChiCD(0,1,1) = 0.6826894921 ; ChiCD({0,0},{1,2},1) = {0.6826894921,0.8427007929}

Inverse χ2 Cumulative Dist     InvChiCD(,)
Returns the inverse χ2 cumulative distribution (Lower value) for the specified p value.

Syntax: InvChiCD(p,df ) See “Inverse CD Syntax (continuous distributions)”
(page 236).

Example: InvChiCD(0.319,1) = 0.9930420738 ; InvChiCD({0.64,0.319},1) = {0.2187421667,0.9930420738}

F Probability Density     FPD(,,)
Returns the F probability density (p value) for the specified data.

Syntax: FPD(x,n:df ,d:df ) See “PD Syntax” (page 236).
Example: FPD(1,1,2) = 0.1924500897 ; FPD({1,2},1,2) = {0.1924500897,0.08838834765}

F Cumulative Distribution     FCD(,,,)
Returns the F cumulative distribution (p value) for the specified data.

Syntax: FCD(Lower,Upper,n:df ,d:df ) See “CD Syntax” (page 236).
Example: FCD(0,1,1,2) = 0.5773502692 ; FCD({0,0},{1,2},1,2) = {0.5773502692,0.7071067812}

Inverse F Cumulative Dist     InvFCD(,,)
Returns the inverse F cumulative distribution (Lower value) for the specified p value.

Syntax: InvFCD(p,n:df ,d:df ) See “Inverse CD Syntax (continuous distributions)”
(page 236).

Example: InvFCD(0.43,1,2) = 0.9625240705 ; InvFCD({0.86,0.43},1,2) = {0.03998368013,0.9625240705}

Binomial Probability     BinomialPD(,)
Returns the binomial probability (p value) for the specified data.

Syntax: BinomialPD([x,]n,P) See “PD Syntax” (page 236).
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Example: BinomialPD(3,5,0.5) = 0.3125 ; BinomialPD({3,5},5,0.5) = {0.3125,0.03125}

Binomial Cumulative Dist     BinomialCD(,)
Returns the binomial cumulative distribution (p value) for the specified data.

Syntax: BinomialCD([[Lower,]Upper,]n,P) See “CD Syntax” (page 236).
Example: BinomialCD(5,10,0.5) = 0.623046875 ; BinomialCD({0,5},{5,8},10,0.5) =

{0.623046875,0.6123046875}

Inverse Binomial Cumulative Dist     InvBinomialCD(,,)
Returns the inverse binomial cumulative distribution for the specified p value.

Syntax: InvBinomialCD(p,n,P) See “Inverse CD Syntax (discrete distributions)”
(page 236).

Example: InvBinomialCD(0.6,10,0.5) = 5 ; InvBinomialCD({0.6,0.3},10,0.5) = {5,4}

Precautions
•　When executing the Inverse Binomial Cumulative Distribution calculation, the calculator uses the

specified p value and the value that is one less than the p value minimum number of significant digits
(p’ value) to calculate minimum number of trials values. The results are assigned to variables xInv
(calculation result using p) and *xInv (calculation result using p’). The calculator always displays
the xInv value only. However, when the xInv and *xInv values are different, the message shown
below will appear with both values.

p value

p’ value

The calculation results of Inverse Binomial Cumulative Distribution are integers. Accuracy may be
reduced when the p value has 10 or more digits. Note that even a slight difference in calculation
accuracy affects calculation results. If a warning message appears, check the displayed values.

Poisson Probability     PoissonPD(,)
Returns the Poisson probability (p value) for the specified data.

Syntax: PoissonPD(x,λ) See “PD Syntax” (page 236).
Example: PoissonPD(1,1.2) = 0.3614330543 ; PoissonPD({1,2},1.2) = {0.3614330543,0.2168598326}

Poisson Cumulative Dist     PoissonCD(,)
Returns the Poisson cumulative distribution (p value) for the specified data.

Syntax: PoissonCD([Lower,]Upper,λ) See “CD Syntax” (page 236).
•　If Lower is omitted, Lower = 0 is assumed.

Example: PoissonCD(1,2,1.2) = 0.5782928869 ; PoissonCD({1,1},{2,3},1.2) = {0.5782928869,0.6650368199}

Inverse Poisson Cumul Dist     InvPoissonCD(,)
Returns the inverse Poisson cumulative distribution for the specified p value.

Syntax: InvPoissonCD(p,λ) See “Inverse CD Syntax (discrete distributions)”
(page 236).

Example: InvPoissonCD(0.58,1.2) = 1 ; InvPoissonCD({0.58,0.75},1.2) = {1,2}
Precautions are the same as those for “Inverse Binomial Cumulative Dist” (page 235).

Geometric Probability     GeoPD(,)
Returns the geometric probability (p value) for the specified data.

Syntax: GeoPD(x,P) See “PD Syntax” (page 236).

235



Example: GeoPD(2,0.8) = 0.16 ; GeoPD({2,3},0.8) = {0.16,0.032}

Geometric Cumulative Dist     GeoCD(,)
Returns the geometric cumulative distribution (p value) for the specified data.

Syntax: GeoCD([Lower,]Upper,P) See “CD Syntax” (page 236).
•　If Lower is omitted, Lower = 0 is assumed.

Example: GeoCD(1,2,0.8) = 0.96 ; GeoCD({1,1},{2,3},0.8) = {0.96,0.992}

Inverse Geometric Cumul Dist     InvGeoCD(,)
Returns the inverse geometric cumulative distribution for the specified p value.

Syntax: InvGeoCD(p,P) See “Inverse CD Syntax (discrete distributions)”
(page 236).

Example: InvGeoCD(0.96,0.8) = 2 ; InvGeoCD({0.96,0.992},0.8) = {2,3}
Precautions are the same as those for “Inverse Binomial Cumulative Dist” (page 235).

Hypergeometric Probability     HypergeoPD(,,,)
Returns the hypergeometric probability (p value) for the specified data.

Syntax: HypergeoPD(x,n,M ,N) See “PD Syntax” (page 236).
Example: HypergeoPD(1,5,10,20) = 0.1354489164 ; HypergeoPD({1,2},5,10,20) =

{0.1354489164,0.3482972136}

Hypergeometric Cumul Dist     HypergeoCD(,,,)
Returns the hypergeometric cumulative distribution (p value) for the specified data.

Syntax: HypergeoCD([Lower,]Upper,n,M ,N) See “CD Syntax” (page 236).
•　If Lower is omitted, Lower = 0 is assumed.

Example: HypergeoCD(1,2,5,10,20) = 0.48374613 ; HypergeoCD({1,1},{2,3},5,10,20) =
{0.48374613,0.8320433437}

Inverse Hypergeo Cumul Dist     InvHypergeoCD(,,,)
Returns the inverse hypergeometric cumulative distribution for the specified p value.

Syntax: InvHypergeoCD(p,n,M ,N) See “Inverse CD Syntax (discrete distributions)”
(page 236).

Example: InvHypergeoCD(0.48,5,10,20) = 2 ; InvHypergeoCD({0.48,0.83},5,10,20) = {2,3}
Precautions are the same as those for “Inverse Binomial Cumulative Dist” (page 235).

Syntax and description
Syntax Description

PD Syntax A single value or a list can be specified for x. Calculation result p is assigned to
variables p and Ans (List Ans when x is a list).

CD Syntax Single values or lists can be specified for Lower and Upper. Calculation result p
is assigned to variables p and Ans (List Ans when Lower and Upper are lists).

Inverse CD Syntax
(continuous distributions)

A single value or a list can be specified for p. The Lower value is assigned to the
xInv and Ans variables (List Ans when p is a list).

Inverse CD Syntax
(discrete distributions)

A single value or a list can be specified for p. The calculation result X value is
assigned to the xInv and Ans variables (List Ans when p is a list).
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Angle/Coord/Sexa

Degrees     °
Specifies degrees as the angle unit.

Syntax: n°

Example: When S > [Angle] > [Radian], 90° = 12π

Radians      r

Specifies radians as the angular unit.
Syntax: nr

Example: When S > [Angle] > [Degree], π2
r = 90

Gradians      g

Specifies gradians as the angle unit.
Syntax: ng

Example: When S > [Angle] > [Degree], 100g = 90

Rectangular to Polar     Pol(,)
Converts rectangular coordinate values to polar coordinates and returns them in list form.

Syntax: Pol(x,y) = (r,θ)
•　The resulting polar coordinates θ are displayed in the range as follows, depending on the S > [Angle]

setting.
Degree: -180 < θ ≤ 180 Radian: -π < θ ≤ π Gradian: -200 < θ ≤ 200

Example: When S > [Angle] > [Radian], Pol( 2, 2) = {2,14π}

Polar to Rectangular     Rec(,)
Converts polar coordinate values to rectangular coordinates and returns them in list form.

Syntax: Rec(r,θ) = (x,y)

Example: When S > [Angle] > [Radian], Rec(2,14π) = { 2, 2}

Degs Mins Secs     °
Inputs a sexagesimal value.

Syntax: Degree Value°[Minute Value°[Seconds Value°]]
Example: 1°15° = 1.25 ; 0°75° = 1.25 ; 0°15° = 0.25 ; 0°0°900° = 0.25
Note: To display calculation results as sexagesimal values, select sF > [Sexagesimal]. For more
information, see “Changing the Display Format of Calculation Results (Format Menu)” (page 17).

Decimal to Sexagesimal     IDMS
Converts a decimal value to a sexagesimal value (degrees (hours), minutes, seconds).

Syntax: nIDMS
Example: 1.25IDMS = 1°15’00”

Hyperbolic Calc
Hyperbolic and inverse hyperbolic functions can be input using the menu items below.

Menu item Function
sinh sinh()
cosh cosh()
tanh tanh()

Menu item Function
sinh−1 sinh−1()
cosh−1 cosh−1()
tanh−1 tanh−1()

Example: sinh(1) = 1.175201194 ; sinh−1(Ans) = 1
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Engineer Symbol
Engineering symbols can be input using the menu items below.

Menu item Symbol 10n

Milli m 10−3

Micro μ 10−6

Nano n 10−9

Pico p 10−12

Femto f 10−15

Menu item Symbol 10n

Kilo k 103

Mega M 106

Giga G 109

Tera T 1012

Peta P 1015

Exa E 1018

•　Appending an engineering symbol immediately after a value causes the value to be 10n (where n is an integer
multiple of 3).

Example: 7.1k = 7100 ; 2G÷100M = 20
Note: To display calculation results with engineering symbols, turn on S > [Display] > [Engineer Symbol]. For
details, see “Display (General)” (page 218).
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Unit Conversions
Converts a value of one unit to a different unit.
Syntax: n unit command  unit command (n= real number or list of real numbers)
•　The two unit commands are linked with “ ” and used as a single unit conversion command. The two unit

commands must be from the same category. Refer to the “Unit Command List” below for available unit
commands.

Example: 25.4 [cm]  [in] = 10 ; {175,162} [m2]  [ha] = {0.0175,0.0162}

Unit Command List

Category Unit Command
Length [fm]

[Å]
[μm]
[mm]
[cm]
[m]
[km]
[AU]
[l.y.]
[pc]
[Mil]
[in]
[ft]
[yd]
[fath]
[rd]
[mile]
[n mile]

Area [cm2]

[m2]
[ha]

[km2]

[in2]

[ft2]

[yd2]
[acre]

[mile2]
Volume [cm3]

[mL]
[L]

[m3]

[in3]

[ft3]
[fl_oz(UK)]
[fl_oz(US)]

Category Unit Command
Volume [gal(US)]

[gal(UK)]
[pt]
[qt]
[tsp]
[tbsp]
[cup]

Time [ns]
[μs]
[ms]
[s]
[min]
[h]
[day]
[week]
[yr]
[s-yr]
[t-yr]

Temperature [°C]
[K]
[°F]
[°R]

Velocity [m/s]
[km/h]
[knot]
[ft/s]
[mile/h]

Mass [u]
[mg]
[g]
[kg]
[mton]
[oz]
[lb]
[slug]
[ton(short)]

Category Unit Command
Mass [ton(long)]
Force [N]

[lbf]
[tonf]
[dyne]
[kgf]

Pressure [Pa]
[kPa]
[mmH2O]

[mmHg]
[atm]
[inH2O]

[inHg]

[lbf/in2]
[bar]

[kgf/cm2]
Energy [eV]

[J]
[calth]

[cal15]

[calIT]

[kcalth]

[kcal15]

[kcalIT]

[l-atm]
[kW･h]
[ft･lbf]
[Btu]
[erg]
[kgf･m]

Power [W]
[calth/s]

[hp]
[ft･lbf/s]
[Btu/min]
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Variable Data
The Variable Data category contains variables that store input and output values of each app. The menu items
that appear when you select C > [Variable Data] are app names.

Variable Data > Statistics
Variables in this category store input values and calculation results for statistical calculations performed and
graphs drawn using the Statistics app.

Statistics > X
Single-variable or paired-variable statistical calculation x-data values:

Menu item Variable
Data Items n
Data x Mean x−

Data x Sum Σx

x-Data Sum of Squares Σx2

Menu item Variable
x-Data Population Std Dev σx
x-Data Sample Std Dev sx
X-Data Minimum minX
X-Data Maximum maxX

Statistics > Y
Paired-variable statistical calculation y-data values:

Menu item Variable
Data y Mean y−

Data y Sum Σy
y-Data Sum of Squares Σy2

xy-Data Products Sum Σxy

Menu item Variable
y-Data Population Std Dev σy
y-Data Sample Std Dev sy
Y-Data Minimum minY
Y-Data Maximum maxY

Statistics > Graph
Regression model information values:

Menu item Variable
a Regression Coefficient a
b Regression Coefficient b
c Regression Coefficient c
d Regression Coefficient d

Menu item Variable
e Regression Coefficient e
Correlation Coefficient r

Coefficient of Determination r2

Error Mean Square MSe

Single-variable statistical calculation output values:

Menu item Variable
1st Quartile Q1

Input Data Median Med

Menu item Variable
3rd Quartile Q3

Input Data Mode Mod
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Statistics > Point Coordinates
Coordinates of summary points when Med-Med Regression is performed:

Menu item Variable
Summary Point Coords x1 x1

Summary Point Coords x2 x2

Summary Point Coords x3 x3

Menu item Variable
Summary Point Coords y1 y1

Summary Point Coords y2 y2

Summary Point Coords y3 y3

Statistics > Input
Statistical calculation input values:

Menu item Variable
Sample Size n
Sample Mean x−

Sample Standard Deviation sx
Sample 1 Size n1
Sample 2 Size n2

Menu item Variable
Sample 1 Mean x−1
Sample 2 Mean x−2
Sample 1 Standard Deviation sx1
Sample 2 Standard Deviation sx2
Sample p Standard Deviation sp

Statistics > Result > Test
Test calculation results:

Menu item Variable
p p
z z
t t

χ2 χ2

F F
Estimated Sample Proportion p
Estim Sample 1 Proportion p1
Estim Sample 2 Proportion p2
Degree of Freedom df
Standard Error se
Correlation Coefficient r

Coefficient of Determination r2

p Value of Factor A pa
F Value of Factor A Fa
Factor A Degrees of Freedom Adf

Menu item Variable
Factor A Sum of Squares SSa
Factor A Mean Squares MSa
p Value of Factor B pb
F Value of Factor B Fb
Factor B Degrees of Freedom Bdf
Factor B Sum of Squares SSb
Factor B Mean Squares MSb
Factor AB p Value pab
Factor AB F Value Fab
Factor AB Deg of Freedom ABdf
Factor AB Sum of Squares SSab
Factor AB Mean Squares MSab
Error Degrees of Freedom Edf
Error Sum of Squares SSe
Error Mean Square MSe

Statistics > Result > Confidence Interval
Confidence interval calculation results:

Menu item Variable
Confidence Int Lower Limit Lower
Confidence Int Upper Limit Upper
Estimated Sample Proportion p

Menu item Variable
Estim Sample 1 Proportion p1
Estim Sample 2 Proportion p2
Degree of Freedom df
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Variable Data > Distribution
Variables in this category store the results of distribution calculations performed using the Distribution app.

Menu item Variable
p p
x Inverse xInv
x1 Inverse x1InvN
x2 Inverse x2InvN

Menu item Variable
Normal Cumulative Dist Lower zLow
Normal Cumulative Dist Upper zUp
t Cumulative Dist Lower tLow
t Cumulative Dist Upper tUp

Variable Data > Table
Menu item Variable Description

Function Table Result F Result Outputs the Graph&Table app’s Table tab contents in
matrix form.

Variable Data > Recursion
Menu item Variable Description

Recursion Table Result R Result Outputs the Recursion app’s Table tab contents in
matrix form.

Variable Data > Equation
Variables in this category store input values and calculation results for higher-order equations or simultaneous
equations solved using the Equation app.

Menu item Variable Description

Hi-Ord Coeff Ply Coef Outputs higher-order equation input coefficients in
matrix form.

Hi-Ord Solutions Ply Result Outputs higher-order equation calculation results in
matrix form.

Linear Coeffs Sim Coef Outputs simultaneous equation input coefficients in
matrix form.

Linear Solutions Sim Result Outputs simultaneous equation calculation results in
matrix form.

All > A to Z
C > [All] displays an alphabetized list of all the calculator’s functions, commands, and app variables. For
details, see “Catalog Menu Details” (page 221).
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All > Symbol
This menu includes the function and symbols in the table below.

 3 () ! ∠ E (Engineer Symbol)

10^() ° (Degrees) : P (Engineer Symbol)

{  r (Radians) T (Engineer Symbol)

}  g (Gradians) = G (Engineer Symbol)

≠ ° $ M (Engineer Symbol)

<  () , k (Engineer Symbol)

>  x ( m (Engineer Symbol)

≤ −1 ) μ (Engineer Symbol)
≥ 2 [ n (Engineer Symbol)
” ＾ ] p (Engineer Symbol)
~  (Sci Notation) f (Engineer Symbol)

π -  (Sci Notation)  
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Appendix

Using CSV Files
You can save the data stored in the list variables, matrix variables or the Spreadsheet app as CSV files. You
can also load CSV files saved in the Storage Memory of the calculator into list or matrix variables, or into the
Spreadsheet app.

Important!
•　Storage Memory (page 196) is used as the memory area for saving and importing CSV files.
•　When saving and importing CSV files, take care to specify the delimiter and decimal point. For details,

see “Specifying the CSV File Import and Export Format (CSV Format)” (page 201).

Import CSV File Requirements
A CSV file that has been output from the Calculate app, Statistics app, Spreadsheet app, or a CSV file
transferred from a computer to Storage Memory can be used for import. The following types of CSV files are
supported for import.
•　A CSV file that uses the comma ( , ) or semi-colon ( ; ) as its delimiter, and the period ( . ) or comma ( , ) as

its decimal point. A CSV file that uses the tab as its delimiter is not supported.
•　CR, LF and CRLF are supported for the line break code.
•　When importing a CSV file to the calculator, if the data in Line 1 of each column of the file (or Line 1 of Column

1 of the file) is a character string enclosed with double quotation marks ( " ) or single quotation marks ( ’ ),
Line 1 of all of the columns of the CSV file will be ignored, and data will be input starting from Line 2.

•　A CSV file name can have up to eight single-byte characters.

Exporting to and Importing From a CSV File

Important!
•　When saving matrix variables, list variables or the Spreadsheet app data to a CSV file, some data is

converted as described below.
-　Fraction data: Converted to calculation line format (Example: 2 3 4 → =2+3/4)
-　  and π data: Converted to a decimal value (Example: 5 → 2.236067977)

•　When a matrix or list variable is saved as a CSV file, the imaginary part of complex number data stored
by the variable is omitted. This means only the real part is saved.

•　Attempting to import the following types of CSV files will result in an error.
-　A CSV file containing data (expression or string) that cannot be converted. In this case, an error

message will appear showing the location in the CSV file (Example: row 2, column 3) where the
data that cannot be converted is located.

-　A CSV file with more than 999 columns or 999 rows into a matrix variable.
A CSV file with more than 26 columns or 999 rows into a list variable or a spreadsheet.
In this case, an “Invalid Data Size” error will occur.

To save matrix variables to a CSV file (Calculate app)
1.　Display the Calculate app’s Matrix tab.

2.　Highlight the matrix variable you want to save to a CSV file and then select T > [CSV] > [Save As].
•　This displays a dialog you can use to select a folder to save the data.

3.　Use the operation below to select the save destination folder.

To select this folder: Perform this operation:
Root directory Highlight ROOT and then press O.
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Other folders (1)　 Highlight the folder you want to select and then press O. This will
take you into the selected folder.

(2)　 Highlight the folder’s name and then press O again.

4.　Use the dialog that appears to input up to eight characters for the file name and then press O.

To import a CSV file into a matrix variable (Calculate app)
1.　Display the Calculate app’s Matrix tab.

2.　Highlight the matrix variable into which you want to import the CSV file.
•　If the matrix variable you highlighted already contains data, the next step will cause the existing data to

be overwritten.

3.　Select T > [CSV] > [Load].

4.　On the dialog that appears, highlight the CSV file you want to import and then press O.

To save a list variable to a CSV file (Statistics app)
The operation below saves the contents of the currently open List Files (page 32) (all list variables on List
Editor) as a CSV file.

1.　Display the Statistics app’s List Editor tab.

2.　Select T > [CSV] > [Save As].
•　This displays a dialog you can use to select a folder to save the data.

3.　Use the operation below to select the save destination folder.

To select this folder: Perform this operation:
Root directory Highlight ROOT and then press O.
Other folders (1)　 Highlight the folder you want to select and then press O. This will

take you into the selected folder.
(2)　 Highlight the folder’s name and then press O again.

4.　Use the dialog that appears to input up to eight characters for the file name and then press O.

To import a CSV file into List Editor (Statistics app)
1.　Display the Statistics app’s List Editor tab.

2.　Depending on the method you want to use to import the CSV file, perform one of the operations below.

To do this: Select this menu item:
Start importing from a specific
column

T > [CSV] > [Load] > [List]

Overwrite all current List Editor
contents

T > [CSV] > [Load] > [File]

3.　On the dialog that appears, highlight the CSV file you want to import and then press O.
•　If you chose [List] in step 2 above, import starts from the column that contains the cell where the cursor is

currently located. The columns on List Editor are overwritten by the number of columns contained in the
CSV file.

To save a spreadsheet to a CSV file (Spreadsheet app)
1.　Display the Spreadsheet app’s Spreadsheet tab.

2.　If required, select T > [Recalculate] to recalculate the spreadsheet contents.
•　Note that recalculation is not performed automatically when you save spreadsheet contents to a CSV file.

Be sure to perform recalculation if the spreadsheet contains a formula, which starts with an equals symbol
(=).

•　Formulas are not saved to the CSV file. Only calculation results are saved.
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•　All ERROR cell data on the spreadsheet is saved as blank data.

3.　Select T > [CSV] > [Save As].
•　This displays a dialog you can use to select a folder to save the data.
•　For the remainder of this procedure, perform the steps from step 3 under “To save matrix variables to a

CSV file (Calculate app)” (page 244).

To import a CSV file into a spreadsheet (Spreadsheet app)
1.　Display the Spreadsheet app’s Spreadsheet tab.

2.　Select T > [CSV] > [Load].

3.　On the dialog that appears, highlight the CSV file you want to import and then press O.
•　This imports the contents of the CSV file you specified to the spreadsheet.

Calculation Priority Sequence
The calculator performs calculations according to a calculation priority sequence.
•　Basically, calculations are performed from left to right.
•　Expressions within parentheses have the highest priority.
•　The following shows the priority sequence for each individual command.

1 Parenthetical expressions
2 Type A functions

-　Functions that take arguments within parentheses: sin(), log(), d/dx(), etc.
-　Prefixes for list, matrix, and vector variables: List, Mat, Vct
-　Composite functions (page 77)： yn, rn, Xtn, Ytn, Xn (n: 1-20)

3 Type B functions (functions that come after the input value)
-　x2, x-1, x!, ° ’ ”, °, r, g
-　engineering symbols

4 powers ( ), roots ( )
5 Fractions
6 Implied multiplication format in front of π, memory name, or variable name: 2π, 5A, etc.
7 Negative sign ((-))

Type C functions (functions that come before the input value)
-　List calculation function (Δlist)
-　Base Prefix (d, h, b, o)

8 Implied multiplication format in front of Type A functions, Type C functions, and parenthesis: 2 3,
A log(2), etc.

9 Permutation (nPr), combination (nCr), complex number polar coordinate symbol (∠)
10 Metric conversion commands
11 × , ÷, Int÷, Rmdr
12 +, –
13 Relational operators: =, ≠, >, <, ≥, ≤
14 And (logical operator), and (bitwise operator)
15 Or, Xor (logical operator), or, xor, xnor (bitwise operator)

Note
•　When functions with the same priority are used in series, execution is performed from right to left.
•　Compound functions are executed from right to left.
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•　If a calculation contains a negative value, you may need to enclose the negative value in parentheses.
If you want to square the value -2, for example, you need to input: (-2)2. This is because x2 is a function
preceded by a value (Priority 3, above), whose priority is greater than the negative sign, which is a
prefix symbol (Priority 7).

Example: s-(M)2iE                  -22 = -4
(s-(M)2)iE     (-2)2 = 4

•　The data that is input when you press the k key depends on the current S > [ Key] (page 219)
setting. Calculation priority depends on the syntax of the formula that is input. Because of this,
changing the above setting may affect calculation results even if the formula is input using identical
key operations.
Example: 100*2k2E
S > [ Key] > [  (Power)]:

100 ÷ 2 calculation priority is higher, so the result is
(100 ÷ 2) × 102 = 5000.

S > [ Key] > [  (Sci Notation)] or [  (Sci Notation)]:

2 × 102 calculation priority is higher, so the result is
100 ÷ (2 × 102) = 0.5.

Error Message Table
General calculation errors
When you see this
message:

It means this: So you need to do this:

Syntax ERROR There is a problem with the format of the
calculation you are performing.

Make necessary corrections.

Math ERROR •　Calculation result that exceeds the
calculation range.

•　Intermediate or final calculation result is
outside the allowable calculation range.

•　Mathematical error (division by zero, etc.)

Check input values and make corrections
to ensure that values are within allowable
limits.

Stack ERROR The calculation you are performing has
caused the capacity of the numeric stack
or the command stack to be exceeded.

Simplify the calculation expression so it
does not exceed the capacity of the stack.

The calculation you are performing has
caused the capacity of the matrix or vector
stack to be exceeded.

Try splitting the calculation into two or more
parts.

Input value must be
integer

Attempting to input a non-integer value in
a location that requires integer input.

Input an integer value.

Input value must be
a matrix

Attempting to input a non-matrix value in a
location that requires matrix input.

Input a matrix value.

Input value must be
a matrix or vector 

Attempt to input a non-matrix or non-vector
value in a location where a matrix or vector
should be input.

Input a matrix or vector.

Input value must be
a list

Attempting to input a non-list value in a
location that requires list input.

Input a list value.

Input value must be
a real number

Attempting to input a non-real number
value in a location that requires real
number input.

Input a real number value.

Invalid Polar Form Attempting to input an imaginary number
for polar form (r∠θ) r or θ.

Check the polar form.
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Wrong argument
size relationship.

The size relationship between two
arguments is opposite from what it should
be.
Example: 3C10

Change the values so the size relationship
required by the syntax is maintained.

Non-Real ERROR Calculation that produces a complex
number when S > [Complex Mode]
> [Real] is specified, even though the
argument is a real number.

Change the [Complex Mode] setting to
something other than [Real].

Can’t Simplify Fraction simplification was attempted
using the ISimp function (page 223), but
simplification could not be performed using
the specified divisor. Example: Specifying
a divisor of 3 to simplify the fraction 4/8.

Specify a different divisor or execute
ISimp without specifying any divisor.

Can’t Solve! Adjust
initial value or
bounds. Then try
again.

A Solve calculation could not obtain a
solution within the specified initial default
estimated value.

Change the specified initial default
estimated value or correct the input
expression.

Time Out A Solve calculation was unable to satisfy
convergence conditions.

If you are performing a Solve calculation,
try changing the initial default estimated
value closer to the expected solution.

Conversion ERROR •　Attempting to use the unit conversion
command to convert between two units
in different categories.

•　Executing a conversion calculation using
the same command twice in a conversion
expression.

In a conversion expression, specify two
different commands that are in the same
category.

Invalid Type An illegal data type is specified. Specify valid data.

List, matrix, and vector calculation errors
When you see this
message:

It means this: So you need to do this:

Invalid list, matrix or
vector

Incorrect use of a list, matrix, or vector. Press b to display the location of an error
and make necessary corrections.

Dimension ERROR Illegal dimension used during matrix,
vector, or list calculations.

Check the matrix, vector, or list dimension.

Complex Number In
List

List containing complex number used in a
calculation or operation for which complex
number data is invalid.

Change all elements in the list to real
numbers.

Complex Number In
Matrix

Matrix containing complex number used
in a calculation or operation for which
complex number data is invalid.

Change all elements in the matrix to real
numbers.

Complex Number In
Matrix or Vector

Matrix or vector containing complex
number used in a calculation or operation
for which complex number data is invalid.

Change all elements in the matrix or vector
to real numbers.

Improper Number of
Elements

You attempted to create a list, matrix, or
vector whose number of elements exceeds
the maximum limit.

A list cannot have more than 999 elements,
and a matrix cannot exceed 999 rows ×
999 columns. For vector elements, specify
within 1 row × 999 columns or 999 rows ×
1 column.
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Equation app errors
When you see this
message:

It means this: So you need to do this:

Infinitely Many
Solutions

An infinite number of solutions for
simultaneous linear equations. –

No Solution No solution for simultaneous linear
equations. –

No Variable No variable within a Solver (page 116)
equation.

Input an equation that includes a variable.

Graph&Table, Recursion, Dyna Graph, Conic Graphs app errors
When you see this
message:

It means this: So you need to do this:

Range ERROR View Window range settings exceeded
when a graph is drawn.

Redraw using the proper View Window
settings.

Circular ERROR The two recursion formulas that were input
cross-reference each other.

Edit the recursion formulas to resolve
the cross-referencing. For details, see the
Note under “To input or edit a recursion
formula” (page 109).

No Variable No variable specified within a function
being used for dynamic graphing in the
Dyna Graph app.

Specify a variable for the graph function.

No item is selected Attempting to draw a graph or create a
table while there is no data selected.

Select data and try again.

Equation does not
have a parameter.

You attempted to execute a Modify
function operation while no expression that
contains a variable is selected.

Select at least one and only one expression
that contains a variable.

Condition ERROR You attempted to execute a Modify
operation while multiple expressions
containing variables are selected.

Expression in use Attempting to copy the expression of a
graph while Modify is running to an area
where an expression that is being used for
graphing is located.

Select a different area and try again.

Too Many Variables Attempting to execute the Modify function
using an expression with more than five
variables.

Change the expression so it contains no
more than five variables.

Invalid Graph Type •　You selected one of the mathematical
function expressions ((a) through (d))
in the Graph&Table app and tried to
execute T > [Modify].

•　You selected one of the mathematical
function expressions ((a) through (d)) in
the Graph&Table app and attempted to
create a number table.
(a)　 Function expression containing

alpha variables, with specification
of values assigned to the variables
(Example: y=Ax − 1,[A=1,2,3])

(b)　 Function expression containing a list
(Example: y={1,2,3}x)

(c)　 Function expression with a range of
variables (Example: y=x,[0,2])

Choose another type of function and try
again.
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(d)　 Inequality (Example: y>sin(x))

Too Many Sectors You attempted to perform a calculation
using [∫dx] > [Root], [∫dx] > [Intersection], or
[∫dx] > [Mixed] with graph analysis (Graph
Solve), but there are 21 or more roots (or
intersections) within the specified range.

Specify a range that is narrower and try
again.

Statistics app errors
When you see this
message:

It means this: So you need to do this:

Condition ERROR You are attempting to display multiple
statistical graphs of different types.

See “Drawing Graphs Using Multiple
Graph Setups” (page 42).

Data is in use Use the dialog that appears after you select
T > [Save Residuals in List] or T >
[Save Result in List] to make the list you
are currently using the save destination.

Specify the number of an empty list.

Spreadsheet app errors
When you see this
message:

It means this: So you need to do this:

Range ERROR The spreadsheet cell range was exceeded
by paste, recall, or other cell operation.

Repeat the procedure taking care that the
cell range is not exceeded.

Circular ERROR There is a circular reference (such as “=A1”
in cell A1) in the spreadsheet.

Change cell contents to remove the circular
references.

Memory app errors
When you see this
message:

It means this: So you need to do this:

Memory ERROR Calculation or memory storage operation
exceeds remaining memory capacity.

•　Simplify the data you are trying to store
to keep it within the available memory
capacity.

•　Delete no longer needed data to make
room for the new data.

Folder has over 200
files. Some will be
skipped. 

The number of files in the storage memory
folder you are trying to open in the Memory
app exceeds 200.

Use your computer (page 210) to distribute
the files among multiple folders so no folder
in storage memory contains more than 200
files.

Sub-folders in this
folder cannot be
displayed. 

In the Memory app, a level 3 nested
storage memory folder is displayed, and
it contains a level 4 nested folder. (The
level 4 folder will be displayed, but it cannot
be opened.)

Use your computer (page 210) to store all
files you want to access in the top three
folder nesting levels.

Too Much Data The number of data items is too large. Delete unneeded data.
Invalid Name The file name you input includes invalid

characters.
Use the correct characters to input a valid
file name.

Invalid Type An illegal data type is specified. Specify valid data.
Storage Memory
Full

The storage memory is full. Delete unneeded data.

Data ERROR A data error occurred. Check to make sure you are writing correct
type of data and try again.

Memory Full You attempted to load a g4m file into the
main memory, but there is not enough
space available.

Delete no longer needed data to make
room for loading g4m files.
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File System ERROR After establishing a connection between
the calculator and a computer, the
calculator memory has been accidentally
formatted by an operation from the
computer. This message appears when
the USB cable is disconnected following
formatting.

Formatting deletes all data remaining in
calculator memory. See “If you accidentally
format calculator memory” (page 251) for
what you need to do.

The memory area has been fatally
corrupted due an electronic component in
the device reaching the end of its service
life, or some other reason.

From the menu that appears along with
the message, select [Initialize All] and
then press O. If this does not resolve
the problem, contact your retailer or your
nearest CASIO service center.

If you accidentally format calculator memory
If the calculator displays the File System ERROR message because its memory was accidentally formatted,
you need to initialize the calculator.

Perform one of the operations shown in the table below.

To do this: Perform this operation:
If you transferred data to the calculator
after executing the formatting operation,
save the transferred data to your computer
before initializing the calculator.

(1)　 Highlight [Save data to PC] and then press O.
(2)　 Perform the operations under “Connecting the Calculator

to a Computer” (page 210) to save calculator data to
your computer and then disconnect the calculator from the
computer.
•　This causes the calculator to display the File System

ERROR message again.
(3)　 Highlight [Initialize All] and then press O.

Initialize the calculator, which discards all
data remaining in its memory.

Highlight [Initialize All] and then press O.

Data communication errors
When you see this
message:

It means this: So you need to do this:

CSV error in row [A]
or column [B]

The imported CSV file included data that
cannot be converted.

Use your computer to check the row A,
column B data in the file and change it to
data that can be converted.

USB Connect
ERROR

USB cable connection broken during data
communication.

Use the USB cable to correctly connect the
calculator and computer.

3D Graph app errors
When you see this
message:

It means this: So you need to do this:

No item is selected Attempting to draw a graph while there is
no data selected.

Select data and try again.

Intersection requires
two or more objects. 
(fx-CG100 only)

You tried to determine a point of
intersection without first using the Line

Use the Line template or Plane template to
draw multiple 3D graphs and try again.

251



template or Plane template to draw multiple
3D graphs.

Relationship
requires two or more
objects. 
(fx-CG100 only)

You tried to determine relationship without
first using the Line template or Plane
template to draw multiple 3D graphs.

Use the Line template or Plane template to
draw multiple 3D graphs and try again.

Geometry app errors
When you see this
message:

It means this: So you need to do this:

First select a
segment. 

You are attempting to construct a
perpendicular bisector without first
selecting a line segment.

Select the required object(s) and then try
again.

First select a line
and point. 

You are attempting to construct a
perpendicular or parallel without first
selecting a line segment and point.

First select 2 points
or a segment. 

You are trying to construct a midpoint
without first selecting two points or a line
segment.

First select the
applicable figure. 

•　You are trying to construct a point of
intersection without first selecting two
lines.

•　You are trying to execute T > [Animate]
> [Add Animation] or [Replace Animation]
without first selecting the required object.

•　You are trying to execute T > [Animate]
> [Add Table] without first selecting the
required object.

First select 2
segments. 

You are trying to construct an angle
bisector without first selecting two line
segments.

Range ERROR View Window range settings exceeded. Press F (Zoom to Fit) or select T
> [View] > [View Window] > [Pre-set
Windows] > [Initialize].

You are trying to specify t0 = t1 on the Edit
Animations screen.

Specify different values for t0 and t1.

Too Many Objects! Work memory became almost full. Delete objects you no longer need or open
a new file.

Too Many Objects!
Work memory
cleared. 

Work memory became full. Delete objects you no longer need or open
a new file.

Invalid
Measurement

You are attempting to use the Expression
command (T > [Option] > [Expression])
to input an expression that contains a
measurement that does not exist.

Check to make sure that the
expression you are inputting contains only
measurements that are currently on the
screen.

Too Many
Animations

You are trying to add more than 10
animations.

Use the Edit Animations screen to delete
animations you no longer need, or create a
new file and add new animations.

First select point(s). You are trying to execute T > [Animate]
> [Trace] without first selecting a point.

Select one or more points and try again.

Too Many Trace
Points

You are trying to specify more than 10 trace
points.

Select up to 10 points and try again.
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Too Many Columns You are trying to add more than 26 columns
to an animation table.

Delete columns from the animation table
that you do not need and try again.

First configure
animation settings. 

•　You are trying to run an animation without
first configuring its settings.

•　You are trying to execute T > [Animate]
> [Add Table] without first configuring
animation settings.

Configure animation settings and try again.

Cannot Add
Animation 

•　The point you selected for an
Add Animation or Replace Animation
command operation cannot be used in
an animation because it is locked, etc.

•　The point you selected for an
Add Animation or Replace Animation
command operation cannot be used in
an animation because it is already being
used in the animation you are configuring
or in another animation.

Select a point to which animation can be
added and try again.

Select the
applicable
measurement icon. 

You are trying to execute T > [Animate]
> [Add Table] without first selecting the
appropriate measurement icon.

Select the icon of a measurement that can
be added to an animation table.

First configure
animation settings
and create a table.

You tried to execute T > [Animate]
> [Display Table] without generating an
animation table.

Generate an animation table first.

Create at least one
figure with a fill color. 

You are attempting to execute a surface
area calculation (T > [Option] > [Area
Calc]) when there is no figure on the screen
with a fill color.

Draw a figure with a fill color and try again.

Settings errors
When you see this
message:

It means this: So you need to do this:

Out of Domain Attempting to input a value that is outside
the allowable input range.

Input a value that is within the allowable
range.

Invalid Setting Input of an improper View Window value. Change the View Window value so it is
within range.

Input of an improper value on the range
screen and use of that value for execution.

Input a proper range value.

Attempting to create a table with a Step
value of 0.

Specify a Step value other than 0.

Attempting to input illegal View Window
setting combinations.
Example: x Minimum = 10, x Maximum =
10

Enter values that have the proper
relationship with each other.

Attempting to create a table in the
Recursion app when the Start value is
greater than or equal to the End value.

Change the value so the Start value is less
than the End value.

Internal calculation generated a
mathematical error (division by zero, etc.)
when executing a function calculation or
a calculation in the Statistics or Financial
app.

Since the calculation contains one or more
values that cannot be calculated, input
different values and try again.

Improper values were input in the 3D
Graph app for a template coefficient.

Input coefficient values that can define the
3D graph.
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Out of Range Calculation result that exceeds the
calculator display range.

Change the calculation formula.

Other errors
When you see this
message:

It means this: So you need to do this:

No Data The specified data does not exist. (Occurs
when a list or variable that does not contain
data is referenced.)

Change the data specification.

Not Enough
Elements

The list you specified for a calculation
does not contain the number of elements
required to perform the calculation.

Check the number of elements required by
the calculation you are trying to perform
and adjust the number of list elements
accordingly.

You attempted to execute a statistical
calculation using a list whose elements are
all zero for the Frequency data.

For Frequency data, use a list whose
elements contain values greater than zero.

Calculation Ranges, Number of Digits, and Precision

Calculation Range and Precision

Calculation Range ±1 × 10-99 to ±9.999999999 × 1099 or 0
Number of Digits for
Internal Calculation

15 digits

Precision In general, ±1 at the 10th digit for a single calculation. Precision for exponential
display is ±1 at the least significant digit. Errors are cumulative in the case of
consecutive calculations.

Function Calculation Input Ranges and Precision
Functions Input Range

sinx
cosx

Degree |x| < 9 × 109

Radian |x| < 5 × 107π

Gradian |x| < 1 × 1010

tanx
Degree Same as sinx, except when |x| ≠ 90(2n−1)
Radian Same as sinx, except when |x| ≠ π/2(2n−1)
Gradian Same as sinx, except when |x| ≠ 100(2n−1)

sin-1x
cos-1x |x| ≤ 1

tan-1x |x| < 1 × 10100

sinhx
coshx |x| ≤ 230.9516564

tanhx |x| < 1 × 10100

sinh-1x |x| < 1 × 10100

cosh-1x 1 ≤ x < 1 × 10100

tanh-1x |x| < 1

logx *

lnx * 1 × 10-99 ≤ x < 1 × 10100

10x * -1 × 10100 < x < 100
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ex * -1 × 10100 < x ≤ 230.2585092

x * 0 ≤ x < 1 × 10100

x2 * |x| < 1 × 1050

x-1 * |x| < 1 × 10100 ; x ≠ 0
x! 0 ≤ x ≤ 69 (x is an integer)

nPr
0 ≤ r ≤ n, n < 1 × 1010 (n, r are integers)

1 ≤ {n!/(n−r)!} < 1 × 10100

nCr
0 ≤ r ≤ n, n < 1 × 1010 (n, r are integers)

1 ≤ n!/r! < 1 × 10100 or 1 ≤ n!/(n−r)! < 1 × 10100

Pol(x,y) x2 + y2 < 1 × 10100

Rec(r,θ) |r| < 1 × 10100

θ: Same as sinx, cosx, tanx

a°b’c” |a|, b, c < 1 × 10100 ; 0 ≤ b, c

a°b’c” = x
|x| < 1 × 10100

Sexagesimal display: |x| < 1 × 107

xy *

x > 0: -1 × 10100 < ylogx < 100
x = 0: y > 0

x < 0: y = n, m
2n + 1  (m, n are integers)

However: -1 × 10100 < ylog |x| < 100

yx  *

y > 0: x ≠ 0, -1 × 10100 < 1x  logy < 100

y = 0: x > 0

y < 0: x = 2n+1, 2n + 1
m  (m ≠ 0; m, n are integers)

However: -1 × 10100 < 1x  log |y| < 100

ab c
Total of integer, numerator, and denominator must be 10 digits or less (including separator
symbol).

GCD(a,b) |a|, |b| < 1 × 1010 (a, b are integers)

LCM(a,b) 0 ≤ a, b < 1 × 1010 (a, b are integers)
*　Complex numbers can be used as arguments.
•　Precision is basically the same as that described under “Calculation Range and Precision” (page 254).
•　xy, yx , x!, nPr, nCr type functions require consecutive internal calculation, which can cause accumulation of

errors that occur with each calculation.
•　Error is cumulative and tends to be large in the vicinity of a function’s singular point and inflection point.
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MicroPython license information
The MIT License (MIT)
 
Copyright (c) 2013-2017 Damien P. George, and others
 
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated
documentation files (the “Software”, to deal in the Software without restriction, including without limitation the
rights to use, copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to
permit persons to whom the Software is furnished to do so, subject to the following conditions:
 
The above copyright notice and this permission notice shall be included in all copies or substantial portions of
the Software.
 
THE SOFTWARE IS PROVIDED “AS IS”, WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED,
INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A
PARTICULAR PURPOSE AND NONINFRINGEMENT.
IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES
OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
THE SOFTWARE.
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